Live2D Cubism Manual

This is the Live2D Cubism manual site.

For a detailed product introduction of Cubism, please refer to the official website.
Live2D Cubism Official Site

(Updated 09/27/2022) 

 

Notes on using Cubism Editor

cmo3, can3, and cmp3 files are backward compatible.
Please note the following items, as older files can be used with newer versions, but the reverse is not supported.

Model files, animation files, and part files created or saved with a newer version of the editor may not open properly with older versions of the editor and may become corrupted. If you wish to edit data created with a newer version of the editor with an older version of the editor, please do so at your own risk.

 

 

How to Use the Manual

If you have any questions about Cubism, please feel free to refer to this page.
It is structured in such a way that it can be understood without having to read it in order from the beginning.
If you are new to Live2D or just want to learn how to create a model, please visit our tutorial site first.

 

 

Manual List

[Pick up]

 

 

[Pick up]

 

 

[Pick up]

 

 

[Pick up]

 

 

[Pick up]

[Pick up]

[Pick up]

 

[Pick up]

[Pick up]

[Pick up]

 

[Pick up]

[Pick up]

 

 

You can also download the latest Cubism Editor here.

Live2D official website

Product Site

Sample Model

 

Tutorial for Cubism Editor.
If you're new here, start here!
Original illustrations, Live2D data, etc.
The right to use and process 2D assets can be bought and sold.
Marketplace.
Manual for Cubism SDK.
If you are an SDK user, please click here.
Users can upload and share their works and files
with other users.
Explains the basic usage of Cubism SDK
.
For requests or problems with the Editor, please contact
us.
    For useful information about Live2D,
go here.

Note on the update Version 3.3

[Note when exporting the model]
Live2D models created with the latest Cubism 3.3 cannot be loaded in third-party applications that do not support Cubism 3.3.
Please check carefully if your product is compatible with the Cubism 3.3 model.
Cautionary Note on Cubism 3.3 Update

 

Manual Update Information

New!

[09/27/2022]: [Edit Level] was added to the "Shortcut Key List”.

[09/27/2022]: Added note on using blendshapes in "Model Template Functions”.

[09/27/2022]: Notes on template functions added to "Blendshapes”.

[09/27/2022]: Details of Ver. 4.2.01 were added to "Update History”.


[09/21/2022]: Update information on Live2D Cubism 4 AE Plugin R6 was added to "Downloads”.

[09/08/2022]: Updated the "Update History”page of Cubism Viewer for Unity.

[08/25/2022]: Added "Reset Dialog Size and Position” to the "File Menu”.

[08/25/2022]: Added an entry in the "Shortcut Key List”regarding the [Expand All/Consolidate All] button in the Shortcut Settings dialog box.

[08/25/2022]: A function to deselect hidden and locked objects has been added to the "Edit Menu”.

[08/25/2022]: Added information about [Warp Deformer Shaping Brush] in the "Transform Brush”and"Tool Details Palette”.

[08/25/2022]: Added information about [Shaping Warp Deformer along Bezier Handles] in the "Editing Methods”and"Modeling Menu”.

[08/25/2022]: I added a note to the "Skinning”section about what to look out for when skinning.

[08/25/2022]: Added the ability to batch duplicate labels in the "Parameter Bookmarks”and"Animation Menu”.

[08/25/2022]: The ability to show/hide track trajectories and set track color and shape has been added.
This can be set from the [View] menu → [Track Trajectory].
*Updated content will be multilingualized and added as a new page within 1-2 weeks.

[08/17/2022]: Added that movement reversal is not possible for "blendshapes”.

[08/04/2022]: Updated the "Update History” page of Cubism Viewer for Unity.

[07/28/2022]: Update information on Live2D Cubism 4 AE Plugin R6 beta1 was added to “Download”.

[06/16/2022]: The details of Ver. 4.2.00 were added to the “Update History”.

[06/16/2022]: New feature introduction video has been added to “New Feature Introduction 4.2”.

[06/16/2022]:  FPS information and random pause settings were added to the “ Physics and Scene Blend Settings” page.

[06/16/2022]:  FPS information was added to the “Data for Embedded Systems” page.

[06/16/2022]:  Added a note on the “Texture Atlas Editing” page regarding the list of images for models and TIPS.

[06/16/2022]:  Added a note to the “Parameter Bookmarks” page about duplicating labels.

[06/16/2022]:  The page “What to check if Editor/Viewer does not start properly” was moved to Live2D Help and the link was added.

[06/16/2022]:  New page on “Checking Physics Information” is now available.

[06/16/2022]:  “Recalculation of Curves” was added to the “Graph Editor” page.

[06/02/2022]: Added details of Cubism Viewer for Unity 1.4.7 beta2 to “Update History”.

[06/02/2022]: The details of Ver4.2.00 beta2 were added to the “Update History”.

[05/19/2022]: Details of Ver4.2.00 beta1 were added to “Update History”.

[05/19/2022]: “New Features 4.2 (beta version)” is now available.

[05/19/2022]:  New page for “Blend Shapes” is now available.

[05/19/2022]: New page for “Limit Settings for Blend Shape Weights” is now available.

[05/19/2022]:  New page on “Multiply Color and Screen Color” is now available.

[05/19/2022]:  “Mirror Edit Function” was added to the “Edit Mesh manually” page.

[05/19/2022]:  Added a note to the “Duplicate Mesh” page about “Flip Against Axis” for mirror editing.

[05/19/2022]:  New page on “Paste Form Special” is now available.

[05/19/2022]:  An enhancement was added to the “Automatic Generation of Four Corner Shapes” page.

[05/19/2022]: New page for “Parameter Bookmarks” is now available.

[05/19/2022]: New page for “Runtime Model Track” is now available.

[05/19/2022]: New page for “Freeze” is now available.

[05/19/2022]: Improvements were added to the “Shortcut Key List” page.

[05/19/2022]: Added a note about tab enhancements to the “About the View Area” page.

[05/19/2022]:  New page for “Random Pause Setting” is now available.

[05/19/2022]:  Added language switching feature to the “Starting Cubism Editor” page.

[05/19/2022]:  Added language switching feature to “About Cubism Viewer (for OW)” page.

[05/19/2022]:  The “Synchronize Parameter Values Across Tabs of Same Model” function was added to the “MultiViews” page.

[05/19/2022]:  New page on “Checking User Data and Event Information” is now available.

[05/19/2022]:  Changed the name of “Shape” to “Form” on the “Edit Form” page.

[05/19/2022]:  In the “About View Area” page, [Add Tab] was changed to [Duplicate Tab].

[05/19/2022]: Changed the text of the video icon from “Movie” to “Video” on the “Select Target Version” page.

[05/19/2022]: Added information on the “Select Target Version” page regarding the latest version of the model target version selection.

[05/19/2022]:  Each page of the menu was updated with the latest information.

[05/19/2022]:  Each page of the palette was updated with the latest information.

[05/19/2022]: Added details of Cubism Viewer for Unity 1.4.7 beta to “Update History”.

[04/21/2022]: The details of Ver. 4.1.05 were added to the “Update History”.

[04/18/2022]: Added to “Tracking Function” in Cubism 4 AE Plugin R5.

[03/24/2022]: The details of Ver. 4.1.05  beta2 were added to the “Update History”.

[02/10/2022]: Added a note in the “Notes on PSD Creation” section regarding cases in which tracking software or other software may cause edges to appear around the ArtMesh.

[02/10/2022]: A link has been added to the “Rotation Deformer” to show how to do a single rotation and to the inspector's instructions.

[02/08/2022]: Details of Ver4.1.05 beta1 were added to “Update History”.

[02/08/2022]: Added a note about [Translate] in the “Temporary deform tool” section.

[02/08/2022]: Added [Export Physics settings] to the “Shortcut Key List”.

[02/08/2022]: [Lock Angle and Magnification] has been added to “Edit Texture Atlas”.

[02/08/2022]: [Initialize FPS] and “Set FPS to any value and register it” were added to “Physics & Scene Blending Settings”.

[02/08/2022]: Added a new feature to the “Parts Palette”: [Add a number to the end of the name when pasting].

[02/08/2022]: Edge of copy & paste was added to “Duplicate Mesh”.

[02/08/2022]: [Motion Export Settings] was added to “Data for Embedded Systems”.

[12/23/2021]: The details of Ver. 4.1.04 have been added to the “Update History”.

[12/16/2021]: Update information on Live2D Cubism 4 AE Plugin R5 beta2 was added to “Download”.

[12/16/2021]: Updated “Tracking Function” page of Cubism AE Plug-in.

[12/10/2021]: The details of Ver. 4.1.03 have been added to the “Update History”.

[12/09/2021]: The details of Ver. 4.1.02 have been added to the “Update History”.

[12/09/2021]: Added details of Cubism Viewer for Unity 1.4.6 to “Update History”.

[10/28/2021]: Details of Ver4.1.02 beta1 were added to “Update History”.

[10/28/2021] : The following item has been added to the “Shortcut Key List”.
       [Attach to nearby key], [Add Single Keyform], [Delete Keyform], [Select Default Key]
       [Palette Menu] All items in the Timeline palette

[10/28/2021]: A new function [Influence] and [Reflect] were added to “Physics & Scene Blend Settings,” and the setting items for [Type] were added.

[10/28/2021]: New page “Copy/Paste Parameter Values” is available.

[10/28/2021]: The “Tool Details Palette” has been updated to include information on the “Rotation Deformer Display Settings”.

[10/28/2021]: Addition of [Random A] and [Random B] motions was added to the “Physics and Scene Blend Settings” section.

[10/28/2021]: Added information on [Number of conversion divisions] and “Number of Bezier Segments” in the “Deformer Verification Function” section.

[10/28/2021]: A new feature, [Partial Vertex Duplication], has been added to the “Duplicate Mesh” section.

[10/28/2021]: [Label Color] was added to “Parts Palette”.

[10/28/2021]: How to select [Input/Output Parameters] was added to “How to Setup Physics Calculations”.

[10/28/2021]: New function “Select all keys when selecting parameters” was added to “Displaying and Operating the Timeline Palette”.

[10/28/2021]: [Cursor Tracking Settings] and menu descriptions were added to “Cubism Viewer (for OW)”.

[10/28/2021]: Added description of [Frame rate used for baking] in “Bake Animation from Physics”.

[09/28/2021]: Update information on Live2D Cubism 4 AE Plugin R5 beta1 was added to “Download”.

[09/28/2021]: New page for Cubism AE Plug-in “Tracking Function” is now available.

[09/15/2021]: Details of Ver. 4.1.01 were added to the “Update History”.

[09/15/2021]: Added a notice to “ Model Template Function”.

[09/14/2021]: New page “ Convert data up to Cubism 2.1 to Cubism 3 or later” is now available.

[08/19/2021]: Details of Ver4.1.01 beta1 were added to “Update History”.

[08/19/2021]: Added [Deform Brush Tool] and [Search and Replace] to the “Shortcut Key List”.

[08/19/2021]: Stroke cancellation in [Stroke mesh-mapping (beta)] was added to “Edit Mesh manually”.

[08/19/2021]: Right-click menu for “Physics Settings” has been added.

[08/19/2021]: In the “Project”, the text [Set as Input Image for Selected Object] has been corrected.

[08/19/2021]: An item for outputting all scenes has been added to “Export Images/Movies”.

[08/19/2021]: Added a note to “Graph Editor” regarding the operation of changing values by pressing the up/down cursor keys.

[06/10/2021]: The details of Ver. 4.1.00 were added to the “Update History”.

[06/10/2021]: New feature introduction video has been added to “New Feature Introduction 4.1”.

[06/10/2021]: Inserting scenes has been added to the “Scene Palette”.

[06/10/2021]: Modified “Temporary deform tool” to include GUI and menu changes.

[06/10/2021]: The “Stroke ArtPath / Edit” and “Edit Mesh Manually” sections have been revised to include a note about icon changes.

[06/10/2021]: Added the ability to display key names in the “Graph Editor”.

[06/10/2021]: Added a note on cursor tracking settings in “About Cubism Viewer (for OW)”.

[05/13/2021]: Details of Ver4.1.00 beta1 were added to “Update History”.

[05/13/2021]: “New Features 4.1 (beta version)” is now available.

[05/13/2021]: Update on new features in Ver4.1.00 beta1
       “Temporary deform tool” new page is available.
       New page “Stroke ArtPath/Re-stroke ArtPath” is available.
       New page “Deformation Brush” is now available.
       New page “Collect Files” is now available.
       New functions have been added to the “File Menu”.
       A new function (Put selected objects into children) has been added to the “Parts Palette”.
       A new function (Hide selected state) was added to “About View Area”.
       New features have been added to the “About the Toolbar” section.
       New features have been added to the “Selection Methods” section.
       A new feature (Stroke mesh-mapping (beta)) was added to the “Edit Mesh manually” section.
       Added a note to “Onion Skin” regarding new features.
       A new feature (Paste Shapes to Different Objects) has been added to the “Copy and Blend Shapes” section.
       A new feature (automatic layout changes in texture atlas editing) has been added to the “Edit Texture Atlas” section.
       Parameter duplication was added to the “Parameter Palette”.
       New functionality has been added to the “Displaying and Working with the Timeline Palette” section.
       New functions have been added to “Basic Dope sheet Operations”.
       New functionality has been added to the “Graph Editor” section.
       A new feature (scene track and scene import) has been added to the “Scene Management and Settings” section.
       New functionality has been added to the “Export Images and Movies” section.
       New function (display of motion curve types) was added to “About Cubism Viewer (for OW)”.

[05/13/2021]: “Shortcut Key List” has been updated.

[04/20/2021]: The details of Ver. 4.0.09 have been added to the “Update History”.

[04/05/2021]: New page for Cubism AE plug-in “About Expression” is now available.

[03/18/2021]: The details of Ver. 4.0.08 were added to the “Update History”.

[02/15/2021]: Details of Ver4.0.08 beta1 were added to “Update History”.

[12/22/2020]: The “List of Shortcut Keys” has been modified with the latest additions.

[12/17/2020]: The details of Ver. 4.0.07 have been added to the “Update History”.

[12/10/2020]: Operations on child objects and parts under child objects have been added to the “Parts Palette”.

[11/26/2020]: Details of Ver4.0.07 beta1 were added to “Update History”.

[11/26/2020]: In the “Tool Details”, “Show menu”, and “Deformer Validation Functions”,
        added note about the display of child elements during warp deformer resizing.

[11/26/2020]: Added “About Physics Settings” regarding separation of output setting items, validity flag, pendulum preview, etc.

[11/26/2020]: Added a note about locking markers in “Marker Function”.

[11/26/2020]: Added a note on deleting form edits in “Creating FAs”.

[10/22/2020]: The details of Ver. 4.0.06 were added to the “Update History”.

[09/23/2020]: Details of Ver4.0.06 beta1 were added to “Update History”.

[08/27/2020]: The details of Ver. 4.0.05 have been added to the “Update History”.

[08/27/2020]: Added a note to the “Log Palette” with more details on the function.

[07/30/2020]: Ver4.0.04 and Ver4.0.05 beta1 details were added to “Update History”.

[07/30/2020]: A warning about masks was added to “Clipping Masks”.

[07/30/2020]: Added information on canvas inversion and various shortcut keys in the “About View Area” section.

[07/30/2020]: Added the ability to redisplay all hidden dialogs in the “File Menu”.

[07/30/2020]: Added “Animation Menu” section for displaying the entire work area.

[07/30/2020]: Additions have been made to the “Tool Details Palette” and “Selection Methods” regarding the adjustment of pen pressure weights in the pen tab.

[07/30/2020]: Warp deformer display settings have been added to the “Tool Details Palette.”

[07/30/2020]: New search items added to “Find and Replace Objects”.

[07/30/2020]: Added a note on the recording function for physics operations in “Physics Settings.”

[07/30/2020]: Added a note on the number of frames in “Scene Management and Settings”.

[07/30/2020]: Added a note in “Loading and Placing Models” on how to handle the retention of material links.

[07/30/2020]: Added information on video export formats in the “Exporting Images and Movies” section.

[07/30/2020]: Export of display aid file (cdi3.json) was added to “Data for Embedded Systems”.

[07/09/2020]: New page “Lightweight playback function” is now available.

[07/09/2020]: New page “Physics Group Settings” is now available.

[07/09/2020]: Added Physics Calculation Group Settings in “Physics Calculation Settings”.

[07/09/2020]: Added updated information on animation preview settings in “Animation Preview”.

[05/25/2020]: Added an update to “Clipping Mask” regarding the white edge of the mask.

[01/30/2020]: Added the update of Cubism Viewer for Unity 1.4.3 to “Update History”.

[12/12/2019]:  Details of Ver. 4.0.03 were added to the “Update History”.

[12/12/2019]: Added a note in “Clipping Masks” about checking the number of masks in the editor.

[12/12/2019]: Added “Shortcut Key List” with the item ArtPath.

© 2010 - 2022 Live2D Inc.