What to check when the Editor/Viewer does not start properly

(Updated 03/11/2021)

If the Editor/Viewer does not start, check the situation according to the following steps.

This page has been moved to Live2D Help and no longer updated.
Please refer to the following pages of Live2D Help for the latest information.
Cubism Editor/Viewer does not start properly (Windows) - Live2D Help
Cubism Editor/Viewer does not start properly (Mac) - Live2D Help

Step 1

Confirmation of operating environment

Review the contents of the “System Requirements” page.
Check to see if all requirements are met.

 

Check installation location

Make sure it is installed correctly in the following locations.

C:Program Files\Live2D Cubism X.X

Check Version

Check the update history to see if the currently installed version of Cubism is the latest.
Update History

If it is not the latest version, update it.

 

Step 2

Check the GPU (graphics board)

Depending on the configuration, the system may be set to use the onboard (built-in graphics processor).
Check the graphics processor settings.

We will use NVIDIA's GeForce graphics processor as an example.

 

No.  Description Reference image
(1) Right-click on the desktop and click on “NVIDIA Control Panel” in the red frame of the reference image on the right.
(2) Please check the location of the red frame part of the reference image on the right in NVIDIA's control panel.
For those who have set “Auto Select”, change the setting to “High Performance NVIDIA Processor” to switch to GeForce as the graphics processor used.
(* The setting method may differ depending on your environment and settings. Contact your graphics processor vendor for more information.)

 

TIPS
“OpenGL initialization failed. Please make sure your computer meets the system requirements.”

may appear and may fail to startup.
If you see this message on a machine that meets your operating environment,
this may be due to an outdated graphics driver, so please update to the latest version.

 

Make sure you are running with administrator privileges

Check to see if your current PC is running with “administrator privileges”.

 

Check that the account name of the logged-in user does not contain any spaces

If the account name of the logged-in user in Windows contains spaces or other special symbols,
there may be problems with the behavior of the Editor/Viewer.

Check to see if the account name of the logged-in user is correct.

 

Check that OpenGL is set to 3.3 or higher

It appears that OpenGL may be switched when upgrading the OS.
Check to see if it meets the operating environment.

 

Step 3

Check if it can be started from a bat file

Please check if it can be successfully started from the following bat file.
If you can operate the application normally from the bat file, please use it as it is, as there is no change in the application content.

For Cubism Editor:
“CubismEditorX.bat” and “CubismEditorX_d3d.bat” are bat files
For Cubism Viewer:
“CubismViewerX.bat” and “CubismViewerX_d3d.bat” are bat files

 

 

Step 4

If there is no improvement after checking up to step 3, there may be some problem.
If you could send us a “log” at the same time you report a bug to the community,
we will be able to deal with it smoothly. We hope you will try the following methods.

 

If logs can be obtained

If the Editor/Viewer can be started, even temporarily, in some way, the following procedure can be used to obtain logs.

When a glitch occurs, the log palette displays the error in “red”.
Follow the steps below to obtain the “log.txt” file.

Click “Help” in the File menu -> Click “Open Log File” -> All “log.txt”

If you can attach the “log.txt” file with your bug report in the community, we will be able to respond smoothly.

 

If logs cannot be obtained

If the Editor itself cannot be started and logs cannot be obtained, obtain fault information from the command prompt.
Please try the following steps.

  1. Click Start Menu -> Windows System Tools -> Command Prompt
  2. Copy and paste “cd ”C:\Program Files\Live2D Cubism X.X”” into the command prompt and press Enter
    * Replace X.X with the name of your version.
  3. Copy and paste “CubismEditorX.bat” into the command prompt and press Enter
    * Please replace X with the name of your version.
  4. Click on the icon in the upper left corner of the command prompt title
  5. From the command prompt menu, click Edit -> Mark (or Selection)
  6. Select all output to the command prompt and copy/paste to a text file

 

If you could attach a “text file” of what you have retrieved along with your bug report in the community,
it will help us to respond smoothly.

 

© 2010 - 2022 Live2D Inc.