Launch Cubism Editor

(Updated 05/19/2022)

This section describes the installation and license authorization of Cubism Editor.

 

Since 4.2.00 beta1, you can select which language to display.
4.1 If you are installing an earlier version, please check this page.

Start Cubism Editor - Cubism 3 Manual

 

Download Installer

Download the Cubism Editor “installer” from the official website.

Please access the “Download Page on the official website and check the Terms of Use.
If you are satisfied with the terms of use, click [I agree to the terms of use. ].

Click the orange [Download Latest Version] button to start downloading.
Cubism Editor is divided into Windows and macOS versions, so please download according to your operating system.

If successful, [Live2D_Cubism_Setup_X.X.XX.exe] for Windows and [Live2D_Cubism_Setup_X.X.XX.pkg] for macOS will be downloaded.

POINT
If the download does not work, for example, an older version is downloaded, please clear your browser's cache before downloading.
Please check your browser's manual for information on deleting the cache.

 

Install

Windows version

Double-click the downloaded installer icon to run it.

[Do you want to allow this app to make changes to your device?] dialog appears, click [Yes].

The [Select Language for Installation] dialog is displayed. Select the language from the list in the red frame and click [OK].
You can continue to switch languages after installation by going to the [File] menu -> [Settings].
For detailed instructions, please refer to the “File Menu” page.

* Please download the version for each language, as language selection is not available for Cubism 4.1 and earlier.

The [Live2D Cubism X.X Setup] dialog box will appear. Click [Next] to proceed to the next screen.

Review the contents of the license agreement, and if there are no problems, click [I Agree (A)] to proceed to the next screen.

Select the destination folder and click [Next] to proceed to the next screen.

Check the required installation components and click [Install].
The installation will begin. Please wait until it is complete.

When installation is complete, click [Finish] to close the installer.

macOS version

Double-click the downloaded installer icon to run it.

Note for installation on macOS 10.15 Catalina or later:
Cubism Editor 4.0.04 beta1 and later versions do not currently support macOS notarization, so you may receive a warning when running the installer.
Please refer to the help article below for more information. (Updated July 9, 2020)
Warning message appears when trying to install on macOS 10.15 Catalina or later

The macOS version does not implement language selection in the installer; the editor language is determined by looking at the OS language settings.
You can continue to switch languages after installation by going to the [File] menu -> [Settings].
For detailed instructions, please refer to the “File Menu” page.

* Please download the version for each language, as language selection is not available for Cubism 4.1 and earlier.

[Welcome to the Live2D_Cubism_Setup_X.X installer] is displayed. Click [Continue] to proceed to the next screen.

Review the [License Agreement] and if there are no problems, click “Continue” to proceed to the next screen.

[Select installation destination] is displayed. Select the disk you wish to install on and click [Continue] to proceed to the next screen.

[Standard Installation on XXXX] will appear.
Confirm the displayed capacity, etc., specify the installation location, and click [Install].

Enter [User Name], [Password], and click [Install Software].

The installation will begin. Please wait until it is complete.

After the installation is successfully completed, click [Close] to close the installer.

 

License Authentication

After installation is complete, launch the Cubism Editor.
When you start Cubism Editor for the first time, a [Start] dialog will appear to select a license.

TIPS
If you have already activated your license, you do not need to go through the activation procedure when updating to a new version.

 

PRO Version

To activate the PRO version, select [Activate PRO or Trial Version].

When the [License activation] dialog box opens, enter the license key and click [Activate License].

When the license is approved, click [OK] to finish the activation.

Trial version

Select [Start Free Trial of PRO Version] to authenticate the trial version.

Click [OK] to start the program as a [trial version].

The free trial version can be used for 42 days from the date of first activation.
When the trial expires, a dialog box similar to the one below will appear.

In this case, clicking the [OK] button will start the editor with limited saving and export-related functions.
* Saving and exporting functions are limited, but it is possible to try out the PRO version's functions.

 

FREE Edition

To use the FREE version, select [Start as FREE Version].

Click [OK] to start the program as a [FREE version].

TIPS
If you want to activate the PRO version from the FREE or trial version, click [Help menu] -> [Activation] to display the activation dialog.
For detailed instructions, please refer to the aforementioned “License Activation, PRO Version” section.

 

Deactivate Licence

To cancel the license, click [Help] menu -> [Deactivate Licence].

POINT
The same license cannot be used in multiple environments.
If you wish to use the software in other environments, please deactivate the license.

If there is a file being edited, a [Confirm] dialog box will open.
Click [Yes] to open the [Save] window and save the file being edited.
Clicking [No] will proceed to cancel the license without saving the file being edited.

When the [Deactivate Licence] dialog box opens, check the precautions and click [OK] if there are no problems.

When the license is released, click [OK] to exit Cubism Editor.

 

© 2010 - 2022 Live2D Inc.