About Cubism Viewer (for OW)

Updated: 05/19/2022

Cubism Viewer (for OW) is a Viewer intended only for validation of data created with Cubism.
In addition to displaying the model, you can check physics, eye tracking, and playback of multiple motions.

An operational form similar to Cubism 2.1 is called “Original Workflow.”
Cubism Viewer (for OW) allows pose switching, such as arms, and facial expression creation, using the parameter fades used in Cubism 2.1.

This allows expression settings, pose settings, motion lists, etc. to be used in a form similar to Cubism 2.1.

Models and motions that can be loaded in Cubism Viewer are data exported for embedded use.
Please note that .cmo3 and .can3 for editing cannot be loaded.

About the Screen of Cubism Viewer (for OW)

Number Item Details
(1) Menu area A menu appears that allows you to load models, manipulate parameters, and play back motion.
The menu to be displayed is selected from the drop-down at the top.
(2) Resource area Display the loaded data and data created in Cubism Viewer.
(3) Setting item area Change and check settings related to expression setting files and motion files.
The settings can be saved in a model settings file.
[File] menu -> [Export] -> [Model Settings (model3.json)]
(4) Model display area The loaded model is displayed here. The model can be moved or scaled.
The [Show] menu allows you to change the background color, display the model with a transparent background, and display the collision detection.

How to Start Cubism Viewer (for OW)

Cubism Viewer (for OW) is included in the Cubism Editor installer.
After the installation, it is placed in the same hierarchy as the executable file, so it can be started from the area in the red frame in the figure below.

Once launched, drop the .moc3 or .model3.json file into the loading dialog box to launch the Viewer.

You can switch the display language from the [File] menu -> [Language]. 

Number Item Details
(1) Language switching You can select from [Japanese], [English], [Korean], or [Chinese].
(2) Revert to the language of the installation (Windows version) Switches to the language selected during installation.
Revert to OS system language (macOS version) Switch to the language of the OS.

The following are the specifications for language settings.

• The language will be switched when the Editor is restarted after changing the setting.
• Language settings are shared within Editors of the same minor version (e.g., 4.2 series).
• Language switching, which is done through the Editor’s [Settings] menu, takes precedence over the installation settings and OS settings.

How to Create Basic Embedded Data

Cubism 2.1 Viewer (for OW) (Conventional Viewer)   Cubism Viewer (for OW)

Execute moc file export from Modeler

[File to be exported]
• Texture file (.png)
• MOC file (.moc)
• Model file (.model.json)

 

Execute moc3 file export from Modeler

[File to be exported]
• Texture file (.png)
• moc3 file (.moc3)
• Model file (.model3.json)
Note: Includes link to physics settings (.physics3.json)

 

“Output motion data” from Animator

[File to be exported]
• Motion file (.mtn)

 

“Export motion file” from Animator

[File to be exported]
• Motion file (.motion3.json)

 
Load the following files into the Viewer
• MOC file (.moc)
• Exported motion (.mtn) file
  Load the following files into the Viewer
• moc3 file (.moc3)  Note: .model3.json is also acceptable

=> File is loaded and the Viewer starts up

• Exported motion (.motion3.json) file

 
Configure settings in the Viewer
• Pose settings (.pose.json)
• Physics settings (.physics.json)
• Expression settings (.exp.json)
  Configure settings in the Viewer
• Pose settings (.pose3.json)
• Expression settings (.exp3.json)

[Notes]
=> Files set in Viewer are marked with an asterisk to the upper right of their names.

 
Exporting Model Setting Files
• Model settings file (.model.json)
  Exporting Model Setting Files
• Model settings file (.model3.json)

[Notes]
=> When you overwrite the (.model3.json) output from Cubism Editor at output, the file created by Viewer (marked with an asterisk) will be saved together.

TIPS

In Cubism 3 or later, the physics settings (physics3.json) are done on the Cubism Editor side, so only the name is displayed in the tree in the Viewer.

Menu

File menu

ItemDetails
AddExpression:
Add motion for facial expressions.
In the setting item area, place a check mark next to the parameter for which you want to set the expression and adjust the parameter.

Pose:
Create a settings file in JSON format to reflect the arm switching mechanism created in the model and motion.
See the “Pose Settings” page for detailed instructions.
ImportMotion for facial expressions (motion3.json/exp3.json):
Load [motion3.json] for facial expressions exported in the animation process into Cubism Viewer.
ExportModel settings (model3.json):
Export the settings made in Cubism Viewer in a JSON format file. Shortcut key [Ctrl] + [S]

All facial expression motions:
Export all facial expression motions as JSON format files.
See the “Expression Settings and Export” page for a detailed explanation.

Pose:
Export the pose switching settings in a JSON format settings file.
See the “Pose Settings” page for a detailed explanation.
SettingsInclude the extension in the default expression name:
Include the extension in the default expression name when adding an expression.

Edit menu

ItemDetails
Restore parameters to default values Reset parameters to default values.
Stopping motion Stops the motion being played.
Difference Comparison Information from two moc3 data files can be compared and checked in the Viewer.
See the “Compare Two MOC3 Data Information Files” page for details.

Show menu

ItemDetails
Display of collision detection Displays the set collision detection.
Enable mipmap Enable mipmap.
Note: Typically, we recommend that you check the box.
Background transparency (beta) Displays the model with a transparent background.
Background color setting Sets the background color.
Frame rate display The frame rate is displayed in the upper right corner of the model display area.

Animation menu

ItemDetails
Enable facial expressions Enables playback of motion for facial expressions.
Automatic Eye-blinking Make the eyes blink automatically.
Enable Physics Enable physics settings.
Enable Pose Switching Enable Pose Switching.
Idle Motion Enables idle motion.
Cursor tracking Enables cursor tracking in the model display area.
Breath Enable breathing.
Use Old Motion Playback MethodEnable the old motion playback method. 
The [Use Old Motion Playback Method] checkbox in the lower right corner of the model display area is checked.
See the “When the reproducibility of motion3.json deteriorates” page for a detailed explanation.
Cursor tracking settingsOpens a dialog box for cursor tracking settings.

About Cubism Viewer (for OW) Features

Cursor tracking settings

Check [Animation] menu -> [Follow Cursor] and drag on the View to move the model following the mouse cursor.
You can also set the parameters you want to follow in the [Animation] menu -> [Cursor Tracking Settings], which allows you to simulate the actual device.

Impact (%):
The degree of influence can be set to affect the movement of the parameter.
A stronger setting will result in a larger movement, while a weaker setting will result in a smaller movement.

Reflect: The cursor tracking is inverted.

Type:
Set the type of parameter you want the cursor to follow.
• In the case of left mouse dragging
(Left mouse X: horizontal movement, Left mouse Y: vertical movement)

• In the case of right mouse dragging
(Right mouse X: horizontal movement, Left mouse Y: vertical movement)

Cursor tracking settings are saved in the model data (cmo3) but are not exported to the embedded data.
If you want the cursor to follow when embedding, configure the settings on the SDK side.

Note: Cursor tracking settings can also be checked in [Physics and Scene Blend Settings].

Image confirmation of curves

Select motion3.json and click “View Motion Changes in Image” from the right-click menu to view the curve in an image.

List of draw order and number of polygons (ArtMesh) information

You can check information such as the draw order of ArtMeshes and the number of polygons.
Click on a moc3 file in the tree -> Select “ArtMesh” from the pull-down menu

The selected ArtMesh flashes blue in the View.

Displaying motion curve type

The motion inspector in the [OW Viewer] now displays the target version inferred from the information contained in the motion.

If you are using “SDK (Others)” in the target version, please consult with the developer and consider whether to check the box.
See the “When the reproducibility of motion3.json deteriorates” page in the SDK Manual for details.

The notation on the inspector will be as follows:

Use Old Motion Playback Method

Prior to version 4.1, Cubism Viewer (for OW) reproduced any motion file with the same curves as the animation in the Cubism Editor.
In Cubism Viewer (for OW) from 4.1 alpha1 to alpha3, motion will be reproduced with the curves reproduced by the SDK.
Also, in Cubism Viewer (for OW) after 4.1 alpha4, the curve reproduction state can be controlled by checking the “Use Old Motion Playback Method” checkbox.

With the “Use Old Motion Playback Method” checked, the motion is played back with the Bezier curve motion with the Bezier handle fixed at 1/3 or 2/3.

If you are using the SDK (Others) in the target version, please consult with the developer and consider whether to check the box.
See the “When the reproducibility of motion3.json deteriorates” page in the [Cubism SDK Manual] for more details.

Waveform comparison

For motions exported with the [SDK (Others)] function for checking curves, curves that are played back with unsupported SDKs are now displayed in light blue.

Comparison of Two MOC3 Data Information Files

Information from two moc3 data files can be compared and checked in the Viewer.

The confirmation procedure is as follows:

  1. Drag and drop the two data files you want to compare into the Viewer
  2. Click [Edit] menu -> Select [Compare Difference]
  3. Check the confirmation dialog box that appears

(1) File information

Display the information of the file you want to compare, such as the file name, the date/time the file was created, and the location of the file.

(2) Categories and detailed items

Canvas:

Display the comparative information on the canvas.

Parts:

Display the comparative information on parts.

Parameter:

Min, Default, and Max values are compared and displayed for each ID.

ArtMesh:

Information on the following items for each ID is displayed for comparison.

1. Blend Mode
2. Culling
3. Texture number
4. Draw order
5. Draw order of Artmesh
6. Mask
7. Number of vertices
8. Number of polygons

Changes from Cubism 2.1 Viewer (for OW)

The following changes were made in Cubism 2.1 and 3 or later.

Motion settings

  Changes Cubism2.1 Viewer (for OW) Cubism Viewer (for OW)
1 Motion file name .mtn .motion3.json
2 Change of description in the file (general)   Change leading letter to uppercase for all key elements
‘type’ -> ‘Type,’ etc.
3 Group name

 idle

Automatically identified and marked as “idle” in the group

 Idle

[Notes]
Must be set to idle by clicking on the “Idle” button to the right of the group name.

(Group names start with a capital letter)

4 Automatic eye blinking motion set mult

Pose settings

  Changes Cubism2.1 Viewer (for OW) Cubism Viewer (for OW)
1 Pose file name .pose.json .pose3.json
2 Change of description in the file (general)   Change leading letter to uppercase for all key elements
‘type’ -> ‘Type,’ etc.
3 Structure

‘parts_visible’

Example of structural modification:
‘parts_visible’ : [ { ‘group’ : [Group Settings] } ,{ ‘group’ : [Group Settings] } ]

‘Groups’

Example of structural modification:
‘Groups’ : [ [ Group Settings ], [ Group Settings ] ]

Facial expression settings

  Changes Cubism2.1 Viewer (for OW) Cubism Viewer (for OW)
1 Expression file name .exp.json .exp3.json
Note: Default expression name is the name without the extension (*1)
(Example) File name: abc.exp3.json -> Default expression name: abc
2 Change of description in the file (general)   Change leading letter to uppercase for all key elements
‘type’ -> ‘Type,’ etc.
3 Change of description in the file fade_in /out FadeIn , FadeOut
4 Change of description in the file ‘params’ ‘Parameters’
5 Change of description in the file ‘calc’
‘add’
‘mult’
Add is omitted in ‘set’ in 2.1
‘Blend’
‘Add’
‘Multiply’
Not omitted in ‘Overwrite’ in 3.x
5 Change of description in the file

‘val’

2.1 had a value for expression (e.g., 1.2 if the eyes are wide open)

‘Value’

In 3.x, it changed to have values that are added and multiplied (+0.2 if the eyes are wide open)

*1 Even if a moc3/model3.json file exported with the previous specification is read by OW Viewer after the change, the expression names already set will not change.
The above modified specifications will be applied when loading a new motion for facial expressions.
It is also possible to make the Viewer work with the previous specifications by checking the [File] menu -> [Setting] -> [Add extension to default expression name].
This setting is saved as a Viewer setting.

Model files

  Changes 2.1Viewer Viewer (Original Workflow)
1 File name of the model file .model.json .model3.json
2 Change of description in the file (general)   Change leading letter to uppercase for all key elements
‘type’ -> ‘Type,’ etc.
3 Collision detection ID naming convention:
D_REF.
ID naming convention:
HitArea Add HitArea item:
For the time being, this will not be exported from the Editor. Find ‘HitArea**’ in the Viewer and display it in the list, then set the name. (Export model3.json from the Viewer)

Burning eye blinking and lip-sync motion

Motion set in “Eye blinking” and “Lip-sync” can be burned (baked) into Live2D parameters when exporting motion.
Since “Scale” and “Effect” data are not exported to motion3.json, this feature can be used to completely reproduce the motion of an animation in the Viewer.

Note, however, that the motion3.json file must be written out again if adjustments are necessary.
Note: When using OW Viewer, burning the motion function for eye blinking and lip-sync is recommended.


When setting motion data, check the “Burn Lip-sync and Blink into Motion” checkbox.
How to burn motion:

If this item is enabled, “Lip-sync” and “Eye blinking” will not be exported to motion3.json separately, so the items will be grayed out.

In this state, clicking “OK” will burn the motion as keyframes on the parameters checked in the Settings for Eye Blinking and Lip-sync, and will output as motion3.json.

If a keyframe is set for the parameter to which “Eye blinking” or “Lip-sync” is applied, the curve of the above effect is calculated (multiplied in the case of eye blinking, added in the case of Lip-sync) for that parameter.

Statistics

The statistics of the moc3 file can be checked.
Click on the moc3 file name -> Select “Statistics” from the pull-down menu to display the target version and other information.

Please let us know what you think about this article.