Cubism Viewer (for OW) 정보

(2022/05/19 업데이트)

Cubism Viewer (for OW)는 Cubism으로 작성한 데이터의 검증만을 목적으로 한 뷰어입니다.
모델의 표시 외에 물리 연산이나 시선 추종, 복수의 모션의 재생 등을 확인할 수 있습니다.

Cubism2.1에 가까운 운용 형태를 「오리지널 워크플로우( Original Workflow )」라고 부릅니다.
Cubism Viewer (for OW)에서는 Cubism2.1에서 사용된 파라미터 페이드를 사용한 팔 등
포즈 전환이나 표정을 만들 수 있습니다.
이것에 의해, 표정 설정, 포즈 설정, 모션 리스트 등을 Cubism2.1에 가까운 형태로 이용할 수 있습니다.

Cubism Viewer에서 처리할 수 있는 모델과 모션은 내장용으로 내보낸 데이터입니다.
편집용 .cmo3, .can3은 처리할 수 없습니다.

 

Cubism Viewer (for OW) 화면 정보

번호 품목 상세
메뉴 영역 모델을 읽고 파라미터를 조작하고 모션을 재생하는 등의 메뉴가 표시됩니다.
표시할 메뉴는 상단의 드롭다운에서 선택합니다.
자원 영역 로드된 데이터와 Cubism Viewer에서 생성된 데이터가 여기에 표시됩니다.
설정 항목 영역

표정 설정 파일이나 모션 파일에 관한 설정을 변경・확인할 수 있습니다.
설정한 내용은 모델 설정 파일에 저장할 수 있습니다.
[파일] 메뉴 → [내보내기] → [모델 설정(model3.json)]

모델 표시 영역

로드된 모델이 여기에 표시됩니다. 모델을 이동하거나 확장할 수 있습니다.
[보기] 메뉴에서 설정을 하는 것으로, 배경색의 변경이나 배경을 투과해 모델을 표시, 충돌 판정의 표시를 할 수 있습니다.

 

Cubism Viewer (for OW)를 시작하는 방법

Cubism Viewer (for OW)는 Cubism Editor의 설치 프로그램에 동봉되어 있습니다.
배포 후 실행 파일과 동일한 계층에 배치되므로 아래 그림의 빨간색 프레임 부분에서 시작합니다.

부팅 후에는 읽기 대화 상자에 .moc3 또는 .model3.json 파일을 드롭하여 Viewer가 시작됩니다.

 

[파일] 메뉴 → [언어]에서 표시할 언어를 전환할 수 있습니다. 

번호 품목 상세
언어 전환 [일본어] [영어] [한국어] [중국어] 중에서 선택할 수 있습니다.
설치 시 언어로 되돌리기(Windows용) 설치 시 선택한 언어로 전환합니다.
OS의 시스템 언어로 되돌리기(macOS용) OS의 언어를 참조하게 됩니다.

이하, 언어 설정시의 사양이 됩니다.

・언어는 설정 후 편집기를 다시 시작하면 전환됩니다.
・언어의 설정은 같은 마이너 버전(4.2계 등)의 에디터내에서 공유됩니다.
・에디터의 [설정] 메뉴에서 실시하는 언어의 전환은 인스톨시의 설정이나 OS의 설정보다 우선됩니다.

 

기본 내장 데이터를 만드는 방법

Cubism2.1 Viewer ( for OW ) ※ 기존의 Viewer   Cubism Viewer ( for OW )

Modeler에서 moc 파일 내보내기 실행

【내보내는 파일】
・텍스쳐 파일(.png)
・moc 파일(.moc)
・모델 파일(.model.json)

 

Modeler에서 moc3파일 내보내기 실행

【내보내는 파일】
・텍스쳐 파일(.png)
・moc3 파일(.moc3)
・모델 파일(.model3.json)
※물리 연산 설정(.physics3.json)의 링크를 포함

 

Animator에서 「모션 데이터 출력」

【내보내는 파일】
・모션 파일(.mtn)

 

Animator에서 「모션파일 내보내기」

【내보내는 파일】
・모션 파일(.motion3.json)

 
Viewer로 다음 파일 로드
・moc 파일(.moc)
・내보낸 모션(.mtn) 파일
  Viewer로 다음 파일 로드
・moc3 파일(.moc3)  ※.model3.json이라도 좋다

⇒파일이 로드되어 Viewer가 일어난다

・내보낸 모션(.motion3.json) 파일

 
Viewer로 설정하기
・포즈 설정(.pose.json)
・물리 연산 설정(.physics.json)
・표정 설정(.exp.json)
  Viewer로 설정하기
・포즈 설정(.pose3.json)
・표정 설정(.exp3.json)

【주의점】
⇒ Viewer에 설정된 파일은 이름의 오른쪽 상단에 별표가 붙습니다.

 
모델 설정 파일 내보내기
・모델 설정 파일 (.model.json)
  모델 설정 파일 내보내기
・모델 설정 파일 (.model3.json)

【주의점】
⇒ 출력시 CubismEditor에서 출력한 (.model3.json)에 덮어쓰면, Viewer로 작성된 파일(별표가 붙은 것)도 함께 저장됩니다.

TIPS
Cubism3 이상에서는 물리 연산 설정(physics3.json)이 CubismEditor 측에서 수행되므로 뷰어에서 이름만 트리에 표시됩니다.

 

메뉴

파일 메뉴

품목 상세
추가 표정:
표정 모션을 추가합니다.
설정 항목 영역에서 표정을 설정하고자 하는 파라미터를 체크하여 파라미터를 조정합니다.

포즈:
모델이나 모션으로 작성한 팔의 전환의 구조를 반영시키기 위한 json 형식의 설정 파일을 작성합니다.
자세한 조작 방법은 「포즈 설정」 페이지를 참조하십시오.
로딩 표정용 모션(motion3.json / exp3.json):
애니메이션 프로세스에서 내보낸 표정용 [motion3.json]을 Cubism Viewer에 로드합니다.
내보내기

모델 설정(model3.json):
Cubism Viewer에서 설정한 내용을 json 형식의 파일로 내보냅니다.
단축키 [Ctrl]+[S]

모든 표정 모션:
모든 표정용의 모션을 json 형식의 파일로 써냅니다.
자세한 설명은 「표정 설정 및 내보내기」 페이지를 참조하십시오.

포즈:
포즈 전환 설정을 json 형식의 설정 파일로 내보냅니다.
자세한 내용은 「포즈 설정」 페이지를 참조하십시오.

설정 기본 표정 이름에 확장자 포함:
표정을 추가할 때 기본 표정 이름에 확장자를 포함합니다.

편집 메뉴

품목 상세
파라미터를 기본값으로 되돌리기  매개 변수를 기본값으로 되돌립니다.
모션 정지  재생 중인 모션을 중지합니다.
차이 비교  2개의 moc3 데이터의 정보를 Viewer상에서 비교 확인할 수 있습니다.
자세한 내용은 「2개의 moc3 데이터 정보 비교」를 참조하십시오.

보기 메뉴

품목 상세
충돌 판정 표시  설정한 충돌 판정을 표시합니다.
밉맵 사용  밉맵을 사용합니다.
※기본적으로 체크를 넣어 두는 것을 추천합니다
배경 투과(beta)  배경을 투과하여 모델을 표시합니다.
배경색 설정  배경색을 설정합니다.
프레임 속도 표시  모델 표시 영역의 오른쪽 상단에 프레임 속도를 표시합니다.

애니메이션 메뉴

품목 상세
표정 사용  표정 모션 재생을 활성화합니다.
자동 눈 패치  자동으로 깜박이도록 합니다.
물리 연산 사용  물리 연산 설정을 사용합니다.
포즈 전환 사용  포즈 전환을 활성화합니다.
아이들링 모션  공회전 모션을 활성화합니다.
커서 추종  모델 표시 영역에서 커서 추적을 활성화합니다.
호흡  호흡을 켭니다.
구 모션 재생 방식 사용 이전 모션 재생 방법을 활성화합니다. 
모델 표시 영역의 오른쪽 하단에 있는 [구 모션 재생 방식 사용]에 체크가 됩니다.
자세한 내용은 「motion3.json의 재현성이 저하되는 경우에 대해」 페이지를 참조하십시오.
커서 추종 설정 커서 추적 설정 대화 상자를 엽니다.

 

 

Cubism Viewer (for OW)의 기능 이해

커서 추종 설정

[애니메이션] 메뉴 → [커서 추종]을 체크하고 뷰를 드래그하면 마우스 커서를 추종하여 모델이 움직입니다.
[애니메이션] 메뉴 → [커서 추종 설정]에서 추종시키고 싶은 파라미터도 설정할 수 있어 실기상의 시뮬레이션을 할 수도 있습니다.

영향도(%):
영향도를 설정하면 파라미터의 움직임에 영향을 줄 수 있습니다.
강하게 설정하면 크게 움직이고 약하게 설정하면 움직임이 작아집니다.

반전: 커서의 추종이 반전됩니다.

종류:
커서를 추종하고 싶은 파라미터에 종별을 설정합니다.
・마우스 왼쪽 드래그의 경우
(마우스 왼쪽 X: 가로 이동 마우스 왼쪽 Y: 세로 이동)

・마우스 오른쪽 드래그의 경우
(마우스 오른쪽 X: 가로 이동 마우스 왼쪽 Y: 세로 이동)

커서 추종 설정은 모델 데이터(cmo3)에 저장되지만 내장 데이터에는 내보내지지 않습니다.
내장시 커서를 추종시키고 싶은 경우는 SDK측에서 설정을 하십시오.

※커서 추종의 설정은 [물리 연산·씬 블렌드 설정]에서도 같은 확인을 할 수 있습니다.

 

커브 곡선 이미지 확인

motion3.json을 선택하고 오른쪽 클릭에서 「모션의 변화를 이미지로 확인」을 클릭하면 커브 곡선을 이미지로 확인할 수 있습니다.

 

 

그리기 순서 및 다각형 수 (아트 메쉬) 정보 목록

아트 메쉬 그리기 순서와 다각형 수 등의 정보를 확인할 수 있습니다.
트리의 moc3 파일을 클릭 → 풀다운 메뉴에서 「아트 메쉬」를 선택

선택한 아트 메쉬가 뷰에서 파란색으로 깜박입니다.

 

 

모션의 커브 타입 표시

이제 [OW Viewer] 모션의 인스펙터에 모션에 포함된 정보에서 추측되는 대상 버전이 표시됩니다.

타겟 버전에서 「SDK (그 외)」를 사용하는 경우 개발자와 상담하고 체크를 할지 여부를 고려하십시오.
자세한 내용은 SDK 매뉴얼 「motion3.json의 재현성이 저하되는 경우에 대해」를 참조하십시오.

인스펙터의 표기는 다음과 같습니다.

구 모션 재생 방식 사용

4.1 이전의 Cubism Viewer (for OW)에서는 어떠한 모션 파일이라도 Cubism 에디터의 애니메이션과 같은 커브로 재현되어 있었습니다.
4.1alpha1에서 alpha3까지의 Cubism Viewer (for OW)에서는 모션이 SDK에서 재생되는 커브로 재현됩니다.
또, 4.1 alpha4 이후의 Cubism Viewer (for OW)에서는 커브의 재현 상태를 「구 모션 재생 방식을 사용」의 체크로 제어할 수 있게 됩니다.

「구 모션 재생 방식을 사용」의 체크를 넣은 상태에서는 베지어 핸들을 1/3, 2/3로 고정한 상태의 베지어 커브의 모션으로 재생되게 됩니다.

타겟 버전에서 SDK(기타)를 사용하는 경우 개발자와 상담하여 체크를 하는지 고려해 보세요.
자세한 내용은 [Cubism SDK Manual]의 「motion3.json의 재현성이 저하되는 경우에 대해」 페이지를 참조하십시오.

 

파형 비교

커브 곡선 확인 기능으로 [SDK (그 외)]로 내보낸 모션에 관해 미대응 SDK로 재생되는 커브 곡선이 하늘색으로 표시됩니다.

 

두 개의 moc3 데이터 정보 비교

두 개의 moc3 데이터 정보를 Viewer에서 비교 확인할 수 있습니다.

확인 방법은 다음과 같습니다.

  1. 비교하려는 두 개의 데이터를 Viewer로 드래그 앤 드롭
  2. [편집] 메뉴 → [차분 비교]
  3. 확인 대화 상자가 표시됨

 

①파일 정보

비교하려는 파일의 이름, 파일 작성 날짜/시간 및 파일 위치가 표시됩니다.

 

②카테고리 및 상세 항목

캔버스:

캔버스 비교 정보가 표시됩니다.

파츠:

파츠 비교 정보가 표시됩니다.

파라미터:

ID별로 Min, Default 및 Max 값이 비교 표시됩니다.

아트 메쉬:

ID별로 다음 항목의 정보가 비교 표시됩니다.

1. 블렌드 모드
2. 컬링
3. 텍스쳐 번호
4. 그리기 순서
5. 그리기 순서
6. 마스크
7. 정점 수
8. 다각형 수

 

Cubism2.1 Viewer (for OW)의 변경 사항에 대해

Cubism2.1과 3 이후에서는 다음과 같이 변경됩니다.

 

 

모션 설정

  변경 내용 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW ) 
1 모션 파일 이름 .mtn .motion3.json
2 파일의 설명 변경(일반)   키 요소는 모두 선두 대문자로 변경
'type' -> 'Type' 등
3 그룹 이름

 idle

자동으로 판별되고 그룹에 「idle」로 표기됨

 Idle

【주의점】
그룹 이름 오른쪽의 「Idle」 버튼을 클릭하여 아이들링 설정이 되어야 합니다.

(그룹명은 대문자 시작)

4 자동 눈 패치 모션 set mult

 

포즈 설정

  변경 내용 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW )
1 포즈 파일 이름 .pose.json .pose3.json
2 파일의 설명 변경(일반)   키 요소는 모두 선두 대문자로 변경
'type' -> 'Type' 등
3 구조

'parts_visible'

구조 변경 예:
'parts_visible' : [ { 'group' : [그룹 설정] } ,{ 'group' : [그룹 설정] } ]

'Groups'

구조 변경 예:
'Groups' : [ [ 그룹 설정 ], [ 그룹 설정 ] ]

 

표정 설정

  변경 내용 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW )
1 표정의 파일명 .exp.json .exp3.json
※디폴트의 표정명은 확장자를 제외한 것(*1)
(예) 파일명: abc.exp3.json → 디폴트의 표정명: abc
2 파일의 설명 변경(일반)   키 요소는 모두 선두 대문자로 변경
'type' -> 'Type' 등
3 파일의 설명 변경 fade_in /out FadeIn , FadeOut
4 파일의 설명 변경 'params' 'Parameters'
5 파일의 설명 변경 'calc'
'add'
'mult'
'set'2.1에서 Add는 생략
'Blend'
'Add'
'Multiply'
'Overwrite'3.x에서는 생략하지 않음
5 파일의 설명 변경

'val'

2.1은 표정을 나타내는 값을 가지고 있었다(눈을 뜨면 1.2 등)

'Value'

3.x에서는, 가산·곱셈되는 값을 갖도록 변경(눈을 보면 +0.2)

*1 이전 사양에서 내보낸 moc3/model3.json을 변경 후 OWViewer로 읽어도 이미 설정되어 있는 표정의 표정명은 바뀌지 않습니다.
새롭게 표정용 모션을 읽을 때에 상기의 변경 후의 사양이 적용됩니다.
[파일] 메뉴 → [설정] → [기본 표정명에 확장자 붙이기]를 체크하면 이전 사양에서 Viewer를 동작시킬 수 있습니다.
이 설정은 Viewer 설정으로 저장됩니다.

 

모델 파일

  변경 내용 2.1Viewer Viewer ( Original Workflow ) 
1 모델 파일의 파일 이름 .model.json .model3.json
2 파일의 설명 변경(일반)   키 요소는 모두 선두 대문자로 변경
'type' -> 'Type' 등
3 충돌 판정 ID 명명 규칙:
D_REF.
ID 명명 규칙:
HitAreaHitArea 항목 추가:
당분간은 에디터로부터는 내보내지 않고, 뷰어로 'HitArea**'를 찾아 리스트에 표시해, 이름을 설정하는 방식이 됩니다. (Viewer에서 model3.json 내보내기)

 

눈 깜빡임과 립싱크의 모션 굽기

「눈 깜빡임」과 「립싱크」로 설정한 모션은 모션 내보낼 때 Live2D 파라미터에 굽는(베이크)할 수 있습니다.
motion3.json에는, 「배율」이나 「효과」의 데이터가 기록되지 않기 때문에, 이 기능을 활용하는 것으로, Viewer상에서 애니메이션의 모션을 완전하게 재현하는 것이 가능합니다.

다만, 조정이 필요한 경우는 다시 motion3.json을 내보낼 필요가 있으므로 주의가 필요합니다.
※OWViewer를 사용할 때는, 눈 깜빡임과 립싱크의 모션 담금질 기능을 추천하고 있습니다.


모션 데이터 설정 시, 「립싱크와 눈 깜빡임을 모션에 베이크」에 체크를 합니다.
모션 베이크 방법:

 

이 항목을 활성화하면 「립싱크」와 「눈 깜빡임」이 개별적으로 motion3.json에 내보내지지 않으므로 항목이 회색으로 바뀝니다.

 

이 상태에서 「OK」를 클릭하면 눈 깜빡임・립싱크 설정으로 체크를 한 파라미터에
키 프레임으로 구워지고 motion3.json으로 출력됩니다.

「눈 깜빡임」이나 「립싱크」의 적용처의 파라미터에 키프레임이 설정되어 있는 경우는, 그 파라미터에,
위의 이펙트의 커브가 계산(눈 깜빡임의 경우는 곱셈, 립싱크의 경우는 가산)됩니다.

 

통계 정보

moc3 파일의 통계를 확인할 수 있습니다.
moc3 파일명을 클릭 → 풀다운 메뉴에서 「통계 정보」를 선택하면 타겟 버전 등의 정보가 표시됩니다.

© 2010 - 2022 Live2D Inc.