关于 Cubism Viewer (for OW)

(2022 年 5 月19日更新)

Cubism Viewer (for OW)是一个仅用于验证 Cubism 创建的数据的查看器。
除了显示模型外,您还可以检查物理模拟、视线跟踪、多个动作的播放等。

类似于 Cubism 2.1的操作模式称为“原始工作流程”。
在 Cubism Viewer (for OW)中,使用 Cubism 2.1中使用的参数 fade 等的手臂。
您将能够切换姿势并创建面部表情。
这允许您以类似于 Cubism 2.1的形式使用面部表情设定、姿势设定、动作列表等。

Cubism Viewer 可以处理的模型和运动是导出用于嵌入的数据。
请注意,无法处理用于编辑的 .cmo3和 .can3。

 

关于 Cubism Viewer (for OW)的画面

编号 物品 细节
菜单区 显示用于加载模型、操作参数、播放动作等的菜单。
从顶部的下拉列表中选择要显示的菜单。
资源区 加载的数据和在 Cubism Viewer 上创建的数据显示在这里。
设定项目区域

您可以变更和检查与面部表情设定文件和动作文件相关的设定。
设定内容可以保存在模型设定文件中。
[文件]菜单→[导出]→[模型设定(model3.json)]

模型展示区

此处显示加载的模型。您可以移动和缩放模型。
通过[显示]菜单设定,可以改变背景颜色,通过背景显示模型,显示碰撞检测。

 

如何启动 Cubism Viewer (for OW)

Cubism Viewer (for OW)包含在 Cubism Editor 安装程序中。
展开后与可执行文件处于同一层次,所以从下图中的红框开始。

启动后,将 .moc3 或 .model3.json 文件放入加载对话框以启动Viewer。

 

您可以从 [文件] 菜单 → [语言] 切换显示的语言。 

编号 物品 细节
语言切换 您可以从[日语]、[英语]、[韩语]和[中文]中进行选择。
返回安装时的语言(Windows版) 切换到安装期间选择的语言。
返回操作系统的系统语言(macOS 版本) 它将引用操作系统的语言。

以下是设定语言时的规范。

・设定后重新启动编辑器时语言会发生变化。
・语言设定在同一次要版本(4.2 系列等)的编辑器中共享。
・从编辑器的[设定]菜单执行的语言切换优先于安装设定和操作系统设定。

 

如何创建基本的嵌入数据

Cubism2.1 Viewer ( for OW )* 常规Viewer   Cubism Viewer ( for OW )

从 Modeler 执行 moc 文件导出

【要导出的文件】
・纹理文件(.png)
・Moc 文件 (.moc)
・模型文件(.model.json)

 

从 Modeler 执行 导出为moc3文件

【要导出的文件】
・纹理文件(.png)
・Moc3文件 (.moc3)
・模型文件(.model3.json)
* 包括物理模拟设定的链接(.physics3.json)

 

来自 Animator 的“输出运动数据”

【要导出的文件】
・运动文件 (.mtn)

 

从 Animator 中“导出动态文件”

【要导出的文件】
・动作文件(.motion3.json)

 
将以下文件加载到Viewer中
・Moc 文件 (.moc)
・导出的运动 (.mtn) 文件
  将以下文件加载到Viewer中
・可以使用 Moc3文件 (.moc3)  * .model3.json。

⇒ 读取文件并启动Viewer

・导出的运动 (.motion3.json) 文件

 
在Viewer中进行设定
・姿势设定(.pose.json)
・物理模拟设定(.physics.json)
・面部表情设定(.exp.json)
  在Viewer中进行设定
・姿势设定(.pose3.json)
・面部表情设定(.exp3.json)

【注意事项】
⇒ 在Viewer上设定的文件名的右上角添加了一个星号。

 
导出模型设定文件
・模型设定文件 (.model.json)
  导出模型设定文件
・模型设定文件 (.model3.json)

【注意事项】
⇒ 输出时 如果从 Cubism Editor 覆盖  (.model3.json) 输出,则 Viewer 创建的文件(带星号)将一起保存。

TIPS
在 Cubism3或更高版本中,物理模拟设定 (physics3.json) 是在 CubismEditor 端完成的,因此在 Viewer 的树中只显示名称。

 

菜单

文件菜单

物品 细节
追加 表情:
为面部表情追加动作。
在设定项目区域检查您要设定面部表情的参数,然后调整参数。

暂停:
创建一个json格式的设定文件,以反映模型或运动创建的手臂切换机制。
有关如何操作的详细信息,请参阅“姿势设定”页面。
加载 面部表情动作(motion3.json / exp3.json):
将动画过程中导出的面部表情[motion3.json]加载到Cubism Viewer中。
出口

模型设定(model3.json):
将 Cubism Viewer 中设定的内容导出为 json 格式文件。
快捷键 [Ctrl] + [S]

所有面部动作:
将所有面部动作导出为 json 格式文件。
有关详细信息,请参阅“面部表情设定和导出”页面。

暂停:
将姿势切换设定导出为 json 格式的设定文件。
有关详细信息,请参阅“姿势设定”页面。

设定 在默认面部名称中包含扩展名:
追加面部表情时,请在默认面部表情名称中包含扩展名。

编辑菜单

物品 细节
将参数恢复为默认值  将参数恢复为其默认值。
停止运动  停止正在播放的动作。
差异比较  您可以在 Viewer 上比较和查看两个 moc3数据的信息。
有关详细信息,请参阅“两个 moc3数据信息的比较”。

显示菜单

物品 细节
碰撞检测显示  显示设定的碰撞检测。
启用 mipmap  启用 mipmap。
* 基本上,建议检查一下。
背景透明度 (beta)  通过背景显示模型。
背景颜色设定  设定背景颜色。
帧率显示  帧率显示在模型显示区域的右上方。

动画菜单

物品 细节
启用面部表情  启用面部表情动作播放。
自动眼裂  让它自动眨眼。
启用物理模拟  启用物理模拟设定。
启用暂停切换  启用姿势切换。
怠速运动  启用怠速运动。
光标跟踪  在模型显示区域启用光标跟踪。
呼吸  启用呼吸。
使用旧动态播放方式 启用旧的运动播放方法。 
勾选模型显示区右下角的[使用旧动态播放方式]。
有关详细说明,请参阅页面“当 motion3.json 再现性恶化时”。
光标跟踪设定 打开光标后续设置对话框。

 

 

关于 Cubism Viewer (for OW) 的功能

光标跟踪设定

检查[动画]菜单→[光标跟随]并在视图上拖动以跟随鼠标光标移动模型。
您还可以从[动画]菜单→[光标跟踪设定]设定您想要跟随的参数,您也可以在真机上进行模拟。

影响(%):
通过设定影响程度,可以影响参数的移动。
如果你设定它更强,它会移动更多,如果你设定它更弱,它会移动更少。

反转:光标跟踪反转。

种类:
设定您希望光标跟随的参数类型。
・鼠标左键拖动时
(鼠标左X:水平移动鼠标左Y:垂直移动)

・拖动鼠标右键时
(鼠标右X:水平移动鼠标左Y:垂直移动)

光标后续设置保存在模型数据 (cmo3) 中,但不保存在内置数据中。
如果您希望在嵌入时光标跟随,请在 SDK 端进行设定。

* 您还可以在[物理/场景混合设定]中检查光标跟踪设定。

 

曲线 曲线图片确认

选择motion3.json,右键单击“检查图片中的运动变化”,检查图片中的曲线曲线。

 

 

绘制顺序和多边形数量(图形网格)信息的列表

您可以检查诸如图形网格的绘制顺序和多边形数量等信息。
单击树上的 moc3文件 → 从下拉菜单中选择“图形网格”

选择的图形网格将在视图上闪烁蓝色。

 

 

运动曲线类型显示

[OW Viewer] 中的动作检查器现在显示从动作中包含的信息推断出的目标版本。

如果您在目标版本中使用“SDK(其他)”,请咨询开发者并考虑是否勾选。
详情请参考 SDK 手册“当 motion3.json 再现性恶化时”。

检查器上的符号如下。

使用旧动态播放方式

在 4.1之前,Cubism Viewer (for OW)再现了与 Cubism 编辑器中的动画具有相同曲线的任何运动文件。
4.1在 Cubism Viewer (for OW) 中从 alpha1到 alpha3,运动会在 SDK 播放的曲线中再现。
此外,在 4.1alpha 4 之后的 Cubism Viewer (for OW)中,您可以通过选中“使用旧动态播放方式”来控制曲线的再现状态。

勾选“使用旧动态播放方式”时,将播放贝塞尔手柄固定在1/3和 2/3的贝塞尔曲线动作。

如果您使用的是目标版本的SDK(其他),请咨询开发者考虑是否勾选。
有关详细信息,请参阅[Cubism SDK 手册]中的“当 motion3.json 再现性恶化时”页面。

 

波形比较

使用曲线曲线确认功能,SDK播放的不支持[SDK(其他)]导出的动作的曲线曲线现在显示为浅蓝色。

 

两个moc3数据信息对比

您可以在 Viewer 上比较和查看两个 moc3数据信息。

确认方法如下。

  1. 将要比较的两个数据拖放到Viewer中
  2. [编辑]菜单→[差异比较]
  3. 将显示一个确认对话框

 

① 文件信息

显示要比较的文件名、文件创建日期/时间和文件位置。

 

②类别及详细项目

帆布:

显示画布比较信息。

部件:

显示部件的比较信息。

参数:

比较并显示每个 ID 的 Min、Default 和 Max 值。

图形网格:

对每个 ID 比较并显示以下项目的信息。

1.混合模式
2. 剔除
3.纹理编号
4. 绘制顺序
5. 绘制顺序
6.面具
7. 顶点数
8. 多边形数量

 

关于Cubism2.1 Viewer (for OW) 的变更

在 Cubism 2.1和3或更高版本中,变更如下。

 

 

运动设定

  变更内容 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW ) 
1 运动文件名 .mtn .motion3.json
2 变更文件中的描述(一般)   所有关键元素都变更为大写
“type”->“Type”等。
3 组:

 idle

组内自动确定并标记为“空闲”

 Idle

【注意事项】
您需要单击组名右侧的“空闲”按钮来设定空闲设定。

(组名以大写字母开头)

4 自动裂眼动作 set mult

 

姿势设定

  变更内容 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW )
1 姿势文件名 .pose.json .pose3.json
2 变更文件中的描述(一般)   所有关键元素都变更为大写
“type”->“Type”等。
3 建造

'parts_visible'

结构变化示例:
'parts_visible': [{'group': [组设定]}, {'group': [组设定]}]

'Groups'

结构变化示例:
'Groups' : [[群组设定]、[群组设定]]

 

面部表情设定

  变更内容 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW )
1 表情文件名 .exp.json .exp3.json
* 默认面部表情名称不包括扩展名(*1)
(例)文件名:abc.exp3.json → 默认表情名:abc
2 变更文件中的描述(一般)   所有关键元素都变更为大写
“type”->“Type”等。
3 变更文件中的描述 fade_in /out FadeIn , FadeOut
4 变更文件中的描述 'params' 'Parameters'
5 变更文件中的描述 'calc'
'add'
'mult'
'set'2.1中省略了add
'Blend'
'Add'
'Multiply'
在'Overwrite'3.x 中没有缩写
5 变更文件中的描述

'val'

2.1有一个面部表情值(1.2如果你睁开眼睛等)

'Value'

在3.x 中,变更为具有要加算/正片叠底的值(如果睁开眼睛,则 +0.2)

*1即使之前规格导出的moc3/model3.json被变更后的OWViewer读取,已设定的表情名称也不会发生变化。
加载新的面部表情动作时将应用上述修改后的规范。
也可以通过勾选[文件]菜单->[设定]->[将扩展名添加到默认面部表情名称]来使用以前的规格操作Viewer。
此设定保存为Viewer设定。

 

模型文件

  变更内容 2.1Viewer Viewer ( Original Workflow ) 
1 模型文件的文件名 .model.json .model3.json
2 变更文件中的描述(一般)   所有关键元素都变更为大写
“type”->“Type”等。
3 碰撞检测 ID命名约定:
D_REF.
ID命名约定:
追加了HitAreaHitArea 项目:
暂时不会从编辑器中导出,而是在查看器中搜索'HitArea **',显示在列表中,并设定名称。(从Viewer中导出 model3.json)

 

眨眼和口形同步动作燃烧

导出动作时,可以将使用“眨眼”和“口形同步”设定的动作刻录(烘焙)到 Live2D 参数中。
由于“倍率”和“效果”的数据没有写入motion3.json,因此可以利用该功能在Viewer上完全再现动画的动作。

但是,如果需要进行调整,则需要再次导出motion3.json,所以要小心。
* 使用 OW Viewer 时,我们建议使用动作刻录功能进行眨眼和口形同步。


设定动作数据时,勾选“将口形同步和眨眼烘焙到动作”。
如何燃烧运动:

 

如果启用此项目,“口形同步”和“眨眼”将不会单独导出到motion3.json,因此该项目将显示为灰色。

 

在这种状态下,如果单击“确定”,则会显示自动眨眼和口形同步的设定中选中的参数。
它被刻录为关键帧并输出为motion3.json。

如果在应用“眨眼”或“口形同步”的参数中设定了关键帧,则该参数设定为
计算上述效果的曲线(眨眼时相乘,口形同步时加算)。

 

统计数据

您可以查看 moc3文件的统计信息。
点击moc3文件名→在下拉菜单中选择“统计”,显示目标版本等信息。

© 2010 - 2022 Live2D Inc.