创建 PSD 的注意事项

(2022 年 2 月10 日更新)

在这里,我们将解释如何创建可以与 Cubism Editor 一起使用的 PSD 和注意事项。
请在创建 PSD 之前检查此页面,或者在载入时是否无法正确加载。

请参阅“素材分离”页面,了解将插图分离成睫毛、睫毛、轮廓等各个部分的工作程序。

请查看“如何制作载入的 PSD”页面,了解制作载入 PSD 的过程。

 

保证工作的图片编辑应用程序

已确认以下两个图片编辑应用程序可以使用 Cubism Editor 正常加载 PSD。

・ Adobe Photoshop
・ Celsys  CLIP STUDIO  PAINT

由上述应用程序以外的其他应用程序创建的 PSD 可能无法正确加载。

 

创建 PSD 的注意事项

可以使用 Cubism Editor 正确载入的 PSD 必须满足以下条件。

・保存格式为[PSD]
・颜色模式为[RGB]
・颜色通道设定为[8bit/通道]

如果不满足这些条件中的任何一个,将无法进行载入。
此外,保存 PSD 以供载入时,还请检查以下几点。

・将颜色配置文件设置为 [sRGB]
・检查是否有同名图层
・设置组合后的图层属性为“通常”或“正片叠底”
・结合线条图和剪贴蒙版
・请勿使用图层蒙版
-[不透明度] 反映在 Cubism Editor 的 PSD 设定中,但 [Fill] 以100% 输出。

POINT
在插图制作阶段使用上述功能没有问题。

每个项目的详细信息在以下项目中进行说明。

 

关于保存格式

Cubism Editor 可以读取的唯一图片数据是 [PSD 格式]。
请务必将用作模型的图片数据保存为 PSD 格式。

POINT
作为例外,您可以导入 PNG 格式的图片。
这是一种图片格式,可用作建模参考图或动画背景。
您还可以使用从纹理集导出的 PNG 图片替换纹理(beta 功能)。

有关替换纹理(beta 功能)的详细信息,请参阅“替换 PNG 文件导出(beta)”。

 

关于色彩模式

Cubism Editor 可以读取的唯一 PSD 颜色模式是 [RGB]。
无法在 [Grayscale] 和 [CMYK] 等 [Non-RGB] 颜色模式下读取。

颜色模式转换方法

在 Photoshop 中选择 [图像] 菜单-> [模式]-> [RGB 颜色]。

 

关于颜色通道设定

Cubism Editor 唯一可以读取的 PSD 颜色通道是 [8bit / 通道]。
无法读取 [16bit/channel] 和 [32bit/channel] 等 [8bit/channel] 以外的颜色通道。

如何转换颜色通道

在 Photoshop 中选择 [图像] 菜单-> [模式]-> [8bit / Channel] 。

 

关于颜色配置文件

当“PSD 载入”时,如果 PSD 具有 sRGB 以外的颜色配置文件,它可能会变为非预期颜色。
因此,具有非 sRGB 配置文件的 PSD 需要在 Photoshop 中将其颜色配置文件转换为 sRGB。

颜色配置文件转换方法

在 Photoshop 中,选择 [编辑] 菜单  → [配置文件转换 (V)]。
(※注意事项: 它不是“指定配置文件”)

对于 CLIP STUDIO PAINT,选择 [显示] 菜单  → [色彩配置文件]  → [预览设定]。

如果“源色彩空间”是 sRGB(符合 IEC61966-2.1等),
由于原来是sRGB,所以不需要转换,所以取消。

如果“源颜色空间”不是 sRGB,请将“转换后的颜色空间”设定为 sRGB。

通常,标准设定很好,但请检查预览开/关。
如果颜色发生显着变化,请变更转换选项设定。

有关转换选项的详细说明,请参阅 Adobe Photoshop 手册。

检查是否有同名图层

基本上,相同的图层名称可以导入Cubism Editor,但如果有相同的图层名称,会造成混乱,给后期带来麻烦。
为了避免这样的麻烦,让我们在素材划分PSD阶段使用不同的图层名称。

 

设置合并后的图层属性为“通常”或“正片叠底”

在载入的 PSD 中,将所有图层的属性设置为“通常”或“正片叠底”
“通常”或“正片叠底”以外的图层属性可能会在导入时更改为意外颜色。

TIPS
图层属性可以在Cubism Editor上设定。
载入后,选择要变更的图形网格并设定[检查器]→[混合模式]。

・通常
・正片叠底 * 如果在 PSD 中设定为正片叠底,即使载入 Cubism Editor 也会自动设定为正片叠底。
・加算

您可以设定这三种类型。

 

[不透明度] 反映在 Cubism Editor 的 PSD 中设定的 % 中,但 [Fill] 以100% 输出。

如果在 PSD 中将 [不透明度] 设定为 50%,则即使将其载入 Cubism Editor,不透明度也会设定为 50%。
[Fill] 在 Cubism Editor 上不会再现,因此即使设定为 [50%],在 Cubism Editor 上也会设定为100%。
对于需要调整暗度的脸颊染色,建议使用[不透明度]而不是[填充]进行设定。

TIPS
也可以在Cubism Editor上设定不透明度。
载入后,选择要变更的图形网格并设定[检查器]→[不透明度]。

 

结合线条图和剪贴蒙版

在要载入的PSD中,一个部分放在一层上。
线条图、填充、滤镜效果、剪贴蒙版等都组合到每个部分的一个图层中。
即使您想将线条图和阴影分开,也可以在每个部分的一个图层中进行管理。

 

不要使用图层蒙版

如果图层蒙版保留在要载入的 PSD 中,则执行“应用图层蒙版”并将其合并为一层。

 

检查是否包含路径信息

如果路径信息包含在由 CC 2019 或更高版本的 Photoshop 创建的 PSD 中,则可能无法将其加载到 Cubism Editor 中。
如果包含路径信息,请在结合前将其删除。

 

当边缘出现在带有“跟踪软件”等的图形网格周围时。

使用跟踪软件进行检查时,有时会在图形网格的边缘绘制线条之类的东西。
* 在编辑器上绘制没有任何问题。

如下图所示,可以通过模糊图形网格的边缘来改善它,所以请尝试一下。

© 2010 - 2022 Live2D Inc.