PSD 생성상의 주의점

업데이트: 2022/02/10

여기에서는 Cubism Editor에서 사용할 수 있는 PSD 생성 방법과 주의점에 대해 설명합니다.
PSD를 작성하기 전이나 가져올 때 올바르게 로드되지 않는 경우에는 이 페이지를 확인해 주십시오.

일러스트를 속눈썹이나 눈알, 윤곽 등 부품별로 나누는 작업 순서에 대해서는 「소재 분류에 대해」를 봐 주세요.

가져오기 PSD를 만드는 작업 순서에 대해서는 「가져오기 PSD를 만드는 방법」을 봐 주세요.

동작 보증하는 이미지 편집 응용 프로그램

Cubism Editor에서 PSD를 정상적으로 로드할 수 있는 것으로 확인된 이미지 편집 응용 프로그램은 다음 두 가지입니다.

  • Adobe Photoshop
  • Celsys CLIP STUDIO PAINT

위 응용프로그램 이외에서 작성된 PSD에 대해서는 제대로 로드되지 않을 수 있습니다.

PSD 작성상의 주의

Cubism Editor에서 올바르게 가져올 수 있는 PSD는 다음 조건을 충족해야 합니다.

  • 저장 형식이 [PSD]인 것
  • 컬러 모드가 [RGB]인 것
  • 컬러 채널의 설정이 [8bit/채널]인 것

이러한 조건이 하나라도 충족되지 않으면 가져올 수 없습니다.
또한 가져오기용 PSD를 보존할 때에는 이하의 점도 아울러 확인해 주십시오.

  • 컬러 프로파일을 [sRGB]로 설정
  • 같은 이름의 레이어가 없는지 확인
  • 결합 후의 레이어 속성은 「일반」 또는 「곱하기」로 한다
  • 선화나 클리핑 마스크를 결합
  • 레이어 마스크를 사용하지 않는다
  • [불투명도]는 PSD에서의 설정이 Cubism Editor에도 반영되지만, [채색]은 100%로 출력된다
Point

일러스트 제작 단계에서는 위 기능의 사용은 문제 없습니다.

각각의 상세에 대해서는 이하의 항목에서 해설합니다.
※이 페이지에서는 포토샵의 경우에 대해 해설합니다.

저장 형식 정보

Cubism Editor에서 읽을 수 있는 이미지 데이터는 [PSD 형식]뿐입니다.
모델로 사용할 이미지 데이터는 반드시 PSD 형식으로 저장하십시오.

Point

예외로 PNG 형식의 이미지를 로드할 수 있습니다.
이것은 모델링 시의 밑그림이나 애니메이션 배경 등에 사용할 수 있는 이미지 형식입니다.
또한 텍스쳐 아틀라스에서 내보낸 PNG 이미지를 이용하여 텍스쳐 교체(beta 기능)를 할 수 있습니다.

텍스쳐 교체(beta 기능)에 대한 자세한 내용은 「PNG 파일 내보내기/교체(beta)」를 참조하십시오.

컬러 모드 정보

Cubism Editor에서 읽을 수 있는 PSD의 컬러 모드는 [RGB]뿐입니다.
[그레이스케일]이나 [CMYK] 등 [RGB 이외]의 컬러 모드는 읽을 수 없습니다.

컬러 모드 변환 방법

Photoshop의 [이미지] 메뉴 → [모드] → [RGB 색상]을 선택합니다.

컬러 채널 설정 정보

Cubism Editor로 불러올 수 있는 PSD의 컬러 채널은 [8bit/채널]뿐입니다.
[16bit/채널]이나 [32bit/채널] 등 [8bit/채널 이외]의 컬러 채널은 읽을 수 없습니다.

컬러 채널 변환 방법

Photoshop의 [이미지] 메뉴 → [모드] → [8bit/채널]을 선택합니다.

컬러 프로파일 정보

「PSD 가져오기」시 PSD에 sRGB 이외의 컬러 프로파일이 설정되어 있으면 의도하지 않는 색으로 변화하는 경우가 있습니다.
따라서 sRGB 이외의 프로파일이 설정된 PSD는 Photoshop에서 컬러 프로파일을 sRGB로 변환해야 합니다.

컬러 프로파일 변환 방법

Photoshop에서 [편집] 메뉴 → [프로파일 변환(V)]을 선택합니다.
(※ 주의: 「프로파일 지정」이 아닙니다)

CLIP STUDIO PAINT의 경우 [표시] 메뉴 → [컬러 프로파일] → [미리보기 설정]을 선택합니다.

「소스 컬러 스페이스」가 sRGB(IEC61966-2.1 등이 붙습니다)로 되어 있는 경우
원래 sRGB로 되어 있어 변환은 필요 없기 때문에 취소해 주세요.

「소스 컬러 스페이스」가 sRGB 이외로 되어 있을 경우 「변환 후의 컬러 스페이스」를 sRGB 로 설정합니다.

일반적으로 표준 설정으로 문제가 없지만 미리보기의 체크를 ON/OFF해서
색상이 크게 바뀌는 경우 변환 옵션 설정을 변경하십시오.

변환 옵션에 대한 자세한 내용은 Adobe Inc.의 Photoshop 매뉴얼을 참조하십시오.

같은 이름의 레이어가 없는지 확인

기본적으로 동일한 레이어 이름이라도 Cubism Editor로 가져올 수 있지만 동일한 레이어 이름이 있으면 혼란이 발생하여 나중에 문제를 일으킬 수 있습니다.
이러한 트러블을 피하기 위해서 소재 분류 PSD의 단계에서 모두 다른 레이어명으로 해 둡시다.

결합 후의 레이어 속성은 「일반」 또는 「곱하기」로 한다

가져올 PSD는 모든 레이어의 속성을 「일반」 또는 「곱하기」로 설정합니다.
「일반」 또는 「곱하기」 이외의 레이어 속성은 로드 시 의도하지 않은 색상으로 변경될 수 있습니다.

Tips

레이어 속성은 Cubism Editor에서 설정할 수 있습니다.
가져오기 후 변경할 아트메쉬를 선택하고 [인스펙터] 팔레트 → [블렌드 방식]을 설정합니다.

  • 일반
  • 곱하기 ※PSD에서 곱하기로 설정되어 있으면 Cubism Editor로 가져왔을 때도 자동으로 곱하기로 설정됩니다.
  • 가산

이 세 가지 유형을 설정할 수 있습니다

[불투명도]는 PSD에서 설정한 %가 Cubism Editor상에서도 반영되지만, [채색]은 100%로 출력된다

[불투명도]는 PSD에서 50% 등으로 설정되어 있는 경우 Cubism Editor로 가져올 때도 불투명도는 50%로 설정됩니다.
[채색]은 Cubism Editor에서는 재현되지 않으므로 [50%] 등으로 설정되어 있어도 Cubism Editor에서는 100%로 설정됩니다.
농도를 조정할 필요가 있는 뺨 물들이기 등에서는 [채색] 대신 [불투명도]로 설정하는 것이 좋습니다.

Tips

불투명도는 Cubism Editor에서도 설정할 수 있습니다.
가져오기 후 변경할 아트메쉬를 선택하고 [인스펙터] 팔레트 → [불투명도]를 설정합니다.

선화나 클리핑 마스크를 결합해 둔다

가져올 PSD는 하나의 레이어에 하나의 부품을 배치합니다.
부품별로 선화나 채색, 필터 효과, 클리핑 마스크 등을 모두 결합하여 하나의 레이어로 만듭니다.
선화나 그림자 등을 나누고 싶은 경우도 1개의 부품당 1개의 레이어로 관리합시다.

레이어 마스크를 사용하지 않는다

가져오는 PSD에 레이어 마스크가 남아 있는 경우 「레이어 마스크 적용」을 실행해 1개의 레이어로 정리해 둡니다.

패스 정보가 포함되어 있지 않은지 확인

Photoshop의 CC2019 이상 버전에서 만든 PSD에 패스 정보가 포함되어 있으면 Cubism Editor로 로드할 수 없게 될 수 있습니다.
패스 정보 등이 포함되어 있는 경우 결합 전에 미리 삭제하도록 합시다.

「트래킹 소프트웨어」 등에서 아트메쉬 주위에 테두리가 나오는 경우

트래킹 소프트 등으로 확인했을 때 아트메쉬의 가장자리에 선과 같은 것이 그려져 버리는 경우가 있습니다.
※에디터상에서는 문제없이 그려져 있음.

아래 그림과 같이 아트메쉬의 가장자리를 흐리게하면 개선될 수 있으므로 시도해 보십시오.

이 기사에 관한 의견 및 요청사항을 보내 주시기 바랍니다.