PSD作成上の注意点

(2020/07/03 更新)

ここでは、Cubism Editorで使用できるPSDの作成方法と注意点について解説します。
PSD作成の前や、インポート時に正しく読み込まれない場合にはこのページをご確認ください。

イラストをまつげや目玉、輪郭などを部品ごとに分ける作業手順については「素材分けについて」のページをご確認ください。

インポートPSDを作る作業手順ついては「インポートPSDの作り方」のページをご確認ください。

 

動作保証している画像編集アプリケーション

Cubism EditorでPSDが正常に読み込めることが確認されている画像編集アプリケーションは以下の2つです。

・Adobe Photoshop
・Celsys CLIP STUDIO PAINT

上記のアプリケーション以外で作成されたPSDについては正しく読み込まれない可能性があります。

 

PSD作成上の注意

Cubism Editorで正しくインポートを行うことができるPSDは、以下の条件が満たされている必要があります。

・保存形式が[PSD]であること
・カラーモードが[RGB]であること
・カラーチャンネルの設定が[8bit/チャンネル]であること

これらの条件が一つでも満たされていない場合、インポートを行うことができません。
また、インポート用のPSDを保存する際には以下の点も併せてご確認ください。

・カラープロファイルを[sRGB]にする
・同じ名前のレイヤーが無いか確認する
・結合後のレイヤー属性は「通常」か「乗算」にする
・線画やクリッピングマスクを結合する
・レイヤーマスクを使用しない
・[不透明度]はPSDでの設定がCubism Editor上にも反映されるが、[塗り]は100%で出力される

POINT
イラスト制作の段階では上記の機能の使用は問題ありません。

それぞれの詳細については以下の項目で解説します。

 

保存形式について

Cubism Editorで読み込める画像データは[PSD形式]のみです。
モデルとして使用する画像データは必ずPSD形式で保存してください。

POINT
例外として、PNG形式の画像を読み込むことができます。
これはモデリング時の下絵や、アニメーションの背景などに使用できる画像形式です。
また、テクスチャアトラスから書き出したPNG画像を利用してテクスチャの差し替え(β機能)を行うことができます。

テクスチャの差し替え(β機能)についての詳細は「PNGファイルの書き出し差し替え(β)」をご覧ください。

 

カラーモードについて

Cubism Editorで読み込めるPSDのカラーモードは[RGB]のみです。
[グレースケール]や[CMYK]など、[RGB以外]のカラーモードでは読み込むことができません。

カラーモードの変換方法

Photoshopの[イメージ]メニュー →[モード]→[RGBカラー] を選択します。

 

カラーチャンネルの設定について

Cubism Editorで読み込めるPSDのカラーチャンネルは[8bit/チャンネル]のみです。
[16bit/チャンネル]や[32bit/チャンネル]など、[8bit/チャンネル以外]のカラーチャンネルでは読み込むことができません。

カラーチャンネルの変換方法

Photoshopの[イメージ]メニュー →[モード ]→[8bit/チャンネル] を選択します。

 

カラープロファイルについて

「PSDインポート」の際、PSDに sRGB 以外のカラープロファイルが設定されていると、意図しない色に変化する場合があります。
そのため、sRGB 以外のプロファイルが設定されているPSDは、Photoshopでカラープロファイルを sRGB に変換する必要があります。

カラープロファイルの変換方法

Photoshopの、[編集]メニュー →[プロファイル変換 (V) ] を選択します。
(※ 注意: 「プロファイルの指定」ではありません)

CLIP STUDIO PAINTの場合は、[表示]メニュー →[��ラープロファイル] →[プレビューの設定]を選択します。

「ソースカラースペース」が sRGB (IEC61966-2.1 などが付きます) となっている場合は、
元々 sRGB になっているため変換は必要ありませんので、キャンセルして下さい。

「ソースカラースペース」が sRGB 以外になっていた場合は、「変換後のカラースペース」を、 sRGB に設定します。

通常は標準の設定で問題ありませんが、プレビューのチェックをON / OFF して
色が大きく変わるような場合は変換オプションの設定を変更して下さい。

変換オプションの詳しい解説は アドビ株式会社の Photoshop のマニュアルをご覧ください。

同じ名前のレイヤーが無いか確認する

基本的に同じレイヤー名でもCubism Editorに取り込むことができますが、同じレイヤー名があると混乱が生じ、後々トラブルの原因になります。
こうしたトラブルを避けるために、素材分けPSDの段階で全て違うレイヤー名にしておきましょう。

 

結合後のレイヤー属性は「通常」か「乗算」にする

インポートするPSDではすべてのレイヤーの属性を「通常」か「乗算」にします。
「通常」か「乗算」以外のレイヤー属性は読み込み時に意図しない色に変化する可能性があります。

TIPS
レイヤー属性はCubism Editor上で設定することができます。
インポート後、変更したいアートメッシュを選択し、[インスペクタ]パレット→[ブレンド方式]の設定を行います。

・通常
・乗算 ※PSDで乗算に設定されていれば、Cubism Editorにインポートされた際も自動で乗算に設定されます。
・加算

これらの3種類を設定することができます。

 

[不透明度]はPSDで設定した%がCubism Editor上でも反映されるが、[塗り]は100%で出力される

[不透明度]はPSDで50%などに設定されていた場合、Cubism Editorにインポートされた際も不透明度は50%に設定されます。
[塗り]はCubism Editor上では再現されないため、[50%」などに設定されていた場合でも、Cubism Editor上は100%に設定されます。
濃さを調整する必要がある頬染めなどでは、[塗り]ではなく[不透明度]で設定することをおすすめします。

TIPS
不透明度はCubism Editor上でも設定することができます。
インポート後、変更したいアートメッシュを選択し、[インスペクタ]パレット→[不透明度]の設定を行います。

 

線画やクリッピングマスクを結合しておく

インポートするPSDでは1つのレイヤーに一つの部品を配置します。
部品ごとに線画や塗り、フィルター効果、クリッピングマスクなどをすべて結合して、1つのレイヤーにします。
線画や影などを分けたい場合も1つの部品につき1つのレイヤーで管理しましょう。

 

レイヤーマスクを使用しない

インポートするPSDにレイヤーマスクが残っている場合は、「レイヤーマスクを適用」を実行し、1つのレイヤーにまとめておきます。

 

パス情報が含まれていないか確認する

PhotoshopのCC2019以降のバージョンで作成したPSD内にパス情報が含まれると、Cubism Editorへの読み込みができなくなる場合があります。
パス情報などが含まれている場合は、結合前にあらかじめ削除するするようにしましょう。

© 2010 - 2021 Live2D Inc.