ビューエリアについて

最終更新: 2022年5月19日

ビューエリアは、Live2Dのモデルが表示されるエリアです。
アートメッシュを選択したりキャンバスに配置したり、メッシュやデフォーマを動かす際に使用します。

ビューについて

ビューには大きく分けて以下のタイプがあります。

モデリングビュー

オブジェクトを変形し、キーフォームを作成する際に使用します。
アートメッシュの編集やパラメータの作成もこのビューで行います。

アニメーションビュー

シーンを作成したり、タイムライン上でキーフレームを打ってモーションを作る際に使用します。
モデルファイルを読み込み、設定したパラメータを動かしながらアニメーションを作成します。

フォームアニメーション(FA)ビュー

フォームアニメーションを作成する際に使用します。
フォームアニメーションとは、モデルデータに影響を与えることなくアニメーション編集のタイムライン上で形状(フォーム)を直接編集できる機能です。

Cubism Editorには、それぞれのビューごとに適したワークスペースがあります。
ワークスペースの詳細については『ワークスペース』のページをご参照ください。

ビューエリアの機能

ここでは、ビューエリア内の各機能について説明していきます。

A.モデリングビュー

DE についての説明はページ下部のそれぞれの説明をご参照ください。

番号 詳細
 ①

【タブについて】

  • タブは複数作成することができ、 ドラッグアンドドロップで それぞれのビューに 自由に移動できます。
  • パラメータは フォーカスしているタブごとに キーフォームの現在値を保持しています。
  • [ウィンドウ]メニュー → [すべてのビューの表示位置を合わせる]を選択すると、すべてのビューの表示位置を合わせることができます。(ショートカットに対応)
  • [ウィンドウ]メニュー → [前のタブに切り替え]または[次のタブに切り替え]を選択すると、選択状態のタブから前後のタブに切り替えます。(ショートカットに対応)

     

    最初のタブが選択状態の時、 [前のタブに切り替え] を実行すると最後のタブへ、最後のタブが選択状態の時、 [次のタブに切り替え] を実行すると最初のタブに切り替えます。

  • タブの右クリックメニューは以下になります。(タブの上で右クリック)

     

    タブを複製:
    選択中のタブを複製します。

    タブを閉じる:
    選択中のタブを閉じます。

    このタブ以外を閉じる:
    選択中のタブ以外を全て閉じます。

    すべてを閉じる:
    タブを全て閉じます。

    エクスプローラで開く:
    選択中のデータが格納されているフォルダを開きます。

タブの削除:
タブの右端にある[×]ボタンを押下すると、選択中のタブを消すことができます。
番号詳細
 ①
描画オブジェクトのロック:
メッシュのみを表示/非表示にしてビュー上でロックすることができます。
オブジェクトはそのまま表示されます。
描画オブジェクトは[アートメッシュ][アートパス]が対象になります。
 ②
デフォーマのロック:
デフォーマのみを表示/非表示にしてビュー上でロックすることができます。
 ③
描画オブジェクトの表示/非表示:
描画オブジェクトを表示/非表示にしてビュー上でロックすることができます。
 ④
グリッドの表示/非表示:
グリッドの表示/非表示を切り替えることができます。
 ⑤
Solo
選択したオブジェクトを単体で表示できます。
 ⑥
グルー状態のオン/オフ切り替え:
グルーで連結(バインド)されている状態を一時的に解除したり、連結し直したりできます。
番号詳細

スナップショット
現在値のキーフォームの画像を半透明で記憶します。
スナップショットは1つ保存可能です。

スナップショットの表示/非表示:
記憶されているスナップショットを表示したり非表示にしたりできます。
 ③
スナップショットの保存:
スナップショットをパーツパレットに画像とし保存します。

 録画ボタン
録画ボタンをクリックするとビュー内の右下に「Recording…」と表示され、その間に動かしたパラメータがキーフレームとして保存されます。
(ランダムポーズ時のモーションもキーフレームとして保存できます)

【録画設定】
[録画]機能で生成されたシーンの追加先を選択できます。


 新しいアニメーションデータを生成:
新しくアニメーションデータ(can3)を作成します。

現在のアニメーションデータに追加:
現在紐づいているアニメーションデータ(can3)にシーンを追加します。

ランダムポーズ:
複数のパラメータを ランダムに動かします。
動きのパターンは⑦[ランダムポーズメニュー]から選択できます。 詳しくは「ランダムポーズ」のページをご参照ください。

ランダムポーズメニュー:  
ランダムに動かすパターンを選択します。
動かしたいパラメータは[設定]から選択することも可能です。
詳しくは「ランダムポーズ」のページをご参照ください。

※ランダムポーズ、ランダムA、ランダムBは [物理演算・シーンブレンド] ダイアログで再生できます。

B.アニメーションビュー

Eについての説明はページ下部のそれぞれの説明をご参照ください。

番号詳細
タブ:
※「タブについて」「タブメニューについて」はモデリングビューと同じです。
タブの削除:
タブの右端にある[×]ボタンを押下するとタブを消すことができます。

C.フォームアニメーション(FA)ビュー

DEについての説明はページ下部のそれぞれの説明をご参照ください。

番号詳細
 ①タブ:
※「タブについて」「タブメニューについて」はモデリングビューと同じです。
タブの削除:
タブの右端にある[×]ボタンを押下するとタブを消すことができます。

ラベル:
フォーム編集されたオブジェクトのラベルの表示/非表示を切り替えることができます。

アニメーションプレビューの表示/非表示:
アニメーションプレビューの表示/非表示を切り替えることができます。

D.描画オブジェクトの描画順スライダー

番号詳細
描画順スライダー:
描画オブジェクトやパーツを選択した際、描画順スライダー上に描画順を示すバーが表示されます。
バーをドラッグすることで描画順を変更することも可能です
描画オブジェクトを選択した場合、バーは赤色で表示されます。
パーツを選択した場合、バーは黄色で表示されます。
描画順グループを選択した場合、バーは黒色で表示されます。

描画オブジェクトに描画順を設定する方法については『描画順について』のページをご参照ください。

E.ビューの制御

番号詳細

背景色の変更:
ビュー内にあるキャンバスの背景色や不透明度を変更、調整できます。

表示倍率の数値制御:
数値入力での指定と左右のドラッグによる拡縮ができます。

拡縮スライダー:
描画倍率は「2」~「3200」までを調整できます。
両脇の[-][+]アイコンをクリックすると段階的に拡縮できます。

原寸表示:
PSDインポート時の原寸で表示できます。

全体表示:
キャンバス全体を表示できます。

フォーカス表示:
選択したオブジェクトがビューの中央に表示されます。

キャンバスの反転:
キャンバスを左右に反転します。

マルチビュー設定:
ビューを分割表示する際のレイアウトを選択できます。

ディバイダ:
この部分をドラッグすると、画面の大きさを自由に変更できます。

ビューエリアの基本操作

操作 詳細
マウスホイールスクロール キャンバスが拡大縮小します。
[Ctrl +[Space]+[ドラッグ]で1%ずつ拡大・縮小
[Space]+[ドラッグ] キャンバスを移動させることができます。
[Space]+[Shift]+[ドラッグ] 最初に動かした方向にキャンバスを平行移動させることができます。
[Ctrl]+[Space]+[ドラッグ] キャンバスを拡縮させることができます。
[R] キャンバスを左右に反転できます。
R+ドラッグ キャンバスを回転できます。
R+Shift+ドラッグ キャンバスをグリッドで回転できます。
R+ダブルクリック キャンバスの回転を0°にリセットできます。
Ctrl+0  全体表示させることができます。
※拡縮や回転したキャンバスを元に戻します
 オブジェクトの選択  オブジェクトをクリックすると選択状態になります。
Shift+クリックで複数の描画オブジェクト選択します。
対象のオブジェクトの上で右クリック

 コンテキストメニューを開きます。

メニューの上部にはオブジェクトの親子階層がツリー表示され選択することができます。

対象のアートメッシュの上で
[Ctrl]+[右クリック]

 アートメッシュのポップリストを呼出します。

 アートメッシュ・デフォーマ選択後
[Delete]キー
 選択したアートメッシュ・デフォーマを削除します。

[E]キー +[ドラッグ]でキャンバスの3D表示

[W]キー +[ドラッグ]で描画順の3D表示

[E]キー/[W]キー+[ダブルクリック]で
各3D表示をリセット

[E]キー +[ドラッグ]でキャンバスを3D表示し、更に[W]キー +[ドラッグ]で描画順を3D表示し視覚的に全体の描画順を確認することができます。

このモードは[全体表示]にすることで元に戻ります。

注意事項
描画順グループを使用しているパーツは、3D表示時に設定が反映されませんのでご注意下さい。

[表示]メニュー→[選択状態を隠す]をクリック

キャンバス上でオブジェクトを選択したとき、UI(アートメッシュの頂点やメッシュの線、デフォーマの枠の線)が非表示になります。

[表示状態を隠す]:OFF [表示状態を隠す]:ON

ショートカットも設定できます。

マルチビュー

ビューエリアの右下にある「マルチビュー」のアイコンをクリックすると、思い通りの配置でビューを複数表示できるようになります。
ビューエリア内は、タブも移動したり追加・削除が可能です

マルチビューの詳細については『マルチビュー』をご参照ください。

※PRO版の限定機能です

モデルの複数表示

エディタ内に複数のモデルを読み込み、同時に表示することもできます。

この記事に関するご意見・
ご要望をお聞かせください。