About the View Area

(Updated 05/19/2022)

The view area is the area where the Live2D model is displayed.
Used to select and place ArtMesh on the canvas and to move meshes and deformers.

 

About View

Views can be broadly classified into the following types.

 

Modeling view

Used to transform objects and create key forms.
Editing ArtMesh and creating parameters are also done in this view.

 

Animation View

It is used to create scenes and keyframe motion on the timeline.
Load a model file and create an animation by moving the parameters you set.

 

Form Animation (FA) View

Used to create form animations.
Form animation is the ability to edit a shape (form) directly on the animation editing timeline without affecting the model data.

The Cubism Editor has a suitable workspace for each view.
For more information on workspaces, please refer to the “Workspaces“ page.

 

View Area Features

This section describes each function within the view area.

 

A. Modeling view

Please refer to the respective explanations for D/E  at the bottom of this page.

Number Details
 (1)

[About Tabs]

  • Multiple tabs can be created, and each view can be moved freely by drag and drop.
  • The parameter holds the current value of the key form for each tab in focus.
  • Select [Window] menu -> [Set All Views to Same Display Position] to align all views. (Supports shortcuts)
  • Select [Window] menu -> [Switch to Previous Tab] or [Switch to Next Tab] to switch from the selected tab to the previous or next tab. (Supports shortcuts)

    When the first tab is selected, [Switch to Previous Tab] switches to the last tab, and when the last tab is selected, [Switch to Next Tab] switches to the first tab.

  • The right-click menu for tabs is shown below. (Right click on the tab)

    Duplicate Tab:
    Duplicates the currently selected tab.

    Close Tab:
    Closes the currently selected tab.

    Close all tabs except the current one:
    Close all tabs except the currently selected one.

    Close All:
    Close all tabs.

    Open in Explorer:
    Open the folder where the currently selected data is stored.

(2) Delete tabs:
Click the [X] button at the right end of a tab to erase the currently selected tab.

 

Number Details
 (1)
Lock Drawable Object:
Only meshes can be shown/hidden and locked on the view.
Objects are displayed as they are.
The drawing objects are [ArtMesh] and [ArtPath].
 (2)
Lock Deformer:
Only deformers can be shown/hidden and locked on the view.
 (3)
Show/hide drawing objects:
Drawing objects can be shown/hidden and locked on the view.
 (4)
Show/Hide Grid: Show/Hide the grid:
You can show/hide the grid.
 (5)
Solo:
Selected objects can be displayed by themselves.
 (6)
Switch Glue on/off:
The glue can be used to temporarily release or reconnect the glued (bound) state.

 

Number Details
 (1)
Snapshot:
Memorize the keyform image of the current value in semi-transparent form.
One snapshot can be saved.
 (2)
Show / Hide Snapshots:
You can show or hide the stored snapshots.
 (3)
Save Snapshot:
Save the snapshot as an image in the Parts palette.
 (4)

 Recording Button:
Clicking the Record button displays “Recording...” in the lower right corner in the view, and the parameters you moved during that time are saved as keyframes.
(Motion during random poses can also be saved as keyframes.)

 (5)
[Recording Settings]
You can select where to add scenes generated by the [Record] function.

  

Generate new animation data:
Create new animation data (can3).

Add to current animation data:
Add a scene to the animation data (can3) currently associated with it.

 (6)
Random Pose:
Randomly moves multiple parameters.
Movement patterns can be selected from (7) [Random Pose Menu].

For details, please refer to the “Random Pose” page.

 (7)

Random Pose Menu:


Select a pattern to move randomly.
The parameter you want to move can also be selected from [Setting].
For details, please refer to the “Random Pose” page.

* Random Pose, Random A, and Random B can be replayed in the [PHYSICS/SCENE BLENDING] dialog.

 

B. Animation View

See the respective descriptions at the bottom of the page for an explanation of E.

Number Details
 (1) Tab:
* “About Tabs” and “About Tab Menu” are the same as in Modeling View.
(2) Delete tabs:
Click the [X] button at the right end of the tab to erase the tab.

 

C. Form Animation View

Please refer to the respective explanations for D/E at the bottom of this page.

Number Details
 (1) Tab:
* “About Tabs” and “About Tab Menu” are the same as in Modeling View.
(2) Delete tabs:
Click the [X] button at the right end of the tab to erase the tab.
(3)
Label:
You can show or hide the labels of form-edited objects.
(4)
Show/hide animation previews:
You can show/hide the animation preview.

 

D. Drawing order slider for drawing objects

Number Details
(1) Drawing order slider:
When a drawing object or part is selected, a bar indicating the drawing order is displayed on the drawing order slider.
You can also change the drawing order by dragging the bar.
(2) When a drawing object is selected, the bar is displayed in red.
(3) When a part is selected, the bar will appear yellow.
(4) When a drawing order group is selected, the bar is displayed in black.

For information on how to set the drawing order for drawing objects, please refer to the “About Drawing Order” page.

 

E. View Control

Number Details
(1)
Change Background Color:
You can change or adjust the background color and opacity of the canvas in the view.
(2)
Numerical control of display magnification:
The size can be specified by entering a numerical value or by dragging left or right.
(3)
Expansion and contraction sliders:
The drawing magnification can be adjusted from “2” to “3200”.
Clicking the [-] and [+] icons on either side of the screen allows you to zoom in and out in steps.
(4)
Display as original size:
The image can be displayed in its original size at the time of PSD import.
(5)
Display All:
The entire canvas can be displayed.
(6)
Focus display:
The selected object appears in the center of the view.
(7)
Canvas Inversion:
Flip the canvas left or right.
(8)
Multiview Settings:
You can select the layout for split views.
(9)
Divider:
Drag this area to change the screen size freely.

 

Basic operation of view area

Operation Details
Mouse wheel scroll The canvas expands and contracts.
[Ctrl] + [Space] + [Drag] to zoom in or out by 1%
[Space] + [Drag] The canvas can be moved.
[Space] + [Shift] + [Drag] You can translate the canvas in the direction you first moved it.
[Ctrl] + [Space] + [Drag] The canvas can be expanded or contracted.
[R] The canvas can be flipped left or right.
[R] + [drag] The canvas can be rotated.
[R] + [Shift] + [Drag] The canvas can be rotated in a grid.
[R] + [Double-click] Can reset the canvas rotation to 0°.
[Ctrl] + [0]  It can be displayed in its entirety.
* Undo a canvas that has been scaled or rotated.
 Object Selection  Click on an object to make it selected.
[Shift] + [Click] selects multiple drawing objects.
[Right-click] on the object in question

 Open the context menu.

At the top of the menu, a tree view of the object's parent-child hierarchy is displayed for selection.

On the target ArtMesh
[Ctrl] + [right click]

 Calls the ArtMesh pop list.

 After ArtMesh deformer selection
[Delete] key
 Deletes the selected ArtMesh deformer.

[E] key + [drag] to display the canvas in 3D

[W] key + [drag] for 3D display of drawing order

[E] key/[W] key + [double-click]to
reset each 3D display

The [E] key+[drag] displays the canvas in 3D, and the [W] key + [drag] displays the drawing order in 3D, allowing the user to visually check the overall drawing order.

This mode can be restored by changing the mode to [Display All].

Precautions
Please note that parts using drawing order groups will not have their settings reflected in the 3D display.

Click[View] menu -> [Hide selected state].

When an object is selected on the canvas, the UI (ArtMesh vertices and mesh lines, deformer border lines) are hidden.

[Hide Display State]: OFF [Hide Display State]: ON

Shortcuts can also be set.

 

multiview

Clicking the “multi-view” icon in the lower right corner of the view area allows you to display multiple views in the arrangement you desire.
Tabs can also be moved, added, and deleted within the view area

For more information on MultiView, please refer to “MultiView”.

* This is a limited function of the PRO version.

 

 

Multiple model displays

Multiple models can be loaded into the editor and displayed simultaneously.

 

 

© 2010 - 2022 Live2D Inc.