Cubism Viewer (for OW)について

(2022/05/19 更新)

Cubism Viewer (for OW)は、Cubismで作成したデータの検証のみを目的としたビューアです。
モデルの表示の他、物理演算や視線追従、複数のモーションの再生等を確認することが出来ます。

Cubism2.1に近い運用形態を「オリジナルワークフロー( Original Workflow )」と呼びます。
Cubism Viewer (for OW)では、Cubism2.1で使用されていたパラメータフェードを使用した腕などの
ポーズ切り替えや表情の作成ができるようになります。
これにより、表情設定、ポーズ設定、モーションリスト等をCubism2.1に近い形で利用することができます。

Cubism Viewerで扱えるモデルやモーションは、組み込み用に書き出されたデータです。
編集用の.cmo3、.can3は扱うことができませんのでご注意ください。

 

Cubism Viewer (for OW)の画面について

番号 項目 詳細
メニューエリア モデルの読み込みやパラメータの操作、モーションの再生などを行うメニューが表示されます。
表示するメニューは、上部にあるドロップダウンから選択します。
リソースエリア 読み込まれたデータやCubism Viewer上で作成されたデータはここに表示されます。
設定項目エリア

表情設定ファイルやモーションファイルに関する設定を変更・確認できます。
設定した内容は、モデル設定ファイルに保存することが可能です。
[ファイル]メニュー →[書き出し]→[モデル設定(model3.json)]

モデル表示エリア

読み込まれたモデルはここに表示されます。モデルを移動や拡縮することができます。
[表示]メニューより設定をすることで、背景色の変更や背景を透過してモデルを表示、当たり判定の表示をすることができます。

 

Cubism Viewer ( for OW )の起動方法

Cubism Viewer(for OW)はCubism Editorのインストーラに同封されています。
展開後は、実行ファイルと同じ階層に配置されていますので、下図の赤枠の部分から起動します。

起動後は、読み込み用のダイアログに .moc3 または .model3.jsonファイルをドロップすることでViewerが立ち上がります。

 

[ファイル]メニュー →[言語]から表示する言語を切り替えることができます。 

番号 項目 詳細
言語の切り替え [日本語][英語][韓国語][中国語]から選択できます。
インストール時の言語に戻す(Windows版) インストール時選択した言語に切り替わります。
OSのシステム言語に戻す(macOS版) OSの言語を参照するようになります。

以下、言語設定時の仕様になります。

・言語は設定後にエディタを再起動すると切り替わります。
・言語の設定は同じマイナーバージョン(4.2系など)のエディタ内で共有されます。
・エディタの[設定]メニューから行う言語の切り替えは、インストール時の設定やOSの設定よりも優先されます。

 

基本的な組込みデータの作成方法

Cubism2.1 Viewer ( for OW )※従来のViewer   Cubism Viewer ( for OW )

Modelerからmocファイル書き出しを実行

【書き出されるファイル】
・テクスチャファイル(.png)
・mocファイル(.moc)
・モデルファイル(.model.json)

 

Modelerからmoc3ファイル書き出しを実行

【書き出されるファイル】
・テクスチャファイル(.png)
・moc3ファイル(.moc3)
・モデルファイル(.model3.json)
※物理演算設定(.physics3.json)のリンクを含む

 

Animatorから「モーションデータを出力」

【書き出されるファイル】
・モーションファイル(.mtn)

 

Animatorから「モーションファイル書き出し」

【書き出されるファイル】
・モーションファイル(.motion3.json)

 
Viewerへ以下のファイルを読み込む
・mocファイル(.moc)
・書きだし出したモーション(.mtn)ファイル
  Viewerへ以下のファイルを読み込む
・moc3ファイル(.moc3)  ※.model3.jsonでもよい

⇒ファイルが読み込まれViewerが立ち上がる

・書き出したモーション(.motion3.json)ファイル

 
Viewerで設定を行う
・ポーズ設定(.pose.json)
・物理演算設定(.physics.json)
・表情設定(.exp.json)
  Viewerで設定を行う
・ポーズ設定(.pose3.json)
・表情設定(.exp3.json)

【注意点】
⇒Viewer上で設定されたファイルには名前の右上にアスタリスクが付きます。

 
モデル設定ファイルの書き出し
・モデル設定ファイル (.model.json)
  モデル設定ファイルの書き出し
・モデル設定ファイル (.model3.json)

【注意点】
⇒出力時CubismEditorから出力した (.model3.json)に上書きすると、Viewerで作成されたファイル(アスタリスクがついたもの)も一緒に保存されます。

TIPS
Cubism3以降では、物理演算設定(physics3.json)はCubismEditor側で行うため、Viewer上では名前のみツリーに表示されます。

 

メニュー

ファイルメニュー

項目 詳細
追加 表情:
表情用のモーションを追加します。
設定項目エリア内で表情を設定したいパラメータにチェックを入れ、パラメータを調整します。

ポーズ:
モデルやモーションで作成した腕の切り替えの仕組みを反映させるための json 形式の設定ファイルを作成します。
詳しい操作方法は「ポーズの設定」のページをご覧ください。
読み込み 表情用モーション(motion3.json / exp3.json):
アニメーション工程で書き出した表情用の[motion3.json]をCubism Viewerに読み込みます。
書き出し

モデル設定(model3.json):
Cubism Viewerで設定した内容をjson形式のファイルで書き出します。
ショートカットキー[Ctrl]+[S]

全ての表情モーション:
全ての表情用のモーションを json形式のファイルで書き出します。
詳しい説明は「表情の設定と書き出し」のページをご覧ください。

ポーズ:
ポーズ切り替えの設定を json形式の設定ファイルで書き出します。
詳しい説明は「ポーズの設定」のページをご覧ください。

設定 デフォルトの表情名に拡張子を含める:
表情を追加する際に、デフォルトの表情名に拡張子を含めます。

編集メニュー

項目 詳細
パラメータをデフォルト値に戻す  パラメータをデフォルト値に戻します。
モーションの停止  再生中のモーションを停止します。
差分比較  2つのmoc3データの情報をViewer上で比較確認することができます。
詳細は「2つのmoc3データ情報の比較」をご覧ください。

表示メニュー

項目 詳細
当たり判定の表示  設定した当たり判定を表示します。
ミップマップを有効にする  ミップマップを有効にします。
※基本的にチェックを入れておくことをお勧めします
背景透過(β)  背景を透過してモデルを表示します。
背景色の設定  背景色を設定します。
フレームレートの表示  モデル表示エリアの右上にフレームレートを表示します。

アニメ―ションメニュー

項目 詳細
表情を有効にする  表情用モーションの再生を有効にします。
自動目パチ  自動でまばたきするようにします。
物理演算を有効にする  物理演算の設定を有効にします。
ポーズ切り替えを有効にする  ポーズ切り替えを有効にします。
アイドリングモーション  アイドリングモーションを有効にします。
カーソル追従  モデル表示エリア上でのカーソル追従を有効にします。
呼吸  呼吸を有効にします。
旧モーション再生方式を使う 旧モーション再生方式を有効にします。 
モデル表示エリアの右下にある[旧モーション再生方式を使う]にチェックが入ります。
詳しい説明は「motion3.jsonの再現性が劣化する場合について」のページをご覧ください。
カーソル追従の設定 カーソル追従設定のダイアログを開きます。

 

 

Cubism Viewer (for OW)の機能について

カーソル追従の設定

[アニメーション]メニュー → [カーソル追従]にチェックを入れビュー上をドラッグするとマウスカーソルに追従してモデルが動きます。
[アニメーション]メニュー → [カーソル追従の設定]から追従させたいパラメータも設定することができ、実機上のシミュレーションを行うことも可能です。

影響度(%):
影響度を設定することで、パラメータの動きに影響を与えることができます。
強めに設定すれば大きく動き、弱めに設定すれば動きが小さくなります。

反転:カーソルの追従が反転します。

種別:
カーソルを追従させたいパラメータに種別を設定します。
・マウス左ドラッグの場合
(マウス左X:横移動  マウス左Y:縦移動)

・マウス右ドラッグの場合
(マウス右X:横移動  マウス左Y:縦移動)

カーソルの追従設定はモデルデータ(cmo3)に保存されますが、組み込みデータには書き出されません。
組み込み時にカーソルを追従させたい場合は、SDK側で設定を行ってください。

※カーソル追従の設定は[物理演算・シーンブレンド設定]でも同様の確認ができます。

 

カーブ曲線の画像確認

motion3.jsonを選択し、右クリックから「モーションの変化を画像で確認」をクリックするとカーブ曲線を画像で確認することができます。

 

 

描画順やポリゴン数(アートメッシュ)情報の一覧

アートメッシュの描画順やポリゴン数などの情報を確認することができます。
ツリー上のmoc3ファイルをクリック → プルダウンメニューから「アートメッシュ」を選択

選択した アートメッシュはビュー上で青く点滅します。

 

 

モーションのカーブタイプの表示

[OW Viewer]のモーションのインスペクタにモーションに含まれる情報から推測されるターゲットバージョンが表示されるようになりました。

ターゲットバージョンで「SDK(その他)」を使用している場合は、開発者と相談しチェックを入れるかどうかご検討ください。
詳細はSDKのマニュアル「motion3.jsonの再現性が劣化する場合について」をご参照ください。

インスペクタ上の表記は以下の通りになります。

旧モーション再生方式を使う

4.1より前のCubism Viewer (for OW)ではどのようなモーションファイルでもCubismエディタのアニメーションと同じカーブで再現されていました。
4.1alpha1からalpha3までのCubism Viewer (for OW)ではモーションはSDKで再生されるカーブで再現されるようになります。
また、4.1 alpha4以降のCubism Viewer (for OW)ではカーブの再現状態を「旧モーション再生方式を使う」のチェックで制御できるようになります。

「旧モーション再生方式を使う」のチェックを入れた状態ではベジェハンドルを1/3、2/3で固定した状態のベジェカーブのモーションで再生されるようになります。

ターゲットバージョンでSDK(その他)を使用している場合は、開発者と相談しチェックを入れるかどうかご検討ください。
詳細は[Cubism SDK Manual]の「motion3.jsonの再現性が劣化する場合について」のページをご参照ください。

 

波形の比較

カーブ曲線の確認機能で[SDK(その他)]で書き出されたモーションに関して未対応のSDKで再生されるカーブ曲線が水色で表示されるようになりました。

 

2つのmoc3データ情報の比較

2つのmoc3データ情報をViewer上で比較確認することができます。

確認方法は以下の手順になります。

  1. 比較したい2つのデータをViewerにドラッグ&ドロップ
  2. [編集]メニュー → [差分比較]
  3. 確認用のダイアログが表示される

 

①ファイル情報

比較したいファイルの名前や、ファイルの作成日/時間、ファイルの場所が表示されます。

 

②カテゴリと詳細項目

キャンバス:

キャンバスの比較情報が表示されます。

パーツ:

パーツの比較情報が表示されます。

パラメータ:

IDごとにMin、Default、Maxの値が比較表示されます。

アートメッシュ:

IDごとに以下の項目の情報が比較表示されます。

1.ブレンドモード
2.カリング
3.テクスチャ番号
4.描画順
5.描画順序
6.マスク
7.頂点数
8.ポリゴン数

 

Cubism2.1 Viewer (for OW)からの変更点について

Cubism2.1と3以降では以下のように変更になります。

 

 

モーション設定

  変更内容 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW ) 
1 モーションファイル名 .mtn .motion3.json
2 ファイル内の記述の変更(全般)   キー要素は全て、先頭大文字に変更
'type' -> 'Type'など
3 グループ名

 idle

自動で判別され、グループに「idle」と表記される

 Idle

【注意点】
グループ名の右の「Idle」ボタンをクリックし、アイドリング設定にする必要あり。

(グループ名は大文字開始)

4 自動目パチモーション set mult

 

ポーズ設定

  変更内容 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW )
1 ポーズファイル名 .pose.json .pose3.json
2 ファイル内の記述の変更(全般)   キー要素は全て、先頭大文字に変更
'type' -> 'Type'など
3 構造

'parts_visible'

構造の変更例:
'parts_visible' : [ { 'group' : [グループの設定] } ,{ 'group' : [グループの設定] } ]

'Groups'

構造の変更例:
'Groups' : [ [ グループの設定 ], [ グループの設定 ] ]

 

表情設定

  変更内容 Cubism2.1 Viewer (for OW) Cubism Viewer ( for OW )
1 表情のファイル名 .exp.json .exp3.json
※デフォルトの表情名は拡張子を除いたもの(*1)
(例)ファイル名:abc.exp3.json → デフォルトの表情名: abc
2 ファイル内の記述の変更(全般)   キー要素は全て、先頭大文字に変更
'type' -> 'Type'など
3 ファイル内の記述の変更 fade_in /out FadeIn , FadeOut
4 ファイル内の記述の変更 'params' 'Parameters'
5 ファイル内の記述の変更 'calc'
'add'
'mult'
'set'2.1では Addは省略
'Blend'
'Add'
'Multiply'
'Overwrite'3.xでは省略しない
5 ファイル内の記述の変更

'val'

2.1は、表情を表す値を持っていた (目を見開くなら、1.2など)

'Value'

3.xでは、加算・乗算される値を持つ様に変更(目を見開くなら +0.2 )

*1 以前の仕様で書き出されたmoc3/model3.jsonを変更後のOWViewerで読み込んでも、既に設定されている表情の表情名は変わりません。
新しく表情用モーションを読み込む際に上記の変更後の仕様が適用されます。
[ファイル]メニュー →[設定]→[デフォルトの表情名に拡張子を付ける]にチェックを入れることで以前の仕様でViewerを動作させることも可能です。
この設定はViewerの設定として保存されます。

 

モデルファイル

  変更内容 2.1Viewer Viewer ( Original Workflow ) 
1 モデルファイルのファイル名 .model.json .model3.json
2 ファイル内の記述の変更(全般)   キー要素は全て、先頭大文字に変更
'type' -> 'Type'など
3 当たり判定 IDの命名規則:
D_REF.
IDの命名規則:
HitAreaHitAreaの項目を追加:
当面はエディタからは書き出さず、ビューアで 'HitArea**'を探して一覧に表示し、名前を設定する方式になります。(Viewerから model3.json を書き出す)

 

まばたきとリップシンクのモーション焼き込み

「まばたき」と「リップシンク」で設定したモーションはモーション書き出し時にLive2Dパラメータに焼き込む(ベイク)ことができます。
motion3.jsonには、「倍率」や「効果」のデータが書き出されない為、この機能を活用することで、Viewer上でアニメーションのモーションを完全に再現することが可能です。

ただ、調整が必要な場合は再度motion3.jsonを書き出す必要がありますので注意が必要です。
※OWViewerを使用の際は、まばたきとリップシンクのモーション焼き込み機能を推奨しております。


モーションデータ設定時、「リップシンクとまばたきをモーションに焼き込む」にチェックを入れます。
モーションの焼き込み方法:

 

この項目を有効にすると、「リップシンク」と「まばたき」が個別にmotion3.jsonに書き出されなくなりますので、項目がグレーアウトします。

 

この状態で、「OK」をクリックすると、まばたき・リップシンク設定でチェックを入れたパラメータ上に
キーフレームとして焼き込まれmotion3.jsonとして出力されます。

「まばたき」や「リップシンク」の適用先のパラメータにキーフレームが設定されている場合は、 そのパラメータに、
上記のエフェクトのカーブが計算(まばたきの場合は乗算、リップシンクの場合は加算)されます。

 

統計情報

moc3ファイルの統計情報を確認できます。
moc3ファイル名をクリック→プルダウンメニューから「統計情報」を選択すると、ターゲットバージョン等の情報が表示されます。

© 2010 - 2022 Live2D Inc.