Editor/Viewer가 정상적으로 기동되지 않는 경우의 확인 사항

(2021/03/11 업데이트)

Editor/Viewer가 기동되지 않는 경우, 아래의 스텝에 맞추어 상황을 확인해 봅시다.

이 페이지는 Live2D 도움말로 이동하여 업데이트를 종료했습니다.
최신 정보는 Live2D 도움말의 다음 페이지를 참조하십시오.
Cubism Editor Viewer가 정상적으로 시작되지 않음 (Windows) - Live2D 도움말
Cubism Editor Viewer가 제대로 시작되지 않음 (Mac) - Live2D 도움말

1단계

운영 환경 확인

운영 환경」 페이지의 내용을 확인합니다.
모든 요구 사항을 충족하는지 확인해 봅시다.

 

설치 위치 확인

다음 위치에 올바르게 설치되었는지 확인합니다.

C:Program Files\Live2D Cubism X.X

버전 확인

업데이트 기록을 검토하여 현재 설치된 Cubism 버전이 최신인지 확인해 보세요.
업데이트 내역

최신 버전이 아닌 경우 업데이트합니다.

 

2단계

GPU(그래픽 보드) 확인

환경 설정에 따라 온보드(내장 그래픽 프로세서)를 사용하도록 설정되어 있을 수 있습니다.
그래픽 프로세서 설정을 확인합니다.

이번은 NVIDIA사GeForce 그래픽 프로세서의 경우를 예로 소개합니다.

 

No.  설명 참고 이미지
바탕 화면을 마우스 오른쪽 버튼으로 클릭하고 오른쪽 참조 이미지의 빨간색 프레임 부분에서 「NVIDIA 제어판」을 클릭합니다.
NVIDIA 제어판에서 오른쪽 참고 이미지의 빨간색 프레임 부분의 위치를 확인하십시오.
「자동 선택」으로 설정된 사람은 「고성능 NVIDIA 프로세서」로 설정을 변경하면 사용 그래픽 프로세서가 GeForce로 전환됩니다.
(※사용 환경이나 설정에 따라 설정 방법이 다를 수 있습니다. 자세한 내용은 그래픽 프로세서 출시자에게 문의하십시오)

 

TIPS
「OpenGL 초기화에 실패했습니다. 컴퓨터가 작동 환경을 충족하는지 확인하십시오.」

라는 메쉬지가 표시되고 시작에 실패할 수 있습니다.
운영 환경을 충족하는 컴퓨터에서 이 메쉬지가 표시되면,
그래픽 드라이버가 오래된 것일 수 있으므로 최신 버전으로 업데이트하십시오.

 

관리자 권한으로 작동하는지 확인

현재 PC가 「관리자 권한」으로 실행되고 있는지 확인해 봅시다.

 

로그인한 사용자의 계정 이름에 공백이 없는지 확인

Windows에서 로그인 사용자의 계정 이름에 공백과 같은 공백이나 특수 기호가 포함된 경우,
Editor/Viewer의 거동에 문제가 발생하는 경우가 있습니다.

로그인 사용자의 계정 이름에 문제가 있는지 확인해 봅시다.

 

OpenGL이 3.3 이상인지 확인

OS 업그레이드 시 OpenGL이 전환되는 경우가 있는 것 같습니다.
작동 환경을 충족하는지 확인합시다.

 

3단계

bat 파일에서 시작할 수 있는지 확인

다음 bat 파일에서 성공적으로 시작할 수 있는지 확인하십시오.
bat 파일로부터 정상적으로 조작을 실시할 수 있는 경우는, 어플리케이션의 내용에 바뀌는 것은 없기 때문에 그대로 사용해 주세요.

Cubism Editor의 경우:
「CubismEditorX.bat」와 「CubismEditorX_d3d.bat」는 bat 파일입니다.
Cubism Viewer의 경우:
「CubismViewerX.bat」와 「CubismViewerX_d3d.bat」는 bat 파일입니다.

 

 

4단계

스텝 3까지 확인해도 개선이 보이지 않는 경우는, 어떠한 불편이 발생하고 있을 가능성이 있습니다.
커뮤니티에 결함 보고를 받는 것과 동시에 「로그」를 보내 주시면,
부드럽게 대응할 수 있기 때문에, 꼭 이하의 방법을 시험해 주시면 다행입니다.

 

로그를 얻을 수 있는 경우

어떠한 형태로, 일시적으로라도 Editor/Viewer를 기동할 수 있는 상황이라면, 이하의 순서로 로그를 취득할 수가 있습니다.

버그가 발생하면 로그 팔레트에 「빨간 글씨」로 오류가 표시됩니다.
아래 절차에 따라 「log.txt」 파일을 얻습니다.

파일 메뉴에서 「도움말」을 클릭 → 「로그 파일 열기」를 클릭 → 모든 「log.txt」

커뮤니티에서, 버그의 보고와 동시에 「log.txt」를 첨부해 주시면, 부드러운 대응이 가능합니다.

 

로그를 얻을 수 없는 경우

Editor 자체를 시작할 수 없고 로그를 얻을 수 없는 경우 명령 프롬프트에서 오류 정보를 가져옵니다.
다음 단계를 시도해 보세요.

  1. 시작 메뉴 → Windows 시스템 도구 → 명령 프롬프트를 클릭합니다.
  2. 명령 프롬프트에 「cd "C:\Program Files\Live2D Cubism X.X"」 괄호 안을 복사하여 붙여넣고 Enter
    ※X.X를 사용하시는 버전명으로 재기록해 주십시오.
  3. 커맨드 프롬프트에 「CubismEditorX.bat」 괄호 안을 복사하여 붙여넣고 Enter
    ※X를 사용하시는 버전명으로 재기록해 주십시오.
  4. 명령 프롬프트 제목 왼쪽 상단 아이콘을 클릭
  5. 명령 프롬프트 메뉴의 편집 → 마크(또는 선택 범위)를 클릭
  6. 명령 프롬프트에 출력된 모든 내용을 선택하여 텍스트 파일에 복사 및 붙여넣기

 

커뮤니티에서, 버그의 보고와 동시에 취득한 내용을 「텍스트 파일」로서 첨부해 주실 수 있으면,
부드러운 대응이 가능합니다.

 

© 2010 - 2022 Live2D Inc.