업데이트 내역

Cubism의 최신 Editor는 여기에서도 DL 할 수 있습니다

※일부 번역에 시간이 걸리는 경우가 있습니다.

 

4.2.01 (2022/09/27)

공통

《개선 항목》

・색 설정에서 ESC 키를 클릭했을 때에 다이얼로그가 닫히지 않는 버그를 수정했습니다.
・[대화 상자의 크기와 위치 재설정] 실행 시 [이미지/동영상 내보내기]에 표시되는 대화상자가 재설정되지 않는 문제를 수정했습니다.
・바로 가기 설정 대화 상자에서 [편집 레벨]의 바로 가기 키 [1] [2] [3]이 유효한 반면 키 설정이 비어 있던 문제를 수정했습니다.

모델링

《개선 항목》

・변형 브러시 툴로 브러시의 버튼을 더블 클릭하면, 일부의 텍스트가 선택 상태가 되어 버리는 버그를 수정했습니다.
・워프 디포머의 성형 브러시의 마우스 커서를 브러시의 커서로 변경했습니다.
・변형 브러시 툴을 [B+드래그]로 사이즈 변경을 실시하면, 브러시 사이즈가 반전해 버리는 버그를 수정했습니다.
・워프 디포머의 성형 브러시 사용시의 툴 상세 팔레트에서, 가중 컬러의 항목을 삭제했습니다.
・파트 팔레트에서 파트를 디포머로 드래그 앤 드롭하면 에러가 나오는 문제를 수정하였습니다.
・블렌드 셰이프가 포함된 모델을 템플릿으로 선택할 수 없도록 경고 대화 상자를 표시합니다.
・폼의 특수한 붙여넣기 옵션 다이얼로그의 초기 사이즈를 조정했습니다.

애니메이션

《개선 항목》

・[라벨을 개별적으로 복제] 대화 상자에서 장면과 장면 팔레트의 정렬 순서가 동일하도록 수정되었습니다.
・[라벨을 개별적으로 복제] 다이얼로그에서, 같은 파라미터의 조합의 태그를 통합해 표시하도록(듯이) 했습니다.
・[라벨을 개별적으로 복제] 대화 상자에서 ID가 일치하지 않는 파라미터가 복제되지 않도록 수정되었습니다.

 

 

4.2.01 beta1 (2022/08/25)

공통

《기능 추가》

・색 설정으로 [RGB]나 [HSL]을 수치 입력할 수 있도록 했습니다.
・[대화 상자의 크기와 위치 재설정] 기능이 추가되었습니다.

《개선 항목》

・바로 가기 설정 대화 상자에서 그룹을 연속적으로 더블 클릭했을 때 그룹이 열리고 닫히지 않는 문제를 수정했습니다.
・바로 가기 설정 대화 상자에서 [가져오기] [모두 되돌리기] [초기화] 실행시 항목 선택, 그룹 개폐 상태 및 스크롤 위치를 저장하도록 수정되었습니다.
・다이얼로그 전반의 표시 위치의 거동을 조정했습니다.
・색의 설정으로 텍스트 입력했을 때에, Enter 키를 누르지 않고 색이 반영되게 되었습니다.
・바로 가기 설정 대화 상자에 그룹의 [모두 펼치기 / 모든 집계] 버튼을 추가했습니다.
・파라미터의 [선택]에서 오브젝트를 선택했을 때에, 숨기고 잠긴 오브젝트의 선택을 해제하는 기능을 추가했습니다.
・자동 백업 설정의 자동 백업 용량 설정이 올바르게 반영되지 않는 문제를 수정했습니다.

모델링

《기능 추가》

・[워프 디포머를 베지어 핸들을 따라 성형] 기능을 추가했습니다.
・변형 브러시 도구에 [워프 디포머의 성형 브러시] 기능을 추가했습니다.

《개선 항목》

・블렌드 셰이프용 파라미터로 [근처 키에 흡착] [이전 키 선택] [다음 키 선택] 단축키가 제대로 작동하지 않는 버그가 수정되었습니다.
・랜덤 포즈 재생했을 때에, 눈의 개폐가 반영되지 않는 버그를 수정했습니다.
・파라미터의 키 이외의 부분에서 워프 디포머를 조작한 후 [기본 설정값으로 되돌리기]를 실행하면 핸들이 어긋나 버리는 버그를 수정했습니다.
・파라미터를 결합했을 때에, 슬라이더의 선의 상태가, 정상적으로 갱신되지 않는 버그를 수정했습니다.
・키 양식 편집 대화 상자에서 목록의 여러 항목을 선택할 수 있습니다.
・확장 보간 대화 상자가 항상 맨 앞면에 표시됩니다.
・키 양식 편집 대화 상자에서 목록에서 스크롤 할 수없는 버그를 수정했습니다.
・파라미터 설정 다이얼로그에서, 편집을 하지 않은 상태에서 캔슬하는 경우에, 불필요한 확인 다이얼로그가 표시되는 버그를 수정했습니다.
・던지기 줄이나 브러시 선택 툴로 선택 이동시키면, 핸들과 정점이 어긋난 상태가 되는 불편을 수정했습니다.
・[기본 형태 잠금]이 유효한 때에, 아트 메쉬와 아트 패스를 동시에 선택한 상태에서 변형 패스의 제어점을 조작하면, 에러가 나오는 버그를 수정했습니다.
・물리 연산 그룹 설정 다이얼로그에서, 입력, 출력 파라미터의 경고 정보의 색 표시가 어긋나고 있던 버그를 수정했습니다.
・반전 설정 다이얼로그에서 체크 박스를 클릭했을 때에, 선두에 스크롤 되어 버리는 버그를 수정했습니다.
・블렌드 셰이프의 가중치 제한 설정 다이얼로그에서, 파라미터의 이름이 일정 이상의 길이가 되면 정상적으로 표시되지 않는 버그를 수정했습니다.
・물리 연산 설정 다이얼로그에서 [물리 연산을 유효하게 한다]의 체크 박스가 스페이스 키로 ON/OFF 되어 버리는 버그를 수정했습니다.
・템플릿 모델을 파일에서 선택할 때 파일 유형을 수정했습니다.
・파라미터의 폴더명을 변경했을 때에, Undo/Redo가 정상적으로 동작하지 않는 버그를 수정했습니다.
・큰 사이즈의 PSD 내보내기를 실행했을 때에 파일의 내보내기가 실패하는 문제를 수정하였습니다.
・1개의 오브젝트에 최대 3개의 파라미터를 대응시킬 때에, 표시되는 정보 다이얼로그가 2회 표시되는 버그를 수정했습니다.
・[스키닝] 및 [변형 패스에서 스키닝]에 표시되는 정보 대화 상자의 문장을 수정했습니다.
・신규 파라미터 작성 다이얼로그에서 [이름][ID][범위]를 클릭했을 때에, 캐릭터 라인 및 수치가 전선택되게 되었습니다.
・파라미터의 조작을 기록해 애니메이션을 생성할 때, 추가되는 씬의 프레임 레이트에 물리 연산의 계산 FPS를 설정하도록 수정되었습니다.
・파라미터의 [변경]으로 변경처의 후보가 없는 경우에, 정보 다이얼로그를 표시하도록 했습니다.
・텍스처 아틀라스 편집으로 [각도와 배율을 락]에 체크가 들어가 있을 때, 쇼트 컷 키로 변경할 수 버리는 버그를 수정했습니다.
・텍스처 아틀라스 편집에서 잠긴 텍스처로 다른 텍스처에서 이동할 수 있는 버그를 수정하였습니다.
・블렌드 셰이프용 파라미터 사용시, 변형 패스의 컨트롤 포인트를 복수 선택해 바운딩 박스로 조작하면, 아트 메쉬의 정점이 정상적으로 이동하지 않는 버그를 수정했습니다.
・특정 순서로 [직전의 표시 상태를 복원]을 실행하면, 직전의 표시 상태가 되지 않는 버그를 수정했습니다.
・파트 팔레트에서 부모와 그 아이의 파트를 이동시켰을 때에, 올바른 구조가 되지 않는 버그를 수정했습니다.
・파트 팔레트나 디포머 팔레트에서, 파트 선택 상태로 다른 파트를 전개/집약했을 때에, 선택 상태의 파트의 위치에 마음대로 스크롤 해 버리는 버그를 수정했습니다.

애니메이션

《기능 추가》

・파라미터 북마크의 라벨을 임의의 트랙에 복제하는 기능을 추가했습니다.
・트랙의 궤도의 표시/비표시와, 궤도의 색이나 형상을 설정할 수 있는 기능을 추가했습니다.

《개선 항목》

・FA 뷰에서 디포머에 변형 브러시 도구가 제대로 작동하지 않는 문제를 수정했습니다.
・앞에 숨겨진 트랙이 있는 경우 뷰를 클릭하면 숨겨진 트랙이 선택되는 버그가 수정되었습니다.
・그래프 에디터의 박스 편집에서, 파라미터의 값을 변경해도 그래프에 반영되지 않는 버그를 수정했습니다.
・그래프 에디터의 박스 편집에서, 커서 키의 좌우 이동으로 키프레임이 덧쓰기되는 버그를 수정했습니다.
・장면 가져오기 시 트랙 이름이 반영되지 않는 오류를 수정했습니다.
・그래프 에디터의 값의 메모리 표시가 스크롤에 추종하지 않는 버그를 수정했습니다.
・모션 데이터 설정 다이얼로그의 콤보 박스의 세로폭을 수정했습니다.
・CAN3파일에 묶는 CMO3파일을 편집하여 저장하지 않고 닫았을 경우에 CMO3파일에 편집이 남는 문제를 수정하였습니다.
・트랙을 복제했을 때에, 연번 화상 트랙의 내보내기 설정이 무효가 되는 문제를 수정하였습니다.
・FREE판 기동시에, 제한을 넘는 모델을 타임 라인에 읽었을 때에, 보존・내보내기를 사용할 수 없는 취지의 정보 다이얼로그를 표시하도록(듯이) 했습니다.
・그래프 편집기에서 배율 XY를 모두 한 번에 편집할 수 있습니다.
・그래프 에디터로 장시간 편집을 하면 에러가 발생하는 문제를 수정하였습니다.

Cubism Viewer

《개선 항목》

・Cubism 4 SDK R5의 수정에 따라 Cubism Viewer에서 사용되는 알고리즘을 수정했습니다. 이 변경으로 인해 Cubism Viewer에는 영향이 없습니다.

 

 

4.2.00 (2022/06/16)

이 버전의 새로운 기능에 대한 자세한 내용은 아래 페이지를 참조하십시오.
새로운 기능 소개 4.2

공통

《기능 추가》

・파일 보존시에, 정상적으로 보존이 종료하지 않았을 경우에 재차 보존하는 기능을 추가했습니다.
・Windows 8.1 지원이 종료되었습니다.
・macOS Mojave 지원이 종료되었습니다.

《개선 항목》

・멀티 뷰에서 [선택 상태 숨기기]를 사용하면 힌트가 계속 표시되는 버그가 수정되었습니다.
・수식 키+Tab을 설정한 단축키가 동작하지 않는 버그를 수정하였습니다.
・로그가 이중으로 표시되는 오류를 수정했습니다.

모델링

《기능 추가》

・내보내기 설정에 [물리 연산 설정 파일에 계산 FPS 내보내기] 항목을 추가했습니다.
・텍스처 아틀라스 편집 다이얼로그의 모델용 화상 리스트에 [배치 완료 및 선택 상태만]의 항목을 추가했습니다.
 배치된 이미지를 선택하면 모델 이미지 목록에 표시됩니다.
・캔버스에서 단일 선택한 아트 메쉬가 텍스처 아틀라스 편집 대화 상자를 열 때 선택됩니다.

《개선 항목》

・랜덤 포즈 설정으로 파라미터의 그룹 구조를 바꿀 때 UI가 업데이트되지 않는 버그를 수정하였습니다.
・물리 연산 설정의 종류 항목이 올바르게 표시되지 않는 버그를 수정하였습니다.
・물리 연산 설정으로 편집을 Undo 하면, 테이블 폭이 초기화되는 버그를 수정했습니다.
・물리 연산 · 장면 블렌드 설정에 [랜덤 포즈 설정]을 추가했습니다.
・파트 팔레트에서 파트를 자신의 계층으로 이동시키면 부정한 상태가 되는 버그를 수정하였습니다.
・복사한 오브젝트를 붙여 넣을 때에, 블렌드 셰이프용의 파라미터에 통상의 파라미터를 붙여 넣어 버리는 버그를 수정했습니다.
 
・블렌드 셰이프용 파라미터에, 동일한 ID의 통상의 파라미터를 가지는 오브젝트를 카피 앤 페이스트 하면, Undo/Redo가 정상적으로 동작하지 않는 버그를 수정했습니다.
 
・파라미터의 키가 흡착하는 범위가 작아져 있는 버그를 수정하였습니다.

애니메이션

《기능 추가》

・파라미터 즐겨찾기의 라벨을 다른 트랙에 복제하는 기능이 추가되었습니다.

《개선 항목》

・깜박임 · 립싱크 설정이 되어 있는 파라미터에 프리즈가 동작하지 않는 버그를 수정하였습니다.
・파라미터 즐겨찾기에서 키의 현재 값을 변경할 때 수치 입력을 할 수 있습니다.
・장면 전환, 애니메이션 파일 전환이 빨라졌습니다.
・파라미터 즐겨찾기의 라벨의 드래그 조작시에, 라벨 위치가 어긋나는 일이 있는 버그를 수정했습니다.
・파라미터 즐겨찾기에서 파라미터와 파라미터 사이를 클릭하면 파라미터 그룹이 선택 상태가 되어 버리는 문제를 수정하였습니다.
・디스플레이의 해상도 설정이 다른 환경에서 만들어진 라벨로부터 파라미터 즐겨찾기를 표시할 때에
 화면의 범위 외에서 팝업이 표시되는 버그를 수정하였습니다.
・모션 파일 내보낼 때 내보내기 장면 설정의 [모든 장면 출력]에서 정상적으로 모션 파일이 내보내지지 않는 문제를 수정했습니다.
・FREE 버전 편집기를 사용하여 임베디드용 모델 트랙을 만들 때 저장 및 내보내기 제한이 있는 경고문을 표시하도록 했습니다.

Cubism Viewer

《개선 항목》

・물리 연산의 설정 항목 영역에서 .physics3.json의 FPS 정보를 확인할 수 있습니다.
・.physics3.json에 FPS 정보가 존재할 때, FPS 정보에 근거한 물리 연산 결과가 되도록 개선했습니다.

 

 

4.2.00 beta2 (2022/06/02)

애니메이션

 《개선 항목》 

・임베디드용 모델 트랙의 모델로, 곱하기 색・스크린색이 올바르게 재현되지 않는 버그를 수정했습니다.
 MOC3 파일에는 영향을 주지 않으므로 4.2.00 beta1로 내보낸 파일은 그대로 사용할 수 있습니다.

Cubism Viewer

 《개선 항목》 

・Cubism Viewer  (for OW)에서 곱하기 색・스크린색이 올바르게 재현되지 않는 문제를 수정했습니다.

 

 

4.2.00 beta1 (2022/05/19)

공통

이 버전의 새로운 기능에 대한 자세한 내용은 아래 페이지를 참조하십시오.
새로운 기능 소개 4.2

《기능 추가》

・단축키 설정 다이얼로그의 UI를 일신했습니다.
 ・카테고리의 선택과 전개/집계를 할 수 있도록 개선되었습니다.
 ・이름이나 키의 기입으로 검색할 수 있는 기능을 추가했습니다.
 ・단축키 2를 추가할 수 있도록 했습니다.

・탭 기능을 추가했습니다.
 ・[모든 뷰의 표시 위치 맞추기] 기능이 추가되었습니다.
 ・[이전 탭으로 전환 / 다음 탭으로 전환] 기능이 추가되었습니다.
 ・탭을 복제 할 때 뷰의 표시 위치를 유지하도록했습니다.

・[Windows 버전] Cubism을 설치할 때 설치할 언어를 선택할 수 있습니다.
・[Mac 버전] OS 설정에서 언어가 변경됩니다.
・에디터의 메뉴 항목에서 표시 언어를 전환할 수 있습니다.

《개선 항목》

・「정점 정보에 가세해 불투명도나 그리기 순서 등도 포함한 것」이라고 하는 의미로 사용되고 있는 「형상」의 이름을 「폼」으로 변경했습니다.
・[탭 추가]를 [탭 복제]로 이름을 변경했습니다.
・파일 메뉴의 [설정] 항목 표시가 개선되었습니다.
・프로젝트 팔레트에서 모델을 캔버스 위에 드래그했을 때의 거동을 개선하였습니다.
・[애니메이션의 타깃 버전 선택] 다이얼로그의 영상 아이콘의 문자를 「Movie」에서 「Video」로 변경하였습니다.
・파일 메뉴의 [구현용 파일 내보내기]를 [구현용 파일 내보내기]로 수정했습니다.

모델링

《기능 추가》

・블렌드 셰이프 기능을 추가했습니다.
・곱하기 색・스크린색 기능을 추가했습니다.
・메쉬 편집 모드에 미러 편집 기능을 추가했습니다.
・메쉬 편집 모드에 「정점을 병합」기능을 추가했습니다.
・특수 폼 붙여넣기 기능을 추가했습니다.
・네 모서리의 형상을 자동 생성하는 기능에 [기준으로 하는 파라미터 값]과 [덮어쓰기 키]를 선택하는 기능을 추가하였습니다.
・동일한 모델의 파라미터 값을 탭 간에 동기화하는 기능을 추가했습니다.
・랜덤 포즈로 움직이는 파라미터를 선택할 수 있게 되었습니다.
・마이너 버전 업에 따라 타겟 버전을 추가했습니다.

《개선 항목》

・파츠 팔레트에서 [밑그림]에 체크가 들어간 폴더의 아이콘을 변경했습니다.
・뷰의 반전 상태에 맞추어 캔버스의 반전의 UI가 갱신되지 않는 버그가 수정되었습니다.
・변형패스 제거 버튼(휴지통 버튼)으로 다른 편집 레벨의 변형 경로가 삭제되는 문제를 수정하였습니다.
・delete 키로 변형 패스를 삭제하면 복수의 아트 메쉬에 걸치는 변형 패스를 작성할 수 없게 되는 버그를 수정했습니다.
・「네 모서리」 자동 생성의 표기를 「네 모서리」로 변경했습니다.

애니메이션

《기능 추가》

・파라미터 즐겨찾기 기능을 추가했습니다.
・임베디드용 모델 트랙 기능을 추가했습니다.
・프리즈 기능을 추가했습니다.
・마커 이동의 쇼트 컷을 추가했습니다.

《개선 항목》

・타임 라인의 시간표시 부분에서 shift를 누르면서 드래그하면 어니언 스킨 마커에 흡착되도록 수정하였습니다.
・부드러운 곡선과 다른 곡선을 혼합하여 사용할 때 드물게 올바른 곡선이 되지 않는 오류를 수정했습니다.
 (과거 파일을 수정할 때 다시 계산이 필요합니다)
・샤이 아이콘의 투과 부분을 수정했습니다.

Cubism Viewer

《기능 추가》

・OWViewer에서 motion3.json의 이벤트 정보를 확인하는 기능을 추가했습니다.
・OWViewer에서 userdata3.json의 추가, 삭제, 내용 확인을 할 수 있게 되었습니다.
・OWViewer에서 메뉴 항목에서 표시 언어를 전환할 수 있습니다.

《개선 항목》

・OWViewer에서 모션이나 이펙트를 파라미터 슬라이더로 확인할 수 있도록 수정되었습니다.

알려진 결함

・복사한 오브젝트를 붙여 넣을 때에 블렌드 셰이프용의 파라미터에 통상의 파라미터를 붙여 넣어 버리는 불편이 있습니다.
 블렌드 셰이프의 매개변수에 키가 없는 상태에서 복사 소스와 붙여넣기 위치가 동일한 ID의 매개변수인 경우에 발생합니다. (2022/05/23)

※상기의 불편은 Cubism 4.2.00 릴리즈판에서 수정될 예정입니다.

 

 

4.1.05 (2022/04/21)

모델링

《개선 항목》

  • 파츠 팔레트의 [텍스트로부터 내보내기] 아이콘 표시가 전환되지 않는 버그가 수정되었습니다.

 

 

4.1.05 beta2 (2022/03/24)

모델링

《개선 항목》

  • Solo 모드에서 비활성 색상을 변경할 때 배경색이 올바르게 그려지지 않는 버그가 수정되었습니다.
  • 아트패스의 [기본 브러쉬 설정] 대화상자에서 설정을 변경한 후 브러시를 전환해도 설정이 업데이트되지 않는 버그가 수정되었습니다.

애니메이션

《개선 항목》

  • 여러 애니메이션 뷰를 닫을 때 관련 폼 애니메이션 뷰가 닫히지 않는 문제를 수정했습니다.

 

 

4.1.05 beta1 (2022/02/08)

공통

《개선 항목》

  • 물리적 연산의 그룹 이름에 [<>] 기호가 포함되어 있으면 내장 파일 내보내기 후 SDK에서 성공적으로 로드할 수 없는 오류를 수정했습니다.
  • 파일을 열지 않은 상태일 때 도구 버튼을 입력할 수 없게 되었습니다.
  • 바로 가기 설정 대화 상자에 [물리연산 설정 내보내기]를 추가했습니다.
  • 메뉴 바에서 [편집] [윈도우] [도움말]을 마우스 오버 할 때 강조 표시되지 않는 오류를 수정했습니다.
  • 파일 메뉴에서 [모두 닫기]를 실행할 때 여러 탭을 열면 팔레트에 정보가 남아 있는 버그가 수정되었습니다.
  • 임시 변형 도구로 컨트롤 포인트를 선택할 때 [Shift+드래그]로 평행 이동할 수 있도록 했습니다.

모델링

《기능 추가》

  • 텍스쳐 아틀라스 편집에서 [각도] [배율]을 잠그고 편집할 수 있도록 했습니다.
  • 물리 연산·씬 블렌드 설정으로, 계산 FPS의 값을 자유롭게 입력해, 지정할 수 있도록 했습니다.
  • 파츠 팔레트에서 객체를 복사하여 붙여 넣을 때 이름 끝에 번호를 삽입하는 설정을 추가했습니다.

《개선 항목》

  • 파츠 팔레트에서 라벨색을 설정한 파츠내에, 다른 색을 설정한 파츠내의 오브젝트를 이동시킨 후 Undo 하면,
    이동한 오브젝트의 색이 되돌아오지 않는 버그가 수정되었습니다.
  • 신규 파츠 작성 후에 그대로 파라미터에 키를 치면, 안의 오브젝트에 키가 쳐 버리는 버그를 수정했습니다.
  • 파라미터에 키가 쳐진 오브젝트를 삭제해도, 키의 표시만 남는 버그를 수정했습니다.
  • 파라미터 팔레트에서 그룹 색상 설정을 변경했을 때 Undo/Redo를 할 수 없는 버그를 수정하였습니다.
  • Solo 모드의 비활성 색상 변경 대화상자에서 취소를 클릭할 때 비활성 색상이 어두워지는 버그를 수정했습니다.
  • Solo 모드에서 임시 변형 도구를 실행할 때 뷰 왼쪽 상단에 있는 디스플레이와 비활성 컬러 표시가 나타나지 않도록 수정되었습니다.
  • [변형브러쉬 도구] [브러시 선택 툴] [글루 툴]의 브러시 크기 상한을 2000px에서 10000px로 수정했습니다.
  • 텍스쳐 아틀라스 편집에서 텍스쳐 이미지 위에 커서를 맞추었을 때 툴팁의 표시가 지연되지 않도록 수정하였습니다.
  • [파츠 설정] [파라미터 설정] [그룹 설정] 대화 상자의 헤더 폭을 편집기 시작 중에 저장합니다.
  • [파츠 설정] [파라미터 설정] [그룹 설정] 대화 상자의 크기를 설정 저장합니다.
  • 브러시 선택 툴, 글루 툴의 브러시 사이즈가 [B+드래그]로 상한이나 하한을 넘는 사이즈로 설정할 수 버리는 버그를 수정하였습니다.
  • 아트 메쉬를 복사하고 메쉬 편집으로 붙여 넣으면 자동으로 연결되어 버리는 버그가 수정되었습니다.
  • 물리 연산·씬 블렌드 설정으로, 씬의 재생에 프레임 스텝을 적용했습니다.
  • 물리 연산 그룹 편집에서 편집한 후 취소로 닫을 경우 확인 대화 상자를 표시하도록 했습니다.
  • 키 폼 편집 대화상자에서 마지막 열의 키 폼 편집을 Enter 키로 반영한 후 다음 입력을 받을 수 없게 되는 버그를 수정했습니다.
  • [움직임 반전]에서 정상적으로 적용할 수 없는 문제를 수정했습니다.
  • 여러 모니터를 사용할 때 컨텍스트 메뉴가 다른 모니터에 표시되는 문제를 수정했습니다.
  • 파라미터 팔레트에서 파라미터와 파라미터 그룹이 여러 개 생길 수 있는 문제를 수정하였습니다.

애니메이션

《기능 추가》

  • [모션 내보내기 설정]을 추가하여 씬별로 임의로 지정한 모션 파일을 내보낼 수 있습니다.
  • 모션 내보내기 설정이 저장되도록 수정되었습니다.

《개선 항목》

  • 모션을 녹화하여 애니메이션 데이터를 생성한 후 새 씬을 만들 수 없는 버그가 수정되었습니다.
  • 모션 파일을 내보낼 때 [립싱크와 눈 깜빡임을 모션에 굽기]에 체크를 하면,
    파라미터 그룹에 설정된 프레임 스텝이 무시되어 에디터의 거동과 다른 모션이 출력되는 버그가 수정되었습니다.
  • 폼 애니메이션 편집에서 특수한 경우에 리토폴로지되지 않는 버그가 수정되었습니다.
  • 로그에 「no object」라고 계속 나오는 버그가 수정되었습니다.
  • 프레임 스텝이 지정된 트랙에 [눈 깜빡임] [립싱크]가 있는 경우에 프레임 스텝이 적용되지 않는 버그가 수정되었습니다.
  • 애니메이션 탭과 폼 애니메이션 탭을 동시에 닫을 때 씬 팔레트의 표시가 남아 버리는 버그가 수정되었습니다.
  • 오디오 트랙의 트랙 길이를 변경하면 오디오가 출력되지 않는 문제를 수정했습니다.
  • 두 개의 애니메이션 파일을 연 상태에서 특정 작업을 수행하면,
    뷰와 씬 팔레트에서 각각 다른 애니메이션 정보가 표시되는 버그가 수정되었습니다.
  • 물리 연산상의 재생이나 씬 트랙에서, 프레임 스텝을 「1컷 지정」으로 해도 1컷의 동작을 하지 않았던 문제를 수정하였습니다.
  • 프레임 스텝의 지정으로, 0프레임으로부터 첫회의 개시 위치까지의 구간은, 1컷으로서 동작하도록(듯이) 했습니다.
  • 씬 팔레트에서 씬을 변경한 후 애니메이션 뷰 탭을 닫으면 오류가 발생하는 문제를 수정했습니다.
  • 타임라인을 스크롤했을 때, 좌우의 표시가 어긋나는 버그가 수정되었습니다.
  • 도프 시트의 [키 프레임을 선택한 행에 붙여넣기]에서 [적용처의 범위가 다를 때 비율로 값을 조정한다]를 선택할 때,
    베지어 곡선의 핸들이 조정되도록 수정되었습니다.
  • 타임라인을 플로팅할 때 일부 키 조작을 할 수 없게 되는 버그가 수정되었습니다.

 

 

4.1.04 (2021/12/23)

공통

《기능 추가》

  • Log4j의 취약성 문제(CVE-2021-44228)에 대응하였습니다.
    구체적인 해결책으로 Cubism Editor에서 사용하는 Apache Log4j의 버전을 취약점을 해결하는 최신 버전 2.17.0으로 업데이트했습니다.
    최신 버전 2.17.0에서는 CVE-2021-44228 외에도 CVE-2021-45105도 지원합니다.
    CVE-2021-45105의 취약점은 현재까지의 Cubism Editor 버전에서는 발생하지 않으므로 안심하십시오.

    Cubism Editor 4.1.03 이전 버전을 사용하는 사용자가 Apache Log4j 취약점(CVE-2021-44228)을 해결하는 방법에 대한 도움말은 도움말 사이트를 참조하세요.
    Log4j의 취약성 문제 (CVE-2021-44228)에 대한 대응

 

모델링

《개선 항목》

  • 변형 패스의 제어점을 복수 선택했을 때에, 바운딩 박스가 갱신되지 않는 버그가 수정되었습니다.

 

 

4.1.03 (2021/12/10)

공통

《개선 항목》

  • 모델/애니메이션 등을 1파일 이상 열고 있는 상태로, 한층 더 모델을 「드래그 앤 드롭」으로 열려고 한 경우에
    데이터가 제대로 열리지 않는 상태가 되는 문제를 수정했습니다.

    ※4.1.02에서 대응한 「프로젝트 팔레트로부터, 모델을 캔버스상에 드래그했을 때의 거동을 개선」의 영향으로 상기의 불편이
    발견되었기 때문에, 수정을 실시해 4.1.03으로서 재차 릴리스했습니다.
    본 버전은 4.1.02의 상기 버그를 제외한 수정 내용이 포함되어 있습니다.

    업데이트 내용은 4.1.02 항목을 참조하십시오.

 

 

4.1.02 (2021/12/9)

이 버전에서는 문제가 발견되었으므로 최신 버전을 사용하십시오.
(다운로드는 할 수 없습니다)

 

공통

《기능 추가》

  • Windows11에 대응했습니다.
  • macOS Monterey에 대응했습니다. (macOS High Sierra는 지원을 종료합니다)
    ※Intel CPU 탑재 모델만 대응했습니다. Apple M1 칩 탑재 모델은 현재 지원하지 않습니다.
    ※OS를 업데이트하기 전에 반드시 Cubism Editor의 정품 인증을 해제하십시오.
     도움말 사이트 「Cubism Editor를 설치하는 macOS를 업그레이드하고 싶습니다

《개선 항목》

  • 프로젝트 팔레트에서 모델을 캔버스로 드래그했을 때의 거동을 개선했습니다.
  • [cmo3·can3 연계 설정] 다이얼로그의 [연결 모델]의 모델명이 올바르게 표시되지 않는 버그가 수정되었습니다.

모델링

《개선 항목》

  • [물리 연산 · 씬 블렌드 설정]에서 씬 블렌드를 업데이트하면 씬 재생의 [랜덤 A] [랜덤 B] 항목이 사라지는 문제를 수정했습니다.

애니메이션

《개선 항목》

  • 파라미터의 결합을 해제하고 선택 후 탭을 전환했을 때 타임라인 편집을 할 수 없게 되는 버그가 수정되었습니다.
  • 도프 시트에서 복사하여 붙여 넣기 및 템플릿을 적용하면 베지어 커브의 모양이 변경되는 문제를 수정했습니다.

 

 

4.1.02 beta1 (2021/10/28)

공통

《기능 추가》

  • 물리 연산·씬 블렌드 설정과 Cubism Viewer (for OW)에서 커서 추종의 설정에 [영향도]와 [반전]이 추가되었습니다.
    또, [종별]에서는 오른쪽 클릭과 왼쪽 클릭을 설정할 수 있게 되었습니다.
  • [파라미터 값 복사] [파라미터 값 붙여넣기] 기능이 추가되었습니다. 매개 변수의 값을 복사하고 붙여 넣을 수 있습니다.

《개선 항목》

  • PRO 버전의 무료 평가판을 시작 버튼을 클릭하면 확인 대화 상자가 표시되도록 수정되었습니다.
  • 팔레트 배치를 리셋하면 팔레트의 표시/숨기기 상태가 메뉴의 체크 상태와 일치하지 않게 되는 버그를 수정하였습니다.
  • 팔레트 배치 재설정이 현재 선택한 작업 공간에서 수행되도록 수정되었습니다.
  • [Mac 버전] 키보드의 일부가 Ctrl 키로 되어 있던 버그가 수정되었습니다.
  • 파츠 설정 대화 상자에서 취소 버튼을 클릭하면 확인 대화 상자가 두 번 표시되는 오류를 수정했습니다.
    또, 확인 다이얼로그에서 취소를 클릭했을 때에, 파츠 설정 다이얼로그로 돌아가 수정했습니다.
  • 뷰 영역의 탭을 닫은 후 이전에 활성화한 탭을 활성화하도록 수정했습니다.
  • 뷰 영역의 탭을 닫으면, 그 탭에서 작업하고 있던 모덜리스 다이얼로그도 닫도록 수정했습니다.
  • 뷰 영역에 아무것도 열리지 않은 상태에서 [윈도우] 메뉴 → [뷰 영역 상태 재설정]을 실행하여 오류 로그가 기록되지 않도록 수정했습니다.
  • 탭 닫기 버튼을 드래그할 때 탭을 이동하려고 하는 버그가 수정되었습니다.
  • [Ctrl+Shift+Alt+E][Ctrl+Shift+Alt+L][Ctrl+Shift+Alt+T]에 기본적으로 할당된 단축키를 사용하지 않았습니다.
    또한 이러한 키에 바로 가기를 할당할 수 있도록 수정했습니다.
  • 물리 연산의 계산 FPS와 씬의 프레임 레이트 fps가 다른 때에 경고 다이얼로그가 나오게 되었습니다.

모델링

《기능 추가》

  • 바로 가기 설정 대화 상자에 [근처 키에 흡착]을 추가했습니다.
  • 회전 디포머의 색상을 변경할 수 있습니다.
  • 물리 연산·씬 블렌드 설정에서 [랜덤 A] [랜덤 B]의 모션을 선택할 수 있습니다.
  • 디포머 검증 대화상자에서 [변환의 분할 수] [베지어 분할 수]를 확인할 수 있습니다.
  • 메쉬 편집 모드에 부분 정점 복제 기능을 추가했습니다.
  • 파츠 팔레트에서 [라벨 색상]을 설정할 수 있습니다.

《개선 항목》

  • 바로 가기 설정 대화 상자에 [키 폼 추가] [키 폼 삭제]를 추가했습니다.
  • PSD를 다시 가져올 때 추가된 아트 메쉬가 디포머 팔레트에 즉시 표시되지 않는 문제를 수정했습니다.
  • 메쉬의 수동 편집 모드에서, 아틀라스 표시로 하여 모드를 종료했을 때, 모델의 외형과 파라미터 팔레트의 상태에 충격이 발생하는 버그를 수정했습니다.
  • 아트 메쉬의 입력 레이어를 전환했을 때 파츠 팔레트의 아이콘이 업데이트되지 않는 버그가 수정되었습니다.
  • 특정 Photoshop 버전에서 저장한 PSD를 로드할 수 없게 되는 문제를 수정했습니다.
  • 인스펙터 팔레트에서 텍스트 입력 중 Undo/Redo의 거동을 수정하였습니다.
  • 파라미터 쇼트컷의 [기본 키 선택]에서 선택한 모든 매개 변수에 대해 기본 키로 돌아가기 설정을 추가했습니다.
  • 파라미터를 복수 선택하여 이동했을 때, 순서가 선택 순서가 되는 버그를 수정했습니다.
  • 글루를 선택하지 않은 상태에서 글루 툴로 전환할 때 브러시가 표시되는 문제를 수정했습니다.
  • [기본 형태 잠금]이 활성화되었을 때 변형 경로의 제어점을 선택하면 바운딩 박스가 조작할 수 있는 버그가 수정되었습니다.
  • 잠긴 객체에 대해 [선택한 오브젝트에 포커스]가 작동하지 않는 버그가 수정되었습니다.
  • 물리 연산·씬 블렌드 설정의 커서 추종으로, 범위 기준을 캔버스 범위에서 뷰 범위로 변경했습니다. 확대 시 조작이 쉬워집니다.
  • 물리 연산·씬 블렌드 설정에서 [입력·출력 파라미터]의 [사용] 체크를 범위 선택할 수 있게 되었습니다.
  • 물리 연산·씬 블렌드 설정의 녹화 기능으로, 계산 FPS에 맞춘 씬 설정으로 보존되게 되었습니다.
  • 디포머 팔레트에서 같은 파츠로 드래그 앤 드롭하면 하이라이트 표시가 남는 버그가 수정되었습니다.
  • 어니언 스킨이 활성화되면 파라미터 팔레트에서 파라미터를 선택할 때 모델링 뷰의 어니언 스킨이 업데이트되지 않는 버그가 수정되었습니다.
  • [회전 디포머 생성 툴]을 사용할 때 Shift 키를 클릭하면 마우스 커서가 잘못된 아이콘으로 바뀌는 버그가 수정되었습니다.
  • 빈 파츠을 삭제했을 때 경고 대화상자가 표시되지 않도록 수정되었습니다.
  • 모델용 이미지의 이름 편집을 Undo/Redo 할 수 없는 버그가 수정되었습니다.
  • 배경색 설정 대화상자에서 [짙은 색과의 차이] [체크 무늬 사이즈]를 변경하면 문장이 무너지는 버그가 수정되었습니다.
  • 파츠 팔레트에서 동일한 파츠로 드래그 앤 드롭하면 하이라이트 표시가 남아 있는 버그가 수정되었습니다.
  • 인스펙터 팔레트에서 글루의 적응도가 키 폼상이 아닌 상태로 편집할 수 있는 버그가 수정되었습니다.
  • 인스펙터 팔레트에서 회전 디포머의 각도·배율이 키폼상이 아닌 상태로 편집할 수 버리는 버그를 수정하였습니다.
  • 임시 변형 툴 실행시에, 일시 변형이 개시되지 않는 상태에서도, 파츠 팔레트·디포머 팔레트가 그레이 아웃 해 버리는 버그를 수정했습니다.
  • 디포머 잠금 유효시에, 뷰 에리어상의 마우스 조작으로 일부의 디포머의 변형 조작을 실행할 수 버리는 버그를 수정했습니다.
  • 파라미터 팔레트에서 결합된 매개변수를 복제할 때 매개변수 ID가 중복되는 문제를 수정했습니다.
  • 아트 패스의 선폭의 최대치를 2000pixel로 변경했습니다.
  • 기본 형태 잠금 실행시에, 인스펙터 팔레트에서 회전 디포머의 각도·배율이 변경할 수 버리는 버그를 수정했습니다.
  • 잠긴 파츠 폴더에 개체를 넣을 때 개체가 편집 잠금이 되지 않는 문제를 수정했습니다.
  • 원화의 추가·삭제로 잘못된 Undo/Redo가 일어날 수 있는 문제를 수정하였습니다.
  • 파츠 팔레트의 오브젝트 표시/숨기기 버튼이 내부 상태와 일치하지 않는 문제를 수정했습니다.
  • 파츠 설정 및 파라미터 설정 다이얼로그의 Cancel 버튼을 클릭했을 때, 확인 다이얼로그가 표시되도록 수정되었습니다.
  • 파츠 팔레트에서 여러 오브젝트를 선택한 후 파츠 폴더를 열고 닫을 때 선택이 취소되는 버그가 수정되었습니다.
  • 모델링에서 블렌드 방식을 변경한 후 애니메이션에도 반영되도록 수정하였습니다.
  • 기본 폼을 잠긴 상태에서도 Alt+드래그로 회전 디포머 원의 크기를 변경할 수 있도록 수정했습니다.
  • 디포머 팔레트에서 선택한 디포머로 드래그 앤 드롭하면 잘못된 상태가 되는 버그가 수정되었습니다.
  • 기본 폼을 잠그고 Ctrl(Alt) 키를 누른 상태에서 워프 디포머 또는 회전 디포머를 편집해도 경고가 발생하지 않도록 수정했습니다.
  • 비표시를 포함한 아트 메쉬를 복수 선택했을 때, 해당의 비표시 아트 메쉬도 정리해 이동해 버리는 버그를 수정했습니다.
  • 새 텍스쳐 아틀라스 설정 대화상자를 열 때 부모 창의 중심에 표시되도록 수정되었습니다.
  • 물리 연산의 계산 FPS가 모델별로 저장됩니다.
  • 긴 파라미터명이 있는 경우에, 그 이외의 파라미터에서도 모델링 뷰 [오른쪽 클릭 메뉴]의 파라미터 슬라이더가 축소되는 버그를 수정했습니다.
  • 파츠 설정 대화상자에서 편집하지 않고 Cancel 버튼을 누를 때 확인 대화상자가 표시되지 않도록 했습니다.
  • 모델링 뷰의 오른쪽 클릭 메뉴가 작업 표시줄의 뒤쪽에 숨어버리는 버그가 수정되었습니다.
  • 브러시 선택 툴로 여러 버텍스를 선택할 때 인스펙터 팔레트의 버텍스 정보가 업데이트되지 않는 버그가 수정되었습니다.
  • 단독 표시의 비활성 컬러 설정이 제대로 반영되지 않았던 버그가 수정되었습니다.
  • 파츠를 복사할 때 복사되는 매개변수를 복사 원본의 모양과 일치하도록 수정되었습니다.
  • 모델을 저장할 때 미사용 원화를 삭제할지 확인하는 대화상자에서 어느 원화가 미사용인지 명칭을 표시하도록 했습니다.
  • 브러시 선택 툴, 글루 툴의 공통 설정을 각각 설정할 수 있도록 수정되었습니다.
  • 변형 패스 툴에서, 링 위에 된 패스의 선두와 말미의 컨트롤 포인트를 선택하면, 마음대로 꺾은 선이 무효가 되는 버그를 수정했습니다.
  • 모델을 복제하고 복제 대상에서 매개 변수 ID를 변경하여 복제 원본으로 다시 가져올 때 변경 전 매개 변수가 적용되는 문제를 수정했습니다.
  • 변형 패스의 컨트롤 포인트가 1개일 때는 인스펙터 팔레트로 선 변형의 폭이나 경도를 변경할 수 없게 했습니다.
  • 물리 연산 설정의 출력 설정 탭에서 배율을 변경했을 때 최대 출력의 자동 조정이 이루어지지 않는 버그가 수정되었습니다.

애니메이션

《기능 추가》

  • 타임 라인 팔레트의 [팔레트 메뉴] 모든 항목에 대해 바로 가기 키를 설정할 수 있도록 했습니다.
  • 타임라인 왼쪽의 속성 패널에서 파라미터를 선택할 때 모든 키를 선택하는 기능을 추가했습니다.

《개선 항목》

  • FA 뷰에서 조정 모드 1과 2를 병용했을 경우에, 정상적으로 형상 편집할 수 없는 버그를 수정하였습니다.
  • canx 형식의 애니메이션 파일을 씬 가져올 때 오류가 발생하는 버그가 수정되었습니다.
  • FA 뷰에서 디포머를 조작할 때 불필요한 경고가 나오는 버그가 수정되었습니다.
  • 일련 스틸 이미지의 여러 프레임을 내보내면 이미지가 씬별로 폴더로 정리됩니다.
    또한 모든 씬 내보내기에서 같은 이름 씬을 덮어 쓰지 않도록 수정했습니다.
  • 오디오 파일을 바꿀 때 오디오 트랙의 파형 표시가 업데이트되지 않는 버그가 수정되었습니다.
  • 파일 확장 후 오디오 파일의 연결이 끊어진 경우 오디오 파일이 제대로 로드되지 않는 오류를 수정했습니다.
  • 폼 애니메이션 편집시의 인스펙터 팔레트 [조정 모드 2]일 때 편집할 수 없는 항목에 수치를 입력할 수 버리는 버그를 수정하였습니다.
  • 연속 이미지, GIF, 동영상 출력에서 GPU 메모리가 해제되지 않는 오류를 수정했습니다.
  • 트랙의 위치를 변경했을 때, 영역 밖으로 나오면 에러가 나오는 버그가 수정되었습니다.
  • 파라미터 선택 상태가 정상적으로 전환되지 않는 오류를 수정했습니다.
  • 링크 부족이 발생한 파일에 대해 [데이터 교체]를 할 때, 대상외 확장자의 파일을 선택할 수 없도록 수정되었습니다.
  • 마커의 툴팁 윈도우에 판정의 어긋남이 있던 버그가 수정되었습니다.
  • 모션 녹화를 저장할 때 열려 있지 않은 can3 파일에 씬이 추가되어 버리는 버그가 수정되었습니다.
  • 물리 연산 애니메이션 베이크에서 물리 연산의 설정 FPS와 씬의 FPS가 다른 경우, 베이크에 사용할 FPS 설정을 선택할 수 있도록 했습니다.
  • 폼 편집을 설정한 모델의 파츠를 모델링의 메쉬 편집 기능으로 정점이 증감하는 변경을 했을 때,
    애니메이션에서 대화상자가 반복적으로 표시되어 조작 불능이 될 수 있는 버그가 수정되었습니다.
  • 특정 조건 하에서 모델 파츠이 흰색으로 표시되는 버그가 수정되었습니다.
  • 트랙을 잠글 때 트랙 선택 범위를 해제하도록 수정되었습니다.
  • 트랙을 복제하면 양식 애니메이션 복구에 실패하는 문제를 수정했습니다.
  • 정지영상(연번) 출력 설정 대화상자에 있는 경고문 「내보내기 범위 밖에 있는 씬의 프레임은 내보내지지 않습니다」는 해당 씬이 있는 경우에만 표시되도록 수정되었습니다.
  • 소재 파일 교환 시 [파일이름을 이용]으로 설정되어 있는 트랙의 이름이 갱신되지 않는 버그가 수정되었습니다.

Cubism Viewer

《기능 추가》

  • Cubism Viewer (for OW)에서 프레임 속도를 확인할 수 있습니다.

 

 

4.1.01 (2021/9/15)

공통

《개선 항목》

  • 시작 시 표시되는 긴급도가 낮은 오류 로그가 로그 팔레트에 표시되지 않도록 수정되었습니다. (로그 파일에는 모두 나열됩니다)

모델링

《개선 항목》

  • 물리 연산·씬 블렌드 설정에서 그룹 편집만을 했을 때 결과가 저장되지 않는 버그를 수정하였습니다.
  • 템플릿 기능 모델을 3.0 이상 형식으로 업데이트했습니다.

애니메이션

《개선 항목》

  • canx 형식의 애니메이션 파일을 can3 형식으로 변환할 때 씬의 길이가 1프레임 길어져 버리는 버그가 수정되었습니다.
  • [마지막 프레임으로] 버튼을 클릭했을 때 작업 영역의 끝으로 이동하지 않는 버그가 수정되었습니다.

 

 

4.1.01 beta1 (2021/8/19)

공통

《개선 항목》

  • 바로 가기 설정 대화 상자에 [변형브러쉬 도구]를 추가했습니다.
  • 바로 가기 설정 대화 상자에 [찾아 바꾸기]를 추가했습니다.
  • 모드리스 다이얼로그를 연 상태에서 캔버스의 확대축소 등의 마우스 휠 조작을 하면, 에디터 전체의 표시 사이즈가 바뀌는 버그를 수정했습니다.
  • 에디터를 재시작하면 캔버스의 배경색 설정이 기본 투명으로 돌아가는 버그가 수정되었습니다.
  • [Windows 버전] 고DPI 설정 시 스포이드의 획득 위치가 어긋나는 문제를 수정하였습니다.
  • [Mac 버전] 시작 시 오류가 발생할 수 있는 버그가 수정되었습니다.
  • [Mac 버전] 파일을 읽을 때 오류가 발생할 수 있는 버그가 수정되었습니다.

모델링

《기능 추가》

  • 스트로크에 의한 메쉬 분할(beta)로 스트로크를 편집 후 확정을 하지 않고 다른 툴로 전환하려고 할 때 확인 대화창을 표시하도록 수정하였습니다.
  • 물리 연산·씬 블렌드 설정 다이얼로그에서, 출력 설정 테이블과 진자 설정 테이블상에서 복수 선택한 상태에서의 동시 편집을 할 수 있게 되었습니다.
  • 물리 연산, 씬 블렌드 설정 대화상자에서 출력 설정 테이블에 복사 및 붙여넣기를 할 수 있습니다.

《개선 항목》

  • 특정 조건 하에서 오브젝트를 복수 선택하고 툴 상세 팔레트 → 일시 워프 변형의 [워프의 분할 수]를 변경하면 오브젝트명이 ID명으로 변경되어 버리는 버그를 수정하였습니다.
  • ID가 63문자로 말미가 알파벳의 파라미터를 복제하면, 부정한 ID가 설정되어 버리는 버그를 수정했습니다.
  • 아트패스 툴을 사용할 때 마우스 커서 표시에 불일치가 있었기 때문에 수정되었습니다.
  • 아트패스 툴의 기본 브러쉬 설정에서 아트패스 브러쉬 설정에서 편집한 내용이 즉시 반영되지 않는 문제를 수정했습니다.
  • [형상 혼합]의 처리를 최적화하여 응답을 개선했습니다.
  • 여러 드로잉 객체를 선택하고 각 꼭지점을 하나씩 선택할 때 경계 상자가 표시되지 않는 버그를 수정했습니다.
  • 파츠의 이름을 바꾸면 파츠 팔레트의 파츠가 펼쳐지는 버그가 수정되었습니다.
  • 디포머의 이름을 바꾸면 디포머 팔레트의 디포머의 배포가 해제되는 버그가 수정되었습니다.
  • 변형브러쉬 도구의 브러쉬 크기를 「B+드래그」로 변경할 때에, 브러쉬 크기를 작게 해 가면 브러쉬의 원이 반전해 버리는 버그를 수정했습니다.
  • 스트로크에 의한 메쉬 분할(beta)로, 쇼트 컷을 사용해 메쉬 편집을 확정했을 때에, [편집 중의 스트로크 확정]의 표시가 캔버스상에 계속 남아 있는 버그를 수정했습니다.
  • 스트로크에 의한 메쉬 분할(beta)의 전선택과 삭제시의 거동을 조정하였습니다.
  • 스트로크에 의한 메쉬 분할(beta)의 조작시에 마우스 커서가 갱신되지 않는 버그를 수정하였습니다.
  • 파라미터 쇼트컷의 [이전 키 선택] [다음 키 선택]에서 파라미터에 반복 설정이 있는 경우 반복하여 키를 선택하도록 수정되었습니다.
  • 파라미터 쇼트컷의 [이전 선택] [다음 선택]에서 매개 변수 팔레트 목록이 스크롤되지 않는 문제를 수정했습니다.
  • 프로젝트 팔레트의 오른쪽 클릭 메뉴에서 [선택 오브젝트의 입력 이미지로 설정]이 원화측과 모델용 화상측에서 같은 명칭이기 때문에, 구별하기 쉬운 명칭으로 변경했습니다.
  • 캔버스의 반전 중에 [선택 오브젝트의 포커스]를 실시하면, 반전 상태가 해제되어 버리는 버그를 수정했습니다.
  • 모델링 메뉴의 [선택되지 않은 오브젝트를 잠금] [모든 잠금 해제] [선택되지 않은 오브젝트 감추기] [모두 보이기]의 대상에 글루가 포함되지 않는 버그가 수정되었습니다.
  • 물리 연산·씬 블렌드 설정 다이얼로그에서, 테이블의 행 이동을 실시하는 화살표 버튼의 조작을 실시하면, 행이 사라져 버리는 일이 있는 불편을 수정했습니다.

애니메이션

《기능 추가》

  • 그래프 편집기에서 핸들과 키가 겹쳐지면 멀리 표시되도록 수정했습니다.
  • 도프 시트, 그래프 편집기에서 위아래로 값을 변경할 수 있습니다.
  • 도프 시트, 그래프 편집기에서 커서 키로 여러 번 이동을 한 번의 Undo로 처리하도록 수정했습니다.
  • 스틸 이미지 (연속) 출력 설정 대화 상자에서 모든 씬의 출력을 선택할 수 있습니다.
  • GIF 애니메이션 출력 설정 대화상자에서 모든 씬의 출력을 선택할 수 있습니다.

《개선 항목》

  • 그래프 편집기에서 마우스 중간 버튼으로 이동할 수 없는 버그를 수정했습니다.
  • 그래프 편집기의 박스 편집에서 해당 키 값의 색상이 변하지 않았던 버그를 수정했습니다.
  • 도프 시트, 그래프 편집기에서 커서 키로 키 이동이 제대로 작동하지 않는 문제를 수정했습니다.
  • 타임라인 도프 시트로 무거운 환경에서 다음과 같은 문제를 개선했습니다.
    ・키 편집시의 응답
    ・키가 움직이지 않는 경우가 있는 문제
  • Live2D 파라미터 그룹의 프레임 스텝 속성에서 편집을 되돌릴 수 없게 되는 버그가 수정되었습니다.
  • 애니메이션에서 여러 모델 트랙을 배치할 때 어니언스킨의 드로잉 부하가 과도하게 증가하는 버그가 수정되었습니다.
  • 모델 트랙을 만들 때 모델의 cmo3 파일이 삭제되고 이동되었을 때 오류 메쉬지를 표시하도록 수정되었습니다.
  • 인스펙터 팔레트의 [사이즈(폭)] [사이즈(높이)]를 드래그 조작으로 변경했을 때, [가로세로 비율 고정]에 체크가 된 상태에서도 올바르게 종횡비가 유지되지 않는 버그를 수정하였습니다.
  • 여러 트랙의 키를 한꺼번에 간격 조정할 때 키가 사라지거나 덮어쓰기되는 문제를 수정했습니다.
  • 이미지나 동영상을 내보내는 동안 취소를 했을 때 파일이 출력되지 않은 경우에도 저장처가 표시되는 문제를 수정하였습니다.

Cubism Viewer

《개선 항목》

  • Viewer에서 열 수 없었던 파일에 대해서, 에러나 경고를 하는 메세지 다이얼로그를 표시하도록 했습니다.

 

 

4.1.00 (2021/6/10)

이 버전의 새로운 기능에 대한 자세한 내용은 아래 페이지를 참조하십시오.
새로운 기능 소개 4.1

공통

《개선 항목》

  • [Mac 버전] 멀티 모니터 환경에서 타겟 버전 선택 대화 상자가 편집기와 별도의 모니터에 표시되는 문제를 수정했습니다.
  • 모델링 및 폼 애니메이션 메뉴 항목의 순서와 이름을 일부 변경했습니다.
  • 임시 변형 도구의 회전에 있어서, 임시 변형 도구로 표시되는 구형의 밖을 드래그 했을 경우에서도 회전할 수 있게 되었습니다.
  • 임시 변형 도구 사용 중에 바운딩 박스가 표시되는 버그가 수정되었습니다.
  • 임시 변형 도구 실행 시 캔버스의 표시를 조정했습니다.
  • 임시 변형 도구 실행 시 파츠 팔레트 및 디포머 팔레트를 편집할 수 없도록 동작이 수정되었습니다.
  • 임시 변형 도구 런타임에 툴 상세 팔레트에서 임시 변형 도구를 전환할 수 있도록 수정되었습니다.
  • 임시 변형 도구 실행 시 조작에 따라 마우스 커서가 변경되도록 수정되었습니다.

모델링

《개선 항목》

  • 물리 연산·씬 블렌드 설정의 [커서 추종 설정] 다이얼로그에 [적용] 버튼을 추가했습니다.
  • 글루를 만들 때 글루 이름의 끝에 대상 아트 메쉬 이름이 포함되도록 사양을 변경했습니다.
  • 캔버스의 글루 버튼의 UI 문자열이 일정 폭 이상이 되는 경우는 말미를 생략해 표시하도록 수정했습니다.
  • 임시 변형 경로의 변형 알고리즘이 개선되었습니다.
  • 임시 스냅샷 기능이 보기 탭당 최대 4개까지 유지되도록 수정되었습니다.
  • 닫힌 파츠을 선택한 상태에서 [기본 설정값으로 되돌리기]를 하면 파츠이 전개되어 버리는 버그가 수정되었습니다.
  • 모델 작성과 관련된 파라미터의 영어・중국어를 일부 수정하였습니다.
  • 찾아 바꾸기 대화상자에서 [캔버스로 선택]을 실행할 때, 파라미터 팔레트의 갱신이 이루어지지 않는 버그가 수정되었습니다.
  • [매개변수 복제]에서 여러 선택된 매개변수가 모두 복제되도록 수정되었습니다.
  • [매개변수 복제]에서 추가되는 매개 변수 이름이 복제 원본과 동일하도록 수정되었습니다.
  • 스트로크로 아트 패스를 만들 때 끝점이 닫힐 수 있는 문제를 수정했습니다.
  • 스트로크에 의한 메쉬 분할(beta) 실행중에 메쉬 편집을 완료했을 때, 캔버스상에 패스의 표시가 남아 버리는 버그가 수정되었습니다.
  • 스트로크에 의한 메쉬 분할(beta) 툴 및 스트로크로 아트 패스를 작성·편집할 때의 마우스 커서를 변경하였습니다.
  • 스트로크에 의한 메쉬 분할(beta) 툴로 편집중에, 다른 툴로 전환했을 때에 편집 내용을 캔슬하도록 수정했습니다.
  • 스트로크에 의한 메쉬 분할(beta) 툴로 편집중에 [삭제]를 실행하여 편집 내용을 삭제할 수 있도록 수정하였습니다.
  • 스트로크에 의한 메쉬 분할(beta) 툴로 [모델용 이미지 표시] [아틀라스 표시] 시에 패스가 표시되지 않는 버그를 수정하였습니다.
  • 메쉬 편집시의 툴 상세 팔레트의 버튼의 아이콘을 일부 변경했습니다.

애니메이션

《기능 추가》

  • 그래프 편집기에 [키의 이름 표시하기] 기능을 추가했습니다.

《개선 항목》

  • [Mac 버전] 동영상 내보낼 때 대화 상자와 진행률 표시줄이 창 뒤에 표시되는 문제를 수정했습니다.
  • 샤이 유효시에 특정 조건하에서 키를 이동할 수 없게 되는 버그를 수정하였습니다.
  • 타임라인의 속성을 선택할 때 드물게 색상이 변하지 않는 다른 색상이 되는 버그가 수정되었습니다.
  • 시작 프레임이 0이 아닌 경우 그래프 편집기의 키 정보가 표시되는 윈도우의 값이 어긋나는 버그가 수정되었습니다.
  • FA에서 특정 오브젝트를 선택한 상태에서 브러시 선택 툴을 사용할 때 브러시 커서의 원이 깜박이는 버그가 수정되었습니다.
  • FA에서 스트로크로 아트 패스를 편집할 때 마우스 커서를 변경했습니다.

Cubism Viewer

《기능 추가》

  • [커서 추종 설정] 기능이 추가되었습니다.

 

 

4.1.00 beta1 (2021/5/13)

이 버전의 새로운 기능에 대한 자세한 내용은 아래 페이지를 참조하십시오.
신기능 소개 4.1(beta판)

공통

《기능 추가》

  • 어니언스킨이 공식 버전이 되었습니다. 주로 다음 기능을 추가했습니다.
    ・뷰 영역 하부에 어니언스킨 ON/OFF 버튼을 설치
    ・어니언스킨의 표시 조건, 대상 등의 세세한 설정을 추가
    ・어니언스킨 마커 기능 추가
    ・어니언스킨의 묘화 위치를 X/Y 방향으로 어긋나는 오프셋 기능을 추가
  • 저장이나 내보내기시에 동명 파일이 존재하는 경우의 명명 방식을 이하와 같이 변경했습니다.
    ・화상/동영상 등: 「저장명(X)」
    ・cmo3, can3 등: 「저장 이름_X」 또는 「저장 이름(X)」을 선택 가능
     메뉴 → 파일 → 설정에 [다른 이름으로 저장 시 파일 이름 끝에 (X) 붙이기] 항목을 추가

《개선 항목》

  • macOS 10.12 (Sierra) 지원이 종료되었습니다.
  • 에디터를 복수 기동시에 배경색의 설정이 서로 영향을 주는 버그를 수정했습니다.

모델링

《기능 추가》

  • 도구 팔레트에 [변형브러쉬 도구]를 추가했습니다.
  • 파라미터 팔레트에 [매개변수 복제]를 추가했습니다.
  • 아트패스 도구에 [스트로크로 아트 패스 작성/편집] 기능이 추가되었습니다.
  • [선택 상태 숨기기] 기능이 추가되었습니다.
  • 새 파츠 생성 다이얼로그에 [선택 오브젝트를 자식에 넣기] 기능을 추가했습니다.
  • 브러시 선택 툴로 워프 디포머를 선택할 때 그라데이션으로 면이 그려져 알기 쉬운 외형이 되도록 수정되었습니다.
  • 텍스쳐 아틀라스 편집의 자동 레이아웃에 [레이아웃 대상] [배율] [회전 허가 유무] 설정 항목을 추가했습니다.
  • 물리 연산 설정으로 출력처의 파라미터가 변경될 때,
    동일 물리 연산 그룹 내에서 동일 규칙으로 변경 가능한 출력처 파라미터에 관해 정리해 변경하는 기능을 추가했습니다.

《개선 항목》

  • 작업 공간을 전환할 때 파츠 팔레트의 검색 상태가 재설정되는 문제를 수정했습니다.
  • 올가미 선택 툴, 브러시 선택 툴, 변형 패스 툴, 글루 툴, 아트패스 툴, 회전 디포머 생성 툴에서
    Ctrl을 눌러 파츠을 조작할 때 경계 상자가 표시되지 않는 버그를 수정했습니다.
  • 파라미터 팔레트의 단축키로 다음·전의 키로 천이할 때, 순간적으로 부정한 값이 될 수 있는 버그를 수정했습니다.
  • 파라미터 편집 대화상자를 닫을 때 파라미터가 기본값으로 재설정되는 버그가 수정되었습니다.
  • 아트 패스의 컨트롤 포인트의 불투명도・굵기 변경 툴의 브러시 사이즈에 대해서,
    브러시 선택 툴과 동일하도록 표현의 흔들림을 수정했습니다.
  • 메쉬를 수동으로 편집하는 동안 ESC에서 편집을 취소하려고 할 때 정점을 추가할 수 없게 되는 버그가 수정되었습니다.
  • 랜덤 포즈로 깜박임을 재생하도록 수정되었습니다.
  • 텍스쳐 아틀라스 편집에서 Space+드래그로 화면 스크롤할 수 없는 버그가 수정되었습니다.
  • 텍스쳐 아틀라스 편집에서 배율이나 위치를 텍스트 입력으로 변경했을 때 Undo 할 수 없는 버그가 수정되었습니다.
  • 밑그림 설정된 파츠가 텍스쳐 아틀라스에 배치되어 있지 않은 경우에 불필요한 경고가 표시되는 버그가 수정되었습니다.
  • 물리 연산·씬 블렌드 설정 에디터의 다이얼로그에서 마우스 커서의 외형이 적절하게 변화하도록 수정되었습니다.
  • PSD의 레이어명이 32문자 이상일 때 도중까지만 로드되는 버그가 수정되었습니다.
  • 계층이 6 이상인 PSD를 읽을 때 계층 구조가 무너지는 버그가 수정되었습니다.
  • 중국어 버전 편집기에서 중국어 PSD를 로드할 때 깨지는 문제를 수정했습니다.
  • 동일 정점을 복수의 글루로 움직이는 모델을 moc3 내보낼 때 SDK상에서 표시가 흐트러질 수 있는 문제를 수정하였습니다.

애니메이션

《기능 추가》

  • 타임라인의 조작성과 UI를 대폭 개선했습니다.
    그래프 편집기:
    ・키프레임이나 핸들의 조작성을 개선
    ・보다 직관적인 곡선 편집 기능 추가
    ・스마트 스냅(값을 반올림) 기능 추가
    ・복사 및 붙여넣기 기능 추가
    ・Alt + Shift로 스마트 스냅 기능의 유효 무효 전환 추가
    도프 시트:
    ・키 프레임이나 값의 조작성을 개선
    ・파라미터 입력 정밀도 향상
    ・무거운 모델 편집시의 조작성을 개선
  • 트랙의 단독 표시 기능을 추가했습니다.
  • 표시 버튼과 잠금 버튼을 드래그로 변경하는 기능을 추가했습니다.
  • 파일을 수집하는 기능을 추가했습니다.
  • 씬 가져오기 기능을 추가했습니다.
  • 씬 트랙 기능을 추가했습니다.
  • 스틸 이미지 연속 번호 내보내기 대화 상자에 [파일 이름 설정]을 추가했습니다.
    (정지 화상의 연속 번호의 자리수 및 스타트 번호를 자유롭게 설정할 수 있습니다)
  • 스틸 이미지 연속 번호 내보내기 대화 상자 [지정된 프레임 출력]을 추가했습니다.
    (출력하는 프레임 범위를 자유롭게 설정할 수 있습니다)

《개선 항목》

  • 애니메이션 작성 후 모델의 파라미터 ID를 변경했을 때 모델 트랙의 파라미터가 이상해질 수 있는 버그가 수정되었습니다.
  • 씬을 가로지르는 트럭 복사, 붙여넣기 문제를 수정했습니다.
  • 여러 트랙을 건너편 편집을 실행한 후에 Undo를 할 수 없는 문제를 수정했습니다.
  • 여러 오디오 트랙이 포함된 씬을 편집기에서 재생할 때 오디오 출력이 지연되는 문제를 수정했습니다.
  • 그룹 트랙의 오디오 트랙이 그룹 트랙 범위를 넘어서 재생되는 버그가 수정되었습니다.
  • 오디오 트랙이 포함된 애니메이션을 재생하면서 표시기를 움직일 때 오디오가 제대로 재생되지 않는 문제를 수정했습니다.
  • 연속번호 트랙에서 연속번호 이미지의 파일명에 대소문자 표기가 다른 파일이 혼입되면 드로잉이 이상해지는 버그가 수정되었습니다.
  • macOS에서 연속 이미지 트랙이 제대로 표시되지 않는 오류를 수정했습니다.
  • 도프 시트에서 트랙, 파츠, 속성 그룹을 포함한 범위 선택이 불법이 되는 버그가 수정되었습니다.
  • 그래프 에디터에서 샤이 상태의 속성도 표시되어 버리는 버그를 수정했습니다.
  • 샤이의 전체 해제 시, 연결된 파라미터 아래의 스테이지의 샤이가 해제되지 않는 버그가 수정되었습니다.
  • 프로퍼티의 「배율 X/Y」의 값을 「0.0」으로 설정하면 에러가 발생하는 버그를 수정했습니다.
  • FA의 폼 편집에서 키 폼이 없는 프레임을 선택한 상태에서 아트 메쉬를 변형하면
    아트 메쉬가 기본 모양으로 돌아가는 버그가 수정되었습니다.
  • 트랙으로 읽어들이고 있는 파일이 링크 끊어진 상태인 경우에 타임 라인 팔레트의 조작 등으로 에러가 되는 버그를 수정했습니다.
  • 소재의 링크 끊김이 발생하고 있는 트랙을 포함한 씬을 복제했을 때에 에러가 되는 버그가 수정되었습니다.
    해당 씬은 복제할 수 없다는 경고 대화상자가 표시됩니다.
  • Cubism Editor에서 내보낸 MOV 파일을 After Effects로 가져올 수 없는 문제를 수정했습니다.

Cubism Viewer

《기능 추가》

  • Cubism SDK for Native, Cubism SDK for Web에서 베지어 커브의 재현성이 열화된 상태를 재현한 상태에서 모션을 재생하는 기능을 추가했습니다.
    열화하는 경우의 차이가 커브 곡선을 화상으로 확인하는 기능으로 시각적으로 확인할 수 있게 되었습니다.
  • 모션 베지어 커브의 취급 유형을 Inspector에서 확인할 수 있습니다.

 

 

4.0.09 (2021/4/20)

모델링

《개선 항목》

  • 4.0.08에서, 글루 작성시에 글루 이름에 아트 메쉬 이름을 유용하도록 사양 변경했습니다만,
    단절이 발생하기 쉬운 상태가 되었기 때문에, 4.0.08 beta1 이전과 같은 사양에 되돌렸습니다.
  • 특정 모델에서 키 양식 편집 대화상자가 제대로 작동하지 못하는 문제를 수정했습니다.
  • 파라미터가 선택되지 않은 상태에서 파라미터를 Shift+왼쪽 클릭하면 정상적으로 파라미터를 선택할 수 없는 버그가 수정되었습니다.

 

 

4.0.08 (2021/3/18)

공통

《개선 항목》

  • 파라미터명에 「><」가 포함되어 있으면 편입 파일 기입 후 SDK로 올바르게 읽을 수 없는 버그가 수정되었습니다.

모델링

《개선 항목》

  • 글루를 만들 때 파츠 팔레트가 업데이트되지 않는 버그가 수정되었습니다.
  • 글루 작성시 글루 이름에 아트 메쉬 이름을 유용하도록 사양 변경했습니다.
  • (※) 특정 모델에서 키 폼 편집 대화상자가 정상적으로 조작할 수 없는 버그를 수정하였습니다.
  • (※) 파라미터가 선택되지 않은 상태에서 파라미터를 Shift+왼쪽 클릭하면 정상적으로 파라미터를 선택할 수 없는 버그를 수정하였습니다.

※이것은 수정이 완전하지 않은 것이 확인되고 있습니다.
버전 4.1.00 beta1(5월 중순 예정) 및 4.0.09(4월 하순 예정)에서 수정될 예정입니다.

Cubism Viewer

《기능 추가》

  • 매개변수 목록에서 키 위치가 표시됩니다.

 

 

4.0.08 beta1 (2021/2/15)

공통

《개선 항목》

  • RADEON 탑재의 일부 환경에서 그릴 때마다 전용 GPU 메모리 사용량이 늘어나는 문제를 수정하였습니다.
  • macOS Big Sur에서 일부 링크가 제대로 열리지 않는 오류를 수정했습니다.

모델링

《개선 항목》

  • 회전 디포머의 부모 - 자식 구조를 구축했을 때, 부모의 회전과 같은 값이 바로 아래의 자식으로 잘못 설정되어 버리는 버그를 수정했습니다.
  • 파라미터의 키에 있어서의 회전 디포머의 각도 표시가, 부모의 회전의 영향을 받은 값으로 변경되어 버리는 버그를 수정했습니다.
  • 인스펙터에서 글루 이름을 변경했을 때 파츠 팔레트의 표시가 업데이트되지 않는 버그가 수정되었습니다.
  • 인스펙터 팔레트의 디포머 필드에 Root에 있는 디포머가 중복되어 표시될 수 있는 버그가 수정되었습니다.
  • 확장 보간을 설정한 드로잉 오브젝트를 복수 선택한 상태에서 「키 폼 편집 다이얼로그」에서 키를 삭제하면,
    삭제 불가능한 키를 삭제할 수 있는 버그가 수정되었습니다.
  • 움직임 반전으로, 적용하는 아트 메쉬 또는 디포머에 부착하는 파라미터가 디폴트 값이 아닌 경우,
    제대로 적용할 수 없는 문제를 수정했습니다.
  • 모션 내보낼 때 내보내기 대상을 모든 파라미터로 설정했을 때 사양을 설명하는 팝업을 표시하도록 했습니다.
  • Cubism 2.1 모델을 가져올 때 다각형이 빠질 수 있는 버그가 수정되었습니다.

 

 

4.0.07 (2020/12/17)

공통

《기능 추가》

  • macOS 11.0 Big Sur를 지원했습니다.
    ※Intel CPU 탑재 모델만 대응했습니다. Apple M1 칩 탑재 모델은 현재 지원하지 않습니다.
    ※macOS 11.0 Big Sur에서는 아래와 같은 제한 사항이 있습니다.
     시스템의 언어 설정이 영어 이외의 경우에도 메뉴 바의 Mac 표준 메뉴가 영어 표기
    ※OS를 업데이트하기 전에 반드시 Cubism Editor의 정품 인증을 해제하십시오.
     도움말 사이트 「Cubism Editor를 설치하는 macOS를 업그레이드하고 싶습니다

모델링

《개선 항목》

  • 특정 조작 시 단축키의 「Delete」를 사용할 수 없는 버그가 수정되었습니다.

Cubism Viewer

《개선 항목》

  • Viewer에서 모션을 연결하고 model3.json을 내보낼 때 경로 표기가 OS 의존적이 되는 문제를 수정했습니다.
    4.0.07 beta1에서 model3.json을 내보낸 경우 이 버전에서 다시 내보내는 것이 좋습니다.

 

 

4.0.07 beta1 (2020/11/26)

공통

《기능 추가》

  • 바로 가기 설정 대화 상자에서 중복 키 설정이 있는 경우 경고를 표시하는 기능을 추가했습니다.

《개선 항목》

  • 동영상 튜토리얼 메뉴의 일부를 수정했습니다.
  • cmox/canx 파일을 열어 편집 후 에디터를 닫을 때에 표시되는 다이얼로그로부터 저장했을 때,
    잘못된 확장자로 덮어 쓰여지는 문제를 수정했습니다.
  • 로그 팔레트에서 실수로 오류가 처리된 로그의 출력을 억제하도록 수정되었습니다.
  • 바로가기 설정 대화상자에서
    중복 키를 설정할 때 기존 설정을 삭제할지 묻는 대화 상자를 표시하도록 수정되었습니다.

 

모델링

《기능 추가》

  • 물리 연산 설정 대화상자에서 그룹 설정 영역의 원래 위치로 [복제] 버튼을 복원했습니다.
  • 물리 연산 설정 대화상자에서 출력 설정의 오른쪽 클릭 메뉴에 [그룹 분리] 기능을 추가했습니다.
  • 물리 연산 설정 대화상자에서 그룹 설정 영역에 연산의 유효/무효를 일시적으로 전환하는 체크 박스를 추가했습니다.
  • 물리 연산 설정 다이얼로그의 진자 표시 영역에서 45° 단위의 회전 조작을 할 수 있게 되었습니다.
  • 워프 디포머의 리사이즈시에 자식 요소(워프 디포머, 회전 디포머, 아트 메쉬)의 사이즈 및 위치를 보이도록
    [워프디포머 리사이즈 시 자식요소 표시] 기능이 추가되었습니다.
  • 파츠 팔레트에서 선택한 파츠 이하의 오브젝트나 파츠를 일괄로 표시/숨기기 및 잠금/잠금 해제할 수 있습니다.
  • 파츠 팔레트에서 선택한 파츠 이하의 파츠를 일괄로 전개/접을 수 있게 되었습니다.

《개선 항목》

  • 파츠 팔레트 및 디포머 팔레트의 [모두 합치기]를 하위 계층도 포함하여 접을 수 있도록 수정되었습니다.
  • 파츠 팔레트에서 파츠를 새로 만들 때 선택한 파츠가 펼쳐지는 버그가 수정되었습니다.
  • 파츠 팔레트의 파츠 설정, 파라미터 팔레트의 파라미터 설정과 그룹 설정의 Undo/Redo의 거동이 부정하게 되는 버그가 수정되었습니다.
  • 파라미터 팔레트에서 파라미터 삭제나 작성 등 후에 Undo/Redo를 실시했을 때, 표시 위치가 어긋나는 버그를 수정하였습니다.
  • 동일한 파라미터에 「반복」과 「눈 깜빡임, 립싱크」를 동시에 설정할 수 없도록 제한을 추가했습니다.
    (동시에 설정한 경우에 발생하는 에러 등의 문제를 방지하기 위한 제한입니다)
  • 인스펙터 팔레트에서 ID나 클리핑을 오랫동안 입력했을 때 텍스트 상자가 깨져버리는 버그가 수정되었습니다.
  • 인스펙터 팔레트의 디포머 풀다운 순서가 디포머 팔레트의 순서와 다를 수 있는 버그가 수정되었습니다.
  • 인스펙터 팔레트에서 불투명도가 키 폼상이 아니어도 변경할 수 있는 버그가 수정되었습니다.
  • 인스펙터 팔레트의 레이아웃을 조정했습니다.
  • 애니메이션 뷰에서 아트 패스를 클릭하여 아트 메쉬와 마찬가지로 모델을 선택할 수 있도록 거동을 수정했습니다.
  • [Mac 버전] 디포머 팔레트에서 계층을 표현하는 선을 표시하도록 수정되었습니다.
  • 멀티 뷰 상태에서 탭을 삭제하거나 재정렬할 때 오류가 발생할 수 있는 버그가 수정되었습니다.
  • 텍스쳐 아틀라스 편집에서 바운딩 박스와 텍스쳐 표시가 어긋나는 버그를 일부 수정하였습니다.
  • 확장 보간의 경우에도 어니언 스킨의 궤도가 선형 보간시의 표시가 되어 버려 일치하지 않는 오류를 수정하였습니다.
  • 잠긴 객체를 캔버스에서 선택하고 잠금 해제할 때 상위 계층의 디포머 잠금이 해제되는 문제를 수정했습니다.
  • 잠긴 객체와 잠겨 있지 않은 객체를 동시에 선택하는 상태에서
    캔버스에서 편집할 수 있는 버그가 수정되었습니다.
  • 잠겨있는 아트 메쉬의 메쉬를 수동으로 편집할 수 있는 버그가 수정되었습니다.
  • 회전 디포머를 회전시킬 때 부하 파츠의 어니언스킨의 궤도가 일치하지 않는 버그가 수정되었습니다.
  • 키 형태가 아닌 상태의 회전 디포머의 자식로서 회전 디포머를 작성할 때 에러가 되는 버그를 수정했습니다.
  • 물리 연산 설정 대화상자에서 입력의 정규화란에 올바르게 값을 입력할 수 없는 버그가 수정되었습니다.
  • 글루를 복사하거나 파츠 내보낼 때 해당 대상의 아트 메쉬도 복사 또는 파츠 내보내기 대상에 포함되도록 했습니다.
  • 아트 패스와 아트 메쉬를 동시에 선택할 때 인스펙터 팔레트에서 그리기 순서 등의 공통 항목을 편집할 수 있도록 수정되었습니다.
  • 두 개의 아트 메쉬로 설정된 변형 경로를 선택할 때 하이라이트가 불법이 될 수 있는 버그가 수정되었습니다.
  • 다른 변형 경로를 가진 아트 메쉬를 여러 개 선택한 상태에서,
    변형 패스의 컨트롤 포인트를 드래그했을 때에 에러가 되는 버그가 수정되었습니다.
  • 불투명도나 그리기 순서가 부정 상태가 된 키 폼이 자동적으로 복구되도록 수정되었습니다. 복구 내용은 로그에 표시됩니다.
  • 변형 패스를 편집할 때 아트 메쉬의 변형을 Undo 할 수 없는 문제를 수정하였습니다.
  • 변형 경로의 제어점을 한 점 삭제하면 인스펙터의 표시가 업데이트되지 않는 문제를 수정했습니다.
  • 오브젝트를 드래그하여 이동 중에 마우스 휠을 조작하면 부정한 거동이 되어 Undo 할 수 없게 되는 버그가 수정되었습니다.
  • 모델 객체의 일괄 설정으로 CSV 내보내기 / 가져오기를 할 때,
    오브젝트나 파라미터의 명칭에 「,」(콤마)가 포함되어 있으면 에러가 되는 버그를 수정했습니다.
  • moc3 내보내기 설정에서 내보내기 유형이 nizima일 때
    「모델 이름」의 끝에 반각 공백이 포함된 경우 내보내기에 실패하는 문제를 수정했습니다.

 

애니메이션

《기능 추가》

  • 타임 라인 팔레트의 마커를 잠그는 기능이 추가되었습니다.
    잠금 중에는 마커 추가, 삭제, 드래그 조작으로 이동할 수 없습니다.
  • FA 기능에서 양식 편집 및 양식 편집 속성 그룹 삭제 기능을 추가했습니다.

《개선 항목》

  • FA 뷰에서 객체 선택만 했음에도 불구하고 저장되지 않은 상태를 의미하는 「*」가 표시되는 문제를 수정했습니다.
  • FA 뷰를 닫을 때 타임 라인 팔레트의 표시가 무너지는 버그가 수정되었습니다.
  • FA 뷰에서 기본 폼이 잠긴 상태에서 워프 디포머를 조작할 때 의도하지 않은 모양 편집이 실행되는 버그가 수정되었습니다.
  • FA의 타임 리맵 기능으로 Undo/Redo를 실행시에 부정한 거동이 되는 버그를 수정하였습니다.
  • FA 뷰에서 Undo했을 때 그리기 순서가 인스펙터 팔레트와 파츠 팔레트에서 어긋남이 발생하는 버그가 수정되었습니다.
  • FA 뷰에서 객체의 그리기 순서가 인스펙터 팔레트와 그리기 순서 슬라이더로 어긋나는 문제를 수정했습니다.
  • FA 뷰에서 아트 메쉬 그리기 순서를 원래 값보다 작게 설정할 수 없는 버그가 수정되었습니다.
  • FA 뷰에서 회전 디포머를 조작할 때 특정 조건 하에서 회전 디포머의 각도가 잘못된 값이 되는 버그가 수정되었습니다.
  • 모델 트랙을 복제할 때 양식 편집 객체의 정렬 순서가 변경되는 문제를 수정했습니다.
  • 타임 라인 팔레트에서 트랙 좌표와 앵커 포인트의 큰 값이 표시되는 버그가 수정되었습니다.
  • 애니메이션 재생시의 연속번호 트랙의 묘화를 개선했습니다.
  • 특정 조건에서 「속성 그룹에서 샤이로 설정한 속성의 작업을 활성화」 설정이 해제되어 있어도
    샤이로 숨겨져 있는 파라미터의 키가 이동해 버리는 버그를 수정했습니다.
  • 타임 라인 팔레트의 트랙에 표시되는 파라미터의 값이 파라미터 결합/해제 시에 올바르게 갱신되지 않는 버그가 수정되었습니다.
  • 타임 라인 팔레트에서 [재생 시작 위치 고정]이 활성화된 상태에서
    「1프레임 앞으로/뒤로」 단축키가 제대로 작동하지 않는 버그가 수정되었습니다.
  • 타임 라인 팔레트에서 「1프레임 앞으로/뒤로」의 조작이 편집 후의 키에 대해 부정한 거동이 되는 버그를 수정하였습니다.
  • 물리 연산 애니메이션 베이크를 실행 중인 진행률 막대의 표시를 개선했습니다. 또한 실행 중에 취소가 가능합니다.
  • 물리 연산 애니메이션 베이크 속도가 향상되었습니다.
  • 새로운 씬을 만들 때 애니메이션의 기본 대상 버전이 「영상」, 「SDK (기타)」로 설정된 경우,
    그래프 에디터의 베지어 조작에 「SDK(Unity)」와 같은 제한이 걸리는 문제를 수정하였습니다.
  • 각종 내보내기 중에 취소를 실시했을 때의 거동이 부정하게 되는 버그를 수정하였습니다.
  • GIF 애니메이션 내보내기에서 Live2D 로고가 첫 프레임에 표시되도록 수정했습니다.

 

Cubism Viewer

《기능 추가》

  • moc3 파일과는 다른 드라이브에 있는 json 파일을 읽을 때 복사할지 확인하는 대화 상자를 표시하도록 변경했습니다.

《개선 항목》

  • moc3 파일과 다른 드라이브에 있는 json 파일을 로드할 때 오류를 표시하도록 수정되었습니다.
  • 통계에 표시되는 총 다각형 수가 Cubism Editor 모델의 통계와 다른 버그가 수정되었습니다.

 

 

4.0.06 (2020/10/22)

Cubism Viewer

《개선 항목》

  • Mac에서 [마우스 쫓기] 기능이 작동하지 않는 문제를 수정했습니다.
  • 마지막 시작 시 창 레이아웃 설정 등이 복원되지 않는 버그가 수정되었습니다.

 

 

4.0.06 beta1 (2020/09/23)

공통

《개선 항목》

  • 파일의 저장이나 동영상 등의 각종 내보낼 때,
    실행 중인 사용자가 쓰기 권한이 없는 폴더를 지정할 때 오류가 발생하는 버그가 수정되었습니다.
  • 특정 조작 시에 마우스 커서가 크게 움직이는 경우가 있는 문제를 수정하였습니다.
  • 특정 상황에서 드래그에 의한 수치 입력의 거동이 부정하게 되는 버그를 수정하였습니다.
  • [Mac 버전] Cubism Editor가 접근성에 대한 액세스를 허용하지 않는 경우 권한을 요청하는 대화 상자를 표시하도록 변경했습니다.

 

모델링

《개선 항목》

  • 모델 파일을 읽을 때 등에 키 폼의 부정한 수치의 불투명도 정보를 로그에 나타내도록 수정했습니다.
  • 확장 보간을 적용한 워프 디포머 변환의 분할 수가 정상시에 거동이 부정하게 되는 버그가 수정되었습니다.
  • 파라미터의 키와 키의 사이를 선택할 때, 회전 디포머의 각도의 값이 「0.0」이라고 표시되어 버리는 버그를 수정했습니다.

 

애니메이션

《기능 추가》

  • 오디오 트랙 수를 무제한으로 배치할 수 있도록 제한을 해제했습니다.

《개선 항목》

  • Windows에서 만든 애니메이션 파일을 Mac에서 열면 소재의 링크가 끊어 버리는 버그가 수정되었습니다.
  • canx 파일을 로드할 때 오류가 발생하여 실패하는 문제를 수정했습니다.
  • 타임 라인 팔레트에서 Live2D 파라미터에 소수점 이하의 값을 설정할 때,
    그래프 편집기에서 키를 조작하여 편집한 경우와 값을 직접 입력하여 편집한 경우에 거동이 다른 버그가 수정되었습니다.
  • 씬을 삭제할 때 씬 팔레트의 선택 상태와 씬의 표시 상태가 부정하게 되는 버그가 수정되었습니다.
  • 씬 팔레트에서 선택하여 씬을 전환할 때 거동이 무거운 버그가 수정되었습니다.
  • 동영상이나 정지화면(연번), 모션 파일을 내보낼 때의 덮어쓰기 확인 대화상자의 표시 횟수를 적절히 수정하였습니다.
  • 무료 버전 편집기의 특정 조건에서 동영상 내보내기가 실패하는 문제를 수정했습니다.
  • 씬에 페이드 값을 설정했을 때, 소수점 이하가 부정한 수치로 모션 파일이 써내 버리는 버그를 수정했습니다.

 

Cubism Viewer

《개선 항목》

  • 표정의 파라미터 편집 및 가산/곱하기 모드의 전환을 할 때, 소수점 이하가 부정한 수치가 되어 버리는 버그를 수정했습니다.
  • 부정한 수치의 불투명도의 파라미터가 있을 때 모델의 표시가 사라져 버리는 버그를 수정했습니다.
  • 잘못된 수치 불투명도의 아트 메쉬를 감지하면 확인 대화 상자를 표시하도록 수정되었습니다.

 

4.0.05 (2020/08/27)

공통

《개선 항목》

  • Windows에서 특정 조건 하에서 설치 시 cmo3·can3이 열리지 않는 버그가 수정되었습니다.
    ※4.0.04 beta1 이후의 버젼으로 당 결함이 발생하고 있는 경우는
    Cubism Editor의 구성 파일을 삭제한 후 다시 설치하여 개선할 수 있습니다.
    도움말 사이트에서 자세한 순서를 안내하고 있으므로, 이쪽의 페이지를 참조해 주세요.
    도움말 사이트 「.cmo3 또는 .can3 파일을 열 수 없음」

  • 로그 팔레트의 복사 버튼에서 복사한 로그에 개행이 많이 포함되어 버리는 버그가 수정되었습니다.
  • 모델 및 애니메이션 파일을 로드할 때 뷰 영역의 표시 배율이 적절하지 않을 수 있는 버그가 수정되었습니다.

 

모델링

《개선 항목》

  • 인스펙터에서 그리기 순서를 숫자 입력으로 변경할 때 파츠 팔레트의 그리기 순서가 업데이트되지 않는 문제를 수정했습니다.

 

4.0.05 beta1 (2020/07/30)

공통

《기능 추가》

  • 뷰 영역의 조작에 다음을 추가했습니다.
     R 키 → 캔버스를 반전
     R 키 + Shift + 드래그 → 캔버스를 그리드로 회전
     R 키/E 키/W 키 + 더블 클릭 → 회전 및 3D 표시 재설정
  • 워프 디포머의 그리드의 색을 변경하는 기능을 추가했습니다.
  • [다음부터 표시 안 함]을 체크한 대화상자를 다시 표시할 수 있음
    [숨김으로 설정한 모든 대화상자 다시 표시] 기능을 추가했습니다.
  • 로그 팔레트에 클리어 등의 기능을 추가했습니다.

《개선 항목》

  • 키보드 단축키 설정 대화상자에서 취소 버튼을 눌러도 편집 내용이 반영되는 문제를 수정하였습니다.
  • 키보드 단축키 설정 대화상자에서 단축키를 삭제해도
    편집기를 다시 시작할 때까지 반영되지 않는 오류를 수정했습니다.
  • 키보드 단축키에 일부 키를 설정할 때 메뉴 바의 표시가 무너지는 버그가 수정되었습니다.
  • 키보드 단축키로 숫자 키패드의 「+」를 등록할 때 작동하지 않는 버그가 수정되었습니다.
  • 프로젝트 팔레트에 포커스한 상태에서 복사, 잘라내기, 붙여넣기 조작을 하면 에러가 나오는 버그가 수정되었습니다.
  • 수치 입력이 조작 불가의 란에 커서를 올리면, 커서가 조작 가능과 같은 외형으로 바뀌어 버리는 버그를 수정했습니다.
  • FA에서 스냅샷 기능을 사용할 때 파라미터가 제대로 반영되지 않는 버그가 수정되었습니다.
  • 뷰 영역의 E 키로 캔버스의 3D 표시시 바로 위와 바로 아래로 향하면 오류가 나오는 버그가 수정되었습니다.
  • 뷰 영역 오른쪽 하단의 힌트가 겹쳐서 표시되는 문제를 수정했습니다.
  • 애니메이션 파일을 가져올 때 소재 교체를 취소하면 오류가 발생하는 버그가 수정되었습니다.
  • 애니메이션 파일을 가져올 때 소재 바꾸기 대화상자를 ✕ 버튼으로 닫으면 오류가 발생하는 버그가 수정되었습니다.
  • 텍스쳐를 가져올 때 Editor 왼쪽 하단의 상태 표시에 로드 중인 텍스쳐 이름을 표시하도록 했습니다.
  • 워프 디포머를 극단적으로 변형시 선택한 정점 이외가 움직여 버리는 버그를 수정하였습니다.
  • 워프 디포머를 접어 변형시,
    베지어의 컨트롤 포인트를 변형시킬 때 분할점 그리드의 거동이 부정하게 되는 버그가 수정되었습니다.
  • 워프 디포머의 불투명도의 수치를 드래그로 입력하면 값이 어긋나는 버그가 수정되었습니다.
  • 오브젝트의 불투명도를 0으로 변경해도 반영되지 않는 문제를 수정했습니다.
  • 어니언 스킨 설정을 변경했을 때 입력값이 정상적으로 적용되지 않는 버그가 수정되었습니다.
  • 어니언 스킨 설정 대화 상자의 항목을 Undo/Redo 할 수 있도록 수정되었습니다.
  • 물리 연산·씬 블렌드 설정에 있어서 진자의 길이가 표시시에 정수로 반올림되는 버그를 수정하였습니다.
  • 파일의 저장이나 동영상 등의 각종 내보낼 때,
    파일 이름에 OS에서 금지된 문자열이 포함되어 있으면 오류가 발생하는 오류를 수정했습니다.
  • 조작을 시각화 기능으로 일부 단축키가 올바르게 표시되지 않는 버그가 수정되었습니다.

모델링

《기능 추가》

  • 물리 연산·씬 블렌드 설정 다이얼로그에 모델의 움직임을 녹화하는 기능을 추가했습니다.
  • 찾아 바꾸기에 [대소문자 구분] 버튼을 추가했습니다.
  • 찾아 바꾸기에 [모두 선택 해제] 버튼을 추가했습니다.
  • 텍스쳐 아틀라스 편집 화면에서 배치된 이미지에 마우스 오버했을 때 명칭을 툴팁 표시하는 기능이 추가되었습니다.
  • 마스크의 아트 메쉬가 삭제됨으로써 클리핑의 아트 메쉬의 인스펙터의 클리핑란이 「null」이 되었을 때,
    경고를 표시하도록 수정되었습니다.
  • 펜탭의 필압으로 브러시 선택 툴과 글루 툴의 가중치를 조정할 수 있도록 수정되었습니다.

《개선 항목》

  • 찾아 바꾸기 대화상자의 [캔버스로 선택] 기능이 가속화되었습니다.
  • 찾아 바꾸기 대화상자에서 바꿀 때 선택 상태가 해제되지 않도록 수정되었습니다.
  • 원화 삭제 후 텍스쳐 아틀라스 편집 대화상자를 열면 오류가 발생하는 버그가 수정되었습니다.
  • 물리 연산 설정이 모델 작업공간에서도 Undo할 수 있도록 수정되었습니다.
  • 파츠 설정 대화 상자의 힌트에서 [여기를 클릭하여 ID 규칙 표시]를 [ID 규칙 표시] 버튼으로 변경했습니다.
  • 모델링 메뉴 → 편집 레벨 표시가 실제 값과 일치하지 않는 문제를 수정했습니다.
  • 「형상 복사」를 실시하지 않고 [형상 붙여넣기] [형상 혼합]을 실시했을 때에, 경고가 표시되도록 수정했습니다. 
    (복사의 거동 자체에는 변경이 없습니다)
  • [형상 복사]를 실시한 대상과는 다른 오브젝트에 대해 [형상 붙여넣기] [형상 혼합]을 실시했을 때,
    경고가 표시되도록 수정되었습니다. (복사의 거동 자체에는 변경이 없습니다)
  • 파라미터 팔레트의 마우스 클릭 거동을 수정했습니다.
  • 파라미터 폴더를 더블 클릭하여 이름을 변경할 때 텍스트 입력란에 포커스되지 않는 버그가 수정되었습니다.
  • 파라미터가 삭제되었을 때, Undo 가능한 형태로 물리 연산의 입력, 출력의 항목이 삭제되게 되었습니다.
  • 메쉬 편집 모드의 취소/완료 버튼의 배치를 OS 기준으로 수정하였습니다. 
    또한 메쉬 편집을 취소 할 때 확인 대화 상자를 표시하도록 수정되었습니다.
  • 메쉬 편집 모드 선택 / 편집 툴로 에지가 생성되는 버그를 수정하였습니다.
  • 메쉬 편집 모드 툴 상세 팔레트의 [바인드] 버튼이 올바르게 표시되도록 수정되었습니다.
  • 변형 경로의 [컨트롤 포인트 제거] 도구로 제어점을 삭제할 때,
    변형 경로 정보가 제대로 삭제되지 않는 오류를 수정했습니다.
  • 툴 상세 컬러 피커 버튼의 배경색에 불투명(체크 무늬)을 표시하도록 수정되었습니다.

애니메이션

《기능 추가》

  • 씬의 설정 항목에 [프레임 수]를 추가했습니다.
    프레임 시작은 [0에서 시작] [1에서 시작]에서 선택할 수 있습니다. (초기값은 [0에서 시작])
  • 타임 라인 팔레트의 작업 영역이 가로로 채워지도록 배율 조정 기능을 추가했습니다.
    애니메이션 메뉴 → 인디케이터 → [작업 영역 전체 보기] 또는 「Shift + F」의 바로 가기 키를 사용합니다.
  • 애니메이션 템플릿을 만들 때 이미 이름이 같은 경우 덮어쓰기 저장을 선택할 수 있습니다.
  • 애니메이션 파일을 열 때 소재가 링크 끊어지지 않도록 수정되었습니다.
    (애니메이션 파일을 저장한 후 소재와의 상대 경로가 변경되지 않은 경우)

《개선 항목》

  • 타임 라인 팔레트에서 파라미터 등의 값을 드래그로 변경하면 Undo가 여러 번 등록되는 버그를 수정했습니다.
  • 타임 라인 팔레트에서 파라미터의 값을 키보드 입력하면 Undo가 두 번 등록되는 버그가 수정되었습니다.
  • 타임 라인 팔레트에서 트랙을 추가할 때 부정한 거동이 발생하는 버그를 수정했습니다.
  • 타임 라인 팔레트에서 아래에 연결할 상대가 없는 파라미터를 연결하려고 할 때 에러가 나오는 버그가 수정되었습니다.
  • 타임 라인 팔레트에서 고부하 시 키를 이동하면 키가 늘어날 수 있는 버그가 수정되었습니다.
  • 트랙 표시/숨기기를 전환하는 조작을 Undo할 수 있도록 수정되었습니다.
  • 씬의 프레임 속도를 낮은 값으로 설정할 때 발생하는 표시 및 거동의 버그가 수정되었습니다.
  • 씬 전환 시 뷰 영역의 시점이 적절하지 않은 버그가 수정되었습니다.
  • 씬의 길이가 실제보다 1 적게 표시되는 버그가 수정되었습니다.
  • 씬의 시작 위치를 100 이상으로 설정할 수 있도록 수정되었습니다.
  • 긴 씬의 위치 등 조작 시에 에러가 나오는 버그를 수정하였습니다.
  • 긴 씬의 타임라인의 확대축소 표시를 Alt+마우스 휠로 실시하면 에러가 나오는 버그가 수정되었습니다.
  • 새로 만든 애니메이션 파일을 선택할 때
    에디터의 타이틀 바에 실제와 다른 파일명이 표시되는 버그가 수정되었습니다.
  • 저장, 가져오기 시 대화상자의 이름이 적절하지 않을 수 있는 버그가 수정되었습니다.
  • 애니메이션 파일을 가져올 때 타겟 버전 선택 대화상자에서,
    OK를 누르지 않고 닫았을 경우에는 파일을 열지 않고 처리를 종료하도록 수정되었습니다.
  • [Mac 버전] 애니메이션 템플릿이 이름순으로 정렬되지 않는 버그가 수정되었습니다.
  • 씬의 시작 위치를 0 이외로 설정할 때 스틸 이미지 (연속) 내보내기 완료 시 내보내기 대상 디렉토리가 열리지 않는 버그가 수정되었습니다.
  • 오디오 파일의 트랙을 복제할 때 트랙 길이가 초기값으로 돌아가는 문제를 수정했습니다.
  • 음성으로 동영상을 내보낼 때 내보내기 범위 내에 링크가 끊긴 음성 트랙이 포함된 경우,
    링크가 끊긴 음성 트랙이 있다는 대화상자를 표시하여 동영상 내보내기 처리를 취소하도록 수정되었습니다.
  • 음성으로 동영상을 내보낼 때 여러 음성 트랙이 있을 때 정상적으로 음성이 출력되지 않는 문제를 수정했습니다.
  • 동영상 내보내기에서 압축되지 않은 경우 해상도를 확인하지 않도록 수정했습니다.
  • 동영상 내보내기(MOV) 시 비디오 코덱을 QuickTimeRLE로 변경했습니다.
  • 동영상 내보내기(MP4)에서 YUV 변환 시의 색 공간을 지정할 수 있도록 수정되었습니다.
  • 동영상 내보내기(MP4)에서 비트레이트를 지정할 수 있도록 수정되었습니다.
  • 무료 버전의 동영상 내보내기에서 Live2D 로고를 숨길 수 있도록 수정되었습니다.

Cubism Viewer

《기능 추가》

  • 표정이나 모션의 페이드 시간을 일괄 변환하는 기능을 추가했습니다.

《개선 항목》

  • 표정이나 모션을 전환할 때, 파라미터의 값이 같은 파츠가 일부 움직여 버리는 일이 있는 불편을 수정했습니다.

 

 

4.0.04 (2020/07/30)

공통

《개선 항목》

  • 특정 macOS 환경에서 초기 평가판 시작에도 불구하고 만료되는 버그를 수정했습니다.
    이 문제로 어려움을 겪고 있다면이 버전으로 업데이트하여 평가판을 시작하십시오.

모델링

《기능 추가》

  • AE 플러그인을 위해 파라미터 결합 상태를 .cdi3.json에 저장하는 기능에 문제가 수정되었습니다.
    Editor 상단 메뉴 [파일] > [내장 파일 내보내기] > [moc3파일 내보내기]
    에서 「표시 보조 파일(cdi3.json) 내보내기」에 체크를 하면 내보내집니다.

 

 

4.0.04 beta1 (2020/07/09)

공통

《개선 항목》

  • FA 편집이 적용되지 않을 수 있는 버그가 수정되었습니다.
  • 파라미터 팔레트에서 폴더와 파라미터를 선택한 상태에서 다른 폴더로 드래그 앤 드롭하면
    폴더 안에 폴더가 들어가는 버그가 수정되었습니다.
  • [Mac] 「CECubismApp 종료」를 선택하거나 Cmd+Q를 눌러 Editor를 종료 할 때,
    저장되지 않은 문서가 있으면 확인 대화 상자를 표시하도록 수정되었습니다.

모델링

《기능 추가》

  • 파라미터 팔레트에서 Shift+왼쪽 클릭으로 다중 선택이 가능합니다.

《개선 항목》

  • 파라미터 팔레트에서 폴더와 그 자식 요소의 파라미터를 동시 선택 상태로
    휴지통 아이콘에서 삭제하려고 할 때 오류가 발생하는 문제를 수정했습니다.
  • 매개변수 팔레트의 키 색상이 잘못된 표시가 될 수 있는 버그가 수정되었습니다.
  • 그리기 순서 그룹을 설정한 파츠를 선택해, 파라미터의 슬라이더상의 키 폼이 없는 장소를 선택하고 있는 상태일 때,
    파츠 그리기 순서 슬라이더의 표시 색상이 회색으로 변경되지 않는 버그가 수정되었습니다.
  • 아트패스 툴로 아트패스를 편집할 때 표시되는 마우스 커서 아이콘 표시가 수정되었습니다.
  • 아트패스의 컨트롤 포인트를 결합했을 때 제대로 결합되지 않는 문제를 수정했습니다.
  • 아트패스 브러쉬 전환 직후에 캔버스 표시가 무너져 버리는 버그가 수정되었습니다.
  • 부정치가 들어간 오브젝트 선택시에 캔버스의 표시가 사라져 버리는 버그가 수정되었습니다.
  • 일부 버튼을 클릭해도 팝업이 표시되지 않는 문제를 수정했습니다.
  • 색상 코드 입력 상자에서 아무것도 입력하지 않고 엔터를 누르면 오류가 발생하는 문제를 수정했습니다.
  • 모양의 블렌드 설정 대화 상자가 아무것도 선택하지 않은 상태에서 열리는 문제를 수정했습니다.
  • 물리 연산 그룹의 리스트 표시, 처리 순서의 바꿀 수 있도록 수정되었습니다.
  • 물리 연산·씬 블렌드 설정에서 파라미터의 이름이 툴팁에 표시되도록 수정되었습니다.
  • 신규 작성된 모델로 물리 연산·씬 블렌드 설정에서의 커서 추종으로,
    추종 파라미터의 초기화에 실패하던 버그가 수정되었습니다.
  • 물리 연산·씬 블렌드 설정으로 커서 추종의 설정을 열 때 초기 상태로 돌아가 버리는 경우가 있는 문제를 수정하였습니다.
  • 물리 연산·씬 블렌드 설정으로 진자 표시 부분의 마우스 휠 조작이 뷰 등의 조작과 반대가 되는 문제를 수정하였습니다.
  • moc3 내보내기 대화 상자의 UI를 개선했습니다.
  • 내보내기 유형이 nizima 인 경우 텍스쳐 폴더의 이름을 「textures」로 변경했습니다.

애니메이션

《기능 추가》

  • 애니메이션 미리보기 설정 대화 상자에 「양식 편집 대상을 앞면에 표시」를 추가했습니다.
    온(기본값)일 때는 폼 편집의 대상 오브젝트를 가장 앞에 그려,
    끄면 애니메이션 뷰에서 그리기 순서와 마찬가지로 그립니다.
  • 애니메이션 재생시의 부하를 경감하는 「경량 재생」 모드를 추가했습니다.

《개선 항목》

  • 타임라인상에서 마우스 드래그에 의한 범위 선택시, 선택 범위를 나타내는 구형이 올바르게 표시되지 않는 버그를 수정했습니다.
  • 타임라인의 Enter 키로 재생 정지에 시간차가 발생하는 버그가 수정되었습니다.
  • FA 뷰에서 애니메이션 단축키를 사용할 수 있도록 수정되었습니다.
  • 재생 속도를 변경하고 애니메이션을 재생할 때 음성 트랙의 재생 속도도 연동하여 바뀌도록 수정되었습니다.

Cubism Viewer

《개선 항목》

  • .model3.json 파일의 Expressions의 Name에 파일명 이외도 지정할 수 있도록 수정되었습니다.
    (반각 영숫자 기호 이외도 가능)

Cubism AE 플러그인

《기능 추가》

  • 파라미터 팔레트의 파라미터 결합 정보를 cdi3.json에 내보내는 기능을 구현했습니다.

 

 

4.0.03 (2019/12/12)

공통

《개선 항목》

  • Editor 시작시 [Live2D에서 알림] 대화 상자가 표시됩니다.

모델링

《개선 항목》

  • 메쉬 편집 모드에서 표시 모드를 변경할 때 메쉬 상태가 업데이트되지 않는 문제를 수정했습니다.
  • 물리 연산 설정 다이얼로그에서 영향도를 낮춘 설정으로 시선의 추종을 하지 않는 상태일 때 올바르게 계산되지 않는 버그를 수정하였습니다.
  • 물리 연산 설정 다이얼로그에서 물리 연산이 설정되어 있는 파라미터를 조작하면 표시가 깜박거리는 버그를 수정하였습니다.
  • 통계에 클리핑 마스크에 대한 정보를 추가했습니다.
  • 마스크의 형상수가 일정수를 초과하는 moc3 출력을 실시하는 경우, 경고 다이얼로그가 표시되도록 수정했습니다.
  • 곡면 디포머 작성 다이얼로그에서 삽입처의 파츠를 변경했을 때의 디폴트 명칭을 [〇〇의 워프]에서 [〇〇의 곡면]으로 변경하였습니다.
  • 움직임 반전 다이얼로그의 설정 상태에 대해 OK 버튼을 누르지 않은 경우도 저장되도록 수정하였습니다.
  • 움직임 반전 다이얼로그를 디포머만 선택 상태로 열 때에,
    축 설정이 부정한 선택으로 되어 OK를 누르지 못하는 문제를 수정하였습니다.
  • 눈 깜빡임・립싱크 설정 다이얼로그의 파라미터 폴더 내의 파라미터가 이중으로 표시되는 버그가 수정되었습니다.
  • 아트 패스의 모든 컨트롤 포인트를 지우면 빈 아트 패스가 남을 수 있는 버그가 수정되었습니다.
  • 아트 패스 관계의 GUI를 개선했습니다.
    ・상세 팔레트, 브러쉬 설정 다이얼로그 내에 각 기능에 액세스하기 쉽게 버튼을 배치
  • 아트 패스의 선폭 취득 설정의 [선만의 텍스쳐]의 초기치를 아래와 같이 변경했습니다.
    ・선으로 간주하는 최대치가 5px
    ・투명으로 간주하는 최소값이 0%
  • 아트패스 툴의 단축키에 대응했습니다.

애니메이션

《개선 항목》

  • 애니메이션 뷰에서 연속 이미지 트랙을 선택할 수 있도록 수정되었습니다.
  • 타임라인에서 속성 그룹을 클릭했을 때 속성 그룹이 선택 상태가 되도록 변경했습니다.
  • 타임라인에서 새 그룹 만들기 버튼을 연속으로 클릭할 때 여러 대화 상자가 표시되는 버그가 수정되었습니다.
  • 타임라인 내에서 트랙 및 속성 그룹의 개폐 마크, 씬을 전환하거나 업데이트할 때,
    트랙이 열려 있어도 닫힌 상태의 마크가 되어 버리는 버그가 수정되었습니다.
  • 타임라인 내에서 키 선택 시의 거동이 부정하게 되는 버그를 수정하였습니다.
  • 타임라인 내에서 그룹을 복제하면 내부 속성이 두배로 되는 문제를 수정했습니다.
  • 타임라인 내에서 키프레임 추가, 삭제 시 커서 표시의 버그가 수정되었습니다.
  • 타임라인에서 선택 범위 내에서 키를 이동할 때,
    커서 아이콘이 변경되는 범위와 실제로 키를 선택할 수 있는 범위가 다른 버그가 수정되었습니다.
  • 잠긴 트랙을 그래프 편집기에서 편집할 수 있는 버그가 수정되었습니다.
  • GIF 애니메이션 내보내기 및 스틸 이미지 (연속) 내보내기의 기본 파일 이름이 씬 이름과 일치하도록 수정되었습니다.
  • 스틸 이미지 (연속) 내보내기의 [선택 중인 1프레임 내보내기]로 저장하는 파일명을 임의로 변경했을 때,
    입력한 파일명대로 저장하도록 수정되었습니다.
  • 스틸 이미지 (연속) 내보내기의 [작업 영역 출력]을 실행했을 때,
    씬 전체의 프레임수가 4자리인 경우는, 보존하는 파일명에 부여하는 연속번호도 4자리수로 하도록 수정했습니다.
  • 동명 트랙을 모션파일 내보내기로 내보낼 때 모두 같은 모션 데이터가 되어 버리는 버그가 수정되었습니다.
  • 파라미터의 결합·결합 해제시에, 파라미터의 표시가 부정하게 되는 불편을 수정했습니다.
  • Ctrl+클릭으로 트랙이나 파라미터 폴더 등에 일괄 키를 치거나 삭제를 시도했을 때,
    실행되지 않고 트랙이 열리고 닫히는 버그가 수정되었습니다.
  • 애니메이션 뷰 파츠의 표시 상태가 모델링 뷰의 파츠의 표시 상태와 동기화되도록 수정되었습니다.
  • FA 편집에서 폼 편집 속성의 키 프레임에서 [키 프레임을 선택한 행에 붙여넣기]를 실행할 때
    일반 파라미터에 붙여 넣을 수있는 버그가 수정되었습니다.
  • FA 편집에서 키프레임을 생성했을 때 삭제한 키폼이 복원되어 버리는 버그를 수정하였습니다.
  • FA 편집에서 조정 모드 1 · 2에서 각각 양식 편집을 수행하면,
    조정 모드 2에서 바운딩 박스의 표시 위치가 어긋나는 버그가 수정되었습니다.
  • FA 편집에서 변형 패스를 조작했을 때에 형상이 리셋되어 버리는 버그를 수정하였습니다.
  • 물리 연산 애니메이션 베이크를 영향도를 낮춘 설정으로 실시했을 경우, 물리 연산 설정 에디터와의 거동과 다른 문제를 수정하였습니다.
  • 단축키의 버그가 수정되었습니다.

Cubism Viewer

《개선 항목》

  • model3.json으로 지정된 cdi3.json의 파일 경로를 찾을 수 없을 때 모델이 제대로 열리지 않는 오류를 수정했습니다.

 

 

4.0.02 (2019/10/15)

공통

《개선 항목》

  • macOS 10.15 Catalina에서 에디터를 설치하지 못하는 버그가 수정되었습니다.

애니메이션

《개선 항목》

  • macOS 10.15 Catalina에서 동영상을 내보낼 수 없는 버그가 수정되었습니다.

 

4.0.01 (2019/10/03)

모델링

《개선 항목》

  • 선택 화살표 툴·올가미 선택 툴에 의한 처리에 관한 Undo/Redo의 버그가 수정되었습니다.
  • 매개 변수를 좁힐 때 키가 강조 표시되지 않는 문제를 수정했습니다.
  • 각종 다이얼로그내의 테이블의 폭을 드래그로 조정할 때의 거동을 통일했습니다.
  • 파츠 팔레트에서 필터를 입력되지 않은 상태로 활성화하면,
    빈 폴더가 숨겨지는 문제를 수정했습니다.
  • 디포머 불투명도가 인스펙터에 반영되지 않는 버그가 수정되었습니다.
  • 디포머 팔레트에서 디포머를 선택한 상태에서 [모두 펼치기]를 실행하면,
    선택 상태가 업데이트되지 않는 버그가 수정되었습니다.
  • 아트 패스의 선폭・불투명도의 브러시 조정의 초기치를 조정했습니다.
  • 아트패스 브러쉬 설정을 내보낼 때 파일 이름의 기본값을 브러쉬 이름으로 변경했습니다.
  • 아트패스 툴을 사용할 때 Ctrl을 누르면 화살표 툴이 되는 기능에 대응했습니다.
  • 아트패스의 컨트롤 포인트를 삭제했을 때, 인스펙터 팔레트의 표시가 사라져 버리는 버그가 수정되었습니다.
  • 마우스의 직사각형 선택으로 숨겨진 아트패스를 선택할 수 있는 버그가 수정되었습니다.
  • 아트패스 툴 상세의 기본 브러쉬 UI에서 브러쉬 설정 대화 상자가 열리도록 버튼을 추가했습니다.
  • 아트패스 자동 생성 대화 상자의 기본 표시 위치를 편집기의 중심으로 변경했습니다.
  • 아트패스 브러쉬 설정 대화상자를 ✕ 버튼으로 닫을 때 인스펙터가 업데이트되도록 처리가 수정되었습니다.
  • 아트패스를 연결할 때 ✕ 버튼을 눌러도 실행되는 버그가 수정되었습니다.
  • 아트패스의 컨트롤 포인트 GUI가 보이기 어려워질 수 있는 버그가 수정되었습니다.
  • 아트패스를 선택할 때 하이라이트 표시를 개선했습니다.
  • 네 모서리 자동 생성 시 값을 올바르게 설정하지 못하는 문제를 수정했습니다.
    네 모서리 자동 생성 시 인스펙터 표시가 사라지는 버그를 수정했습니다.

애니메이션

《개선 항목》

  • 프로젝트 팔레트의 데이터 교체 기능으로 연속 번호 이미지 폴더를 바꿀 수 없는 버그가 수정되었습니다.
  • FA 모드에서 Ctrl+드래그로 디포머의 구조가 변경되지 않도록 기능을 제한했습니다.
  • FREE판에서 프레임 스텝을 사용하지 않아도
    「임의의 프레임 스텝은 PRO판의 기능입니다」 다이얼로그가 표시되어 각 수치를 변경할 수 없는 버그를 수정했습니다.

 

4.0.00 (2019/9/4)

공통

《기능 추가》

  • 폼 애니메이션 작업 공간을 추가했습니다.
  • 어니언스킨(beta) 기능을 구현했습니다.
    키프레임이나 키 폼의 전후의 상태가 반투명으로 표시되어 움직임의 천이를 확인할 수 있습니다.
  • Live2D 공식 Live2D 모델 & 일러스트 소재 시장 「nizima (니지마)」 링크 버튼을
    에디터 오른쪽 상단에 설치했습니다. (일본어판만)

《Cubism4에서 폐지된 기능》

  • Cubism4 릴리스에 따라 아래 2.1 형식 데이터의 내보내기 기능을 폐지했습니다.
     ・메뉴의 「파일」→[2.1용 모델 데이터(cmox)로 저장]
     ・메뉴의 [파일]→[내장용 파일 내보내기]→[moc 파일 내보내기(2.1용)]
     ・메뉴의 「파일」→[내장용 파일 내보내기]→
      [모션파일 내보내기]에서 열리는 대화 상자의 항목 [2.1 형식(mtn)으로 내보내기]

《Cubism3에서의 변경점》

  • 팔레트 배치 및 바로 가기와 같은 편집기 설정은 Cubism4 및 Cubism3에서 별도로 저장됩니다.
    Cubism4를 처음 시작할 때 Cubism3 설정이 자동으로 인계됩니다.

모델링

《기능 추가》

  • 마스크의 반전 기능을 구현했습니다.
    기존의 클리핑 마스크를 그릴 때 반전하여 적용할 수 있습니다.
    이것에 의해 마스크로 숨기는 등의 표현이 가능하게 되었습니다.
  • 확장 보간 기능을 구현했습니다.
    키폼 사이를 곡선으로 보간함으로써 회전 등으로 자연스러운 표현이 가능하게 되었습니다.
  • 아트 패스 기능을 구현했습니다.
    모델에 배치한 컨트롤 포인트와 설정한 브러시 정보를 바탕으로 선을 그릴 수 있는 영상 용도의 기능입니다.
    원화의 선의 질감이나 표현을 살린 채로, 보다 직감적인 선의 조작・표현이 가능하게 되었습니다.
  • Cubism Viewer가 cdi3.json을 지원했습니다.
    모델을 내보낼 때 cdi3.json을 내보내기로 체크하고 내보낸 모델은
    Cubism Viewer에서 파라미터 이름, 파츠 이름이 표시됩니다.

《개선 항목》

  • [눈 깜빡임・립싱크 설정] 대화 상자의 항목 순서가
    파라미터 팔레트의 항목 순서와 동기화되지 않는 버그가 수정되었습니다.
  • 브러시 선택 툴 및 글루 툴의 브러시 크기가 툴 상세 팔레트의 값에서 예상되는 크기에 대해 반경비 2배(면적비 4배)의 크기가 되는 버그를 수정했습니다.
    툴 상세 팔레트의 값에서 예상되는 크기에 대해 반경비 2배(면적비 4배)의 크기가 되는 버그를 수정하였습니다.
  • 메쉬 편집 모드에서 화살표 키로 정점을 이동할 수 없는 버그가 수정되었습니다.
  • 물리 연산 설정을 내보낼 때 ID가 중복되는 버그가 수정되었습니다.
  • 물리 연산·씬 블렌드 설정의 표시 확대시에 표시 품질의 저하를 경감했습니다.
  • 여러 개를 선택할 때 값이 다른 워프 디포머 변환의 분할 수, 베지어의 분할 수, 아트 메쉬 그리기 순서,
    클리핑, 사용자 데이터에 대한 의도하지 않은 편집을 감지하면 확인 대화 상자를 표시하도록 수정되었습니다.
  • 배경색 스포이드 도구의 커서 표시 위치가 어긋나는 버그가 수정되었습니다.
  • 특정 조작을 수행할 때 화살표 툴로 조작할 수 없는 변형 경로가 생성되는 버그가 수정되었습니다.
  • 타겟 버전 선택 대화상자를 통해 [디포머 변환(3.2방식)]이 업데이트되었을 때
    인스펙터 팔레트의 표시가 갱신되지 않는 버그가 수정되었습니다.
  • 인스펙터 팔레트상에서 [디포머 변환(3.2방식)]의 Undo/Redo를 할 수 없는 버그를 수정하였습니다.
  • 프로젝트 팔레트에서 다른 원화로 레이어를 이동시킬 때 미사용으로 인식되는 버그가 수정되었습니다.

애니메이션

《기능 추가》

  • 애니메이션의 용도에 따라 타겟 버전 설정을 추가했습니다.
    씬을 새로 만들 때 기본 대상 버전을 설정할 수 있습니다.
    프로젝트 팔레트의 [애니메이션 데이터]를 클릭 → 인스펙터 팔레트의 [타겟 버전 설정]에서
    재설정도 가능합니다.
  • 연속 번호 이미지 트랙 기능을 구현했습니다.
    일련 번호로 내보낸 이미지를 전용 트랙에 일괄 배치할 수 있습니다.
    배치된 연속 이미지는 타임 리맵 기능을 사용하여 그래프 편집기에서 표시 타이밍을 조정할 수 있습니다.
  • 프레임 스텝 기능을 구현했습니다.
    리미티드 애니메이션처럼 끊어진 움직임을 재현하는 것이 가능합니다.
  • 폼 애니메이션 기능(영상 용도)을 구현했습니다.
    파라미터를 편집하지 않고 Animator 타임라인에서 모델 데이터의 형상을 직접 편집할 수 있는 영상 제작에 편리한 기능입니다.

《개선 항목》

  • 연속 번호 이미지/동영상을 출력으로 「모두 출력」하면 1프레임 부족하는 버그를 수정하였습니다.

Cubism Viewer

  • [보기] 메뉴의 [밉맵 사용]이 제대로 작동하지 않는 문제를 수정했습니다.
  • 마스크의 반전 기능에 대응했습니다.

 

 

Cubism 3 시리즈 업데이트 내역

Cubism 3 시리즈의 업데이트 내역은 여기

© 2010 - 2022 Live2D Inc.