关于Cubism Viewer(for OW)

最終更新: 2023年4月24日

此页面适用于Cubism 4.2及更早版本的旧版本。 点击此处查看最新页面

Cubism Viewer(for OW)是一个仅用于验证Cubism创建的数据的Viewer。
除了显示模型外,您还可以检查物理模拟、视线跟踪、多个动态的播放等。

类似于Cubism 2.1的操作模式称为“原始工作流程(Original Workflow)”。
在Cubism Viewer(for OW)中,可以对使用Cubism 2.1中使用的参数渐变的手臂等,
进行姿势切换、表情创建。
这允许您以类似于Cubism 2.1的形式使用表情设置、姿势设置、动态列表等。

Cubism Viewer可以处理的模型和动态是输出用于嵌入的数据。
请注意,无法处理用于编辑的.cmo3和.can3。

关于Cubism Viewer(for OW)的画面

编号 项目 细节
① 菜单区 显示用于导入模型、操作参数、播放动态等的菜单。
从顶部的下拉列表中选择要显示的菜单。
② 资源区 在这里显示导入的数据和在Cubism Viewer上创建的数据。
③ 设置项目区 您可以变更和检查与表情设置文件和动态文件相关的设置。
设置内容可以保存在模型设置文件中。
[文件]菜单 → [输出] → [模型设置(model3.json)]
④ 模型显示区 此处显示导入的模型。您可以移动和缩放模型。
通过[显示]菜单设置,可以变更背景颜色,透过背景显示模型,显示重叠检测。
* 无法在macOS版本中设置背景颜色的Alpha值(透明度)。

如何开启Cubism Viewer(for OW)

Cubism Viewer(for OW)包含在Cubism Editor安装程序中。
展开后与执行文件置入同一层次,所以从下图中的红框开启。

开启后,通过将.moc3或.model3.json文件放入导入用对话框启动Viewer。

您可以从 [文件]菜单 → [语言]切换显示的语言。 

编号 项目 细节
① 语言切换 您可以从[日文]、[英文]、[韩文]和[中文]中进行选择。
② ·返回安装时的语言(Windows版) 切换到安装时选择的语言。
返回OS的系统语言(macOS版) 它将参考OS的语言。

以下是设置语言时的规范。

·设置后重启Editor后将切换语言。
·语言设置在相同次要版本(4.2系列等)的Editor中共享。
·从Editor的[设置]菜单执行的语言切换优先于安装时的设置和OS的设置。

如何创建基本的嵌入数据

Cubism2.1 Viewer ( for OW )* 常规Viewer   Cubism Viewer(for OW)

从Modeler执行moc文件输出

【要输出的文件】
·纹理文件(.png)
·Moc文件(.moc)
·模型文件(.model.json)

 

从Modeler执行moc3文件输出

【要输出的文件】
·纹理文件(.png)
·moc3文件(.moc3)
·模型文件(.model3.json)
* 包括物理模拟设置(.physics3.json)的链接

 

从Animator“输出动态数据”

【要输出的文件】
·动态文件(.mtn)

 

从Animator“输出动态文件”

【要输出的文件】
·动态文件(.motion3.json)

 
将以下文件导入到Viewer中
·Moc文件(.moc)
·输出的动态(.mtn)文件
  将以下文件导入到Viewer中
·moc3文件(.moc3) * .model3.json亦可

⇒ 导入文件并启动Viewer

·输出的动态(.motion3.json)文件

 
在Viewer中进行设置
·姿势设置(.pose.json)
·物理模拟设置(.physics.json)
·表情设置(.exp.json)
  在Viewer中进行设置
·姿势设置(.pose3.json)
·表情设置(.exp3.json)

【注意事项】
⇒ 在Viewer上设置的文件名称的右上角添加了一个星号。

 
输出模型设置文件
·模型设置文件 (.model.json)
  输出模型设置文件
·模型设置文件 (.model3.json)

【注意事项】
⇒ 输出时,如果从Cubism Editor覆盖输出的(.model3.json),则Viewer创建的文件(带星号)将一起保存。

TIPS

在Cubism 3或更高版本中,物理模拟设置(physics3.json)是在CubismEditor端完成的,因此在Viewer的树中只显示名称。

菜单

文件菜单

项目细节
追加表情:
追加表情用动态。
在设置项目区域选中您要设置表情的参数,然后调整参数。

姿势:
创建一个json格式的设置文件,以应用模型或动态创建的手臂切换机制。
具体操作方法请参考“姿势设置”页面。
导入表情动态(motion3.json/exp3.json):
将动画过程中输出的表情用[motion3.json]导入到Cubism Viewer中。
输出模型设置(model3.json):
将Cubism Viewer中设置的内容输出为json格式文件。快捷键[Ctrl] + [S]

所有表情动态:
将所有表情用动态输出为json格式文件。
有关详细说明,请参考“设置和输出表情”页面。

姿势:
将姿势切换设置输出为json格式的设置文件。
有关详细说明,请参考“姿势设置”页面。
设置在默认表情名称中包含文件扩展名:
追加表情时,请在默认表情名称中包含文件扩展名。

编辑菜单

项目细节
将参数恢复为默认值 将参数恢复为默认值。
停止动态 停止正在播放的动态。
差异比较 您可以在Viewer上比较和查看两个moc3数据的信息。
有关详细信息,请参考“两个moc3数据信息的比较”。

显示菜单

项目细节
重叠检测显示 显示设置的重叠检测。
启用Mipmap 启用Mipmap。
* 基本上,建议勾选此项。
透明背景(beta) 通过透明背景显示模型。
* 此功能无法在macOS版本中使用。
背景颜色设置 设置背景颜色。
* 无法在macOS版本中设置Alpha值(透明度)。
帧率显示 帧率显示在模型显示区域的右上方。

动画菜单

项目细节
启用表情 启用表情动态播放。
自动眨眼 使其自动眨眼。
启用物理模拟 启用物理模拟设置。
启用姿势切换 启用姿势切换。
闲置动态 启用闲置动态。
光标跟踪 在模型显示区域启用光标跟踪。
呼吸 启用呼吸。
使用旧动态播放方式启用旧动态播放方法。 
选中模型显示区右下角的[使用旧动态播放方式]。
有关详细说明,请参考“关于motion3.json的再现性变差的情况”页面。
光标跟踪设置打开光标后续设置对话框。

关于Cubism Viewer(for OW)的功能

光标跟踪设置

勾选[动画]菜单 → [光标跟随],并在视图上拖动以跟随鼠标光标移动模型。
您还可以从[动画]菜单 → [光标跟踪设置]设置您想要跟踪的参数,您也可以在实机上进行模拟。

影响度(%):
通过设置影响度,可以影响参数的动作。
如果您设置为更强,则动作会更大,如果您设置为更弱,则动作会更小。

反转:光标跟踪反转。

类型:
设置您希望光标跟踪的参数类型。
·鼠标左键拖动时
(鼠标左X:水平移动 鼠标左Y:垂直移动)

·鼠标右键拖动时
(鼠标右X:水平移动 鼠标左Y:垂直移动)

光标后续设置保存在模型数据(cmo3)中,但不输出到嵌入数据。
如果您希望在嵌入时光标跟踪,请在SDK端进行设置。

* 您还可以在[物理模拟/场景混合设置]中检查光标跟踪设置。

曲线 曲线图片确认

选择motion3.json,右键单击“通过图片确认动态变化”,通过图片确认曲线曲线。

绘制顺序和多边形数量(图形网格)信息的列表

您可以检查诸如图形网格的绘制顺序和多边形数量等信息。
单击树上的moc3文件 → 从下拉菜单中选择“图形网格”

选择的图形网格将在视图上闪烁蓝色。

显示动态曲线类型

[OW Viewer]中的动态检查器现在显示从动态中包含的信息推断出的目标版本。

如果您在目标版本中使用“SDK(其他)”,请咨询开发人员并考虑是否勾选。
详情请参考SDK手册“关于motion3.json的再现性变差的情况”。

检查器上的符号如下。

使用旧动态播放方式

在4.1之前的Cubism Viewer(for OW)中,任何动态文件均以与Cubism Editor中动画的相同曲线再现。
在从4.1alpha1到alpha3的Cubism Viewer(for OW)中,动态会以SDK播放的曲线再现。
此外,在4.1 alpha4或更高版本的Cubism Viewer(for OW)中,您可以通过选中“使用旧动态播放方式”来控制曲线的再现状态。

勾选“使用旧动态播放方式”时,将播放贝塞尔曲线的形状固定在1/3和2/3的贝塞尔曲线动态。

如果您使用的是目标版本的SDK(其他),请咨询开发人员考虑是否勾选。
有关详细信息,请参考[Cubism SDK 手册]中的“关于motion3.json的再现性变差的情况”页面。

波形比较

关于使用曲线曲线的确认功能由[SDK(其他)]输出的动态,通过不支持的SDK播放的曲线曲线显示为浅蓝色。

两个moc3数据信息的比较

您可以在Viewer上比较和查看两个moc3数据信息。

确认方法如下。

  1. 将要比较的两个数据拖放到Viewer中
  2. [编辑]菜单 → [差异比较]
  3. 将显示一个确认对话框

① 文件信息

显示要比较的文件名称、文件创建日期/时间和文件位置。

② 类别及详细项目

画布:

显示画布比较信息。

部件:

显示部件的比较信息。

参数:

比较并显示各ID的 Min、Default和Max值。

图形网格:

对各ID比较并显示以下项目的信息。

1. 混合模式
2. 剔除
3. 纹理编号
4. 绘制顺序
5. 图形网格的绘制顺序
6. 蒙版
7. 顶点数
8. 多边形数量

关于Cubism2.1 Viewer(for OW)起的变更点

在Cubism 2.1和3或更高版本中的变更如下。

动态设置

  变更内容 Cubism2.1 Viewer(for OW) Cubism Viewer(for OW) 
1 动态文件名 .mtn .motion3.json
2 变更文件中的描述(一般)   所有键元素都变更为首字母大写
“type” → “Type”等。
3 组名

 idle

自动判断,并在组内标记为“idle”

 Idle

【注意事项】
您需要单击组名右侧的“Idle”按钮来设置闲置设置。

(组名首字母大写)

4 自动眨眼动态 set mult

姿势设置

  变更内容 Cubism2.1 Viewer(for OW) Cubism Viewer(for OW)
1 姿势文件名 .pose.json .pose3.json
2 变更文件中的描述(一般)   所有键元素都变更为首字母大写
“type” → “Type”等。
3 结构

‘parts_visible’

结构变更示例:
‘parts_visible’: [{‘group’: [组设置]}, {‘group’: [组设置]}]

‘Groups’

结构变更示例:
‘Groups’ : [[组设置]、[组设置]]

表情设置

  变更内容 Cubism2.1 Viewer(for OW) Cubism Viewer(for OW)
1 表情文件名称 .exp.json .exp3.json
* 默认表情名称不包括文件扩展名(*1)
(例)文件名称:abc.exp3.json → 默认表情名称:abc
2 变更文件中的描述(一般)   所有键元素都变更为首字母大写
“type” → “Type”等。
3 变更文件中的描述 fade_in /out FadeIn , FadeOut
4 变更文件中的描述 ‘params’ ‘Parameters’
5 变更文件中的描述 ‘calc’
‘add’
‘mult’
在“set”2.1中省略Add
‘Blend’
‘Add’
‘Multiply’
在“Overwrite”3.x中不省略
5 变更文件中的描述

‘val’

2.1有一个表示表情的值(如果睁开眼睛,则1.2等)

‘Value’

在3.x中,变更为具有要加算/正片叠底的值(如果睁开眼睛,则+0.2)

*1 即使通过以之前规格输出的moc3/model3.json被变更后的OWViewer导入,已设置的表情的表情名称也不会发生变化。
导入新表情动态时将应用上述变更后的规格。
也可以通过勾选[文件]菜单 → [设置] → [将文件扩展名添加到默认表情名称]来使用以前的规格操作Viewer。
此设置保存为Viewer设置。

模型文件

  变更内容 2.1Viewer Viewer(Original Workflow)
1 模型文件的文件名称 .model.json .model3.json
2 变更文件中的描述(一般)   所有键元素都变更为首字母大写
“type” → “Type”等。
3 重叠检测 ID命名规则:
D_REF.
ID命名规则:
追加了HitAreaHitArea项目:
暂时不会从Editor中输出,而是在Viewer中搜索“HitArea **”,显示在列表中,并设置名称。(从Viewer输出model3.json)

眨眼和口形同步动态刻录

输出动态时,可以将使用“眨眼”和“口形同步”设置的动态刻录(烘焙)到Live2D参数中。
由于“倍率”和“效果”的数据没有输出到motion3.json,因此可以利用该功能在Viewer上完全再现动画的动态。

但是,如果需要进行调整,则需要再次输出motion3.json,所以需要注意。
* 使用OW Viewer时,我们建议使用眨眼和口形同步的动态刻录功能。


动态数据设置时,勾选“燃烧口形同步并眨眼动作”。
如何刻录运动:

如果启用此项目,“口形同步”和“眨眼”将不会单独输出到motion3.json,因此该项目将显示为灰色。

在这种状态下,如果单击“OK”,则会在眨眼和口形同步设置中选中的参数上
被刻录为关键帧并输出为motion3.json。

如果在应用“眨眼”或“口形同步”的参数中设置了关键帧,则该参数中
计算上述效果的曲线(眨眼时正片叠底,口形同步时加算)。

统计

您可以查看moc3文件的统计。
点击moc3文件名称 → 在下拉菜单中选择“统计”,显示目标版本等信息。

请问这篇文章对您有帮助吗?
是否
关于本报道,敬请提出您的意见及要求。