Update history

You can also download the latest Cubism Editor here.

Note: Some translations may take time.

4.2.04 beta1(2023/02/02)

Common

>

  • View tabs can now be closed with a middle mouse button click.
  • A link item to the Live2D help website has been added to the Help menu.

>

  • A warning is now displayed when changing the default value of a parameter for a keyed blendshape.
  • Fixed an issue where multiple rotated deformers were selected and warp deformers were created on the parent in different positions and sizes.
  • Fixed a problem where the save dialogue did not appear under certain circumstances.

Modeling

>

  • A Size item has been added to the Create Warp Deformer dialogue to allow the parent warp deformer to be created with a size that takes into account the keyforms of the child objects when creating the deformer.
  • The previously entered values are now stored in the Range in the Create New Parameter dialog.
  • The previously entered values are now stored in the Range in the Create New Parameter dialog.
  • The length of the parameter name field in the parameter palette can now be changed.
  • The Blendshape Weight Limit Settings dialog now displays a confirmation message when editing a graph creates a graph with all weight limits less than 100%.
  • When the physics settings (physics3.json) are changed during export, the reason for the change is now displayed in a dialog box.
  • A “Verify Placement” function has been added to the Texture Atlas edit screen to detect art meshes with specific placement conditions.

>

  • The inner margin size of the art mesh automatically generated when importing PSDs can now be adjusted from the settings menu.
  • Adjusted the size of the inner margin of the art mesh automatically generated when importing PSDs from 0px to 1px.
  • Fixed a problem in which deleting the original image after importing PSD left the object only in the deformer palette and displayed an error.
  • Fixed a problem with the Mesh Divide by Stroke (β) tool in mesh edit mode that prevented selection of path control points when the canvas was enlarged to a large size.
  • Fixed a problem in which null was not displayed in the inspector palette when referencing a nonexistent object as clipping.
  • Partially fixed a problem in which dragging an object from top to bottom in the parts palette would insert the object one ahead of the drop destination.
  • Fixed a problem in which opening the right-click menu when multiple selections were made in the deformer palette would result in a single selection.
  • Fixed a bug in “Delete deformer and reflect parameters to child elements” where opacity, multiply color, and screen color were not reflected.
  • Fixed a problem in which an invalid value of “-0.0” could be set for a parameter.
  • The warning when deleting multiple parameters at once has been modified to omit some of the parameter names.
  • When duplicating parameters, the numbering of trailing numbers has been changed to the same specifications as in the parts palette.
  • Fixed an issue where the cursor tracking settings were not loaded correctly in the physics and scene blend settings.
  • Fixed a bug that prevented the SDK from correctly reading the physics3.json output from the moc3 file export when a symbol was included in the physics operation group name.
  • Physics groups that do not work due to no input or pendulum settings in the physics and scene blend settings are no longer exported in the physics settings (physics3.json).

Animation

>

  • The split position of the timeline palette is now remembered.
  • Fixed a bug that caused physics animation baking to fail in the embedded model track.

4.2.03(2023/01/31)

>

  • We have greatly improved the Editor’s translations, especially for Chinese and Korean, in the following aspects.
  • The same meaning was unified where the wording was not unified.
  • Improved wording that was not expressed as intended.

4.2.02 (12/20/2022)

Common

>

• A button has been added to copy the message displayed in the dialog box when an error occurs during license activation.
• When an error occurs during license activation, a help page link is now displayed in the dialog box.

Modeling

>

• Fixed a problem in which checkboxes in the clipping list were displayed differently from the specifications of other checkboxes.
• Fixed a bug that caused part of the clipping list to be hidden under the taskbar.
• Fixed a bug that prevented editing blend shapes after deleting the target parameter of a Limit Settings for Blend Shape Weights.

4.2.02 beta2 (11/29/2022)

Common

>

• macOS Ventura is now supported.
• A setting was added to display the full path of the file name in [Recent Files].

>

• Fixed a UI bug in the background color setting dialog box.
• [Mac version] Fixed a UI bug in the shortcut settings dialog box.

Modeling

>

• Added dialog boxes for validation of mapped parameters. You can now check the number of parameters mapped to an object.
• Selection of clipping masks and reversing clipping can now be performed.
• Label colors set in the Parts palette can now also be reflected in the Deformer palette.
• Shuffle playback of scenes is now available in the Physics Settings dialog box.

>

• When an object is not selected or an object without a key is selected, a dialog box is now displayed when the parameter is “reversed,” “adjusted,” or “changed.”
 
• Fixed a bug that could cause warp deformer handles to shift when editing vertices.
• The Parts palette has been changed so that when an object is pasted it is inserted on top of the currently selected object.
• Fixed a bug that allowed floating palettes to be shrunk until they disappeared.
• Fixed a problem in which the multiply color and screen color notations were slightly shifted depending on the color when blending forms.
• Fixed a problem in which the Cancel button did not return to the original shape when the blend function was used on the keyform of a blend shape.
• Fixed a bug that caused the workspace to switch when changing the edit level.
• Fixed a problem in which multiple confirmation dialog boxes were displayed at the same time when editing in FA view.
• [Mac version] Fixed a problem in which folders could not be deleted from the right-click menu in the Parameter palette.

Animation

>

• The name of [Replace Scene Track with Image Sequence Track] was changed to [Create Image Sequence Track from Scene Track].

>

• The name field for parameters in timeline can now be expanded.
• Fixed a problem in which the “Burn Lip Sync and Blink into Motion” setting during motion export would cause the motion to be burned into the animation being edited.
 

4.2.02 beta1 (10/13/2022)

Common

>

• Fixed a problem in which switching the glue on/off could not be saved when registering shortcuts.
• Fixed a problem in which the magnification display for Physics and Scene Blending Settings was not displayed correctly.

Modeling

>

• Fixed a problem that caused an error when copying a form with glue selected.
• When exporting .physics3.json, incorrect output settings that specify a pendulum that does not exist have been corrected so that they will not be exported.
• In the Physics and Scene Blending Settings, pendulum numbers for non-existent incorrect outputs are now displayed in red text.

Animation

>

• Fixed an issue where the cursor would flicker when clicking on a label in a parameter bookmark.
• Fixed a problem in which [Restore Previous View] could not be executed in the Form Animation View.
• In the Still image (sequential number) output setting, the minimum number of sequential digits and the number of digits in the final frame are now the same.

4.2.01 (09/27/2022)

Common

>

•Fixed a problem in which the dialogue did not close when the ESC key was pressed in the colour settings.
•Fixed a problem in which the dialogue displayed in [Export Image/Movie] was not reset when [Reset Dialogue Size and Position] was executed.
•Fixed a problem in which the shortcut keys [1], [2] and [3] for [Edit Level] in the shortcut settings dialogue were blank while they were enabled.

Modeling

>

• Fixed a problem in which double-clicking a brush button in the Deform Brush Tool caused some text to become selected.
• The mouse cursor for the Warp Deformer’s shaping brush has been changed to a brush cursor.
• Fixed a bug that caused the brush size to be inverted when resizing the Deform Brush Tool with [B+drag].
• Removed the Weight color item from the Tool Details palette when using the Warp Deformer’s shaping brush.
• Fixed a bug that caused an error when dragging and dropping parts to deformers in the Parts palette.
• A warning dialog box is now displayed to prevent the selection of models containing Blend Shape as templates.
• Adjusted the initial size of the Options for Paste Form Special dialog box.

Animation

>

• In the [Duplicate Label Individually] dialog box, the order of scenes and scene palettes is now the same.
• In the [Duplicate Label Individually] dialog box, tags with the same parameter combination are now merged together.
• In the [Duplicate Label Individually] dialog box, parameters with unmatched IDs are no longer duplicated.

4.2.01 beta1 (08/25/2022)

Common

>

  • Added the ability to enter numerical values for [RGB] and [HSL] in the color settings.
  • [Reset Dialog Size and Position] function has been added.

>

  • Fixed a bug in which groups did not open and close when continuously double-clicked in the Shortcuts Settings dialog box.
  • When [Import], [Restore all], or [Initialize] is executed in the Shortcuts Settings dialog box, the item selection, group open/close status, and scroll position are now saved.
  • Adjusted the behavior of the display position of dialog boxes in general.
  • Colors are now reflected without pressing the Enter key when text is entered in the color settings.
  • Added group [Expand all/Collapse all] buttons to the Shortcuts Settings dialog box.
  • Added the ability to deselect hidden and locked objects when objects are selected with the parameter [Select].
  • Fixed a bug in which auto backup capacity settings were not reflected correctly in Auto Backup settings.

Modeling

>

  • [Shape warp deformer along Bezier handles] function has been added.
  • [Warp deformer shaping brushes] function has been added to the Deform Brush tool.

>

  • Fixed a bug in which the shortcuts for [Attach to nearby key], [Select Previous Key], and [Select Next Key] in the Blend Shape parameters did not function properly.
  • Fixed a bug in which the opening and closing of eyes were not reflected when playing back random poses.
  • Fixed a bug that caused handles to shift when executing [Reset to default values] after operating warp deformers in non-keyed parameter locations.
  • Fixed a bug in which the slider line status was not updated properly when parameters were linked.
  • Multiple items in a list can now be selected in the Edit Keyform dialog box.
  • The Extended Interpolation dialog box is now always displayed in the foreground.
  • Fixed a bug that prevented scrolling in the list in the Edit Keyform dialog box.
  • Fixed a bug in which an unnecessary confirmation dialog box was displayed in the Parameter Settings dialog box when canceling without editing.
  • Fixed a bug that caused handles and vertices to become misaligned when moving a selection with the lasso or brush selection tool.
  • Fixed a bug that caused an error when manipulating the control point of deform paths with an ArtMesh and ArtPath selected at the same time when [Lock Default Forms] was enabled.
  • Fixed a bug in which the color display of warning information for input and output parameters was misaligned in the physics group settings dialog box.
  • Fixed a bug in which clicking a checkbox in the Inversion Settings dialog box scrolled to the top.
  • Fixed a bug in which the Limit Settings for Blend Shape Weights dialog box did not display properly when the parameter name exceeded a certain length.
  • Fixed a bug in which the [Enable Physics] checkbox in the Physics Settings dialog box was turned on and off with the space key.
  • The type of file when selecting a template model from a file has been corrected.
  • Fixed a bug in which Undo/Redo did not work correctly when changing the folder name of a parameter.
  • Fixed a bug that caused file export to fail when executing a large PSD export.
  • Fixed a bug in which the displayed information dialog box appeared twice when mapping up to three parameters to a single object.
  • The wording in the information dialog boxes for [Skinning] and [Use deformation path for Skinning] has been corrected.
  • When clicking [Name], [ID], or [Range] in the Create New Parameter dialog box, all strings and numerical values are now selected.
  • When recording parameter operations and generating animations, the frame rate of the added scene has been modified to set the calculated FPS of the physics.
  • When there are no candidates for a change destination in [change] parameter, an information dialog box is now displayed.
  • Fixed a bug in which changes could be made with shortcut keys when the [Lock Angle and Magnification] checkbox was checked in the Edit Texture Atlas dialog box.
  • Fixed a bug in Texture Atlas editing where a locked texture could be moved from another texture.
  • Fixed a bug in which ArtMesh vertices did not move correctly when using Blend Shape parameters and multiple control points of deform paths were selected and manipulated with a bounding box.
  • Fixed a bug in which the previous display state was not restored when [Restore to Latest Visibility Status] was executed in a specific procedure.
  • Fixed a bug that prevented the correct structure when moving a parent and its child parts in the Parts palette.
  • Fixed a bug in the Parts palette and deformer palette in which when a part was selected and another part was expanded/collapsed, it scrolled to the position of the selected part on its own.

Animation

>

  • Added the ability to duplicate labels of parameter bookmarks to any track.
  • Added the ability to show/hide track trajectory and set track color and shape.

>

  • Fixed a bug in which the Deform Brush Tool did not work correctly for deformers in the FA View.
  • Fixed a bug in which clicking on the View when there is a hidden track in the foreground would select the hidden track.
  • Fixed a bug in which changes to parameter values were not reflected in graphs when editing boxes in the Graph Editor.
  • Fixed a bug in Graph Editor box editing where moving the cursor key left or right would overwrite the keyframe.
  • Fixed a bug in which track names were not reflected when importing scenes.
  • Fixed a bug in which the memory display of values in the Graph Editor did not follow scrolling.
  • The height of the combo box in the Motion Data Settings dialog box has been corrected.
  • Fixed a bug in which edits were saved in a CMO3 file when a CMO3 file associated with a CAN3 file was edited and closed without saving.
  • Fixed a bug in which the export setting for image sequence tracks was invalid when duplicating a track.
  • When the FREE version is started, an information dialog box is displayed indicating that saving and exporting cannot be used when a model exceeding the limit is loaded into the timeline.
  • The Graph Editor can now edit both magnification X and Y at once.
  • Fixed a bug that caused an error when editing for a long time in the Graph Editor.

Cubism Viewer

>

  • Modified the algorithm used in Cubism Viewer to match the modifications in Cubism 4 SDK R5. This change has no effect on Cubism Viewer.

4.2.00 (06/16/2022)

For details on the new features of this version, please refer to the following page.
What’s New in 4.2

Common

>

  • When saving a file, a function to save the file again has been added if the saving did not end normally.
  • Windows 8.1 is no longer supported.
  • macOS Mojave is no longer supported.

>

  • Fixed a problem in which hints remained displayed when [Hide selected state] was used in Multiview.
  • Fixed a bug that caused shortcuts with the modifier key + Tab to not work.
  • Fixed a bug that caused the log to be displayed in duplicate.

Modeling

>

  • Added an item [Export calculate FPS to physics settings file] to the export settings.
  • Added the [Placed and selected only] item to the list of model guide images in the Edit Texture Atlas dialog box.
    Selecting a placed image displays it in the list of model guide images.
  • A single selected ArtMesh on the canvas will be selected when the Edit Texture Atlas dialog box is opened.

>

  • Fixed a problem in which the UI was not updated when changing the group structure of parameters in the random pose setting.
  • Fixed a problem in which the type items in the physics settings were not displayed correctly.
  • Fixed a bug that caused the table width to be initialized when Undo edit was performed on the physics settings.
  • Added [Random Pose Setting] to Physics and Scene Blending Settings.
  • Fixed a bug in the Parts palette that caused an incorrect status when a part was moved into its own hierarchy.
  • Fixed a problem in which regular parameters could be pasted into parameters for Blend Shapes when pasting copied objects.
  • Fixed a bug that prevented Undo/Redo from working correctly when copying and pasting an object with the same ID and normal parameters into a Blend Shape Parameter.
  • Fixed a problem that caused a reduction in the range to which the key of a parameter is adsorbed.

Animation

>

  • Added the ability to duplicate Parameter Bookmarks labels to another track.

>

  • Fixed a problem in which freeze did not work for parameters with eye blinking and lip-sync settings.
  • In Parameter Bookmarks, numeric input is now possible when changing the current value of a key.
  • Switching between scenes and animation files is now faster.
  • Fixed a problem in which label positions were sometimes shifted when dragging labels of Parameter Bookmarks.
  • Fixed a problem in which clicking between parameters in a parameter bookmark would cause the parameter group to become selected.
  • Fixed a bug that caused a pop-up to appear outside the range of the screen when displaying Parameter Bookmarks from labels created in environments with different display resolution settings.
  • Fixed a problem in which motion files were not being exported properly when [Output All Scenes] was selected in the export scene settings during motion file export.
  • When using the FREE version of the Editor to create Runtime Model Track, a warning message with save/export restrictions is now displayed.

Cubism Viewer

>

  • FPS information in .physics3.json can now be checked in the physics setting items area.
  • When FPS information exists in .physics3.json, physics calculation results are now based on the FPS information.

4.2.00 beta2 (06/02/2022)

Animation

 > 

  • Fixed a problem in which multiply and screen colors were not reproduced correctly for models in the Model Track for Embedded Use.
    MOC3 files are not affected, so files exported with 4.2.00 beta1 can still be used.

Cubism Viewer

 > 

  • Fixed a bug in Cubism Viewer (for OW) that multiply and screen colors were not reproduced correctly.

4.2.00 beta1 (05/19/2022)

Common

For details on the new features of this version, please refer to the following page.
What’s New in 4.2

>

  • The UI of the shortcut settings dialog box has been redesigned.
    • Usability has been improved so that the category can be selected and expanded/aggregated.
    • The function that makes it possible to search by entering a name or a key has been added.
    • Shortcut 2 can now be added.
  • Functionality for tabs has been added.
    • Added the [Set All Views to Same Display Position] function.
    • Added the [Switch to Previous Tab / Switch to Next Tab] function.
    • View display position is now maintained when tabs are duplicated.
  • [Windows version] The user can now select the language in which Cubism will be installed when installing Cubism.
  • [Mac version] The language has been changed in the OS settings.
  • The display language can now be switched from the Editor menu item.

>

  • The name of “shape” used to mean “including opacity, draw order, etc. in addition to vertex information” has been changed to “form.”
  • [Add Tab] has been renamed [Duplicate Tab].
  • The display of the [Setting] item in the File menu has been improved.
  • The behavior when dragging a model from the project palette onto the canvas has been improved.
  • In the [Target version selection for animation] dialog box, the text of the video icon was changed from “Movie” to “Video.”
  • [Export For Runtime] in the File menu has been changed to [File Export for Embedded].

Modeling

>

  • Blend Shape functionality has been added.
  • Multiply Color and Screen Color functions have been added.
  • A Mirror Edit function has been added to the Mesh Edit mode.
  • A “merge vertices” function has been added to the Mesh Edit mode.
  • A Paste Form Special function has been added.
  • The ability to select [Parameter Value to Reference] and [Overwrite key] for the automatic generation of the four corner shapes has been added.
  • A function to synchronize parameter values for the same model across tabs has been added.
  • Parameters to be moved in Random Poses can now be selected.
  • The target version was added along with minor version upgrades.

>

  • Changed the icons of folders with [Guide Image] checked in the Parts palette.
  • Fixed a bug that prevented the canvas inversion UI from updating to match the inversion state of the View.
  • Fixed a problem in which the Delete deform path button (trash button) would delete deform paths of different edit levels.
  • Fixed a problem in which deform paths spanning multiple ArtMeshes could not be created when deleting a deform path using the delete key.
  • The notation of “Synthesize corners” has been changed to “Auto Generation of Four Corner Forms.”

Animation

>

  • Parameter Bookmarks functionality has been added.
  • Runtime Model Track functionality has been added.
  • A freeze function has been added.
  • A shortcut for moving markers has been added.

>

  • Fixed that caused holding down Shift and dragging on the time display portion of the timeline to adsorb the onion skin marker.
  • Fixed a rare problem in which mixing smooth curves with other curves did not result in the correct curves.
    (Recalculation is required when modifying past files.)
  • Fixed the transparency of the Shy icon.

Cubism Viewer

>

  • A function to check event information in motion3.json in OW Viewer has been added.
  • OW Viewer can now be used to add, delete, and check the contents of userdata3.json.
  • OW Viewer can now be used to switch the display language from the menu item.

>

  • Fixed a problem that prevented motions and effects from being checked with sliders of parameters in OW Viewer.

Known Defects

  • When pasting a copied object, it is possible to paste normal parameters into parameters for Blend Shapes.
    This occurs when there is no key in the parameter for the Blend Shape and the source and destination parameters have the same ID. (05/23/2022)

* The above defects will be fixed in the Cubism 4.2.00 release version.

Click here for past updates

Please let us know what you think about this article.