Precautions for PSD creation

(Updated on 2020/07/03)

here, Cubism This section explains how to create PSDs that can be used with Editor and notes.
Please check this page before creating a PSD or if it is not imported correctly at the time of import.

For the work procedure to divide the illustration into eyelashes, eyeballs, contours, etc. for each part, see "About material divisionPlease check the page.

For the work procedure to create an imported PSD, see "How to make an imported PSDPlease check the page.

 

Operation guaranteed image editing application

Cubism The following two image editing applications have been confirmed that PSD can be read normally by Editor.

· Adobe Photoshop
· Celsys CLIP STUDIO PAINT

PSDs created by applications other than the above may not be loaded correctly.

 

Precautions for PSD creation

Cubism The PSD that can be imported correctly in the Editor must meet the following conditions.

· The storage format is [PSD]
· The color mode is [RGB]
· Color channel setting is [8bit / channel]

If at least one of these conditions is not satisfied, import can not be performed.
Also, please confirm the following points when saving the import PSD.

-Set the color profile to [sRGB]
・ Check if there is a layer with the same name
-Set the layer attribute after combining to "normal" or "multiplication"
-Combine line art and clipping masks
・ Do not use layer mask
・ [Opacity] is set in PSDCubism Although it is reflected on the Editor, [Fill] is output at 100%.

POINT
The use of the above function is no problem at the stage of illustration production.

Details of each are explained in the following items.

 

About preservation format

Cubism The only image data that can be loaded with Editor is [PSD format].
Be sure to save the image data used as a model in PSD format.

POINT
As an exception, you can load images in PNG format.
This is an image format that can be used for underlining at modeling, background of animation, etc.
In addition, texture replacement (beta function) can be performed by using PNG image exported from texture atlas.

For details on texture replacement (β function), see ".Export and replace PNG files (β)"Please refer to the.

 

About color mode

Cubism The PSD color mode that can be read by Editor is [RGB] only.
[Grayscale], [CMYK], etc. It cannot be read in the color mode other than [RGB].

How to convert color mode

Select [Image] menu-> [Mode]-> [RGB Color] in Photoshop.

 

About color channel setting

Cubism The PSD color channel that can be read by Editor is only [8bit / channel].
[16bit / channel], [32bit / channel], etc. Cannot be read in color channels other than [8bit / channel].

How to convert color channels

Select [Image] menu-> [Mode]-> [8bit / channel] in Photoshop.

 

About Color Profile

When "PSD import" is set, if a color profile other than sRGB is set in PSD, it may change to an unintended color.
Therefore, for PSDs that have profiles other than sRGB set, you need to convert the color profiles to sRGB in Photoshop.

Color profile conversion method

In Photoshop, select [Edit] menu-> [Profile Conversion (V)].
(* Note: This is not "Specify profile")

For CLIP STUDIO PAINT, select [View] menu-> [Color Profile]-> [Preview Settings].

If "Source Color Space" is sRGB (IEC 61966-2.1, etc. is appended)
Because it was originally sRGB, conversion is not necessary, please cancel.

If "source color space" is not sRGB, set "converted color space" to sRGB.

Normally, there is no problem with the standard setting, but you can turn on / off the preview check
Please change the setting of the conversion option when the color greatly changes.

For a detailed explanation of conversion options, refer to the Adobe Photoshop manual.

Make sure there is no layer with the same name

Even with basically the same layer nameCubism You can import it into the Editor, but having the same layer name will cause confusion and cause trouble later.
In order to avoid such troubles, let's use different layer names at the stage of material separation PSD.

 

Set the layer attribute after merging to "normal" or "multiply"

In the PSD to import, the attributes of all layers"Normal"Or "multiplication"To
Layer attributes other than "normal" or "multiply" may change to unintended colors when imported.

TIPS
The layer attribute isCubism It can be set on the Editor.
I want to change it after importingArtmeshSelect and set the [Inspector] palette → [Blend method].

·Normal
・ Multiplication * If it is set to multiplication in PSD,Cubism It is automatically set to multiplication when it is imported into Editor.
・ Addition

These three types can be set.

 

[Opacity] is the% set in PSDCubism Although it is reflected on the Editor, [Fill] is output at 100%.

[不透明度]はPSDで50%などに設定されていた場合、Cubism Editorにインポートされた際も不透明度は50%に設定されます。
[塗り]はCubism Editor上では再現されないため、[50%」などに設定されていた場合でも、Cubism Editor上は100%に設定さ���ます。
濃さを調整する必要がある頬染めなどでは、[塗り]ではなく[不透明度]で設定することをおすすめします。

TIPS
Opacity isCubism It can also be set on the Editor.
I want to change it after importingArtmeshSelect and set the [Inspector] palette → [Opacity].

 

Merge line art and clipping mask

In the importing PSD, one part is placed on one layer.
For each part, combine all the line drawings, fills, filter effects, clipping mask, etc. into one layer.
If you want to divide line drawings and shadows, let's manage it with one layer per part.

 

Do not use layer mask

If a layer mask remains in the PSD to be imported, execute "apply layer mask" and put it in one layer.

 

Check if path information is included

If the path information is included in the PSD created with CC 2019 or later version of Photoshop,Cubism You may not be able to load it into the Editor.
If it contains path information, delete it before joining.

© 2010-2020 Live2D Inc.

English中文한국어日本語