更新履歴

Cubism3 の最新のEditorはこちらからもDLできます

3.2.07(2018/11/15)

共通

《改善項目》

  • 日本語版チュートリアル動画のメニューを更新しました。

 

Modeler

《機能追加》

  • パラメータグループにIDを設定できるようになりました。グループの汎用性のため、標準パラメータグループ名・IDに設定することをお勧めします。
    標準パラメータグループリスト
  • パラメータを結合した状態で、2点/3点キーの挿入に対応しました。
  • 指定した複数のパラメータに対して一括でパラメータのキーを反転する機能を実装しました。

 

《改善項目》

  • キーフォームを動かした状態で新規パラメータを作成した際、キーフォームがデフォルト値に戻る不具合を修正しました。
  • パラメータを操作した状態で絞り込みを実行した際に、表示が基準値になる不具合を修正しました。
  • パラメータパレットでパラメータ名が長くなった場合に縮小表示するように変更しました。(2.1と同じ仕様)
  • 手動でパラメータIDを設定し【デフォルトの設定値に戻る】を実行した際に正しい位置に戻らない場合がある不具合を修正しました。
  • パラメータ設定で上限と下限の変更とリピートの設定が同時に出来ない不具合を修正しました。
  • パラメータの最大値、最小値を超えてキーが設定されていると、マスクに関する警告表示が出てしまう不具合を修正しました。
  • マスクに関する警告表示で、パラメータ編集による状況変化に対して正しい検出が行われるようにしました。
  • macOS版でパーツ、デフォーマパレット内のドラッグ操作を行うと動作が遅延する不具合を修正しました。
  • パラメータフォルダの名称をすべて削除した状態で確定した場合、再度名称を変更することができなくなる不具合を修正しました。
  • パラメータパレットで「変更」を行った際に、表示されるパラメータ一覧が実際の並び順と違う不具合を修正しました。
  • 物理演算・シーンブレンドの設定ダイアログで、変更した「計算FPS」の設定が保存されるように修正しました。
  • マスクのヒント表示の文言を修正し、警告をより分かりやすく修正しました。
  • パラメータの値が大きいとき、稀にデータ表示が不正になる不具合を修正しました。
  • デフォーマを作成した際、同名の他パーツが存在すると意図しないパーツに格納される不具合の修正しました。
  • プロジェクトパレット内のモデル用画像の名称を元の文字数より多くした際、表示が不正になる不具合を修正しました。
  • パラメータの絞り込み時、連結が解除された表示になる不具合を修正しました。
  • 情報ダイアログが数回表示され、Editorが終了できないように見える不具合を修正しました。
  • パラメータ設定ダイアログの大きさを変更した際に、設定が保存されるように変更しました。
  • 形状のブレンド機能を使用した際にUndo/Redoが正常に動作しない不具合を修正しました。
  • アトラス配置を行ったパーツの倍率が保存すると違う数値になってしまうときがある不具合を修正しました。
  • 不透明度の数値が規定値より大きい値を表示してしまう不具合を修正しました。

 

Animator

《改善項目》

  • 非表示状態にあるパーツが不透明度を100%にしても非表示状態になる不具合を修正しました。
  • ベジェハンドルがフレームに吸着してしまう不具合を修正しました。
  • ベジェハンドルが設定されているキーのコピーペーストを行うと、ペースト後にハンドルの形状が変わってしまう不具合を修正しました。
  • モーションの書き出し範囲を最小2フレームに制限しました。(SDK上の不具合を防ぐため)
  • モデルトラックに対するトラック名の編集が保存されない不具合を修正しました。
  • シーンの複製を行った際、トラックの非表示情報がリセットされてしまう不具合を修正しました。
  • シーンの素材削除後、Undo/Redoが正常に動作しない不具合を修正しました。
    Undoができないことをダイアログで確認してから素材を削除すると、それ以前へのUndo操作ができないようになります。

 

Cubism3 Viewer(OW)

《機能追加》

  • 2つのmoc3データを読み込み、情報を比較する機能を追加しました。

 

3.2.06(2018/10/22)

Modeler

《改善項目》

  • テクスチャアトラスの新規作成時にキャンセルを行うと不正なデータになる不具合を修正しました。
  • 反転機能の適用時に、回転デフォーマの基準角度が反転されない不具合を修正しました。
  • アートメッシュのコピー時にモデル用画像が破損する不具合を修正しました。

 

3.2.05(2018/09/20)

共通

《改善項目》

  • 英語版チュートリアル動画のメニューを更新しました。

 

Modeler

《改善項目》

  • macOS Mojave (10.14)で、数値入力ボックスを左右にマウスドラッグして数値を変えようとすると任意の値で止まらずに変化し続けてしまう不具合を修正しました。
  • moc3書き出し設定ダイアログの設定が保存されない不具合を修正しました。
  • パラメータの録画ボタンをクリックした後に、保存先の設定を変更した場合にエラー表示となって記録されたモーション内容が保存されない不具合を修正しました。
  • パーツパレットからデフォーマパレットへアイテムをドラッグ&ドロップした際に、デフォーマの親子の変更が出来ない不具合を修正しました。
  • デフォーマパレットからパーツパレットへアイテムをドラッグ&ドロップした際に、パーツの親子の変更が出来ない不具合を修正しました。

 

Animator

《改善項目》

  • macOS Mojave (10.14)で、動画書き出し機能が利用できるようになりました。
  • キーを全選択した上で間隔調整したあと、そのままキーを移動するとパラメータフォルダを閉じているキーが移動されない不具合を修正しました。

 

3.2.04(2018/09/06)

Modeler

《機能追加》

  • アートメッシュを残した状態で原画を削除できるように拡張しました。
  • 物理演算設定で計算のFPSを指定できるように拡張しました。
  • 自動バックアップの設定ダイアログを追加しました。
  • パラメータの操作を記録してアニメーションを生成する機能を実装しました。
    (ランダムアニメーションでも手動のパラメータ操作でも記録される)
  • テクスチャアトラス編集時に、「ファイル」>「テクスチャのロック(β)」のメニューを追加しました。
  • テクスチャアトラス編集時に、PNG画像の書き出し、差し替え機能を実装しました。
  • この機能によりCubism2.1のようにテクスチャアトラス配置された画像の差し替えが可能になります。
    ・テクスチャアトラス編集時に「ファイル」>「テクスチャ画像の書き出し(β)」および、「テクスチャ画像の差し替え(β)」から利用できます。
    ※ β段階のためUndoは未対応です。
  • ロックされたテクスチャから原画、モデル用画像を抽出する機能を追加しました。
    この機能により、「テクスチャ画像の差し替え」を行ったデータに対してオブジェクトの再配置が可能になります。
    ・モデリング時に、「モデリング」>「テクスチャ」>「テクスチャアトラスから原画に反映(β)」から利用できます。
    ※ β段階のためUndoは未対応です。
  • テクスチャアトラス編集時にモデル用画像を非表示にする設定を追加しました。
    ・テクスチャアトラス編集時に「表示」>「モデル用画像を表示」から利用できます。
  • テクスチャアトラス編集時、タブをマウスホバーするとテクスチャ名をポップアップ表示するように拡張しました。
  • テクスチャアトラス編集時、タブの右クリックからテクスチャ名を変更する機能を実装しました。
  • 原画のPSD書き出し機能を実装しました。以下のいずれかの方法で書き出しできます。
    ・「ファイル」>「画像/動画書き出し」>「PSD画像(β)」 から「すべての原画をPSD書き出し」
    ・プロジェクトパレットの特定の原画を右クリックして「PSD書き出し(β)」
  • 原画の空のレイヤーグループの削除が出来るように拡張しました。
    ・プロジェクトパレットの原画の右クリックから「空のレイヤーグループを削除」
  • 2次マ向けの投稿データを生成するため書き出し機能を「moc3ファイル書き出し」に追加しました。
    「ファイル>組込み用ファイル書き出し>moc3ファイル書き出し」から呼び出せます。
    この書き出しフォーマットでの投稿は2次マで対応次第利用できるようになります。
  • 描画速度を改善しました。特に大量のアートメッシュを持つモデルで大幅に軽量化しております。
  • モデルファイルの読み込み、書き出しの時間を短縮しました。
  • テクスチャアトラス編集時、タブのドラッグ&ドロップで順序を入れ替える機能を実装しました。
  • 「カーソル位置のオブジェクト」のポップアップ表示時に、非表示オブジェクトをまとめて最下部に表示するよう拡張しました。

《改善項目》

  • メッシュ編集時、消しゴムツールでマウスを速くドラッグすると消しムラになる不具合を修正しました。
  • 一部の拡張子のファイルがエディタで開けない不具合を修正しました。
  • グループ化したパーツを描画順スライダーで設定した際、インスペクタの描画順表示が更新されない不具合を修正しました。
  • パーツパレット、デフォーマパレットで、以下の不具合を修正しました
    ・オブジェクトの移動時にスクロールが一番上に戻る不具合
    ・オブジェクトの入れ替え時にハイライトされないことがある不具合
  • パラメータパレットで複数のパラメータを選択して、右クリックメニューから「削除」を行うと、複数選択が外れてしまう不具合を修正しました。
  • パラメータの名称や範囲などを変更した際、パラメータの絞り込みを解除しないと変更が反映されない不具合を修正しました。
  • クリッピングでマスクに指定されたアートメッシュに問題がある場合、実行時にヒント、出力時に警告を表示するようにしました。
  • パーツに設定されたキーフォームが欠けているときの、非表示に関する挙動を修正しました。
  • ネットワークドライブ上のファイルが「最近開いたファイル」一覧にあるとき、エディタの動作が重くなる不具合を修正しました。
  • 特定の操作により同一のオブジェクトが複数されてしまった場合、削除ができなくなる不具合を修正しました。
  • パーツの書き出しのデータサイズが肥大化してしまう不具合を修正しました。
  • 下絵を持つモデルをテンプレートに用いた場合、オブジェクトが下絵と対応付けられてしまう不具合を修正しました。
  • PSD再インポート時に、パーツパレット、デフォーマパレットのアイコンが更新されない不具合を修正しました。
  • PSD再インポート時に、Animatorのモデルトラックのサムネイルが更新されない不具合を修正しました。
  • パーツパレット、デフォーマパレットで特定の状態でファイルのコピー、ペーストを行った時、オブジェクトが二重で生成される不具合を修正しました。
  • テクスチャアトラス編集のUndo/Redoが正常に動作しない不具合を修正しました。
  • メッシュ編集後に、テクスチャの表示をアトラス・モデル用画像切り替えて、Undo/Redoすると表示が崩れる不具合を修正しました。

 

Animator

《機能追加》

  • タイムライン上で、タイムコードとフレームの両方表示に対応しました。
  • インスペクタパレットの「最終フレーム」の設定はタイムコードベースかフレームベースかを選択できるようになりました。
  • タイムラインのパラメータフォルダ列の背景色を黄色に変更しました。
  • プロパティの選択色とグラフエディタの表示色を対応しました。
  • モーションファイル(motion3.json)の読み込み機能を実装しました。(モデルトラック名の部分で右クリック)
  • ドープシート上でShift+クリックで範囲選択が出来るようになりました。
    インジケーター/選択行からShift+クリックの位置までキーフレームを選択します。
  • 音声データの開始点/終了点が認識しやすいように範囲外の背景色を薄い紫色に変更しました。
  • シャイ機能を強化しました。
    ・選択したプロパティを全部シャイする機能。
    ・キーフレームが打たれてないプロパティを全部シャイにする機能。
  • 素材のリンク切れ時にファイルのフルパスではなくファイル名を表示するように修正しました。

《改善項目》

  • 用語修正:アニメーションの「長さ」という表記を「最終フレーム」に変更しました。
  • タイムラインに長い名前のモデルを配置した際も、パラメータスライダを正常に縮小できるようにしました。
  • ビューエリア上でのモデル選択はタイムライン上の選択と同期するように修正しました。
  • 不正な選択状態を防ぐため、トラック、エフェクト、フォルダを閉じた時点で、ドープシートの選択範囲を解除するようにしました。
  • Editor上で背景色を設定してもGif書き出し時に反映されない不具合を修正しました。
  • グラフエディタで全体のキーフレームを0より前の位置に移動させた際、カーブの描画が崩れる不具合を修正しました。
  • カーブエディタ上のキーフレームを矢印キーで移動させた際、稀に数値が変化してしまう不具合を修正しました。
  • 「パーツ表示と配置&不透明度」を閉じた状態で矩形選択でキーフレームの削除を行った際、パーツ表示のキー以外が削除されない不具合を修正しました。
  • シーンパレットでドラッグ操作を行った際、開いているシーンと選択されているシーンの見た目がずれる不具合を修正しました。
  • 音声入りのモーションで、ループをONにしていた場合に発生する不具合を修正しました。
    ・ループする直前にエンターを押すと音声が停止しない
    ・ループするまで再生が数秒間止まる

 

Cubism3 Viewer(OW)

《機能追加》

  • アートメッシュの一覧機能が追加されました。リストを選択することで表示の位置を把握することできます。

《改善項目》

  • moc3をダブルクリックで起動した際、ファイルが開かれない不具合を修正しました。
  • クリッピングでマスク指定をしたArtMeshが正常に出力されなかった場合、Viewerに読み込めなくなる不具合を修正しました。
  • クリッピングでマスクに問題があるときに警告を表示するようにしました。

 

3.2.03(2018/08/06)

Modeler

《機能追加》

  • テクスチャアトラスを最初に作る際に配置される要素を以下から選択できるようになりました。
    ・表示状態のモデル用画像
    ・すべてのモデル用画像
    ・配置しない
  • テクスチャアトラス生成時に下絵は配置されないように変更されました。後から手動で配置することは可能です。
  • テクスチャアトラス編集時、右端のリストで「表示状態かつ未配置のみ」を絞り込み表示する機能を実装しました。

《改善項目》

  • モデル用画像関連のエラーによりEditorの動作が重くなる不具合を修正しました。
  • PSDの再インポート時にテクスチャアトラスを再構築するよう修正しました。
  • PSDレイヤーのサイズが変化したPSDの再インポート時、テクスチャアトラスの配置がずれる不具合を修正しました。

 

3.2.02_1(2018/07/25)

※ インストーラの更新のみ

共通

《改善項目》

  • Windows環境でエディターの起動に数分から数時間かかる場合がある不具合を修正しました。

 

3.2.02(2018/06/28)

Animator

《改善項目》

  • Animatorで別シーンから複製したトラックの削除、複製ができない不具合を修正しました。

 

3.2.01(2018/06/21)

共通

《改善項目》

  • 表示されていないアートメッシュ、下絵などによりメモリ使用量が増大しないように最適化しました。
  • 大きめの下絵を多数配置しているケースで大幅に軽量化します。
  • 特定の条件下でデフォーマの透明度が即時反映されない不具合を修正しました。
  • 保存せずファイルを終了した際に、保存を求めるダイアログにて保存操作をすると、別名保存となる不具合を修正しました。
  • ファイル置き換え時、選択ダイアログに関連しないファイルも表示される不具合を修正しました。
  • プロジェクトパレットの選択時の色を、他パレットに合わせ色を統一しました。
  • 「確認」ダイアログの機能を改善しました:
    ・Yキーを押すことにより、「はい」ボタンを押したときと同じ効果となります。
    ・Nキーを押すことにより、「いいえ」ボタンを押したときと同じ効果となります。
    ・Cキーを押すことにより、「取消」ボタンを押したときと同じ効果となります。
    ・左右の矢印キーを押すことにより、それぞれのボタンへフォーカスが移動します。

Modeler

《機能追加》

  • 複数のメッシュ編集時、メッシュ選択用のポップアップを出すように修正しました。「メッシュが閉じていません」という警告時、メッシュを再選択出来ない状況を回避できます。
  • PSD再インポート時に、旧ファイルにしか無いレイヤーは、旧ファイルに対応付けられたままにするよう仕様変更しました。
    この変更により、旧ファイルにのみ対応付けられたファイルが誤って削除されることが無くなります
  • PSD再インポート時に、複数の既存PSDファイルを選択して差し替えられるよう拡張しました。
  • プロジェクトパレットを拡張しました。
    ・原画レイヤーが未使用な場合、ツリーのレイヤー上で「## 未使用 ##」と出るように拡張しました。
    ・原画のインスペクタ上で、「モデル用画像での利用数」と「モデル用画像への接続数」を表示するように拡張しました。
    ・利用数はカレント状態で繋がっているモデル用画像(実際にアートメッシュに表示されるもの)の数になります。
    ・接続数は非カレント状態のものも含めたモデル用画像(カレント原画の切り替えによって利用中になるもの)の数になります。
    ・原画のインスペクタ上で、「差し替え済みフラグ」のオンオフを切り替えられるように拡張しました。(注 Undo未対応)
    ・PSD原画、原画レイヤー、モデル用画像グループ、モデル用画像、に関して、インスペクタ上で「メモ」を入力できるように拡張しました。
    ・PSD原画、レイヤー、モデル用画像の名前を変更できるように拡張しました。(注 Undo未対応)
    ・原画の右クリックから「未使用レイヤーの削除機能」を追加しました。
    この機能により、一部だけ使っているPSDファイルをすっきりさせることができます。
    ・パレット内で原画レイヤーのドラッグ移動に対応しました。
    この機能により、プロジェクト上の複数PSDファイルを単一のファイルにまとめることが可能になります。
    ・原画レイヤーの右クリックから「モデル用画像を生成」を追加しました。
    ・モデル用画像の右クリックから「アートメッシュへの不正な接続を解除(β)」を追加しました。
    何らかのバグでアートメッシュに複数のモデル用画像が関連付けられてしまった場合のリカバリーに利用できます。
    ・モデル用画像、原画レイヤーのドラッグに関して、複数同時にドラッグできるように拡張しました。'
  • ガイド機能を強化しました。
    ・ガイド線の追加をショートカットで行えるようになりました。
    ・ガイドの色を全て一括で設定できるようになりました。
    ・ガイドのデフォルト色が設定できるようになりました。'
  • 動きの反転機能の拡張しました。
    ・複数のオブジェクトを選択時に、同じパラメータを保持し更に親子関係のあるオブジェクトにも処理が反映されるようになりました。
    (以前は、処理を中断していましたが、警告を表示して処理を継続できるようにしました)
    ・回転デフォーマの軸の位置、回転の角度に対応しました。'
  • 「変形パス」「グルー」「メッシュ編集モード時のツール詳細」にショートカットを割り当てられるようにしました。
  • バウンディングボックスの表示・非表示の切り替え機能を追加しました。(ショートカットにも対応)
  • 「デフォーマパレット」「パーツパレット」からオブジェクトのロックを行った際に、インスペクタパレット内の情報もロックされる機能を追加しました。
    ・ファイルメニュー → 設定メニュー → 「オブジェクトのロック時にインスペクタをロック」から変更が可能です。

《改善項目》

  • 特定の条件下で動きの反転が反映されない不具合を修正しました。
  • moc3ファイル書き出し設定ダイアログのpixelsPerUnitに1.0を入れた場合、一部の設定が保存されない不具合を修正しました。
  • 回転デフォーマの変形がアンドゥできない不具合を修正しました。
  • プロジェクトパレットの「リンク切れ」となっているリソースの文字色を赤に変更し、目立つように修正しました。
  • プロジェクトパレット内で、関連付けされたアイコンを表示するようにしました。
  • メッシュ編集モードの初回開始時に、GUIが欠けた状態になる不具合を修正しました。
  • アートメッシュのプレビューアイコンがずれて表示される不具合を修正しました。
  • 「形状のコピー」を行った際に、不透明度と描画順も反映されるよう修正しました。
  • moc3ファイル書き出し時に、すでに存在しているmoc3ファイルに対して上書きを行う場合、model3.jsonを出力するか選択できるようにしました。
  • 複数選択でのメッシュ編集時、反転している要素の移動などが正常に動作しない不具合を修正しました。
  • インスペクタパレットからオブジェクトに対して「不透明度」または「描画順」を変更した際に、1回のアンドゥ操作で戻れるよう修正しました。
  • PSD再インポート、追加インポート、PSD原画削除、プロジェクトパレット上の各種操作のアンドゥ/リドゥに関する不具合を修正しました。
  • ショートカット周りの軽微な不具合を修正しました。
  • 特定のファイル書き出しの際、デフォルトのファイル名にモデルファイルの名前を使用するよう修正しました。
  • デフォーマの作成ダイアログに「連続作成」と「作成のショートカット」を追加しました。
    ・連続作成:Shift + Enter
    ・作成  :Ctrl + Enter
  • 変形パスの、パスの削除アイコンを更新しました。
  • パーツパレット・デフォーマパレット内で、選択したオブジェクトがロック状態の際、矢印キーで移動できないように修正しました。
  • Solo機能について強化しました。
    ・非アクティブなエリアをグレー表示(色変更可)にすることで、選択されたオブジェクトを表示・編集しやすくなります。
    ・選択されていたオブジェクト以外を一時的にロックするよう処理を修正しました。

Animator

《機能追加》

  • タイムラインでフレーム位置に目印がつけられるよう「マーカー機能」を実装しました。
  • グラフエディタ上でキーの挿入に関する機能を強化しました。
    ・Ctrl + 左クリック:グラフ上の任意の位置にキーを追加する
    ・Ctrl + Shift + 左クリック:グラフ上のカーブ位置にキーを追加する
  • Shift + 左クリックで、プロパティの複数選択ができるようになりました。
  • シーンインスペクタの「デフォルト補間方式」でパラメータとパーツの曲線をデフォルト設定できるようになりました。
  • ワークエリアのバーにマウスをホバーすると情報を確認できるようになりました。
  • 全選択機能(Ctrl + A)を強化しました。
    ・ドープシート:選択されたトラック全部のキーフレームを選択する。
    ・グラフエディタ:選択されたパラメータ全部のキーフレームを選択する。
  • ショートカットを追加しました。(表示されない場合はショートカットの初期化を行ってください)
    ・J    :前のキーフレームへ移動(選択されたパラメータ)
    ・K    : 次のキーフレームへ移動(選択されたパラメータ)
    ・Shift + J :前のキーフレームへ移動(選択されたトラック)
    ・Shift + K :次のキーフレームへ移動(選択されたトラック)
    ・Shift+B : 現在の位置をトラックの始めに移動させる
    ・Shift+N :現在の位置をトラックの終わりに移動させる
    ・Shift+M :現在の位置にトラックを移動させる
    ・未設定 :タイムライン上すべてのトラックを展開・畳む
  • インスペクタ上でシーンサイズの変更を行う際、縦横比を維持する機能を実装しました。

《改善項目》

  • 動画書き出し時、Mac OS版の解像度制限 [幅(4096)と高さ(2304)]を超える数値を入力した場合、警告により書き出しができないよう修正しました。
  • Cubism 2.1のフェード設定が反映されない不具合を修正しました。
  • 編集メニューの削除、全選択、解除がタイムラインへ適用されるように修正しました。
  • キーフレームの反転機能でデフォルト値が中心の値でない場合、キーが範囲外に打たれてしまう不具合を修正しました。
  • グループトラックを全体移動させた後にアンドゥを行うと、中にある子トラックもアンドゥされるように修正しました。
  • キーフレームのコピーペストやテンプレートの適用時、ベジェハンドルの位置が維持されるように修正しました。
  • キーを単一選択し、その後他のキーの矩形選択を行うと、正常に選択状態が切り変わらない不具合を修正しました。
  • ドープシート上で、0フレームよりも前に打たれているキーが見えるようになりました。
  • シーンを切り替えた際に、表示倍率が維持されない不具合を修正しました。

Cubism 3 Viewer ( for OW )

《改善項目》

  • moc3の書き出し設定で「非表示パーツを書き出し」にチェックを入れても反映されない不具合を修正しました。

 

3.2.00(2018/04/27)

Modeler

《機能追加》

  • デフォーマの検証機能を追加しました。
    (組み込み時のパフォーマンス低下の原因となる親のデフォーマからのはみ出しなどが確認できます)
  • 動きの反転機能を追加しました。
    (ワープデフォーマに設定されたパラメータの片側のキーを、反対側のキーとして生成し、対応する頂点へ動きを反転させて適用します)
  • 頂点情報をインスペクタで表示、編集する機能を追加しました。
  • ガイド機能を追加しました。
    ・キャンバス上の任意の座標位置にガイドを追加
    ・選択されている頂点の座標位置にガイドを追加
    ・頂点を移動時にガイドにスナップ
  • 中身の無いデフォーマを選択する機能を追加
  • デフォーマパレットのメニューに、対象のデフォーマ以下をたたむ機能を追加しました。
  • オブジェクトの表示状態を直前の状態に復元する機能を追加しました。
    (オブジェクトの表示非表示をメインメニュー、右クリックメニュー、ショートカットから行った場合のみ)
  • β搭載していたスキニング機能が正式に実装しました。

《改善項目》

  • 複選択されているオブジェクトのロック/ロックを解除、表示/非表示について処理の内容を修正しました。
  • パーツパレット・デフォーマパレットのポップアップメニュー内にある選択の処理について一部不具合を修正しました。
  • テクスチャアトラス生成時にエラーになる不具合を修正しました。
  • motion3.jsonなどが「最近開いたファイル」に表示されてしまう不具合を修正しました。
  • インスペクタの表示を改善しました。
  • デフォーマ作成時、挿入先のパーツが「選択しているパーツ」になるように処理を修正しました。
  • デフォーマの連続作成時、入力した名前を維持するように修正しました。
  • デフォーマ作成時、Enterキー押下で即時作成できるように修正しました。
  • 新規でパーツを追加する際、選択しているオブジェクトがパーツの子に入るよう修正しました。
  • 形状のコピー/ペーストを行った後、メッシュの頂点の選択が解除されないように修正しました。
  • 描画順設定時にポップアップされる「加算ボタン」の配置を変更しました。
  • 複数のモデルを開いた状態でそれぞれのパラメータにフォルダを作成すると、通し番号が共有される不具合を修正しました。
  • PSD画像の書き出し時に、周期的にズレた表現になる不具合を修正しました。
  • 物理演算設定にてミュート状態の音声が入ったアニメーションを再生した場合に音声が再生される不具合を修正しました。

Animator

《機能追加》

  • アニメータで、motion3.json を書き出し時に、リップシンク、瞬きのカーブをパラメータへベイクする機能を追加しました。
    オリジナルワークフローにおけるリップシンク、瞬きのカーブは、そのまま保持してSDKで合成するのではなく、エディタからの書き出し時にベイクして使う方式が推奨されます。
  • 動画書き出し機能(.mp4, .mov)を追加しました
  • 選択されたキーフレームの値を基準値で反転する機能を実装しました。
  • パラメータを跨いだキーフレームのコピーペースト機能を実装しました。
  • モーション書き出しに、リップシンクとまばたきをモーションに焼き込む機能を追加しました。
  • シャイ機能に「全部シャイ/全部解除」の機能を追加しました。
  • 矢印キーによるキーフレームの移動がグラフエディタ上で行えるようになりました。
  • グラフエディタで、キー移動時のスナップ機能を実装しました。
  • シーンをまたいだトラックへシーンをコピー&ペーストできる機能を実装しました。
  • ワークスペースバーの水平移動機能を追加しました。
  • 複数パラメータに個別フェードを設定する機能を実装しました。

《改善項目》

  • mac でのモーションの書き出し時、ファイル保存ダイアログでmotion3.json の拡張子が自動で付与されない不具合を修正しました。
  • タイムラインで選択エリアを囲んで右クリックメニューを表示した際、選択範囲が解除される不具合を修正しました。[macOS版]
  • 連番書き出し中にPCがスリープモードに入らないようにする機構を入れました。
  • 2.1用モーション(mtn)書き出しの際に、パーツ表示の値に整数0と1以外の値が入ってしまう不具合を修正しました。
  • gifアニメーションと連番書き出しの際に、Live2Dロゴの表示有効化が効かない不具合を修正しました。
  • 音声トラックの「ボリューム」値が再生時に反映されない不具合を修正しました。

Cubism 3 Viewer ( for OW )

《機能追加》

  • Original Workflowに対応したViewerを追加しました。
    背景透過(β)はWindows版のみ利用できます。

 

3.1.04(2018/03/13)

Modeler

《機能追加》

  • テクスチャ(アトラス)の生成方式を選択できるように拡張しました。
    テクスチャアトラス編集ダイアログのメニュー「テクスチャ>テクスチャ生成方式 > 高品質 / 低品質(非推奨)」から選択できます。
    高品質は 3.1.04 から搭載された方式。低品質は 3.1.03 までの方式となります。

《改善項目》

  • 複数選択したパラメータ(パラメータフォルダ)を移動する際、選択状態が解除されてしまう不具合を修正しました。
  • キーフォーム編集ダイアログ内で、キーの追加削除時の判定を改善し、操作性を向上させました。
  • パラメータを複数選択しパラメータリスト以外の部分にドロップした場合、移動したパラメータの表示が消える不具合を修正しました。
  • 複数のアートメッシュに変形パスを設定してコピーペーストを行った場合に、コピー後の変形パスを編集するとコピー前のアートメッシュに影響を与えてしまう不具合を修正しました。
  • 複数のアートメッシュに対して変形パスを適用し、一方のアートメッシュをロック(もしくは非表示)にした状態で変形パスの操作を行うとロックされたアートメッシュが動く不具合を修正しました。
  • テクスチャアトラス編集時に、25%などの倍率に縮小すると、品質が劣化する不具合を修正しました。
  • ショートカットの「タブを閉じる」の[Ctrl]+[W]が効かない不具合を修正しました。
  • 物理演算設定(physics3.json)の設定情報のIDが重複するケースがあったため、重複しないよう修正しました。
  • 同じcan3ファイルを複数開ける不具合を修正しました。
  • パーツパレット・デフォーマパレット・ビューエリア間の選択状態の同期について一部挙動を修正しました。
  • ファイル書き出し時に、拡張子をつけずに保存を選択した際、自動で拡張子を付与する機能が正常に動作しない不具合を修正しました。
  • チュートリアル動画を案内するダイアログを追加しました(日本語版のみ)

Animator

《機能追加》

  • マウスホイール押下+ドラッグでタイムラインを縦横同時にスクロールする機能を追加しました。
  • トラックとプロパティグループ上で、シャイにしたプロパティの操作(追加、削除、移動)を有効か無効か選択できるようにしました。
  • トラック名の編集ができるようになりました。(トラック名で右クリック)
  • アニメーション編集モードを切り替えるショートカットを追加しました。(C キー)

《改善項目》

  • シーン切替時、プロパティ選択、編集モード、シャイモード、パラメータの幅などの状態が維持されるように修正しました。
  • 音声ファイルを配置し、位置を移動後にアンドゥを実行した場合、音声の位置が正しく戻らない不具合を修正しました。
  • トラック全体を移動させた場合、まとめてアンドゥが実行されず段階的にアンドゥされてしまう不具合を修正しました。
  • モデルトラックを複製したのちリップシンク設定を行う場合、どのモデルトラックを選択しても一番上に存在するモデルトラックにのみリップシンクが設定される不具合を修正しました。
  • 音声の入ったシーンを再生中、タイムラインをクリックすると、音声のみ再生が先頭に戻ってしまう不具合を修正しました。
  • アニメーションテンプレートのパレットからフォルダが削除できない不具合を修正しました。
  • タイムライン上で音声トラックの先頭部分を短くした際、途中再生時に音声がずれて聞こえてしまう不具合を修正しました。
  • グラフエディタ上で、選択状態や再生位置など重要度の低い項目はアンドゥの対象から除外しました。
  • ログパレットとインスペクタパレットの操作をした後、ショートカットが効かなくなってしまう不具合を修正しました。
  • 音声ファイルがリンク切れしている状態でもシーンの複製ができるようになりました。(できれば非推奨)
  • キーフレームのコピー&ペーストを実行し、選択を解除しない状態で移動を行った場合に選択されていないキーフレームが一部移動される不具合を修正しました。

 

3.1.03(2018/02/08)

共通

《改善項目》

  • AnimatorとViewerの音声再生時、メモリの使用量が徐々に増えていく不具合を修正しました。

Modeler

《改善項目》

  • 画像(PNG)の書き出しで、半透明部分が劣化する不具合を修正しました。
  • ロックされたデフォーマが非選択時にグレーで表示されている不具合を修正しました。
  • 「1フレーム戻る」のショートカットラベル名の重複を修正し、「1フレーム進む」を追加しました。
  • オブジェクトの表示・非表示、ロックの切替時にデフォーマパレットの情報が更新されない不具合を修正しました。
  • 画像を下絵として配置する際に半透明にならない不具合を修正しました。
  • pngファイルが「最近開いたファイル」の中に表示される不具合を修正しました。
  • ロックされたデフォーマを選択し、ロックを解除したときバウンディングボックスが再表示されない不具合を修正しました。
  • 特定条件下でバウンディングボックスが見えないのに操作できてしまう不具合を修正しました。
  • ワープデフォーマのベジェのハンドルを操作すると、意図しない変換の分割点が動いてしまう不具合を修正しました。
  • グルーとグルーが接続するアートメッシュを同時にコピーした際、グルーがコピー元のアートメッシュを接続してしまう不具合を修正しました。
  • テキストコンポーネントにフォーカスがある状況で、Ctrl+Sを押した場合に反応しない不具合を修正しました。

Animator

《機能追加》

  • モーション書き出し時、まばたきとリップシンクの書き出しオプションを追加しました。

《改善項目》

  • 結合したパラメータに「Ctrl+左クリック」でキーフレームが打てない不具合を修正しました。
  • アニメーション再生の時、音声とモーションがずれる問題を修正しました。
  • タイムラインで横にスクロールすると時間軸の表示がズレる不具合を修正しました。
  • リップシンクのキーフレームの生成方式が変更されました。不要なキーが減り、微調整しやすくなりました。
  • タイムライン下の拡大縮小UIで拡縮すると再生位置を中心に拡縮するになりました。
  • キーフレーム選択の背景色とキーの色をより目立つように修正しました。
  • page up,page downのショートカットで再生位置を変更する時、一緒にキーフレームが動いてしまう不具合を修正しました。
  • アニメータのボーン編集でUndoが正常に動作しない不具合を修正しました。
  • パラメータの数値を入力してエンターを押すと再生開始されてしまう不具合を修正しました。

 

3.1.02(2017/12/25)

Modeler

《改善項目》

  • 3.1.1 以降メッシュ編集時の消しゴム機能が正常に動作しない不具合を修正しました。

Animator

《改善項目》

  • 個々のパラメータスライダ上で左クリックして値を変更すると、一回目のクリックが無効になる不具合を修正しました。

 

3.1.01(2017/12/21)

Modeler

《機能追加》

  • PSDファイルの書き出し機能のベータ版を追加しました。メニュー「ファイル>画像/動画書き出し>PSD画像(β)」から実行できます。
    パラメータによって変形した結果をレイヤー分けされたPSD画像として書き出します。一部原画のPSDと異なる表現になる場合がありますのでご注意下さい。
  • スキニング機能のベータ版を実装しました。メニュー「モデリング>スキニング」から各種スキニング処理を実行します。
    このスキニング処理は、長い髪の毛、揺れるひも等、細長いアートメッシュを柔らかく変形する簡易スキニング機能となります。
    (3Dのように自由な変形が出来るスキニングには今後の対応を予定しております)
    詳しい内容はマニュアルをご覧ください。
    https://docs.live2d.com/cubism-editor-manual/skinning/
  • タブにエクスプローラで開く項目を追加しました。

《改善項目》

  • デフォーマ/パーツパレットで複数のデフォーマを選択し親子関係を構築した際、複数まとめてアンドゥできない不具合を修正しました。
  • パラメータパレット上で、パラメータの選択精度を改善しました。
  • スナップショットが下絵に保存されないことがある不具合を修正しました。
  • グリッド表示のショートカットが正しく表示されない不具合を修正しました。
  • 描画順グループの設定がUndo / Redoできない不具合を修正しました。
  • Viewerの物理演算の設定のテーブルで列に対して値の一括設定が出来るように処理を追加しました。
  • パーツ作成がUndo/Redoが出来ない不具合を修正しました。

Animator

《機能追加》

  • 矢印キーで、選択されたキーフレームを1フレームずつ移動する機能を実装しました。

《改善項目》

  • 操作中のundoの精度を改善しました。
  • タイムライン上部のデュレーションの操作精度を改善しました。
  • キーフレーム間にキーフレームを追加した際、カーブが滑らかに遷移しない不具合を修正しました。
  • タイムラインのズーム精度を改善しました。
  • キーフレームのドラッグ移動の精度を改善しました。
  • アニメーション再生の時、再生位置の赤いバーの上下部がずれる不具合を修正しました。

3.1.00(2017/11/30)

3.1 新機能

  • 物理演算のアニメーションベイク機能を実装しました。
    物理演算で設定した「髪揺れ」や「服揺れ」などの動きをアニメータのタイムライン上のキーフレームとして焼き付ける(ベイクする)ことができます。
  • 複数のシーンをブレンドしてプレビューを行う機能を実装しました。
    Cubism SDKのモーションブレンドの確認をエディター上で行えるようになります。 本機能と物理演算設定エディタが統合されViewerとなりました。
    メニューの「モデリング」→「Viewerを開く」から呼び出せます。
  • パラメータに紐づいたキーフォーム(描画順や不透明度)を複数同時に変更する、マルチ キー編集機能を実装しました。
  • シーンのモデルトラックに対して、任意のタイムライン上にユーザーデータを追加することができる機能を実装しました。
    Cubism SDKと組み合わせることで任意の時刻にエフェクトを出すなどアプリケーション側との連携が取りやすくなります。
    追加したユーザーデータは、モーション(.motion3.json)に付与されて書き出され、最新のSDKと組み合わせることが可能です。
  • アートメッシュにユーザーデータを追加することができる機能を実装しました。
    Cubism SDK上で特定のアートメッシュに対して個別処理を行いたい場合などアプリケーション側との連携が取りやすくなります。
    追加したユーザーデータは、ユーザーデータファイル(.userdata3.json)として書き出され、最新のSDKと組み合わせることが可能です。
  • アニメータのモデルトラック内のパラメータに対してフォルダで管理できるようになりました。
    モデラーで設定したモデルのパラメータフォルダがそのままアニメータのタイムラインに表示されるようになります。

3.1の新機能の詳細は下記ページをご参照下さい。
[3.1の新機能紹介]

共通

《改善項目》

  • macOS High Sierra に正式対応しました。
    【注意事項】
    ライセンスを解除してからHigh Sierraにアップグレードを行ってください。
    ライセンスを解除せずにアップグレードを実施するとライセンスが解除されてしまい、再度登録が出来なくなります。
  • Javaメモリ最大確保量を搭載RAMの量に応じて自動で決められるように修正しました。
    これにより、ファイルサイズの大きいモデルファイルが開けないケースが改善されます。

Modeler

《機能追加》

  • 物理演算の設定で多段振り子を用いた場合に振り子シミュレータと動きが一致しないケースがある不具合を修正しました。
    多段振り子を用いた場合の物理演算の計算処理に変更があるため、動作の再確認および、SDKをご利用の場合は最新にアップデートして頂きますようお願いします。
  • グルーがパーツパレットに表示されるようになりました。パーツパレットからグルーに対して非表示や重みのロックが可能になります。

《改善項目》

  • グルーが付与されたアートメッシュを含むパーツを削除した場合に、エラーになる不具合を修正しました。
  • Cubism2.1のモデル( cmox )のロード時、カリングが反映されない不具合を修正しました。
  • カリングされたオブジェクトによるクリッピングが正常に機能しない不具合を修正しました。
  • ワープデフォーマを、ベジェ風のアンカー(またはハンドル)の操作で裏返りが発生する状態まで変形したあと、再度編集すると、不正な変形が発生する不具合を修正しました。
    ※ 変換用の点(ピンクの四角の点)を極端に大きく編集している状態で、ベジェ風のアンカー(またはハンドル)を編集した場合は、稀に期待しない変形になることがあります。
  • '選択オブジェクトのパラメータ構成を揃える'機能をモデリングメニューに追加しました。
  • 物理演算設定エディタのプレビューで物理演算の動きがカクつく問題を改善しました。
  • フリー版でパーツが29個までしか作成できない不具合を修正しました。

Animator

《機能追加》

  • モーションを書き出す際に不透明度の書き出しオプション設定を追加しました。
  • 矢印キーで、タイムラインの再生位置を1フレームずつ移動させる機能を追加しました。
  • タイムラインでドラッグして再生位置を移動する時、音声ファイルも再生させるように修正しました。

《改善項目》

  • インスペクタパレット内での[長さ]の設定時にスクロールバーの表示が更新されない不具合を修正しました。
  • Animatorでパラメータを結合すると、右クリックで移動できてしまう不具合を修正しました。
  • Cubism2.1のcanxファイルからmotion3.jsonを書き出しの場合、全体不透明度の値が正規範囲を超えてしまう不具合を修正しました。
  • グラフエディタで、リピートに設定されているパラメータのキーを操作する際、エディタがフリーズしてしまう不具合を修正しました。
  • シャイを設定したパラメータのキーフレーム編集のルールを変更しました。
    詳しい内容はマニュアルをご覧ください。
    https://docs.live2d.com/cubism-editor-manual/timeline-basic-operation/
  • Macの一部の環境でアニメーションデータの書き出し、読み込みが失敗する不具合を修正しました。

 

3.0.16(2017/11/01)

Modeler

《機能追加》

  • 回転・ワープデフォーマ生成時に、自動で決定される名前、IDのルールを改善しました。
    末尾に付与される連番のルールを以下のように修正しました。
    修正前:顔、顔0、顔1、顔2
    修正後:顔、顔2、顔3、顔4
  • 縦横異なるサイズのテクスチャアトラスの作成、編集、moc3 書き出しに対応しました。

《改善項目》

  • 2.1 の cmoxファイルをロードした際、下絵が消える不具合を修正しました。
  • パラメータパレットのフォルダをダブルクリックで展開する際、名前が表示されている場所でのみ
    「名前の変更」になり、それ以外は「フォルダの開閉」になるように修正しました。
  • 描画順スライダーで描画順を編集した後、Undoができない不具合を修正しました。
  • 一つのオブジェクトに対して4つ以上のパラメータが対応付けられた場合、警告メッセージを表示するように修正しました。

 

Animator

《改善項目》

  • グラフエディターに切り替えた後にシートを切り替えるとタイムライン上で左右のパネルのスクロール同期が動作しない不具合を修正しました。
  • can3ファイルを開こうとした際に、ファイルの置き換え時にフリーズする不具合を修正しました。
  • GIFアニメのループがスムーズに繋がらない不具合を修正しました。
  • シーン名の変更後、シーンパレットの選択の表示が変更後のシーンに切り替わらない不具合を修正しました。

 

3.0.15(2017/10/10)

Modeler

《改善項目》

  • 3.0.14以降で起きる、パラメータの並び順を変更したモデルに対して書き出したmoc3ファイルがSDKで正常に動作しない不具合を修正しました。
  • 3.0.14 以降で起きる、一部のモデルデータをロードした際に大量のエラーが発生して重くなる不具合を修正しました。
  • モデルデータの一部が不正な状態になった場合に、ロード時に修復するように修正しました。
    修復されたオブジェクトには (recovered)という名前が付与されて、パーツパレットの先頭に追加されます。
    (recovered)と付与されたオブジェクトが不要であれば削除してお使いください。

 

3.0.14(2017/10/05)

Modeler

《改善項目》

  • 編集を行ったファイルに対して、タブの名前の先頭に * を表示するように処理を変更しました。
  • タブ閉じた際に、次に開かれるタブがパラメータを結合したモデルの時エラーが発生する不具合を修正しました。
  • モデル編集の際、Enterキーを押下時にアニメーションが裏で再生される不具合を修正しました。
  • 名前、IDなどのテキスト入力時に、Shift+A 、Shift+D などを押すと、ショートカットイベントが走ってしまい、その後の入力が出来なくなる不具合を修正しました。
  • キーを打っていないパラメータでキーフォーム編集ダイアログを開いた際、2点/3点の追加ボタンを押下後更にキーの追加をすると、[OK]ボタンがグレーアウトし押下できない不具合を修正しました。
  • パラメータのキーフォームが設定されていない位置でも、矢印キーでオブジェクトを移動できてしまう不具合を修正しました。
  • パラメータ設定ダイアログ内の [説明] 項目の列の幅が調整できない不具合を修正しました。
  • アートメッシュの自動接続の設定情報を保存するように処理を追加しました。「外周を保つ」のチェックのデフォルトをONに変更しました。
  • メッシュ編集時のメニュー > メッシュ編集モードの「メッシュを自動生成」をクリックするとエラーになる不具合を修正しました。
  • グルーの重み調整時にUndo/Redoが正常に機能しない不具合を修正しました。
  • パラメータパレットのフォルダやパラメータが一番下に配置できない不具合を修正しました。
  • パーツをグループ化した際、パーツパレット上で選択状態が消え、インスペクタが更新されない不具合を修正しました。
  • ペンタブ使用時にパーツパレットおよびデフォーマパレットの項目毎の表示/非表示、ロックの挙動が安定しない不具合を修正しました。
  • デフォーマパレットのドラッグアンドドロップでの階層入れ替え操作の不具合を修正しました。
  • デフォーマパレットの「選択状態に連動してツリーを開く」をOFFにしていても展開されてしまう不具合を修正しました。
  • デフォーマの子にグルーを設定したアートメッシュを含んでいる場合、「子を含めて選択」が正しく動作しない不具合を修正しました。
  • デフォーマ新規作成時の「挿入先のパーツ」の並び順を、パーツパレットに表示されている並び順になるように処理を修正しました。
  • 全グループの展開/集約ボタンが、グループが一つでも展開されている時は、集約するように処理を修正しました。
  • ツール詳細パレットが正しく更新されない不具合を修正しました。
  • グリッドの間隔がエディタの情報として保持されない不具合を修正しました。
  • 表示倍率を2%か3200%にした際、パーツ選択の後フォーカスを使用してもフォーカス状態にならない、1:1 ボタンが機能しない不具合を修正しました。
  • SDK上とエディタ上でのパラメータが同じ並び順にソートされるように修正しました。
  • 特定の条件下で moc 書き出しを行うと正常に書き出しができない不具合を修正しました。
  • 物理演算設定エディタにヘルプメニューを追加しました。
  • モデルの統計情報ダイアログの自動更新に関連する不具合を修正しました。
  • モデルの統計情報ダイアログの自動更新のチェックを維持するように処理を追加しました。

 

Animator

《機能追加》

  • グラフエディターでshiftキーを押してキーを移動する際、縦のみ移動される機能を実装しました。
  • Ctrl + Aで選択されたトラックの全てのキーフレームを選択する機能を実装しました。
  • 選択エリアを囲む時、縦のオートスクロール機能を実装しました。

《改善項目》

  • ショートカットからワークスペースの長さを変更する処理で、undoできない不具合を修正しました。
  • テキストフィールドにフォーカスがある状況で、キャンバス上の編集を行うとUndoが正常に機能しない不具合を修正しました。
  • 選択エリアを囲む際、0の前まで選択される不具合を修正しました。
  • 背景画像の位置のキーを削除すると、モデルの位置のキーも同時に削除される不具合を修正しました。
  • リピートパラメータのデフォルトカーブタイプをリニアに変更しました。
  • グラフエディタでキーをドラッグして編集中、ビュー上のモデルの動きがリアルタイムに更新されていない不具合を修正しました。
  • グラフエディタでベジェハンドルを操作したのち、ドープシートでキーの移動を行った際にハンドルがリセットされる不具合を修正しました。
  • モーション書き出し(全シーン)を行う際、保存先をエクスプローラで開くように修正しました。

 

3.0.13(2017/09/06)

Modeler

《機能追加》

  • 選択したタブに合わせてワークスペースを自動で切り替えるモードを実装しました。
    ・ファイル → 設定 → タブの選択に合わせてモードを自動切替
  • コピーペースト(パーツのインポート・エクスポート)時、必要に応じて位置調整用デフォーマが自動で挿入されるように拡張しました。
    ・位置調整用デフォーマは、パラメータを割り当てられたオブジェクトをまとめて簡単に移動・拡大縮小・回転できるようになり、コピーペースト後の作業に関して利便性が向上します。
    (位置調整後はデフォーマを削除してください)
    ・今回の修正で、モデル間のコピーペースト、パーツのインポート・エクスポートの利便性が向上し、またより安定して行える様になり、パラメータ付きのデフォーマ、
    アートメッシュを部分的なテンプレートのように再利用することが容易になります。

《改善項目》

  • ビュー上のタブ部分を途中表示できるように改善しました。
  • マルチビューの時、選択できないはずのタブが選択できる不具合を修正しました。
  • 多くのタブを同時に開いた際に、すべてのタブが選択できるようにタブをリストで表示するボタンを追加しました。
    ※タブ、ビューの追加機能であった、+ボタンは廃止されました。
    ※今後もタブの追加機能は以下の2つの方法でご利用頂けます。
    ・追加したいタブの上で右クリックした際に表示されるメニューの「タブの追加」
    ・メインメニューのウィンドウ >現在選択されているタブの追加
  • ビューエリアで、マウス位置を固定したまま連続でタブが閉じられるよう修正しました。
  • ビュー上のタブを右クリックした際、稀にタブの右クリックメニューが表示されない不具合を修正しました。
  • Cubism Editor 3.0.11 以降、メッシュ編集モードで「モデル用画像表示」モードにすると、元のPSDより縮んだ見た目になりポリゴンの表示位置がずれる不具合を修正しました。
    (3.0.11では、表示は崩れますが既存のデータを読み込んでも崩れるような問題は発生していません)
  • Cubism Editor 3.0.11 で実装された表示品質を1/2などにする機能を利用した状態でテクスチャアトラス編集を行うと、初期の格子状の配置時にレイアウトが崩れる不具合を修正しました。
  • 新規モデル作成時に生成された下絵パーツが、テクスチャの追加時に下絵として機能しない不具合を修正しました。
  • 新規モデル作成時に下絵パーツが下絵として設定されない不具合を修正しました。
  • 画像を読み込み、下絵として追加を選んだ際にエラーが発生する不具合を修正しました。
  • 自動メッシュ生成の実行時にフローティングパレットがブロックされない不具合を修正しました。
  • メッシュ編集モードで、メニューなどのUIの部分にポリゴンの頂点の追加ができてしまう不具合を修正しました。
  • パラメータのキーフォーム編集ダイアログの編集結果がアンドゥできない不具合を修正しました。
  • パラメータパレット内の「選択」を押下した際、インスペクタ、パーツパレット、パラメータパレットに選択状態を更新するように処理を修正しました。
  • 2.1に合わせてパーツパレット上でデフォマー親子関係を構築する際、パーツの構造は変更しないよう仕様を変更しました。
  • パーツパレット、デフォーマパレットで、全体の表示状態、全体のロック状態を変更すると、最後に選択していたフォルダが開く不具合を修正しました。
  • パーツパレット、デフォーマパレットで、項目ごとの可視状態、ロック状態を変更した時、エディタ上での選択状態が変更されてしまう不具合を修正しました。
  • コピーペースト時、ペースト先に親デフォーマが存在しない場合に正常に動作しない不具合を修正しました。
  • パーツのインポート・エクスポート時、インポート先に親デフォーマが存在しない場合に正常に動作しない不具合を修正しました。
  • 画像のリンク切れエラーが発生した際に、リンク切れが発生しているオブジェクトの名称と、解決方法をログに出力し、リカバリーできるように修正しました。
  • Cubism Editor 3.0.10 以前のバージョンで作成した物理演算データから物理演算設定ファイルを書き出すと、Cubism SDK 上で正常に動作しない不具合を修正しました。
  • 物理演算設定エディタにて入力設定のプリセット名が長い場合、レイアウトが崩れてしまう不具合を修正しました。
  • 物理演算設定エディタにて再生されないシーンが表示される不具合を修正しました。
  • 物理演算設定エディタで出力調整ボタンにツールチップを表示するようにしました。

Animator

《機能追加》

  • アニメータのショートカット機能を追加しました。(カスタマイズはショートカット設定ダイアログへ)
    ・Home       タイムラインの始めへ移動
    ・End       タイムラインの終わりへ移動
    ・Shift+Home    ワークエリアの始めへ移動
    ・Shift+End    ワークエリアの終わりへ移動
    ・未設定      現在の位置をワークスペースの始めに設定
    ・未設定      現在の位置をワークスペースの終わりに設定
    ・PageUp      1フレーム戻る
    ・PageDown    1フレーム進む
  • グラフエディタは以下のように改善されました
    ・縦幅のオートリサイズはオンオフできるようになりました。(タイムラインのオプションメニューから設定)
    ・複製のキーフレームを削除する機能を実装しました。(delete キー)
    ・複数選択でキーフレーム補間法の変更が出来るようになりました。
  • トラックやエフェクト列をダブルクリックすると列が展開する機能を追加しました。
  • パラメータのシャイ(非表示)状態のオンオフをドラッグでできるようなりました。複数のパラメータを効率よく切り替えることができます。

《改善項目》

  • モデルファイルのパラメータ結合状態により、アニメータで読み込みが失敗してしまう不具合を修正しました。
  • タイムラインの拡大縮小機能は以下のように改善しました
    ・Alt+マウスホイールで拡縮する際、「カーソル」を中心で拡大縮小する
    ・Ctrl+マウスホイールに対応(グラフエディタのみ:縦)
    ・拡縮する際、画面がスクロールされてしまう不具合を修正しました。
  • 複数のキーフレームを選択時、「オレンジ色のハイライト表示」ではなく「選択エリアの背景色を濃くする」ように変更し、選択状態をより見やすく改善しました。
  • 音声トラックを含むグループトラックを非表示にした際に音声もミュートになるように修正しました。
  • キーフレーム編集でアンドゥする際、選択エリアと再生位置ポジションがアンドゥされない不具合を修正しました。
  • タイムラインでduraion,workspaceを変更した後、アンドゥができない不具合を修正しました。
  • グラフエディタでキーを移動するとベジェコントローラー位置がリセットされる不具合修正しました。
  • グラフエディタで[Enter]キーを押下し再生する際、稀に編集内容が変更される不具合を修正しました。
  • グラフエディタ上でキーが二点の場合に上下の移動が正常に動作しない不具合を修正しました。
  • Cubism3で出力したmtnファイルのリップシンク、まばたき設定がViewerで反映されない不具合を修正しました。

3.0.12(2017/08/28)

Modeler

《改善項目》

  • 3.0.11で発生していた、矢印ツールなどにおいて小さなアートメッシュのクリック選択が適切に行えない不具合を修正しました。
  • 物理演算のGUIのレイアウトが崩れる不具合を修正しました。

3.0.11(2017/08/17)

Modeler

《機能追加》

  • 物理演算設定機能を正式対応しました。
    ・よく利用する設定のプリセット化
    ・物理モデルのプレビュー
    ・モデルの揺れ幅の半自動調整
    ・モーション再生しながらの動作確認
    ・physics3.jsonの読み書き出し
    などの物理演算を使うにあたって便利な機能が追加されました。
    メニューについて、β版は 「メニュー > ファイル > Viewerを開く」になっておりましたが、正式版では
    「メニュー > モデリング > 物理演算設定エディタを開く」に変わっております。
    詳しい操作方法などマニュアルについては下記をご参照下さい。
    物理演算設定エディタについて
    物理演算の設定方法
    【注意事項】
    正式対応に伴い計算処理を大きく見直したため、β版で設定した物理演算は正しく動作しなくなります。
    お手数ですが再度設定頂けますようお願いします。
  • モデルで使用されるテクスチャを、より軽量なテクスチャで表示・編集できるよう拡張しました。(縮小倍率は1/2, 1/4 , 1/8 に対応)
    ・1/2 にした場合は、テクスチャの面積は1/4 になり、読み込み、編集時の速度が向上し、メモリ使用量が抑制されます。
    ・表示倍率は、「表示」メニュー>「表示品質(モデル用画像表示)」、もしくはプロジェクトパレットのモデル選択時のインスペクタから選択できます。
  • 現在のビューの表示状態を「表示」メニュー>「<表示方式>」から確認、設定出来るように拡張しました。
    ・表示状態はモデル用画像表示と、テクスチャアトラス表示のいずれかになります。
    ・切り替えはこれまで通り T キーで可能です(標準設定時)
  • [T]による表示方式の切り替えの際、キャンバス上のメッセージを「原画表示」から、より適切な「モデル用画像表示」に変更しました。
  • パラメータパレットに、複数のパラメータを選択した状態で並び順を替える機能を追加しました。
  • 変形パスの複数点の選択と、バウンディングボックスによる編集に対応しました。

《改善項目》

  • パラメータパレットをウィンドウの右端に配置した際、サブメニューウィンドウが画面外に表示され操作ができない不具合を修正しました。
  • モデルを縮小して表示(モデル用画像表示)した際、正しい表示(テクスチャアトラス表示)と僅かにズレる不具合を修正しました。
  • パラメータの範囲変更時、現行のキーフォームより狭く設定した場合、警告として”範囲を変更しますか”の確認ダイアログを出すようにしました。
  • パラメータの変更ダイアログで変更をキャンセルしても反映されてしまう不具合を修正しました。
  • キーフォーム編集ダイアログで、ダイアログが点滅する(キーの追加ができない)不具合を修正しました。
  • 文字入力ボックスにカーソルがある場合に、Ctrl+Sなどのショートカットが効かない不具合を修正しました。
  • 画像のメモリ管理で不正な状態になる不具合を修正しました。

Animator

《機能追加》

  • アニメータの間隔調整機能は以下のように改善しました。
    ・連続適用ができるように修正しました。
    ・適用後の値を維持するように修正しました。
    ・ダイアログを表示した状態でキーフレームの選択エリアを囲み直せるように修正しました。
  • アニメータのグラフエディターは以下のように改善しました。
    ・値0の目盛り線を追加しました。
    ・縦のグリッドはキーの移動と一緒に動くように修正しました。
    ・縦のグリッドの値がパラメータの上限/下限値をオーバーする不具合を修正しました。
  • タイムライン上のグループ列(ピンク)のキーフレームを複数選択できるようにしました。
  • グラフエディタでキーの値一覧を切り替えできる機能を実装しました。
  • トラック内のパーツ表示にキーフレームを挿入する際に、デフォルトカーブタイプを「オートスムーズ」から「ステップ」に変更しました。
  • パラメータスライダからキーの値を変更する際、パラメータの範囲に合わせて切りのいい値になるように修正しました。

《改善項目》

  • シーン削除後、他の操作を行わずエディタを閉じた場合に保存確認ダイアログが表示されない不具合を修正しました。
  • グラフエディタ上で、リンクしたパラメータにスライダを使用してキーフレームを挿入する際、グラフが更新されない不具合を修正しました。
  • グラフエディタ上で、リンクしたパラメータに直接キーフレームを挿入することができない不具合を修正しました。
  • シーンを削除したりコピーした後、シーンパレット上で選択されているシーンとビュー上で表示されているシーンが違う不具合を修正しました。
  • タイムライン上で、右クリックした際に表示されるキーフレームの操作メニューが、エフェクト用トラックには表示されない不具合を修正しました。
  • トラックを水平移動させるとカーブタイプがリセットされる不具合を修正しました。
  • シーンのインスペクタにファイル名の項目を追加しました。
  • キーフレームを複数選択し移動した後にアンドゥで戻ると、選択範囲のみ戻らない不具合を修正しました。
  • パラメータスライダ上でキーフレームの数値を変えると、設定されたカーブのタイプが解除されてオートスムーズになる不具合を修正しました。
  • モデルを配置する際、デフォルトのサイズは100%になるように修正しました。
  • リピートパラメータが設定されているシーンを複製した後、リピートパラメータを触るとエディタがフリーズする不具合を修正しました。
  • インバースステップにしたキーを移動した際にインバースステップが解除されてしまう不具合を修正しました。
  • シーン切替時に、キーフレームのコピーペースト等をショートカットで行えない不具合を修正しました。
  • アニメーションの再生、停止をショートカットで実行した際に反応が遅れる不具合を修正しました。

3.0.10(2017/08/03)

共通

《改善項目》

  • macOS 版でライセンスキー入力画面がライセンス認証画面の背面に表示される不具合を修正しました。
  • パレットの値をスライドで変化させている時に、ウィンドウの切り替えなどでフォーカス変更を行うと、カーソルが透明化されたままになる不具合を修正しました。
  • Editorを最小化する際、パラメータや描画順のポップアップメニューのダイアログが表示されたままになっている不具合を修正しました。

Modeler

《改善項目》

  • Windows 10 Creators Update 環境でGodModeを有効にしているとファイル選択ダイアログの表示時にアプリケーションが異常終了する問題に正式に対応しました。
  • 複数のアプリケーションで同時に同じファイルに書き込んだ場合、不正なファイルが出来る不具合を解決しました。
  • 「Ctrl+スペース+ドラッグ」の操作時、拡大縮小される向きと表示されるアイコンが相違している不具合を修正しました。
  • パーツパレット、デフォーマパレットの「全体の展開・開閉」ボタン押下時に、選択状態の表示が消える不具合を修正しました。
  • キャンバス上の右クリックメニューからオブジェクトを選択した際に、パラメータパレットが更新されない不具合を修正しました。
  • グリッドの設定が保存されない不具合を修正しました。
  • パーツパレット、デフォーマパレットで、要素が編集できない(自身または親がロック)場合に、該当するオブジェクトをグレー表示にしました。
  • パラメータを結合後、共通のキーフォームでもキーが黄色表示される不具合を修正しました。
  • パラメータフォルダを閉じた状態で移動を行った場合、フォルダの内容が非表示になる不具合を修正しました。
  • パーツ、デフォーマパレットから、オブジェクトを選択し「方向キー」で移動させようとすると、ビュー内でのオブジェクトの位置移動の代わりに、パレット内のオブジェクトの順序が入れ替わる不具合を修正しました。
  • 3.0.08以降パラメータを複数選択して削除することができない不具合を修正しました。
  • 3.0.08以降パラメータを削除した後undoが効かない不具合を修正しました。
  • ワープデフォーマの変換の分割数、ベジェの分割数について、上限を超えて数値を入力できてしまう不具合を修正しました。
    ・分割数が100の上限を超えて設定された場合でも100で置き換わります。
  • 特定の条件でモデルの表示が崩れる不具合を修正しました。
    (ブレンド方式(通常、加算、乗算)、カリングON/OFF、クリッピングの有無を、様々な組み合わせで利用している場合に発生)
  • 一部のファイルで読み込みに以下のエラーが出る問題、およびそのファイルを書き出し時に大量のエラーが出力される不具合を修正しました。
    ERROR [ deserialize failed : wrong CImageResource :.. 略
    ※ 初回の読み込み時は同様のエラーが発生しますが、このバージョンで書き出すことで同様のエラーは発生しないようになります。
    ※ 今回の修正により、不要なデータが破棄されたことで一部のファイルはデータサイズが小さくなります。
  • moc3書き出しについてSDKとエディタで動作が異なる、下記の不具合を修正しました。
    ・パラメータの最小値~最大値の範囲外にキーが打たれている場合、そのキーが削除されて書き出される。

Animator

《機能追加》

  • モーションデータにワークスペース情報を出力する機能を実装しました。
  • ビューエリアのタブ表示部分にモデルファイルをドラッグするとモデルが開かれ、タブ以下にドラッグするとモデルトラックが追加される機能を実装しました。
  • モデラー上で連結したパラメータがアニメータ上でも再現されるようになりました。

《改善項目》

  • 音声ファイルを含むcanxファイルを開く際、音声ファイルのパスに日本語が含まれていると正常に動作しない不具合を修正しました。
  • canxをインポートする際、2.1でQuickTimeを使用しているデータだった場合に音声トラックを取り込めない不具合を修正しました。
  • モデルトラックを作成する際、トラック名とファイル名が一致していない不具合を修正しました。
  • 「音声ファイルから自動的にシーンを生成」を行う際、最初に配置されたモデルの位置とシーンのサイズが反映されない不具合を修正しました。
  • 複数のキーフレームを選択し移動を行うと、いくつかのキーが追従しない不具合を修正しました。
  • モデラー側でパーツの構造を変えた後にアニメータ側でモデルの再読み込みを行っても、パーツの構造がモデラー側と一致していない不具合を修正しました。
  • png連番書き出し時にプログレスバーでキャンセルできない不具合を修正しました。
  • モーションデータの中にモデルの不透明度とパーツの不透明度の値範囲が統一されていない不具合を修正しました。
  • モーションデータ(motion3.json)内のスムースカーブのベジェコントローラーが1/3,2/3の位置と一致しない不具合を修正しました。

3.0.09(2017/07/27)

Modeler

《改善項目》

  • Windows 10 Creators Update 環境でGodModeを有効にしているとファイル選択ダイアログの表示時にアプリケーションが異常終了する問題を暫定対処しました。
    それに伴い、ファイル選択ダイアログの一部が英語表記となります。
  • Cubism Editor3.0.08以降で、以下の条件に該当するCubism 2.1のモデルファイル( cmox )が開けない不具合を修正しました。
    ・2.1上でPSDファイルを再インポートした際に、新しいPSDで破棄されたレイヤーから生成された描画オブジェクト(アートメッシュ)を含む cmox ファイル

 

3.0.08(2017/07/20)

Modeler

《機能追加》

  • 「4隅の形状を自動生成」において、前回のパラメータ設定を記憶する機能を実装しました。
  • 「4隅の形状を自動生成」において、現在選択されているオブジェクトで利用できるパラメータのみ表示するように改良しました。
  • 「グルー」ツールに切り替えた際、オブジェクトが未選択の場合は、全てのグルーのタブを表示するように改良しました。
  • 変形パスツール以外の状態で、変形パスの点が選択された際「編集」メニュー>「削除」(またはDeleteキー)で、変形パスを削除するように改良しました。
  • 変形パスを選択した際、変形対象となるアートメッシュを色分けして職別できるようにしました。
  • メインのアートメッシュは青、サブのアートメッシュは赤で表示されます。
    (変形パスはメインのアートメッシュのオプション要素として保持されます)
  • 変形パスを選択した際、変形対象となるアートメッシュを職別できるよう、インスペクタに表示する機能を実装しました。
  • プロジェクトパレット>原画の中に入る PSD ファイル名に、拡張子 .psd を付与するように変更しました。
  • 右クリックメニューにパラメータ編集機能を追加しました。

《改善項目》

  • テクスチャアトラスの最後の一枚を削除できないように修正しました。
  • メッシュ編集時の「ポリゴンを生成」ボタンを「自動接続」に変更しました。
  • 自動メッシュ生成のプリセットで、ボタンの間にマージンを追加して、誤操作が発生しにくように修正しました。
  • 自動メッシュ生成のプリセットの「上書き」を行う際、確認ダイアログを出すように修正しました。
  • 未選択状態でメッシュ編集を開始すると、ツールのボタンが不正な状態になる不具合を修正しました。
  • 変形パスの「線変形の幅」にマイナスの値を設定出来る不具合を修正しました。
  • 変形パスの折れ線設定の切り替えがUndoできない不具合を修正しました。
  • 変形パスのコントロールポイントが2点の場合、一部の線が欠けて表示される不具合を修正しました。
  • 特定の条件下で変形パスを動かそうとするとエラーが発生して動かない不具合を修正しました。
  • 不正な変形パスを含むモデルのロード時に、数字が表示されるエラーダイアログが出て、その後もエラーが出続ける不具合を修正しました。
    ・不正な状態になった変形パスはロード時に削除されます。(不正な状態になる問題は別途修正予定です)
  • 編集レベル2,3それぞれに変形パスが設定されている場合、どちらかがDeleteキーに反応しなくなる不具合を修正しました。
  • 複数のアートメッシュに変形パスを適用した状態で、メッシュの自動生成などを行うと正常に動作しない不具合を修正しました。
  • グルーのバインド時、3つ以上の点が1つにまとまってバインドされてしまう不具合を修正しました。
  • グルーのバインドを大量の点に対して行った場合、処理に時間がかかる不具合を修正しました。
  • グルーの重み付けの表示色が、より適切な印象になるよう改良しました。
  • グルーが設定されたオブジェクトについてはメッシュの自動生成を行えないように修正しました。
  • 「倍率を指定して拡大縮小」の機能が特定の条件で正常に動作しない不具合を修正しました。
  • 右クリックメニューの「選択オブジェクト」の階層一覧からオブジェクトを選択した際に、パレット、インスペクタの状態が更新されない不具合を修正しました。
  • 2.1のモデル(.cmox) を読み込んだ際、透明部分の発色が変わる不具合を修正しました。
    (透明度の高いPSDレイヤーを、複数の描画オブジェクトとして配置していた場合に発生)
  • パーツパレット、デフォーマパレットでドラッグアンドドロップを行った際、ハイライトの色がアイコンに色とかぶる不具合を修正しました。
  • ワープデフォーマの反転時に、角の三角形が消える不具合を修正しました。
  • デフォーマ作成時にパーツを選択した際、「パーツの親」にデフォーマを作成できる不具合を修正しました。
  • デフォーマパレット内で、複数の要素を選択移動した後、選択状態が正しく描画されない不具合を修正しました。
  • デフォーマパレットで、要素の並び順がパーツパレットの並び順と異なる不具合を修正しました。
  • デフォーマパレットで要素をドラッグアンドドロップした際、セルがハイライトされない不具合を修正しました。
  • デフォーマが一つもない場合、アートメッシュがデフォーマパレットで表示されない不具合を修正しました。
  • デフォーマパレットで要素を移動時に階層構造を保たずにフラットになってしまう不具合を修正しました。
  • デフォーマパレットでルート階層へ要素を追加できない不具合を修正しました。
  • ワープデフォーマ、回転デフォーマ作成ダイアログの、「挿入先のパーツ」と「名前」の項目順番を変更しました。
  • 回転デフォーマを複数選択して原点移動すると、1つの回転デフォーマしか移動しない不具合を修正しました。
  • 回転デフォーマと曲面デフォーマを選択して原点移動すると、曲面デフォーマのベジェ風ハンドルが付いてこない不具合を修正しました。
  • 一部の2.1のモデルを読み込み moc 書き出しを行うと、2.1及び3.0エディタと異なる表現になる不具合を修正しました。
  • 2つ以上のパラメータに紐づくオブジェクトに対して、任意の1つのパラメータのキーを全て削除すると形状が崩れる場合がある不具合を修正しました。
  • オブジェクトが未選択でバウンディングボックスが表示されていない時に、バウンディングボックスを操作できてしまう不具合を修正しました。
  • テクスチャアトラス作成後にメッシュの自動生成をプリセットで実行するとエラーとなる不具合を修正しました。
  • Fire Alpaca など一部のソフトウェアで出力したPSDファイルの読み込み時に色が変わる不具合を修正しました。
  • マルチビューでオブジェクトにマウスホバーした時に、表示されているすべてのビューでツールチップが表示されてしまう不具合を修正しました。
  • PNG差し替えを行った cmox ファイルを 3.0 でロードした場合に、同じ領域を複数のオブジェクトで利用している部分の濃度が濃くなる不具合を修正しました。

Animator

《機能追加》

  • シーンパレット上で「名前」でソートする機能を実装しました。
  • モデルトラックの倍率編集のXYを、リンクして編集する機能を実装しました。
  • トラックの「表示/非表示」機能と、「ロック/ミュート」機能を実装しました。
  • ガイドの表示機能を追加しました。

《改善項目》

  • 連結したパラメータを選択して、グラフエディタで片方しか表示されない不具合を修正しました。
  • タイムラインのグループ内の描画順が逆になる不具合を修正しました。
  • モデルや背景のトラックの前後を入れ替える際、下に配置されているトラックを上に移動しても入れ替えることができない不具合を修正しました。
  • モーションデータ(motion3.json)のセグメントに不正な情報が書き出される不具合を修正しました。
  • シーンを切り替え時、展開していたトラックが閉じてしまう不具合を修正しました。
  • シーンを切り替え時、選択状態を保つように改善しました。
  • エディタを再起動後、音声トラックの位置が0秒0コマにリセットされる不具合を修正しました。
  • 音声ファイルが設定されている状態で「SDK用途に制限」にチェックを入れた場合、リアルタイムでベジェハンドルが更新されない不具合を修正しました。
  • ワークエリア開始時と音声ファイル開始時の間で再生を停止すると、再開時に音声が2重に流れている状態になる不具合を修正しました。
  • グループの配置・不透明度をコピー&ペーストすると、グループ内のトラックにもコピー&ペーストされる不具合を修正しました。
  • モデルトラック上のキーフレームを複数選択して削除やコピーを実行した際に、一部のキーしか適用されない不具合を修正しました。
  • モデルトラックやエフェクト列のキーを選択して間隔調整を行う時に、一部のキーしか適用されない不具合を修正しました。
  • タイムラインにキーを打った後、ワークエリアのオレンジバーの左端にある矢印でタイムライン全体を移動させると、キーが消えるの不具合を修正しました。
  • キャンバスからはみ出したモデルの一部がアニメーション再生時に非表示、停止時に半透明にならない不具合を修正しました。

3.0.07(2017/07/06)

共通

《機能追加》

  • 現在開いているアプリケーションよりも、新しいアプリケーションで生成したファイルを開いた際に警告する機能を実装しました。(cmo3, can3使用時)

《改善項目》

  • 2.1 モデル(cmox)のロード時にメッシュが欠ける問題を解決しました。
  • 物理演算で中間設定の反応速度を「0」へ設定すると動作しなくなる問題を解決しました。

Modeler

《機能追加》

  • 未使用のモデル用画像を削除する機能を実装しました。以下の方法で削除できます。
    ・プロジェクトパレットのモデル名>モデル用画像 の右クリックから「未使用のモデル用画像を削除」※未使用のモデル用画像がある場合のみ利用可
    ・プロジェクトパレットのモデル名>モデル用画像>グループ名 の右クリックから「未使用のモデル用画像を削除」※未使用のモデル用画像がある場合のみ利用可
    ・プロジェクトパレットのモデル名>モデル用画像>グループ名> モデル用画像名 の右クリックから「モデル用画像を削除」※未使用の場合のみ利用可
  • 空のモデル用画像グループを削除する機能を実装しました。
    ・プロジェクトパレットのモデル名>モデル用画像 の右クリックから「空のグループを削除」※空のグループがある場合のみ利用可
  • モデル用画像グループの名称をインスペクタで変更する機能を実装しました。
    ・プロジェクトパレット>モデル用画像の中に入っているグループを選択して、インスペクタから変更できます。
  • モデル用画像の使用状況を確認する機能を実装しました。
    ・プロジェクトパレットで各モデル用画像を選択するとインスペクタにアートメッシュの数、テクスチャアトラスでの配置数を確認できます。
  • モデル用画像に関連付けられている原画に関して、現在使われている原画以外の接続を解除する機能を実装しました。
    ・プロジェクトパレットから各モデル用画像を選択し、右クリックから「カレント原画以外の接続を解除」
    ・プロジェクトパレットから各モデル用画像グループを選択し、右クリックから「カレント原画以外の接続を解除」を実行するとグループ内のモデル用画像全てについて同様の処理を行います。
  • 空のモデル用画像グループを削除する機能を実装しました。
    ・プロジェクトパレットで、モデル用画像(一覧)を右クリックし「空のグループを削除」
    ・プロジェクトパレットで、モデル用画像グループを右クリックし「グループを削除」
  • モデル用画像を利用しているアートメッシュを選択する機能を実装しました。
    ・プロジェクトパレットで、各モデル用画像を選択し、右クリックから「関連アートメッシュを選択」

《改善項目》

  • インスペクタからオブジェクトの名前を変更した際に、ツリーが更新されない不具合を修正しました。
  • ビューエリア内の「デフォーマのロック」をONにした際、一部のGUIが表示される不具合を修正しました。
  • 親のパーツが不可視のアートメッシュの変形パスが、キャンバス上で表示されてしまう不具合を修正しました。
  • 複数選択状態で移動してから再度移動しようとすると、単一選択として処理される不具合を修正しました。
  • パラメータパレット上でパラメータの順番を変更しても、 パラメータ設定ダイアログ上の順番に反映されない不具合を修正しました。
  • 親がロックされている際、変形パスがロックされない不具合を修正しました。
  • パーツがロック状態の際、オブジェクトの描画状態の不具合を修正しました。
  • 描画順グループの中に描画順グループがあると正しく描画順が反映されず、不正な表示になる不具合を修正しました。
    ・3.0.06以前で同様の状況でmoc3書き出しを行っている場合、再度書き出し直すことでSDK上でも正しく表示されるようになります。
  • テクスチャアトラス編集画面の倍率設定のショートカットを、2.1と同じになるように修正しました。
  • メッシュ編集時に欠ける問題を解決しました。
  • 「エッジの外周を保つ」が正常に機能しない不具合を修正しました。
  • 「メッシュの再構成」が正常に機能しない不具合を修正しました。
  • アートメッシュを選択して反転した際、パラメータの反転が正常に動作しない問題を修正しました。
  • アートメッシュ化したスナップショットが不正な状態になり cmo3 ファイルが正常に読み込めなくなる不具合を修正しました。
  • 1つのアートメッシュに、分離された複数のメッシュ領域がある場合、その間が繋がってしまう不具合を修正しました。
  • スナップショットからのアートメッシュ生成を複数回連続で行うと、不正な状態になる不具合を修正しました。
  • パーツパレットの「選択状態に連動してツリーを開く」をオフにした状態で、不正な動作になる不具合を修正しました。
  • パーツの表示/非表示が正しく適用できない不具合を修正しました。
  • デフォーマパレットで個別にロックを解除した時、親のロックが外れない不具合を修正しました。
  • デフォーマを全て非表示にするとアートメッシュの表示をオンにしても表示されない不具合を修正しました。
  • デフォーマパレットとキャンバス上で「デフォーマの子要素」の選択機能を追加しました。

Animator

《機能追加》

  • SDKの仕様によりベジェコントローラーの制限機能を実装しました。

《改善項目》

  • 背景を配置したシーンを複製すると、背景とモデルの前後関係が複製元と一致しない不具合を修正しました。
  • キーフレーム選択時、トラックの列とエフェクトの列のキーが一括で選択できるようになりました。
  • ワークスペースの終点を音声の途中に設定すると、終点以降も再生が続き音声が重複する不具合を修正しました。
  • 音声トラックを選択してキャンバスで編集しようとすると、エラーが出る不具合を修正しました。
  • タイムラインでシーンの長さを変更してもインスペクタやシーンパレットに反映されない不具合を修正しました。
  • タイムラインパレットがビューエリアの側面にある場合、タイムラインの初期化エラーが発生しアニメーションファイル(can3)が開けない不具合を修正しました。
  • タイムラインパレット上でトラックを選択した際に、キャンバスに即時反映されない不具合を修正しました。
  • シーンパレットからシーンを複製した時に、タブが追加される不具合を修正しました。
  • シーンを開くたびにビュー上にタブが作成され、タブが選択できなくなってしまう不具合を修正しました。
  • シーンパレットでシーンを開く操作を「ダブルクリック」から「シングルクリック」に変更しました。
  • アニメーションファイルを開いている時にマルチビューが実行できるように機能を追加・修正しました。
  • タブを切り替えた時に、シーンパレットの選択・表示状態がキャンバスの選択・表示状態と異なる不具合を修正しました。
  • 複数のアニメーションファイル開いている時、タブを切り替えてもシーンパレットの内容が切り替わらない不具合を修正しました。

3.0.06(2017/06/23)

Animator

《不具合修正》

  • まばたき、リップシンクが設定されたモデルをタイムラインに読み込んだ際、キャンバス内でモデルの表示倍率が変化したり、エディタの操作が重くなる不具合を修正しました。

3.0.05(2017/06/22)

共通

《改善項目》

  • ライセンス解除時にファイルの保存メッセージが表示されない不具合を修正しました。
  • macOS 版で Viewer の物理演算設定を編集する際、入力がスムーズに行えない不具合を修正しました。
  • macOS 版で Viewer の「元に戻す」、及び「やり直す」の修飾キーが commad キーではない不具合を修正しました。
  • 物理演算の入力の設定でタイプ「Angle」を指定した際に正常に動作しない不具合を修正しました。
  • エディタでEnterを押下時に、再生/停止コマンドが実行され、エラーが発生する不具合を修正しました。
  • Viewer の物理演算設定のボタン等が見切れてしまう不具合を修正しました。

Modeler

《機能追加》

  • モデルの書き出し時に、差し替え済みのPSDファイルが残っている場合、確認の上で削除する機能を実装しました。
  • インスペクタ上のパーツの設定を階層表示するように修正しました。
  • パラメータ一覧表へ説明欄を追加しました。
  • パラメータの並べ替え時に自動スクロール機能を実装しました。

《改善項目》

  • 回転デフォーマ選択時、デフォーマの名前がツールチップで表示されない不具合を修正しました。
  • ワークスペースのアニメーションのパレットの配置についてリセット(初期状態)で、パラメータパレットが表示されるように修正しました。
  • キャンバスで右クリックメニューにある「選択オブジェクトのパラメータ構成を揃える」の機能が正しく動作しない不具合を修正しました。
  • ワープデフォーマの作成ダイアログのUIが環境によって崩れる不具合を修正しました。
  • グルーを使ったモデルをmoc3書き出しを行った後、SDKで読み込むとエラーになる場合がある不具合を修正しました。
    再度moc3を書き出し直すことで、SDKで発生するエラーが解消されます。
  • パラメータパレットで絞り込み表示を行った際、パラメータを選択できないためキーの手動編集ができない不具合を修正しました。
  • インスペクタ上で親パーツに自分を指定できる不具合を修正しました。
  • パーツパレットの「描画順」の表示が500のまま変わらない不具合を修正しました。
  • パラメータパレット上でキーを打つ時10.333333ような桁数が多いキーを作成できてしまう不具合を修正しました。
  • Ctrl+Spaceで拡大した際に拡大率の数値が反映されない不具合を修正しました。
  • パーツパレットのパーツを選択時に選択、展開ができないことがある不具合を修正しました。
  • IDの変換機能にパーツのIDの先頭の文字列をPart <-> PARTSで置き換えるオプションを追加しました。
  • パレットで選択時Ctrl+C(ショートカット)でコピーできない不具合を修正しました。
  • パーツパレットでパーツを選択し「子のオブジェクトを全て選択」の処理を行った際に、パーツパレットでフィルタされているオブジェクトが選択される不具合を修正しました。
  • パーツパレットでオブジェクトを選択している時にフィルタを掛けると、フィルタされたオブジェクトの選択が解除されない問題を修正しました。
  • パーツパレットでパーツを選択し「子のオブジェクトを全て選択」の処理を行った際に、子要素にパーツが含まれている時にパーツも選択されていない問題を修正しました。
  • パーツパレットの要素の右クリックにコピー、カット、ペースト機能を追加しました。
  • パーツパレットでパーツ以外を選択して右クリックを表示した時に、「子のオブジェクトを全て選択」が有効になる問題を修正しました。
  • パーツパレットでAltキーを使って子のオブジェクトを全て選択した際に、メインメニューにフォーカスが移って選択状態が不正になる不具合を修正しました。
  • ESCを押した時にパーツパレット、デフォーマパレットの選択状態が正しく更新されない不具合を修正しました。
  • パーツパレットで項目の移動後に階層構造をが保てないことがある不具合を修正しました。
  • パーツパレットでパーツ内のオブジェクトを移動させると順番が逆になる不具合を修正しました。
  • パーツパレットでオブジェクトを複数選択した際に、デフォーマパレットで要素の複数選択が反映されない不具合を修正しました。
  • パラメータで共通ではないキーフォームはキーの色を黄色表示するように修正しました。
  • 変換の分割数の縦横いずれかが1のワープデフォーマを、2.1 cmox , moc 書き出した場合にエラーが発生する問題を解決しました。
    2.1の曲面デフォーマは2x2が最小の分割数のため自動的に2x2に変換されて書き出されます。
  • 2.1cmox , moc 書き出し時に、テクスチャアトラスに配置されていないアートメッシュがあるとエラーが発生して正常に書き出せない問題を解決しました。
    テクスチャアトラスに配置されていないアートメッシュは警告の上で破棄して書き出されます。
  • 2.1moc 書き出し時に、1/2 , 1/4などのテクスチャサイズを選んだ場合に、データ内容によっては正常に書き出しが行われない問題を解決しました。
  • テクスチャアトラスの自動レイアウト時にプログレスバーを出すように修正しました。
  • テクスチャアトラス編集開始時に、アートメッシュ化されていないモデル用画像の配置を削除できるように修正しました。
    アートメッシュ化されていないモデル用画像はアトラス編集時の画面で「No ArtMesh」と表示するように修正しました(これまでは no polygon と表示)
  • テクスチャアトラス編集時の右側のモデル用画像一覧から、アートメッシュ化されていないモデル用画像を除外しました。
  • インスペクタ上で、パーツの親パーツを、自身または子要素に設定すると不正な状態になる問題を解決しました。
  • PSDインポート時に、レイヤーグループの表示・非表示が適切に反映されない問題を解決しました。
  • 3.0.04でブラシサイズ(ブラシ選択、メッシュ編集時の消しゴム、グルー調整)の下限が10に設定され細かい作業ができない問題を解決するため、下限を1.0に変更しました。
  • 2.1向けに書き出したモデルを再度 3.0に読み込むとIDが重複していますというエラーが出る問題を解決しました。
  • モデルを閉じた時に、メモリが開放されない問題を改善しました。
  • 特定のモデルのロード時に一部の画像が消える問題を解決しました。
  • 2点以下しか持たないアートメッシュを生成できてしまう問題を解決しました。
    既に2点以下で作成済みのアートメッシュについてリカバリーする方法についてはFAQのQ19をご確認下さい。
  • デフォーマの親子関係に有るものを同時に選択した状態で反転を行うと、親デフォーマが反転された上で、子要素も反転されるため、結果として子要素が2重の反転となり反転していない見た目になる問題を解決しました。
  • モデルテンプレート適用後、パーツパレット内に、大量のPSDインポート時の空パーツが残ってしまう問題を解決しました。
  • PSD再インポート時に、完全にマッチング成功した場合でも、マッチング無し用のフォルダができてしまう問題を解決しました。
  • 回転デフォーマが選択されている状態で、ワープデフォーマの作成を実行するとエラー表示となりデフォーマが作成されない問題を解決しました。
  • 3.0で作成したモデルをモデルテンプレートとして使用すると、適用時の画面で再生ができない問題を解決しました
  • 2.1モデルで、型をまたいで同一のID文字列が使われていた時に、3.0で読み込めない問題を解決しました。
  • ロック、表示・非表示がパーツにも適用されている不具合を修正しました。
  • ロック、表示・非表示のundo,redoが効かない不具合を修正しました。
  • メインメニューのロック、表示・非表示の有効状態が不正になる不具合を修正しました。
  • Viewerにおけるモデル表示の高速化、表示品質の改善、およびメモリ使用量の軽減を実施しました。

Animator

《機能追加》

  • 2.1のアニメーションテンプレートファイルを3.0で使えるようになりました。
  • 2.1のSDK,Viewer向けのモーションデータ(mtn)の書き出し機能を実装しました。
  • ドープシートに縦のグリッド線を追加しました。
  • メインメニューにモデルの差し替え(全シーン)の項目を追加しました。
  • グラフエディタでキーフレームを複数選択し、バウンディングボックスの拡縮を行う際に、Shiftキーでの補助機能を実装しました。
  • グラフエディタでShift + キーフレーム移動する際、X軸をロックする機能を実装しました。

《改善項目》

  • モデルの配置、音声の読み込みがUndoできない不具合を修正しました。
  • ドープシート上で追加したキーフレームをグラフエディタ上でアンドゥするとすぐに反映されない不具合を修正しました。
  • アニメーションテンプレート適用後、複数のキーが選択されている状態でも、単一のキー移動になってしまう不具合を修正しました。
  • アニメーションテンプレートを適用した瞬間、ビュー内のモデルにモーション変化が無い不具合を修正しました。
  • トラックの「配置&不透明度」>「傾き(シアー)」が適用されない問題を解決しました。
  • シーンのサイズを変更した後、キャンバス上でトラックを正常に編集できない問題を解決しました。

3.0.04(2017/06/12)

Modeler

《改善項目》

  • テンプレート適用時にエラーログが出力される問題を解決しました。
  • テンプレート適用後にUndoした場合に、左上(0,0)に回転デフォーマが残る問題を解決しました。
  • 3.0形式のID( ParamAngleX など )のモデルデータをテンプレートとして利用した場合に、正常に動作しない問題を解決しました。
  • 親のパーツを持たないデフォーマを持つモデルをテンプレートとして用いた場合に、正常に動作しない問題を解決しました。
  • 3.0.03 以降、特定のデータに関してコピー&ペーストが失敗する場合がある問題を解決しました。

Animator

《改善項目》

  • 一部のアニメーションデータが正常に読み込めなくなる問題を解決しました。

3.0.03(2017/06/05)

共通

《機能追加》

  • FREE版を実装しました。Pro版との機能差分は下記をご参照下さい。
    [Cubism 3 PRO/FREE 機能比較]
  • Viewer機能を追加しました。Viewerでは物理演算機能(β)を使用することが出来ます。
    物理演算機能の使用方法に関しては下記マニュアルをご参照下さい。
    [物理演算(β)]

《改善項目》

  • GPU初期化時の環境関係のラベル名を修正しました。
  • ヘルプ→バージョン情報の表記の修正しました。
  • ウィンドウの最小サイズを800*600へ変更しました。
  • 2.1モデルを開こうとした時にIDの変換について提示するように処理を追加しました。
  • ヘルプメニューの[ログファイルを開く]のパスを修正しました。
  • ヘルプメニューのリンク先のURLを更新しました。
  • プロジェクトパレット上のモデル、アニメーションファイルを閉じるのに、該当ファイルはエディタが閉じるまで削除できない不具合を修正しました。
  • ダイアログがアプリケーションと無関係の場所に出る問題を解決しました。
  • Modeler・Animatorのキャンバスサイズを表す枠がキャラクターの背面に回ってしまい、枠が見えない問題を解決しました。

Modeler

《機能追加》

  • IDの変換機能を追加しました。2.1のIDを3.0推奨のID形式に変換することが可能です。
  • Alt+クリックでパーツを選択した際、パーツ内のオブジェクトを2.1と同様にすべて選択するように処理を追加しました。
  • 当たり判定用のアートメッシュを生成する機能を搭載しました。
    [モデリングメニュー > アートメッシュ>当たり判定用アートメッシュを生成]
  • テクスチャアトラス編集時に、モデル用画像の一覧を右端に表示するように拡張し、
    未配置のモデル用画像をテクスチャアトラス上に配置出来る機能を追加しました。

《改善項目》

  • パーツパレット内でオブジェクトをクリック後、左右どちらかに少しでも移動させてしまうと、パーツ内でオブジェクトが一番下か一番上に移動してしまう不具合を修正しました。
  • パーツの新規作成時、描画順範囲外(0 ~ 1000以外)のパーツを作成できる不具合を修正しました。
  • Mac版のパーツパレットの描画順は1000の時表示は [...] として表示される不具合を修正しました。
  • パレット間の選択オブジェクトの同期について不具合を修正しました。
  • 描画順のインクリメント、デクリメント機能を使用した時に描画順の値の範囲外を設定できる不具合を修正しました。
  • パーツをダブルクリックした時に選択状態がはずれる不具合を修正しました。
  • ビューで右クリックからメッシュを選択した際に、パーツパレット上で選択状態で表示されない不具合を修正しました。
  • ワープデフォーマ作成後に、パラメータパレットでキーの追加を行う際の追加先が不自然になる不具合を修正しました。
  • アートメッシュの不透明度をインスペクタ上でスライドで設定しようとした際、数値と表示が一致しなくなる不具合を修正しました。
  • アートメッシュのロック中変形パスが表示される不具合を修正しました。
  • ビューのメニュー、アートメッシュの編集のメニューの上にGUIが重なって表示される不具合を修正しました。
  • 回転デフォーマの先端がカメラの拡大率によって見えづらくなる不具合を修正しました。
    また、回転デフォーマの先端のハンドルのフォーカスがカメラの拡大率によってズレる不具合を修正しました。
  • パーツパレットでパーツを削除した際にデフォーマパレットが更新されない不具合を修正しました。
  • グルーアイコンを押した際、グルーの使い方を紹介する説明用のポップアップを表示するように処理を追加しました。
  • 回転デフォーマをCtrl+ドラッグする際に少し変化してしまう問題を解決しました。
  • Cubism2.1でも発生していた「回転デフォーマを曲面デフォーマに入れた際にズレる」課題を解決しました。
  • cmoxのロードの際、反転している要素が正常に読み込めない問題を解決しました。
  • 回転デフォーマの形状のブレンドが正常に動作しない問題を解決しました。
  • メッシュの自動生成時、処理の完了前に別の操作ができてしまい、不正な状態にあることがないように修正しました。
  • 複数のアートメッシュを選択してメッシュ編集モードに入ると頂点を正常に編集できない問題を解決しました。
  • アートメッシュを複製するとSDK上でテクスチャが正しく関連付けられない問題を解決しました。
  • テクスチャアトラス編集時に、空のアートメッシュを削除してOKを押しても消えずに残っってしまう問題を解決しました。
  • テクスチャアトラスに、同じモデル用画像が二回以上配置される問題を解決しました。
  • PNGの下絵の読み込みを行ってからPSDを再インポートしようとすると正常に動作しない問題を解決しました
  • PSDの再インポート時にエラーが発生し正常に動作しない問題を解決しました。
  • ブラシ選択、消しゴム、グルー機能など範囲を指定するツールに関して、B+ドラッグでサイズを変更する際に一度小さくしすぎると正常に動作しなくなる問題を解決しました。
  • PNGの画像配置、スナップショット等を利用したあとで、PSD再インポート(差し替え)が反映されない問題、および、古い原画(PSD)を削除できない問題を解決しました。
  • 一部のオブジェクトを編集しようとするとパラメータ値が不正な動きをする問題を解決しました。
  • 2つ以上のパラメータを対応付けたオブジェクトに、新しくキーを追加すると形状が崩れる不具合を修正しました。
  • パーツ書き出し、読み込む時にオブジェクトの順序が崩れる問題を解決しました。
  • 特定の条件下で moc3 が書き出せなくなる問題を解決しました。
  • 複数アートメッシュを選択してメッシュ編集を行う場合に正常に頂点が編集できない問題を解決しました。
  • 形状のブレンド時に前回使用した値を初期状態として開くように修正しました。
  • 「親のデフォーマを選択」の実行時に、パーツパレット、デフォーマパレットの選択状態が変わらない問題を解決しました。

Animator

《機能追加》

  • タイムライン上で一個のキーフレーム移動ができるようになりました。
  • タイムライン上で「選択されたトラック」がわかりやすいように、選択時トラックのラベルを濃い色に変更しました。
  • トラックの複製機能を追加しました。(右クリック → ポップアップメニュー)
  • アニメーションテンプレート機能を実装しました。
  • キーフォームのペーストとアニメーションテンプレートの適用時、適用範囲を表示するようにしました。

《改善項目》

  • グラフエディタで、ベジェのコントローラーが打たれたキーの最大値最小値を超えるとハンドルをつかめない不具合を修正しました。
  • アニメータに素材を配置したときに、アンカーがセンターに設定されない不具合を修正しました。
  • 特定の環境にて、タイムラインパレットのアニメーショントラックを全て展開した状態でアニメーションを再生すると、フレームレートが極端に低下する不具合を修正しました。
  • カーブタイプがリセットされる不具合を修正しました。(キーをドラッグ移動、コピーペスト、間隔調整を行う後)
  • アニメーション再生速度制御のUIを改善しました。
  • キーの移動、コピー&ペーストに対するundo処理を修正しました。
  • タイムライン上で複数列のキーを選択し、右クリックしてポップアップが表示された状態でキーをドラッグ移動すると一行しか移動しない不具合を修正しました。
  • 選択状態が分かりづらかった為、キーフレームの選択範囲が、選択エリア(青い枠)に全部囲まれるように修正しました。
  • キーの削除をBackspace/Deleteキーで行った際に、トラックの展開状態が閉じる不具合を修正しました。

3.0.02(2017/05/11)

共通

  • シーンパレットから削除したシーンのタブが残る不具合を修正しました。
  • ツールバーの編集レベルのアイコンをクリックしても変化しない不具合を修正しました。
  • パーツデータのファイルアイコンが正しく表示されない不具合を修正しました。
  • 英語版のUI全般について文言を修正しました。
  • GPUが動作環境の要件を満たしていない場合、ユーザに通知するよう修正しました。
  • 描画の更新時にメモリが不要に消費され正常に動作しなくなる問題について一部修正しました。
    ・同問題に関する安定度は大幅に改善しておりますが、一部問題が残っており次回アップデートにおける対応を予定しております。
  • Windowsでアプリケーションのインストール情報が正しく表示されない不具合を修正しました。
  • Windowsでログインユーザのアカウント名に空白が含まれている場合、エディタを起動することが出来ない不具合を修正しました。

Modeler

  • macOSで何も選択されていない状態で右クリックした際にポップアップメニューが表示されない問題を修正しました。
  • macOSの英語版でパラメータのテキストフィールドからポップアップするメニューで選択、反転などのボタンの幅が狭く文字が途切れる不具合を修正しました。
  • macOSの英語版でデフォーマの作成ダイアログのボタンの文字が見切れる不具合を修正しました。
  • ビューを2画面以上にした状態でビューエリアのメニューの「アートメッシュをロック」が全てのビューに反映されてしまう不具合を修正しました。
  • モデルを開いていない状態で、パーツパレットのパーツ新規作成、パーツ設定を開こうとするとエラーが発生する不具合を修正しました。
  • モデルを開いていない状態で、パラメータパレットのパラメータ新規作成、パラメータの編集、パラメータのフィルタを開こうとするとエラーが発生する不具合を修正しました。
  • モデルを開いたときの編集レベルが2に設定されるよう修正しました。
  • PSDインポート時にモデルのデフォルトのパラメータのIDが2.1の仕様で設定される不具合を修正しました。
    ・3.0からのIDの仕様に関しては下記マニュアルをご参照下さい。[ FAQ ]2.1のモデルを読み込めますか?
  • PSDインポート時のアートメッシュのデフォルトIDをLayerからArtMeshに変更しました。
  • メッシュの線幅に不正な値を入力出来る不具合を修正しました。
  • 3.0仕様のIDでランダムポーズが正常に動作しない不具合を修正しました。
  • メッシュの自動生成の「プリセット」を削除する際に確認ダイアログを出すように修正しました。
  • パーツリスト内で複数のパーツをデフォーマ上に移動し親子関係を構築すると、描画順が同一の場合すべて逆順となる不具合を修正しました。
  • テクスチャアトラス編集を開いている状態でスペースキーを押下するとOKボタンを押された状態で編集が終了する問題を修正しました。
  • ボタンからメッシュ編集モードに切り替えた場合にスペースキーを押下するとメッシュ編集が終了する問題を修正しました。
  • テンプレート適用時にパラメータパレットが更新されない問題を修正しました。

Animator

  • モデリングビューにフォーカスがある場合、タイムラインパレットの誤動作を防ぐため操作できないよう変更しました。
  • シャイを使用してパラメータを非表示にした状態で非表示パラメータより下のパラメータを選択すると表示がずれる不具合を修正しました。
  • macOSでタイムライン上でCtrl、Altキーが効かない不具合を修正しました。

3.0.01(2017/04/27)

共通

  • macOSで言語ロケールが中国、韓国の場合に、文言に日本語が含まれる問題を修正しました。
    ・インストーラに応じた言語で表示されるようになります。
  • タブの切り替えで、パラメータパレット、タイムラインパレットの更新がされない不具合を修正しました。

Modeler

  • オブジェクト選択時のインスペクタに表示される描画順の更新が正しく表示されない(0になる)不具合を修正しました。
  • 英語版で文言の表示が崩れる不具合を修正しました。
  • パラメータパレットのフォルダアイコンがずれて表示される不具合を修正しました。
  • ビューエリアの右クリックメニューで表示されるデフォーマ階層についてアートメッシュの名前を表示するように修正しました。
    ・名前がない場合はIDが表示されます。

3.0.00(2017/04/26)

共通

  • モデラーとアニメータが統合され、モデル編集とアニメーション付けを同時並行で行うことができるようになりました。
  • マルチビューに対応し、同じモデルを複数開いて編集することができるようになりました。
    ・複数のビューで異なるパラメータを設定し、表示を確認しながら編集することができます。
    ・一部のビューでアニメーション再生し、動きを確認しながら編集することができます。
  • マルチドキュメントに対応し、複数のモデルを同時に開いて比較、コピペなどを行うことができるようになりました。

Modeler

  • PSDのインポート時、最初にテクスチャアトラス化する必要がなくなりました。
    ・アニメーション制作の場合はアトラスを作成しないまま作品を制作することができます。
    ・SDK開発に必要なテクスチャアトラスは、テクスチャアトラス編集から作成、編集できます。
  • アートメッシュとデフォーマを同時に編集できるようになりました。
    ・アートメッシュをロックしてデフォーマを編集したい場合は、Shift+Aによりアートメッシュをロックできます。
    ・デフォーマをロックしてアートメッシュを編集したい場合は、Shift+Dによりデフォーマをロックできます。
  • デフォルトのフォームをロックする機能を搭載しました。
    ・「デフォルトのフォームをロック」をオンにすると、あるオブジェクトの編集時にデフォルトのパラメータ値が選択されている場合は、ロックされて編集できないようになります。
    ・原画と完全一致する状態を残しつつ、動きをつけていくことができるようになりミス防止に繋がります。
  • グルー(頂点の吸着機能)が搭載され関節などの接続が容易になりました。
    ・異なるアートメッシュの頂点を自動で接続することができるようになりました。
    ・パラメータに合わせて重み(ウエイト)を調整することで、繊細な動きを定義することができます。
  • 描画順グループの実装。
    ・パーツ自体に「描画順」を設定し、中に入れ子になっているオブジェクトも一時的に親のフォルダと同じ描画順にすることができます。
    ・描画順グループにしたパーツ内では、ローカルの描画順となり、そのパーツ内でだけの描画順になります。
    ・描画順グループにしたパーツはパラメータでキーフォームを設定できるようになりました。
  • パラメータのリピートの実装。
    ・単一のパラメータでリピートする動きを表現できるようになりました。
  • メッシュ編集機能を大幅に改良しました。
    ・メインのキャンバス上の表示位置でメッシュ編集モードに切り替えて編集できるようになりました。
    ・頂点の追加後に自由に移動しても問題なく表現できるようになりました。
  • メッシュの自動生成を後からリアルタイムに適用できるようになりました。
    ・アートメッシュ単体への適用ができるようになりました。
    ・設定値を保存できる「プリセット機能」を実装しました。
  • 変形パスが新しい形に生まれ変わりました。
    ・「編集レベル」の2,3に異なる変形パスを割り当て、詳細な編集、大まかな編集のように使い分けることができます。
    ・変形パスがアートメッシュの変形に自動で追随するようになりました。
    ・複数の変形パスを1つのアートメッシュに対応付けることができるようになりました。
    ・パス状ではない「点」の状態で影響を与えることができるようになりました。
    ・変形パスの影響範囲をパスごとに設定できるようになりました。
  • 選択オブジェクトがパラメータで設定されたキー以外の編集不可な場所にある場合、編集しようとすると自動的に編集可能なキー位置まで移動してから編集開始するように改良しました。
  • モデルテンプレートを改良しました。
    ・マッチング時にメッシュの分割を元のデータに合わせて自動で行います。
  • パラメータパレットを大幅に改良しました。
    ・パラメータを階層表示できるようになりました
    ・キーの2点挿入、3点挿入、削除など頻繁に使う機能をパレット上のボタンで実行できるようになりました。
    ・ドラッグ&ドロップにより順序の入れ替えが可能になりました。
    ・パレット上に数値を表示し、スライダーで編集できるようになりました。
  • パーツパレットとデフォーマパレットを大幅に改良しました。
    ・アートメッシュがサムネイル表示されるようになりました。
    ・パーツパレット上でオブジェクトのフィルタリング表示ができるようになりました。
    ・パーツパレットが複数階層に対応しました。
    ・パーツパレット上で、Photoshopのレイヤーと同じツリー表示になりました。
    ・パーツパレット上に描画順を数値で表示しました。
    ・デフォーマパレットに表示/非表示機能を実装しました。
  • プロジェクトパレットを実装しました。
  • 自動アニメーション機能を搭載し、アニメーションを設定しなくても動きをプレビューすることができるようになりました。
    ・ランダムポーズのメニューから3パターン選択することができます。
  • Solo 機能(Sキー)により、一時的に選択オブジェクトだけを表示して編集できるようになりました。
  • フォーカス機能(Fキー)により、選択オブジェクトを瞬時に表示中央に移動させることができるようになりました。
  • スナップショットをアートメッシュとして配置することができるようになりました。
    ・複数の形状を下絵として配置、反転しての利用、パラメータ割り当てによる変形などが可能です。
  • ワープデフォーマを改良しました。
    ・ワープデフォーマの連続作成ができるようになりました。即座に親子関係の構造を構築できるようになりました。
    ・変換の分割で設定した交差する分割点も直接編集できるようになりました。
    ・編集時ベジェの編集タイプを6パターン選べるようになりました。
    ・変換の分割数やベジェの分割数をリアルタイムに変更できるようになりました。
  • 回転デフォーマを改良しました。
    ・回転デフォーマの連続作成ができるようになりました。同じ位置に作成されるため、位置合わせが不要になる場合があります。
    ・基準角度を設定できるようになりました。両腕の位置など相対的に角度を入力して回転させることができます。
  • 回転デフォーマ作成ツールを実装しました。
    ・ドラッグしながら即時に作成することで、位置やハンドルの長さを調節しながら配置していくことが可能になりました。

Animator

  • タイムライン上で直接にスライダーを操作してパラメータの調整ができるようになりました。
  • 再生位置(キャレット)を固定する機能が実装されました。
  • 時間の目盛りは秒とフレームが2種類切り替えられるようになりました。
  • インスペクタパレット上で随時シーンの情報を変更できるようになりました。
  • パーツ表示は単純なON/OFFの調整から不透明度の調整まで行えるようになりました。
  • リップシンクと目パチのエフェクトは適用するパラメータの数量制限を外して、適用したいパラメータにチェックを入れればいくらでも設定することができるようになりました。(詳細はリップシンク/目パチの設定方法へ)
  • スクロール機能が改良されました。
    ・マウスホイル で 縦スクロール
    ・Shift + マウスホイルで横スクロール
    ・Ctrl + マウスホイールで横方向の拡大表示
    ・Alt + マウスホイールで縦方向の拡大表示(カープ専用)
  • GUIDの認識機能を追加して、パラメータやパーツのIDが変更されてもアニメータ側の該当キーフレームは消されないようにしました。
  • モーションデータの形式はjson形式に統一しました。
  • グラフエディタを改良しました。
    ・リニア、スムース、ベジェ、ステップ、インパースステップ五つのカーブを用意し、より感覚的な曲線操作ができるようになりました。
    ・グリッドは、なし、1フレーム、5フレーム、秒の四つのグリッド線から選べるようになりました。
    ・カーブの縦拡大が可能です。(Alt + マウスホイル)

今後対応を予定している機能

  • Live2D Viewer の機能を Live2D Cubism に搭載する予定です。
    ・物理演算の設定や、モーションの再生などを、Live2D Cubism 上で手軽に行えるよう準備中です。
  • アニメーションテンプレートについては、今後実装予定です。
  • .mp3ファイルの読み込みは今後対応予定です。
  • AfterEffects用プラグインについては対応を予定しておりますが、時期は未定です。
  • Cubism2.0/2.1で搭載されていた動画の入力・出力はQuickTimeのセキュリティ問題により非搭載となっております。
    ・今後一部のフォーマットに限り書き出し対応する予定ですが、時期は未定です。

廃止になった機能

  • アニメーションでのテキスト入力は3.0では実装を見送りました。
  • PNGによるテクスチャアトラスの差し替え機能の実装を見送りました。
    ・Cubism3.0 では、PSDの読み込み時にテクスチャアトラスに化を必須ではない流れに変更しました。
    映像制作のようなケースではテクスチャアトラスに配置することで劣化するなどの課題があるため、それを避けるための実装となっております。
    PSDのインポートによる利用法が多かったため、このような判断をしておりますが、要望が多い場合、今後PNGの差し替えに対応することも検討させて頂きます。

Copyright © 2018 Live2D Inc.