更新履歴

Cubismの最新のEditorはこちらからもDLできます

4.1.02 beta1(2021/10/28)

共通

《機能追加》

  • 物理演算・シーンブレンド設定とCubism Viewer (for OW)で、カーソル追従の設定に[影響度]と[反転]が追加されました。
    また、[種別]では右クリックと左クリックが設定できるようになりました。
  • [パラメータ値をコピー] [パラメータ値を貼り付け]機能を追加しました。パラメータの値のコピーと貼り付けができるようになります。

《改善項目》

  • PRO版の無料トライアルを開始ボタンをクリックした際に、確認ダイアログが表示されるよう修正しました。
  • パレット配置のリセットを行うと、パレットの表示・非表示の状態がメニューのチェック状態と一致しなくなる不具合を修正しました。
  • パレット配置のリセットを、現在選択しているワークスペースで行うように修正しました。
  • [Mac版]キーボードの一部がCtrlキーになっていた不具合を修正しました。
  • パーツ設定ダイアログでキャンセルボタンをクリックした際、確認ダイアログが二回表示される不具合を修正しました。
    また、確認ダイアログで取消をクリックした際に、パーツ設定ダイアログに戻る修正をしました。
  • ビューエリアのタブを閉じたら、一つ前にアクティブにしていたタブをアクティブにするように修正しました。
  • ビューエリアのタブを閉じると、そのタブで作業していたモードレスダイアログも閉じるように修正しました。
  • ビューエリアに何も開いてない状態で、[ウィンドウ]メニュー → [ビューエリアの状態のリセット]を実行で、エラーログが記録されないように修正しました。
  • タブの閉じるボタンをドラッグした際に、タブを移動しようとする不具���を修正しました。
  • [Ctrl+Shift+Alt+E][Ctrl+Shift+Alt+L][Ctrl+Shift+Alt+T]にデフォルトで割り当てられていたショートカットを廃止しました。
    また、これらのキーにショートカットを割り当てられるように修正しました。
  • 物理演算の計算FPSと、シーンのフレームレートfpsが異なる時に、警告ダイアログが出るようになりました。

モデリング

《機能追加》

  • ショートカット設定ダイアログに[近くのキーに吸着]を追加しました。
  • 回転デフォーマの色を変更できるようになりました。
  • 物理演算・シーンブレンド設定で[ランダムA][ランダムB]のモーションが選択できるようになりました。
  • デフォーマの検証ダイアログで[変換の分割数][ベジェの分割数]が確認できるようになりました。
  • メッシュ編集モードに部分的な頂点の複製機能を追加しました。
  • パーツパレットで[ラベル色]を設定できるようになりました。

《改善項目》

  • ショートカット設定ダイアログに[キーフォーム追加][キーフォーム削除]を追加しました。
  • PSDを再インポートした際に、追加されたアートメッシュがデフォーマパレットに即時表示されない不具合を修正しました。
  • メッシュの手動編集モードで、アトラス表示にしてモードを終了した際に、モデルの見た目とパラメータパレットの状態に齟齬が生じる不具合を修正しました。
  • アートメッシュの入力レイヤーを切り替えた時に、パーツパレット上のアイコンが更新されない不具合を修正しました。
  • 特定のPhotoshopのバージョンで保存したPSDが読み込めなくなることがある不具合を修正しました。
  • インスペクタパレットでのテキスト入力中のUndo/Redoの挙動を修正しました。
  • パラメータのショートカットの[デフォルトのキーを選択]で選択しているすべてのパラメータに対し、デフォルトのキーに戻る設定を追加しました。
  • パラメータを複数選択して移動した時に、順番が選択順になる不具合を修正しました。
  • グルーを選択していない状態でグルーツールに切り替えた時に、ブラシが表示される不具合を修正しました。
  • [デフォルトのフォームをロック]が有効な時に、変形パスの制御点を選択しているとバウンディングボックスが操作できる不具合を修正しました。
  • ロックされているオブジェクトに対して、[選択オブジェクトをフォーカス]が機能しない不具合を修正しました。
  • 物理演算・シーンブレンド設定のカーソル追従で、範囲基準をキャンバス範囲からビュー範囲に変更しました。拡大時に操作がしやすくなります。
  • 物理演算・シーンブレンド設定で、[入力・出力パラメータ]の[使用]チェックが範囲選択できるようになりました。
  • 物理演算・シーンブレンド設定の録画機能で、計算FPSに合わせたシーン設定で保存されるようになりました。
  • デフォーマパレットで同じパーツにドラッグアンドドロップすると、ハイライト表示が残る不具合を修正しました。
  • オニオンスキンが有効時、パラメータパレット上でパラメータを選択した際に、モデリングビューのオニオンスキンが更新しない不具合を修正しました。
  • [回転デフォーマ作成ツール]を使用時に、Shiftキーをクリックするとマウスカーソルが不正なアイコンに変わる不具合を修正しました。
  • 空のパーツを削除した時に、警告ダイアログを表示しないように修正しました。
  • モデル用画像の名前の編集を、Undo/Redoできない不具合を修正しました。
  • 背景色の設定ダイアログで、[濃い色との差][チェック柄サイズ]を変更すると文言が見切れる不具合を修正しました。
  • パーツパレットで同じパーツにドラッグアンドドロップすると、ハイライト表示が残る不具合を修正しました。
  • インスペクタパレットでグルーの適応度が、キーフォーム上ではない状態で編集できてしまう不具合を修正しました。
  • インスペクタパレットで回転デフォーマの角度・倍率が、キーフォーム上ではない状態で編集できてしまう不具合を修正しました。
  • 一時変形ツール実行時に、一時変形が開始されない状態でも、パーツパレット・デフォーマパレットがグレーアウトしてしまう不具合を修正しました。
  • デフォーマのロック有効時に、ビューエリア上のマウス操作で一部のデフォーマの変形操作が実行できてしまう不具合を修正しました。
  • パラメータパレットで、結合したパラメータを複製した際に、パラメータIDが重複してしまう不具合を修正しました。
  • アートパスの線幅の最大値を、2000pixelに変更しました。
  • デフォルトのフォームをロック実行時に、インスペクタパレットで回転デフォーマの角度・倍率が変更できてしまう不具合を修正しました。
  • ロックされたパーツフォルダにオブジェクトを入れた時、そのオブジェクトが編集ロックにならないことがある不具合を修正しました。
  • 原画の追加・削除で、間違ったUndo/Redoが起きることがある不具合を修正しました。
  • パーツパレットのオブジェクト表示/非表示ボタンが、内部の状態と一致しないことがある不具合を修正しました。
  • パーツ設定およびパラメータ設定ダイアログのCancelボタンをクリックした際、確認ダイアログが表示されるよう修正しました。
  • パーツパレットで複数オブジェクトを選択した後にパーツフォルダの開閉を行うと、選択が解除される不具合を修正しました。
  • モデリングでブレンド方式を変更後、アニメーションにも反映するように修正しました。
  • デフォルトのフォームをロックした状態でも、Altドラックで回転デフォーマの円のサイズを変更できるように修正しました。
  • デフォーマパレットで、選択しているデフォーマにドラッグアンドドロップすると不正な状態になる不具合を修正しました。
  • デフォルトのフォームをロックして、Ctrl(Alt)キーを押しながらワープデフォーマや回転デフォーマを編集しても警告を出さないように修正しました。
  • 非表示を含むアートメッシュを複数選択した際、該当の非表示アートメッシュもまとめて移動してしまう不具合を修正しました。
  • 新規テクスチャアトラス設定ダイアログを開く際、親のウィンドウの中心に表示されるように修正しました。
  • 物理演算の計算FPSが、モデルごとに保存されるようになりました。
  • 長いパラメータ名がある場合に、それ以外のパラメータでも、モデリングビュー[右クリックメニュー]のパラメータスライダが縮む不具合を修正しました。
  • パーツ設定ダイアログで編集をせずにCancelボタンを押した時に、確認ダイアログを表示しないようにしました。
  • モデリングビューの右クリックメニ���ーが、タスクバーの裏側に見切れてしまう不具合を修正しました。
  • ブラシ選択ツールで頂点を複数選択した際に、インスペクタパレットの頂点情報が更新されない不具合を修正しました。
  • ソロ表示の非アクティブカラーの設定が、正しく反映されていなかった不具合を修正しました。
  • パーツをコピーした際に、コピーされるパラメータをコピー元の見た目の並びに合わせるように修正しました。
  • モデル保存時に未使用の原画を削除するか確認するダイアログで、どの原画が未使用か名称を表示するようにしました。
  • ブラシ選択ツール、グルーツールの共通の設定を各々で設定できるように修正しました。
  • 変形パスツールで、輪上になったパスの先頭と末尾のコントロールポイントを選択すると、勝手に折れ線が無効になる不具合を修正しました。
  • モデルの複製をして、複製先でパラメータのIDを変えて複製元にインポートしなおしても、変更前のパラメータが適用される問題を修正しました。
  • 変形パスのコントロールポイントが1つだけの時は、インスペクタパレットで線変形の幅や硬さを変更できないようにしました。
  • 物理演算設定の出力設定タブで倍率を変更した際に、最大出力の自動調整が行われない不具合を修正しました。

アニメーション

《機能追加》

  • タイムラインパレットの[パレットメニュー]全ての項目に対し、ショートカットキーを設定できるようにしました。
  • タイムライン左側のプロパティパネルのパラメータ選択時に、すべてのキーを選択する機能を追加しました。

《改善項目》

  • FAビューで調整モード1と2を併用した場合に、正常に形状編集できない不具合を修正しました。
  • canx形式のアニメーションファイルをシーンインポートした際に、エラーが発生する不具合を修正しました。
  • FAビューでデフォーマを操作した際に、不要な警告が出る不具合を修正しました。
  • 連番静止画の複数フレームの書き出しで、画像がシーンごとにフォルダへまとめられるようになりました。
    また、全シーンの書き出しで、同名シーンは上書きされないように修正しました。
  • 音声ファイルを差し替えた際、音声トラックの波形表示が更新されない不具合を修正しました。
  • ファイル展開後に音声ファイルのリンク切れを解消した場合に、音声ファイルが正常に読み込まれない不具合を修正しました。
  • フォームアニメーション編集時のインスペクタパレット[調整モード2]の時に、編集できない項目に数値を入力できてしまう不具合を修正しました。
  • 連番画像、GIF、動画出力で、GPUメモリが解放されない不具合を修正しました。
  • トラックの位置を変更した際、領域外に出るとエラーが出る不具合を修正しました。
  • パラメータの選択状態が、正常に遷移しない不具合を修正しました。
  • リンク切れが発生しているファイルに対して[データの差し替え]を行う際に、対象外の拡張子のファイルは選択できないように修正しました。
  • マーカーのツールチップウインドウに、判定のずれがあった不具合を修正しました。
  • モーション録画の保存時に、開いていないcan3ファイルにシーンが追加されてしまう不具合を修正しました。
  • 物理演算のアニメーションベイクで、物理演算の設定FPSとシーンのFPSが異なる時、ベイクに使用するFPS設定を選択できるようにしました。
  • フォーム編集を設定したモデルのパーツを、モデリングのメッシュ編集機能で頂点が増減するような変更を加えた際に、
    アニメーションでダイアログが繰り返し表示されて操作不能になることがある不具合を修正しました。
  • 特定の条件下で、モデルのパーツが白に表示される不具合を修正しました。
  • トラックをロックした際に、トラックの選択範囲を解除するように修正しました。
  • トラックの複製を行うと、フォームアニメーションのリカバリーに失敗する不具合を修正しました。
  • 静止画(連番)出力設定のダイアログにある警告文「書き出し範囲外にあるシーンのフレームは書き出しされません」は、該当シーンがある場合のみ表示されるように修正しました。
  • 素材ファイル差し替え時に、[ファイル名を利用]に設定されているトラックの名前が更新されない不具合を修正しました。

Cubism Viewer

《機能追加》

  • Cubism Viewer (for OW)で、フレームレートを確認できるようになりました。

 

 

4.1.01(2021/9/15)

共通

《改善項目》

  • 起動時に表示される緊急度が低いエラーログは、ログパレットに表示されないように修正しました。(ログファイルにはすべて記載されます)

モデリング

《改善項目》

  • 物理演算・シーンブレンド設定で、グループ編集のみを行った際に結果が保存されない不具合を修正しました。
  • テンプレート機能のモデルを、3.0以降の形式に更新しました。

アニメーション

《改善項目》

  • canx形式のアニメーションファイルをcan3形式にコンバートした際に、シーンの長さが1フレーム長くなってしまう不具合を修正しました。
  • [末尾に移動]ボタンをクリックした際に、ワークエリアの末尾へ移動しない不具合を修正しました。

 

 

4.1.01 beta1(2021/8/19)

共通

《改善項目》

  • ショートカット設定ダイアログに[変形ブラシツール]を追加しました。
  • ショートカット設定ダイアログに[検索と置換]を追加しました。
  • モードレスダイアログを開いた状態でキャンバスの拡縮などのマウスホイール操作を行うと、エディタ全体の表示サイズが変わる不具合を修正しました。
  • エディタを再起動すると、キャンバスの背景色設定がデフォルトの透明に戻ってしまう不具合を修正しました。
  • [Windows版]高DPI設定のときにスポイトの取得位置がずれる不具合を修正しました。
  • [Mac版]起動時にエラーが発生することがある不具合を修正しました。
  • [Mac版]ファイル読み込み時にエラーが発生することがある不具合を修正しました。

モデリング

《機能追加》

  • ストロークによるメッシュ割り(β)で、ストロークを編集後に確定を行わず他のツールに切り替えようとした際に、確認ダイアログを表示するように修正しました。
  • 物理演算・シーンブレンド設定ダイアログで、出力設定テーブルと振り子設定テーブル上で複数選択した状態での同時編集ができるようになりました。
  • 物理演算・シーンブレンド設定ダイアログで、出力設定テーブルに対してコピーアンドペーストができるようになりました。

《改善項目》

  • 特定の条件下でオブジェクトを複数選択し、ツール詳細パレット → 一時ワープ変形の[ワープの分割数]の変更を行うとオブジェクト名がID名に変更されてしまう不具合を修正しました。
  • IDが63文字で末尾がアルファベットのパラメータを複製すると、不正なIDが設定されてしまう不具合を修正しました。
  • アートパスツールの使用時、マウスカーソルの表示に不整合があったため修正しました。
  • アートパスツールのデフォルトブラシ設定で、アートパスのブラシの設定で編集した内容がすぐに反映されない不具合を修正しました。
  • [形状をブレンド]の処理を最適化し、レスポンスを改善しました。
  • 複数の描画オブジェクトを選択し、それぞれの頂点を1つずつ選択した際に、バウンディングボックスが表示されない不具合を修正しました。
  • パーツの名前を変更すると、パーツパレットのパーツの展開が解除される不具合を修正しました。
  • デフォーマの名前を変更すると、デフォーマパレットのデフォーマの展開が解除される不具合を修正しました。
  • 変形ブラシツールのブラシサイズを「B+ドラッグ」で変更する際に、ブラシサイズを小さくしていくとブラシの円が反転してしまう不具合を修正しました。
  • ストロークによるメッシュ割り(β)で、ショートカットを使用してメッシュ編集を確定した際に、[編集中のストロークの確定]の表示がキャンバス上に残り続ける不具合を修正しました。
  • ストロークによるメッシュ割り(β)の全選択と削除時の挙動を調整しました。
  • ストロークによるメッシュ割り(β)の操作時に、マウスカーソルが更新されない不具合を修正しました。
  • パラメータのショートカットの[前のキーを選択][次のキーを選択]でパラメータにリピート設定がある場合、リピートしてキーを選択するように修正しました。
  • パラメータのショートカットの[前を選択][次を選択]で、パラメータパレットのリストがスクロールしないことがある不具合を修正しました。
  • プロジェクトパレット内の右クリックメニューで、[選択オブジェクトの入力画像として設定]が原画側とモデル用画像側で同じ名称のため、区別しやすい名称に変更しました。
  • キャンバスの反転中に[選択オブジェクトのフォーカス]を行うと、反転状態が解除されてしまう不具合を修正しました。
  • モデリングメニューの[未選択オブジェクトをロック][すべてのロックを解除][未選択オブジェクトを隠す][すべてを表示]の対象にグルーが含まれていなかった不具合を修正しました。
  • 物理演算・シーンブレンド設定ダイアログで、テーブルの行移動を行う矢印ボタンの操作を行うと、行が消えてしまうことがある不具合を修正しました。

アニメーション

《機能追加》

  • グラフエディタで、ハンドルとキーが重なった場合に離れて表示するように修正しました。
  • ドープシート、グラフエディタで、上下で値の変更ができるようになりました。
  • ドープシート、グラフエディタで、カーソルキーによる複数回の移動を1回のUndoで処理するように修正しました。
  • 静止画(連番)出力設定のダイアログで、全シーンの出力が選択できるようになりました。
  • GIFアニメ出力設定のダイアログで、全シーンの出力が選択できるようになりました。

《改善項目》

  • グラフエディタで、マウスのミドルボタンで移動が出来ない不具合を修正しました。
  • グラフエディタのボックス編集で、該当キーの値の色が変わらなかった不具合を修正しました。
  • ドープシート、グラフエディタで、カーソルキーによるキー移動が正しく動作しない場合がある不具合を修正しました。
  • タイムラインのドープシートで、重い環境下での以下の不具合を改善しました。
    ・キー編集時のレスポンス
    ・キーが移動しない場合がある不具合
  • Live2Dパラメータグループのコマ打ちプロパティで、編集を元に戻すことができなくなる不具合を修正しました。
  • アニメーションで複数のモデルトラックを配置した際に、オニオンスキンの描画負荷が過剰に高まる不具合を修正しました。
  • モデルトラックの作成時に、モデルのcmo3ファイルが削除・移動されていた場合、���ラーメッセージを表示するように修正しました。
  • インスペクタパレットの[サイズ(幅)][サイズ(高さ)]をドラッグ操作で変更した際に、[縦横比を固定]にチェックが入った状態でも正しく縦横比が維持されない不具合を修正しました。
  • 複数のトラックのキーをまとめて間隔調整した際に、キーが消えたり上書きされたりする不具合を修正しました。
  • 画像や動画の書き出し中にキャンセルを行った場合に、ファイルが出力されていない場合も保存先が表示されてしまう不具合を修正しました。

Cubism Viewer

《改善項目》

  • Viewerで開けなかったファイルに対して、エラーや警告を行うメッセージダイアログを表示するようにしました。

 

 

4.1.00(2021/6/10)

本バージョンの新機能の詳細は下記ページをご参照ください。
新機能紹介 4.1

共通

《改善項目》

  • [Mac版]マルチモニタ環境において、ターゲットバージョン選択ダイアログがエディタとは別のモニタに表示されることがある不具合を修正しました。
  • モデリングとフォームアニメーションのメニュー項目の順序と名称を一部変更しました。
  • 一時変形ツールの回転において、一時変形ツールで表示される矩形の外をドラッグした場合でも回転できるようになりました。
  • 一時変形ツール使用中にバウンディングボックスが表示されてしまう不具合を修正しました。
  • 一時変形ツール実行時のキャンバス上の表示を調整しました。
  • 一時変形ツール実行時にパーツパレットおよびデフォーマパレットを編集不可になるように挙動を修正しました。
  • 一時変形ツール実行時にツール詳細パレット上で、一時変形ツールの切り替えを行えるように修正しました。
  • 一時変形ツール実行時に操作に応じてマウスカーソルが変更されるように修正しました。

モデリング

《改善項目》

  • 物理演算・シーンブレンド設定の[カーソル追従の設定]ダイアログに[適用]ボタンを追加しました。
  • グルー作成時にグルー名の末尾に対象のアートメッシュ名が含まれるように仕様を変更しました。
  • キャンバス上のグルーのボタンのUIの文字列が一定幅以上になる場合は末尾を省略して表示するように修正しました。
  • 一時変形パスの変形のアルゴリズムを改善しました。
  • 一時的なスナップショット機能がビューのタブ毎に4つまで保持できるように修正しました。
  • 閉じたパーツを選択した状態で[デフォルト設定値に戻す]を行うとパーツが展開してしまう不具合を修正しました。
  • モデル作成に関連するパラメータの英語・中国語を一部修正しました。
  • 検索と置換ダイアログで[キャンバスで選択]を実行時、パラメータパレットの更新が行われない不具合を修正しました。
  • [パラメータ複製]で複数選択されたパラメータがすべて複製されるように修正しました。
  • [パラメータ複製]で追加されるパラメータ名を、複製元と同じになるように修正しました。
  • ストロークでアートパスを作成する際、端点が閉じてしまうことがある不具合を修正しました。
  • ストロークによるメッシュ割り(β)実行中にメッシュ編集を完了した際、キャンバス上にパスの表示が残り続けてしまう不具合を修正しました。
  • ストロークによるメッシュ割り(β)ツールおよびストロークでアートパスを作成・編集する際のマウスカーソルを変更しました。
  • ストロークによるメッシュ割り(β)ツールで編集中に、別のツールに切り替えた際に編集内容をキャンセルするように修正しました。
  • ストロークによるメッシュ割り(β)ツールで編集中に、[削除]を実行することで編集内容を削除できるように修正しました。
  • ストロークによるメッシュ割り(β)ツールで[モデル用画像表示][アトラス表示]の際にパスが表示されない不具合を修正しました。
  • メッシュ編集時のツール詳細パレットのボタンのアイコンを一部変更しました。

アニメーション

《機能追加》

  • グラフエディタに[キーの名前を表示する]機能を追加しました。

《改善項目》

  • [Mac版]動画書き出し時、ダイアログやプログレスバーがウィンドウの背後に表示されることがある不具合を修正しました。
  • シャイ有効時に特定の条件下においてキーの移動ができなくなる不具合を修正しました。
  • タイムラインのプロパティを選択した際、稀に色が変わらない、異なる色になる不具合を修正しました。
  • 開始フレームが0以外の場合にグラフエディタのキー情報が表示されるウインドウの値がずれる不具合を修正しました。
  • FAで特定のオブジェクトを選択した状態でブラシ選択ツールを使用した際、ブラシのカーソルの円が点滅する不具合を修正しました。
  • FAにおいてストロークでアートパスを編集する際のマウスカーソルを変更しました。

Cubism Viewer

《機能追加》

  • [カーソル追従の設定]機能を追加しました。

 

 

4.1.00 beta1(2021/5/13)

本バージョンの新機能の詳細は下記ページをご参照ください。
新機能紹介 4.1(beta版)

共通

《機能追加》

  • オニオンスキンが正式版になりました。主に以下の機能を追加しました。
    ・ビューエリア下部にオニオンスキンON/OFFボタンを設置
    ・オニオンスキンの表示条件、対象などの細かい設定を追加
    ・オニオンスキンマーカー機能を追加
    ・オニオンスキンの描画位置をX/Y方向にずらすオフセット機能を追加
  • 保存や書き出し時に同名ファイルが存在する場合の命名方式を以下のように変更しました。
    ・画像/動画など:「保存名(X)」
    ・cmo3、can3など:「保存名_X」もしくは「保存名(X)」を選択可能
     メニュー→ファイル→設定に[別名保存時にファイル名末尾に(X)を付ける]の項目を追加

《改善項目》

  • macOS 10.12 (Sierra)のサポートを終了しました。
  • エディタを複数起動時に背景色の設定がお互いに影響する不具合を修正しました。

モデリング

《機能追加》

  • ツールパレットに[変形ブラシツール]を追加しました。
  • パラメータパレットに[パラメータ複製]を追加しました。
  • アートパスのツールに[ストロークでアートパスを作成/編集]機能を追加しました。
  • [選択状態を隠す]機能を追加しました。
  • 新規パーツ作成ダイアログに[選択オブジェクトを子に入れる]機能を追加しました。
  • ブラシ選択ツールでワープデフォーマを選択する際、グラデーションで面が塗られてわかりやすい見た目になるように修正しました。
  • テクスチャアトラス編集の自動レイアウトに[レイアウト対象][倍率][回転の許可の有無]の設定項目を追加しました。
  • 物理演算設定で出力先のパラメータが変更される際、
    同一物理演算グループ内で同一規則で変更可能な出力先パラメータに関してまとめて変更する機能を追加しました。

《改善項目》

  • ワークスペースを切り替える際にパーツパレットの検索状態がリセットされてしまう不具合を修正しました。
  • 投げ縄選択ツール、ブラシ選択ツール、変形パスツール、グルーツール、アートパスツール、回転デフォーマ作成ツールで
    Ctrlを押してパーツの操作をする時にバウンディングボックスが表示されない不具合を修正しました。
  • パラメータパレットのショートカットで次・前のキーに遷移するとき、瞬間的に不正な値になることがある不具合を修正しました。
  • パラメータ編集ダイアログを閉じた際に、パラメータがデフォルト値にリセットされる不具合を修正しました。
  • アートパスのコントロールポイントの不透明度・太さの変更ツールのブラシサイズについて、
    ブラシ選択ツールと同じになるように、表現の揺れを修正しました。
  • メッシュの手動編集中にESCで編集をキャンセルしようとすると頂点の追加ができなくなる不具合を修正しました。
  • ランダムポーズでまばたきを再生するように修正しました。
  • テクスチャアトラス編集でSpace+ドラッグで画面スクロールできない不具合を修正しました。
  • テクスチャアトラス編集で倍率や位置をテキスト入力で変更した際にUndoできない不具合を修正しました。
  • 下絵設定されたパーツがテクスチャアトラスに配置されていない場合に不要な警告が表示される不具合を修正しました。
  • 物理演算・シーンブレンド設定エディタのダイ��ログでマウスカーソルの見た目が適切に変化するように修正しました。
  • PSDのレイヤー名が32文字以上のとき途中までしか読み込まれない不具合を修正しました。
  • 階層が6以上あるのPSDを読み込んだときに階層構造が崩れる不具合を修正しました。
  • 中国語版のエディタで中国語のPSDを読み込むと文字化けする不具合を修正しました。
  • 同一頂点を複数のグルーで動かすモデルをmoc3書き出しした際にSDK上で表示が乱れる可能性がある不具合を修正しました。

アニメーション

《機能追加》

  • タイムラインの操作性やUIを大幅に改善しました。
    グラフエディタ:
    ・キーフレームやハンドルの操作性を改善
    ・より直感的なカーブの編集機能を追加
    ・スマートスナップ(値を丸める)機能を追加
    ・コピー&ペースト機能を追加
    ・Alt+Shiftでスマートスナップ機能の有効無効の切り替えを追加
    ドープシート:
    ・キーフレームや値の操作性を改善
    ・パラメータの入力精度を改善
    ・重いモデル編集時の操作性を改善
  • トラック���ソロ表示機能を追加しました。
  • 表示ボタンとロックボタンをドラッグで変更する機能を追加しました。
  • ファイルを収集する機能を追加しました。
  • シーンインポート機能を追加しました。
  • シーントラック機能を追加しました。
  • 静止画連番書き出しダイアログに[ファイル名設定]を追加しました。
    (静止画の連番数字の桁数およびスタート番号を自由に設定できます)
  • 静止画連番書き出しダイアログ[指定のフレームを出力]を追加しました。
    (出力するフレーム範囲を自由に設定できます)

《改善項目》

  • アニメーション作成後にモデルのパラメータIDを変更した際、モデルトラックのパラメータがおかしくなる場合がある不具合を修正しました。
  • シーンを跨いだトラックのコピー、貼り付けに関する不具合を修正しました。
  • 複数のトラックを跨いだ編集を実行後にUndoできない場合がある不具合を修正しました。
  • 複数の音声トラックを含むシーンをエディタ上で再生した際に、音声出力が遅延する不具合を修正しました。
  • グループトラック内の音声トラックが、グループトラックの範囲を超えて再生される不具合を修正しました。
  • 音声トラックを含むアニメーションを再生しながらインジケーターを動かした際に、音声が正しく再生されない不具合を修正しました。
  • 連番画像トラックで、連番画像のファイル名に大文字小文字の表記が異なるファイルが混入すると、描画がおかしくなる不具合を修正しました。
  • macOSで連番画像トラックが正常に表示されない不具合を修正しました。
  • ドープシートで、トラック、パーツ、プロパティグループを含んだ範囲選択が不正になる不具合を修正しました。
  • グラフエディタでシャイ状態のプロパティも表示されてしまう不具合を修正しました。
  • シャイの全解除時、連結したパラメータの下の段のシャイが解除されない不具合を修正しました。
  • プロパティの「倍率X/Y」の値を「0.0」に設定するとエラーが発生する不具合を修正しました。
  • FAのフォーム編集で、キーフォームのないフレームを選択した状態でアートメッシュの変形を行うと
    アートメッシュがデフォルトの形状に戻ってしまう不具合を修正しました。
  • トラックで読み込んでいるファイルがリンク切れ状態の場合にタイムラインパレットの操作などでエラーとなる不具合を修正しました。
  • 素材のリンク切れが発生しているトラックを含むシーンを複製した際にエラーとなる不具合を修正しました。
    当該シーンは複製できない旨を警告するダイアログが表示されるようになりました。
  • Cubism Editorで書き出したMOVファイルをAfter Effectsにインポートできない問題を修正しました。

Cubism Viewer

《機能追加》

  • Cubism SDK for Native、Cubism SDK for Webでベジェカーブの再現性が劣化した状態を再現した状態でモーションを再生する機能を追加しました。
    劣化する場合の差がカーブ曲線を画像で確認する機能で視覚的に確認できるようになりました。
  • モーションのベジェカーブの取り扱いタイプをインスペクタから確認できるようになりました。

 

 

4.0.09(2021/4/20)

モデリング

《改善項目》

  • 4.0.08で、グルー作成時にグルー名にアートメッシュ名を流用するように仕様変更しましたが、
    見切れが発生しやすい状態になっていたため、4.0.08 beta1以前と同じ仕様に戻しました。
  • 特定のモデルでキーフォーム編集ダイアログが正常に操作できない不具合を修正しました。
  • パラメータが未選択の状態でパラメータをShift+左クリックすると正常にパラメータを選択できない不具合を修正しました。

 

 

4.0.08(2021/3/18)

共通

《改善項目》

  • パラメータ名に「><」が含まれていると組み込みファイル書き出し後SDKで正しく読み込めない不具合を修正しました。

モデリング

《改善項目》

  • グルー作成時にパーツパレットが更新されない不具合を修正しました。
  • グルー作成時にグルー名にアートメッシュ名を流用するように仕様変更しました。
  • (※)特定のモデルでキーフォーム編集ダイアログが正常に操作できない不具合を修正しました。
  • (※)パラメータが未選択の状態でパラメータをShift+左クリックすると正常にパラメータを選択できない不具合を修正しました。

※これらは修正が完全でないことが確認されています。
バージョン4.1.00 beta1(5月中旬予定)および4.0.09(4月下旬予定)で修正される予定となっております。

Cubism Viewer

《機能追加》

  • パラメータの一覧でキーの位置が表示されるようなりました。

 

 

4.0.08 beta1(2021/2/15)

共通

《改善項目》

  • RADEON搭載の一部環境で描画の度に専用GPUメモリ使用量が増えていく不具合を修正しました。
  • macOS Big Surで一部のリンクが正常に開けない不具合を修正しました。

モデリング

《改善項目》

  • 回転デフォーマの親子構造を構築した際、親の回転と同じ値が直下の子に誤って設定されてしまう不具合を修正しました。
  • パラメータのキーにおける回転デフォーマの角度表示��、親の回転の影響を受けた値に変更されてしまう不具合を修正しました。
  • インスペクタでグルーの名前を変更した時、パーツパレット上の表示が更新されない不具合を修正しました。
  • インスペクタパレットのデフォーマ欄に、Rootにあるデフォーマが重複されて表示されることがある不具合を修正しました。
  • 拡張補間を設定した描画オブジェクトを複数選択した状態で「キーフォーム編集ダイアログ」からキーを削除すると、
    削除不可のキーを削除できてしまう不具合を修正しました。
  • 動きの反転で、適用するアートメッシュまたはデフォーマに紐付くパラメータのいずれかがデフォルト値でない時、
    正しく適用できないことがある不具合を修正しました。
  • モーション書き出し時に、書き出し対象を全てのパラメータに設定した時、仕様を説明するポップアップを表示するようにしました。
  • Cubism 2.1のモデルをインポートした際にポリゴンが抜けることがある不具合を修正しました。

 

 

4.0.07(2020/12/17)

共通

《機能追加》

  • macOS 11.0 Big Surに対応しました。
    ※Intel CPU搭載モデルのみ対応しました。Apple M1チップ搭載モデルは現在サポートしておりません。
    ※macOS 11.0 Big Surでは下記の制限事項があります。
     システムの言語設定が英語以外の場合でもメニューバーのMac標準のメニューが英語表記になる
    ※OSのアップデート前に、必ずCubism Editorのライセンス認証を解除してください。
     ヘルプサイト「Cubism EditorをインストールしているmacOSをアップグレードしたい

モデリング

《改善項目》

  • 特定の操作時にショートカットキーの「Delete」が使用できない不具合を修正しました。

Cubism Viewer

《改善項目》

  • Viewerでモーションを関連付けてmodel3.jsonを書き出す際、パス表記がOS依存のものになってしまう不具合を修正しました。
    4.0.07 beta1でmodel3.jsonを書き出した場合は本バージョンで書き出し直すことを推奨します。

 

 

4.0.07 beta1(2020/11/26)

共通

《機能追加》

  • ショートカット設定ダイアログで、重複するキー設定が存在する場合に警告を表示する機能を追加しました

《改善項目》

  • 動画チュートリアルのメニューの一部を修正しました。
  • cmox/canxファイルを開き編集後エディタを閉じる際に表示されるダイアログから保存した際に、
    不正な拡張子で上書きされてしまう不具合を修正しました。
  • ログパレットで、誤ってエラー扱いになっていたログの出力を抑制するように修正しました。
  • ショートカット設定ダイアログで、
    重複するキーを設定した際に既存の設定を削除するかの確認ダイアログを表示するように修正しました。

 

モデリング

《機能追加》

  • 物理演算設定ダイアログで、グループ設定エリアの元の場所に[複製]ボタンを復元しました。
  • 物理演算設定ダイアログで、出力設定の右クリックメニューに[グループを分離]機能を追加しました。
  • 物理演算設定ダイアログで、グループ設定エリアに演算の有効/無効を一時的に切り替えるチェックボックスを追加しました。
  • 物理演算設定ダイアログの振り子表示エリアで45°刻みの回転操作が行えるようになりました。
  • ワープデフォーマのリサイズ時に子要素(ワープデフォーマ、回転デフォーマ、アートメッシュ)のサイズおよび位置が見えるよう
    [ワープデフォーマリサイズ時の子要素を表示]機能を追加しました。
  • パーツパレットで選択したパーツ以下のオブジェクトやパーツを一括で表示/非表示およびロック/ロック解除できるようになりました。
  • パーツパレットで選択したパーツ以下のパーツを一括で展開/畳めるようになりました。

《改善項目》

  • パーツパレットおよびデフォーマパレットの[すべてを集約]を子階層も含めて畳めるように修正しました。
  • パーツパレットで、パーツを新規作成時に、選択していたパーツが展開してしまう不具合を修正しました。
  • パーツパレットのパーツ設定、パラメータパレットのパラメータ設定とグループ設定のUndo/Redoの挙動が不正になる不具合を修正しました。
  • パラメータパレットでパラメータの削除や作成等の後にUndo/Redoを行った際、表示位置がずれる不具合を修正しました。
  • 同一のパラメータに「リピート」と「まばたき・リップシンク」を同時に設定できないように制限を加えました。
    (同時に設定した場合に発生するエラー等の問題を防ぐための制限です)
  • インスペクタパレットで、IDやクリッピングを長く入力した場合にテキストボックスが見切れてしまう不具合を修正しました。
  • インスペクタパレットのデフォーマのプルダウンの並び順がデフォーマパレットの並び順と異なることがある不具合を修正しました。
  • インスペクタパレットで不透明度がキーフォーム上でなくても変更できてしまう不具合を修正しました。
  • インスペクタパレットのレイアウトを調整しました。
  • アニメーションビューで、アートパス上をクリックすることでアートメッシュと同様にモデルを選択できるように挙動を修正しました。
  • [Mac版]デフォーマパレットで階層を表現する線を表示するように修正しました。
  • マルチビュー状態でタブの削除や並び替えを行う際にエラーが発生する場合がある不具合を修正しました。
  • テクスチャアトラス編集でバウンディングボックスとテクスチャ表示がずれる不具合を一部修正しました。
  • 拡張補間の場合でもオニオンスキンの軌道が線形補間時の表示となってしまい一致しない不具合を修正しました。
  • ロックされたオブジェクトをキャンバス上から選択してロック解除する際、親階層のデフォーマのロックが解除される不具合を修正しました。
  • ロックされたオブジェクトとロックされていないオブジェクトを同時選択している状態で
    キャンバス上で編集できてしまう場合がある不具合を修正しました。
  • ロックされているアートメッシュのメッシュの手動編集が行えてしまう不具合を修正しました。
  • 回転デフォーマを回転させた際に、配下のパーツのオニオンスキンの軌道が一致しない不具合を修正しました。
  • キーフォームではない状態の回転デフォーマの子として回転デフォーマを作成する際にエラーになる不具合を修正しました。
  • 物理演算設定ダイアログで、入力の正規化欄に正しく値を入力できない不具合を修正しました。
  • グルーをコピーまたはパーツ書き出しする際、その対象のアートメッシュもコピーまたはパーツ書き出しの対象に含めるようにしました。
  • アートパスとアートメッシュを同時選択した際に、インスペクタパレットで描画順などの共通する項目を編集できるように修正しました。
  • 二つのアートメッシュに設定した変形パスの選択時にハイライトが不正になることがある不具合を修正しました。
  • 異なる変形パスを持つアートメッシュを複数選択した状態で、
    変形パスのコントロールポイントをドラッグした時にエラーになる不具合を修正しました。
  • 不透明度や描画順が不正状態となったキーフォームが自動的に修復されるように修正しました。修復内容はログに表示されます。
  • 変形パスの編集時にアートメッシュの変形がUndoできないことがある不具合を修正しました。
  • 変形パスのコントロールポイントを一点削除するとインスペクタの表示が更新されないことがある不具合を修正しました。
  • オブジェクトをドラッグで移動中にマウスホイールを操作すると不正な挙動になりUndoできなくなる不具合を修正しました。
  • モデルのオブジェクトの一括設定でCSVのエクスポート/インポートを行う際、
    オブジェクトやパラメータの名称に「,」(カンマ)が含まれているとエラーとなる不具合を修正しました。
  • moc3書き出し設定で、書き出し種別がnizimaのとき
    「モデル名」の末尾に半角スペースが含まれている場合に書き出しに失敗する不具合を修正しました。

 

アニメーション

《機能追加》

  • タイムラインパレットのマーカーをロックする機能を追加しました。
    ロック中はマーカーの追加・削除・ドラッグ操作での移動ができなくなります。
  • FA機能で、フォーム編集およびフォーム編集プロパティグループの削除機能を追加しました。

《改善項目》

  • FAビューで、オブジェクトの選択しか行っていないにもかかわらず未保存状態を意味する「*」が表示されてしまう不具合を修正しました。
  • FAビューを閉じた際に、タイムラインパレットの表示が崩れる不具合を修正しました。
  • FAビューで、デフォルトフォームがロックされた状態でワープデフォーマを操作した際に意図しない形状編集が実行される不具合を修正しました。
  • FAのタイムリマップ機能でUndo/Redoを実行時に不正な挙動になる不具合を修正しました。
  • FAビューで、Undoした際に描画順がインスペクタパレットとパーツパレットでずれが生じる不具合を修正しました。
  • FAビューで、オブジェクトの描画順がインスペクタパレットと描画順スライダーでずれが生じる不具合を修正しました。
  • FAビューで、アートメッシュの描画順を元の値より小さく設定できない不具合を修正しました。
  • FAビューで回転デフォーマを操作する際、特定の条件下で回転デフォーマの角度が不正な値になる不具合を修正しました。
  • モデルトラック複製時に、フォーム編集オブジェクトの並び順が変わってしまう不具合を修正しました。
  • タイムラインパレットで、トラックの座標やアンカーポイントの大きな値の表示が見切れる不具合を修正しました。
  • アニメーション再生時の連番画像トラックの描画を改善しました。
  • 特定の条件下で、「プロパティグループ上でシャイにしたプロパティの操作を有効化」設定がオフになっていても、
    シャイで非表示になっているパラメータのキーが移動してしまう不具合を修正しました。
  • タイムラインパレットのトラックに表示されるパラメータの値がパラメータ結合/解除時に正しく更新されない不具合を修正しました。
  • タイムラインパレットで[再生開始位置の固定]が有効になっている状態で
    「1キーフレーム進む/戻る」のショートカットが正しく動作しない不具合を修正しました。
  • タイムラインパレットで、「1キーフレーム進む/戻る」の操作が編集後のキーに対して不正な挙動になる不具合を修正しました。
  • 物理演算のアニメーションベイクを実行中のプログレスバーの表示を改善しました。また実行中にキャンセルが可能になりました。
  • 物理演算のアニメーションベイクの速度が向上しました。
  • 新規シーンの作成時、 アニメーションのデフォルトターゲットバージョンが「映像」「SDK(その他)」になっているとき、
    グラフエディタのベジェ操作に「SDK(Unity)」と同様の制限がかかってしまう不具合を修正しました。
  • 各種書き出し中にキャンセルを行った際の挙動が不正になる不具合を修正しました。
  • GIFアニメ書き出しでLive2Dロゴが最初のフレームに表示されるように修正しました。

 

Cubism Viewer

《機能追加》

  • moc3ファイルとは別のドライブにあるjsonファイルを読み込む際にコピーするかを確認するダイアログを表示するように変更しました。

《改善項目》

  • moc3ファイルとは別のドライブにあるjsonファイルを読み込む際にエラーを表示するように修正しました。
  • 統計情報で表示される総ポリゴン数が、Cubism Editorのモデルの統計情報と違う不具合を修正しました。

 

 

4.0.06(2020/10/22)

Cubism Viewer

《改善項目》

  • Macで[マウスを追いかける]機能が動作しないことがある不具合を修正しました。
  • 前回起動時のウィンドウのレ��アウト設定などが復元されない不具合を修正しました。

 

 

4.0.06 beta1(2020/09/23)

共通

《改善項目》

  • ファイルの保存や動画などの各種書き出し時、
    実行中のユーザーが書き込み権限を持たないフォルダを指定した際にエラーが発生する不具合を修正しました。
  • 特定の操作時にマウスカーソルが大きく動いてしまうことがある不具合を修正しました。
  • 特定の状況下でドラッグによる数値入力の挙動が不正になる不具合を修正しました。
  • [Mac版]Cubism Editorにアクセシビリティへのアクセスを許可していない場合に許可を促すダイアログを表示するように変更しました。

 

モデリング

《改善項目》

  • モデルファイル読み込み時などに、キーフォームの不正な数値の不透明度情報をログに表すように修正しました。
  • 拡張補間を適用したワープデフォーマの変換の分割数が、正常時に挙動が不正になる不具合を修正しました。
  • パラメータのキーとキーの間を選択時、回転デフォーマの角度の値が「0.0」と表示されてしまう不具合を修正しました。

 

アニメーション

《機能追加》

  • 音声トラック数を無制限に配置できるように制限を解除しました。

《改善項目》

  • Windowsで作成したアニメーションファイルをMacで開くと素材のリンクが切れてしまう不具合を修正しました。
  • canxファイルの読み込み時エラーが出て失敗する不具合を修正しました。
  • タイムラインパレットでLive2Dパラメータに小数点以下の値を設定する際、
    グラフエディタでキーを操作して編集した場合と値を直接入力して編集した場合で挙動が異なる不具合を修正しました。
  • シーンを削除した際にシーンパレットの選択状態とシーンの表示状態が不正になる不具合を修正しました。
  • シーンパレットから選択してシーンを切り替える際に挙動が重い不具合を修正しました。
  • 動画や静止画(連番)、モーションファイルの書き出し時の上書き確認ダイアログの表示回数を適切に修正しました。
  • フリー版エディタの特定の条件下で動画書き出しが失敗する不具合を修正しました。
  • シーンにフェード値を設定した際、小数点以下が不正な数値でモーションファイルが書き出されてしまう不具合を修正しました。

 

Cubism Viewer

《改善項目》

  • 表情のパラメータ編集および加算/乗算モードの切り替えを行う際、小数点以下が不正な数値になってしまう不具合を修正しました。
  • 不正な数値の不透明度のパラメータがあるときにモデルの表示が消えてしまう不具合を修正しました。
  • 不正な数値の不透明度のアートメッシュを検出した場合に確認ダイアログを表示するように修正しました。

 

4.0.05(2020/08/27)

共通

《改善項目》

  • Windowsで特定の条件下でインストール時にcmo3・can3が開けない不具合を修正しました。
    ※4.0.04 beta1以降のバージョンで当不具合が発生している場合は
    Cubism Editorの設定ファイルを削除してから再インストールすることで改善できます。
    ヘルプサイトにて詳しい手順をご案内しておりますので、こちらのページをご参照ください。
    ヘルプサイト「.cmo3 や .can3 ファイルが開けない」

  • ログパレットのコピーボタンからコピーしたログに改行が多く含まれてしまう不具合を修正しました。
  • モデルおよびアニメーションファイル読み込み時のビューエリアの表示倍率が適切でないことがある不具合を修正しました。

 

モデリング

《改善項目》

  • インスペクタで描画順を数値入力で変更したとき、パーツパレットの描画順が更新されないことがある不具合を修正しました。

 

4.0.05 beta1(2020/07/30)

共通

《機能追加》

  • ビューエリアの操作に以下を追加しました。
     Rキー→キャンバスを反転
     Rキー+Shift+ドラッグ→キャンバスをグリッドで回転
     Rキー/Eキー/Wキー+ダブルクリック→回転および3D表示をリセット
  • ワープデフォーマのグリッドの色を変更する機能を追加しました。
  • [次回から表示しない]にチェックを入れたダイアログを再表示できる
    [非表示設定にした全てのダイアログを再表示]機能を追加しました。
  • ログパレットにクリアなどの機能を追加しました。

《改善項目》

  • キーボードショートカット設定ダイアログでキャンセルボタンを押下しても編集内容が反映されてしまう不具合を修正しました。
  • キーボードショートカット設定ダイアログでショートカットを削除しても
    エディタを再起動するまで反映されない不具合を修正しました。
  • キーボードショートカットに一部のキーを設定した際にメニューバー上の表示が崩れる不具合を修正しました。
  • キーボードショートカットでテンキーの「+」を登録した際に動作しない不具合を修正しました。
  • プロジェクトパレットにフォーカスした状態でコピー・切り取り・貼り付け操作をするとエラーが出る不具合を修正しました。
  • 数値入力が操作不可の欄にカーソルをのせると、カーソルが操作可能のような見た目に変わってしまう不具合を修正しました。
  • FAでスナップショット機能を使用した際にパラメータが正しく反映されない不具合を修正しました。
  • ビューエリアのEキーによるキャンバスの3D表示時、真上および真下に向けるとエラーが出る不具合を修正しました。
  • ビューエリア右下のヒントが重なって表示されてしまう不具合を修正しました。
  • アニメーションファイルのインポート時に素材の置き換えをキャンセルするとエラーが出る不具合を修正しました。
  • アニメーションファイルのインポート時に素材の置き換えダイアログを✕ボタンで閉じるとエラーが出る不具合を修正しました。
  • テクスチャのインポート時、Editor左下のステータス表示にロード中のテクスチャ名を表示するようにしました。
  • ワープデフォーマを極端に変形時、選択した頂点以外が動いてしまう不具合を修正しました。
  • ワープデフォーマを折り曲げて変形時、
    ベジェのコントロールポイントを変形させる際に分割点のグリッドの挙動が不正になる不具合を修正しました。
  • ワープデフォーマの不透明度の数値をドラッグで入力すると値がずれる不具合を修正しました。
  • オブジェクトの不透明度を0に変更しても反映されないことがある不具合を修正しました。
  • オニオンスキン設定を変更した際に、入力値が正常に適用されない不具合を修正しました。
  • オニオンスキン設定ダイアログの項目をUndo/Redoできるように修正しました。
  • 物理演算・シーンブレンド設定において、振り子の長さが表示の際に整数に丸められる不具合を修正しました。
  • ファイルの保存や動画などの各種書き出し時、
    ファイル名にOSで禁止されている文字列が含まれているとエラーが出る不具合を修正しました。
  • 操作を可視化機能で、一部のショートカットキーが正しく表示されない不具合を修正しました。

モデリング

《機能追加》

  • 物理演算・シーンブレンド設定ダイアログにモデルの動きを録画する機能を追加しました。
  • 検索と置換に[大文字小文字の区別]ボタンを追加しました。
  • 検索と置換に[すべて選択 解除]ボタンを追加しました。
  • テクスチャアトラス編集画面で配置済みの画像にマウスオーバーした際に名称をツールチップ表示する機能を追加しました。
  • マスクのアートメッシュが削除されたことでクリッピングのアートメッシュのインスペクタのクリッピング欄が「null」になった際に、
    警告を表示するように修正しました。
  • ペンタブの筆圧でブラシ選択ツールとグルーツールの重みを調整できるように修正しました。

《改善項目》

  • 検索と置換ダイアログの[キャンバスで選択]機能を高速化しました。
  • 検索と置換ダイアログで、置換時に選択状態が解除されないように修正しました。
  • 原画削除後にテクスチャアトラス編集ダイアログを開くとエラーが出る不具合を修正しました。
  • 物理演算設定がモデルワークスペース上でもUndoできるように修正しました。
  • パーツ設定ダイアログ内のヒントの[ここをクリックでIDのルールを表示]を[IDのルールを表示]ボタンに変更しました。
  • モデリングメニュー → 編集レベルの表示が実際の値と一致しなくなる不具合を修正しました���
  • 「形状のコピー]を実施せずに[形状の貼り付け][形状のブレンド]を行った際に、警告が表示されるように修正しました。 
    (コピーの挙動そのものに変更はありません)
  • [形状のコピー]を実施した対象とは異なるオブジェクトに対して[形状の貼り付け][形状のブレンド]を行った際に、
    警告が表示されるように修正しました。 (コピーの挙動そのものに変更はありません)
  • パラメータパレットのマウスクリックの挙動を修正しました。
  • パラメータフォルダをダブルクリックして名称を変更する際、テキスト入力欄にフォーカスされない不具合を修正しました。
  • パラメータが削除された際に、Undo可能な形で物理演算の入力、出力の項目が削除されるようになりました。
  • メッシュ編集モードのキャンセル/完了ボタンの配置をOS基準に修正しました。 
    また、メッシュ編集をキャンセルする際に確認ダイアログを表示するように修正しました。
  • メッシュ編集モードの選択・編集ツールでエッジが生成される不具合を修正しました。
  • メッシュ編集モードのツール詳細パレット内の[バインド]ボタンが正しく表示されるように修正しました。
  • 変形パスの[コントロールポイントの削除]ツールでコントロールポイントを削除時に、
    変形パスの情報が正しく削除されない不具合を修正しました。
  • ツール詳細のカラーピッカーのボタンの背景色に不透明(市松模様)を表示するように修正しました。

アニメーション

《機能追加》

  • シーンの設定項目に[フレーム数]を追加しました。
    フレームの始まりを[0から開始][1から開始]から選択できます。(初期値は[0から開始])
  • タイムラインパレット内のワークエリアが横幅いっぱいに表示されるように拡大縮小率を調整する機能を追加しました。
    アニメーションメニュー → インジケーター →[ワークエリアの全体表示]もしくは「Shift + F」のショートカットキーを使用します。
  • アニメーションテンプレートの作成時、既に同じ名前のものがある場合は上書き保存を選択できるようになりました。
  • アニメーションファイルを開いた際に素材がリンク切れにならないよう修正しました。
    (アニメーションファイルを保存後に素材との相対パスが変更されていない場合)

《改善項目》

  • タイムラインパレットで、パラメータ等の値をドラッグで変更するとUndoが複数回登録される不具合を修正しました。
  • タイムラインパレットで、パラメータの値をキーボード入力するとUndoが2回登録される不具合を修正しました。
  • タイムラインパレットで、トラックを追加時に不正な挙動になる不具合を修正しました。
  • タイムラインパレットで、下に連結する相手がいないパラメータの連結を行おうとした際にエラーが出る不具合を修正しました。
  • タイムラインパレットで、高負荷時にキーを移動するとキーが増えることがある不具合を修正しました。
  • トラックの表示/非表示を切り替える操作をUndoできるように修正しました。
  • シーンのフレームレートを低い値に設定した際に発生する表示や挙動の不具合を修正しました。
  • シーン切り替え時のビューエリアの視点が適切でない不具合を修正しました。
  • シーンの長さが実際より1少なく表示される不具合を修正しました。
  • シーンの開始位置を100以上に設定出来るように修正しました。
  • 長いシーンのポジションなど、操作時にエラーが出る不具合を修正しました。
  • 長いシーンのタイムラインの拡縮表示をAlt+マウスホイールで行うとエラーが出る不具合を修正しました。
  • 新規作成したアニメーションファイルを選択している際に
    エディタのタイトルバーに実際と異なるファイル名が表示される不具合を修正しました。
  • 保存、インポート時のダイアログの名称が適切でないことがある不具合を修正しました。
  • アニメーションファイルインポート時のターゲットバージョン選択ダイアログで、
    OKを押さずに閉じた場合にはファイルを開かずに処理を終了するように修正しました。
  • [Mac版]アニメーションテンプレートが名前順に並ばない不具合を修正しました。
  • シーンの開始位置を0以外に設定時、静止画連番書き出し完了時に書き出し先ディレクトリが開かない不具合を修正しました。
  • 音声ファイルのトラックを複製した際、トラックの長さが初��値に戻ってしまう不具合を修正しました。
  • 音声ありでの動画書き出し時に書き出し範囲内にリンク切れの音声トラックが含まれている場合は、
    リンク切れの音声トラックがある旨のダイアログを表示して動画書き出し処理をキャンセルするように修正しました。
  • 音声ありでの動画書き出し時、複数の音声トラックがある場合に正常に音声が出力されない不具合を修正しました。
  • 動画書き出しで、非圧縮の場合は解像度をチェックしないように修正しました。
  • 動画書き出し(MOV)時のビデオコーデックをQuickTimeRLEに変更しました。
  • 動画書き出し(MP4)でYUV変換時の色空間を指定できるように修正しました。
  • 動画書き出し(MP4)でビットレートを指定できるように修正しました。
  • フリー版の動画書き出しでLive2Dロゴを非表示に設定できるように修正しました。

Cubism Viewer

《機能追加》

  • 表情やモーションのフェード時間を一括で変換する機能を追加しました。

《改善項目》

  • 表情やモーションを切り替える際、パラメータの値が同じパーツが一部動いてしまうことがある不具合を修正しました。

 

 

4.0.04(2020/07/30)

共通

《改善項目》

  • 特定のmacOS環境で、初回のトライアル開始にもかかわらず期限切れとなる不具合を修正しました。
    当該の問題でお困りの場合は、本バージョンにアップデートしてトライアル開始して下さい。

モデリング

《機能追加》

  • AEプラグイン向けにパラメータ結合状態を.cdi3.jsonに保存する機能に不具合があり修正しました。
    Editor上部メニューのファイル>組込みファイル書き出し>moc3ファイル書き出し
    から「表示補助ファイル(cdi3.json)書き出す」にチェックを入れると書き出されます。

 

 

4.0.04 beta1(2020/07/09)

共通

《改善項目》

  • FAの編集が適用されないことがある不具合を修正しました。
  • パラメータパレットで、フォルダとパラメータを選択した状態で別のフォルダにドラッグアンドドロップすると
    フォルダの中にフォルダが入ってしまう不具合を修正しました。
  • [Mac]「CECubismAppを終了」を選択もしくはCmd+Qを押してEditorを終了する際、
    未保存のドキュメントがあれば確認ダイアログを表示するように修正しました。

モデリング

《機能追加》

  • パラメータパレット上でShift+左クリックで複数選択が可能になりました。

《改善項目》

  • パラメータパレットで、フォルダとその子要素のパラメータを同時選択状態で
    ゴミ箱アイコンから削除しようとするとエラーになる不具合を修正しました。
  • パラメータパレットのキーの色が不正な表示になることがある不具合を修正しました。
  • 描画順グループを設定したパーツを選択し、パラメータのスライダ上のキーフォームのない場所を選択している状態のとき、
    パーツの描画順スライダの表示色がグレーに変更されない不具合を修正しました。
  • アートパスツールでアートパスを編集する際に表示されるマウスカーソルのアイコンの表示を修正しました。
  • アートパスのコントロールポイントの結合を行った際に、正しく結合されないことがある不具合を修正しました。
  • アートパスのブラシ切り替え直後に、キャンバスの表示が崩れてしまう不具合を修正しました。
  • 不正値が入ったオブジェクト選択時にキャンバスの表示が消えてしまう不具合を修正しました。
  • 一部のボタンをクリックしてもポップアップが表示されない不具合を修正しました。
  • カラーコード入力ボックスで、何も入力せずエンターを押すとエラーが出る不具合を修正しました。
  • 形状のブレンド設定ダイアログが何も選択していない状態で開けてしまう不具合を修正しました。
  • 物理演算グループのリスト表示、処理順序の入れ替えができるように修正しました。
  • 物理演算・シーンブレンド設定でパラメータの名前がツールチップで表示されるように修正しました。
  • 新規作成されたモデルで物理演算・シーンブレンド設定でのカーソル追従で、
    追従パラメータの初期化に失敗していた不具合を修正しました。
  • 物理演算・シーンブレンド設定でカーソル追従の設定を開いた際に初期状態に戻ってしまうことがある不具合を修正しました。
  • 物理演算・シーンブレンド設定で振り子表示部分のマウスホイール操作がビューなどの操作と逆になる不具合を修正しました。
  • moc3書き出しダイアログのUIを改善しました。
  • 書き出し種別がnizimaの場合のテクスチャフォルダの名称を「textures」に変更しました。

アニメーション

《機能追加》

  • アニメーションプレビュー設定ダイアログ内に「フォーム編集の対象を前面に表示する」を追加しました。
    オン(デフォルト値)のときはフォーム編集の対象オブジェクトを最も手前に描画し、
    オフにするとアニメーションビューにおける描画順と同様に描画します。
  • アニメーション再生時の負荷を軽減する「軽量再生」モードを追加しました。

《改善項目》

  • タイムライン上でマウスドラッグによる範囲選択の際、選択範囲を示す矩形が正しく表示されない不具合を修正しまし���。
  • タイムラインのEnterキーでの再生停止に時間差が生じる不具合を修正しました。
  • FAビューでアニメーションのショートカットが使えるように修正しました。
  • 再生速度を変更してアニメーションを再生した際に、音声トラックの再生速度も連動して変わるように修正しました。

Cubism Viewer

《改善項目》

  • .model3.jsonファイルのExpressionsのNameにファイル名以外も指定できるように修正しました。
    (半角英数字記号以外も可)

Cubism AEプラグイン

《機能追加》

  • パラメータパレットのパラメータ結合情報をcdi3.jsonに書き出す機能を実装しました。

 

 

4.0.03(2019/12/12)

共通

《改善項目》

  • Editor起動時に[Live2Dからのお知らせ]ダイアログが表示されるようになりました。

モデリング

《改善項目》

  • メッシュ編集モードで表示モード���変更したときにメッシュの状態が更新されないことがある不具合を修正しました。
  • 物理演算設定ダイアログで影響度を下げた設定で視線の追従をしない状態のときに正しく計算されない不具合を修正しました。
  • 物理演算設定ダイアログで物理演算が設定されているパラメータを操作すると表示がちらつく不具合を修正しました。
  • 統計情報でクリッピングマスクに関する情報を追加しました。
  • マスクの形状数が一定数を超えるmoc3出力を行う場合、警告ダイアログが表示されるように修正しました。
  • 曲面デフォーマ作成ダイアログで挿入先のパーツを変更したときのデフォルト名称を[〇〇のワープ]から[〇〇の曲面]へ変更しました。
  • 動きの反転ダイアログの設定状態について、OKボタンを押していない場合も保存されるように修正しました。
  • 動きの反転ダイアログをデフォーマのみ選択状態で開いた際に、
    軸設定が不正な選択になってしまいOKを押せないことがある不具合を修正しました。
  • まばたき・リップシンク設定ダイアログのパラメータフォルダ内のパラメータが二重に表示される不具合を修正しました。
  • アートパスのコントロールポイントをすべて消すと、空のアートパスが残ることがある不具合を修正しました。
  • アートパス関係のGUIを改善しました。
    ・詳細パレット、ブラシ設定ダイアログ内に各機能へアクセスしやすいようにボタンを配置
  • アートパスの線幅取得設定の[線のみのテクスチャ]の初期値を下記のように変更しました。
    ・線と見なす最大値が5px
    ・透明と見なす最小値が0%
  • アートパスツールのショートカットキーに対応しました。

アニメーション

《改善項目》

  • アニメーションビュー上で連番画像トラックを選択できるように修正しました。
  • タイムライン内でプロパティグループをクリックした際に、プロパティグループが選択状態になるように変更しました。
  • タイムライン内で新規グループの作成ボタンを連続でクリックした際に、複数のダイアログが表示される不具合を修正しました。
  • タイムライン内でトラックやプロパティグループの開閉マーク、シーンを切り替えたり更新した際に、
    トラックが開いていても閉じた状態のマークになってしまう不具合を修正しました。
  • タイムライン内でキー選択時の挙動が不正になる不具合を修正しました。
  • タイムライン内で、グループを複製すると中のプロパティが倍増してしまう不具合を修正しました。
  • タイムライン内で、キーフレーム追加、削除時のカーソル表示の不具合を修正しました。
  • タイムライン内で選択範囲内のキーを移動するとき、
    カーソルアイコンが変化する範囲と、実際にキーを選択できる範囲が異なる不具合を修正しました。
  • ロックされたトラックをグラフエディタで編集できてしまう不具合を修正しました。
  • GIFアニメ書き出し、および静止画(連番)書き出しのデフォルトファイル名を、シーン名と合わせるように修正しました。
  • 静止画(連番)書き出しの[選択中の1フレームを書き出し]で保存するファイル名を任意に変更した際、
    入力したファイル名の通りに保存するよう修正しました。
  • 静止画(連番)書き出しの[ワークエリアを出力]を実行した際、
    シーン全体のフレーム数が4桁である場合は、保存するファイル名に付与する連番も4桁とするよう修正しました。
  • 同名トラックをモーションファイル書き出しで書き出した際に、すべて同じモーションデータになってしまう不具合を修正しました。
  • パラメータの結合・結合解除時に、パラメータの表示が不正になる不具合を修正しました。
  • Ctrl+クリックで、トラックやパラメータフォルダ等に一括でキーを打つ/削除を行おうとした際、
    実行されずにトラックが開閉してしまう不具合を修正しました。
  • アニメーションビューのパーツの表示状態が、モデリングビューのパーツの表示状態に同期されるように修正しました。
  • FA編集にて、フォーム編集プロパティのキーフレームで[キーフレームを選択行にペースト]を実行時に
    通常のパラメータにペーストできてしまう不具合を修正しました。
  • FA編集にてキーフレームを生成した際、削除したキーフォームが復元されてしまう不具合を修正しました。
  • FA編集にて、調整モード1・2でそれぞれフォーム編集を行うと、
    調整モード2でバウンディングボックスの表示位置がずれる不具合を修正しました。
  • FA編集で変形パスを操作した際に、形状がリセットされてしまう不具合を修正しました。
  • 物理演算のアニメーションベイクを影響度を下げた設定で行った場合、物理演算設定エディタとの挙動と異なる問題を修正しました。
  • ショートカットキーの不具合を修正しました。

Cubism Viewer

《改善項目》

  • model3.jsonで指定されたcdi3.jsonのファイルパスが見つからないときに、モデルが正しく開けない不具合を修正しました。

 

 

4.0.02(2019/10/15)

共通

《改善項目》

  • macOS 10.15 Catalinaでエディターのインストールに失敗する不具合を修正しました。

アニメーション

《改善項目》

  • macOS 10.15 Catalinaで動画の書き出しが出来ない不具合を修正しました。

 

4.0.01(2019/10/03)

モデリング

《改善項目》

  • 矢印選択ツール・投げ縄選択ツールによる処理に関するUndo/Redoの不具合を修正しました。
  • パラメータの絞り込みを行った際に、キーがハイライトされないことがある不具合を修正しました。
  • 各種ダイアログ内のテーブルの幅をドラッグで調整する際の挙動を統一しました。
  • パーツパレットで、フィルターを未入力の状態で有効にした際、
    空のフォルダが非表示になる不具合を修正しました。
  • デフォーマの不透明度がインスペクタに反映されない不具合を修正しました。
  • デフォーマパレットでデフォーマを選択した状態で[すべてを展開]を実行した際、
    選択状態が更新されない不具合を修正しました。
  • アートパスの線幅・不透明度のブラシ調整の初期値を調整しました。
  • アートパスのブラシ設定を書き出す時に、ファイル名のデフォルトをブラシ名に変更しました。
  • アートパスのツールを使用時に、Ctrlを押下すると矢印ツールになる機能に対応しました。
  • アートパスのコントロールポイントを削除したとき、インスペクタパレットの表示が消えてしまう不具合を修正しました。
  • マウスの矩形選択で非表示のアートパスが選択出来る不具合を修正しました。
  • アートパスのツール詳細のデフォルトブラシのUIからブラシ設定ダイアログが開けるようにボタンを追加しました。
  • アートパスの自動生成ダイアログのデフォルトの表示位置をエディタの中心に変更しました。
  • アートパスのブラシの設定ダイアログを✕ボタンで閉じた時、インスペクタが更新されるように処理を修正しました。
  • アートパスの接続時に✕ボタンを押しても実行される不具合を修正しました。
  • アートパスのコントロールポイントのGUIが見えづらくなることがある不具合を修正しました。
  • アートパスの選択時、ハイライトの表示を改善しました。
  • 四隅の自動生成時に値が正しくセットできないことがある不具合を修正しました。
    四隅の自動生成時にインスペクタの表示が消える不具合を修正しました。

アニメーション

《改善項目》

  • プロジェクトパレットのデータの差し替え機能で、連番画像フォルダの差し替えができない不具合を修正しました。
  • FAモードで、Ctrl+ドラッグでデフォーマの構造が変更されないよう機能を制限しました。
  • FREE版でコマ打ちを使用していなくても
    「任意のコマ打ちはPRO版の機能です」ダイアログが表示され各数値を変更できない不具合を修正しました。

 

4.0.00(2019/9/4)

共通

《機能追加》

  • フォームアニメーションのワークスペースを追加しました。
  • オニオンスキン(β)機能を実装しました。
    キーフレームやキーフォームの前後の状態が半透明で表示され、動きの遷移を確認することができます。
  • Live2D公式のLive2Dモデル&イラスト素材マーケット「nizima (にじま)」へのリンクボタンを
    エディタ右上部に設置しました。(日本語版のみ)

《Cubism4から廃止になった機能》

  • Cubism4リリースに伴い、下記の2.1形式データの書き出し機能を廃止しました。
     ・メニューの「ファイ���]→[2.1用モデルデータ(cmox)として保存」
     ・メニューの[ファイル]→[組み込み用ファイル書き出し]→[mocファイル書き出し(2.1用) ]
     ・メニューの「ファイル]→[組み込み用ファイル書き出し]→
      [モーションファイル書き出し]から開くダイアログ内の項目[2.1形式(mtn)として書き出し]

《Cubism3からの変更点》

  • パレットの配置やショートカットなどのエディターの設定はCubism4とCubism3で別々に保存されるようになりました。
    Cubism4の初回起動時にCubism3の設定が自動で引き継がれます。

モデリング

《機能追加》

  • マスクの反転機能を実装しました。
    従来のクリッピングマスクを描画時に反転して適用することができます。
    これによりマスクで隠すなどの表現が可能になりました。
  • 拡張補間機能を実装しました。
    キーフォーム間を曲線的に補間することで、回転などで自然な表現が可能になりました。
  • アートパス機能を実装しました。
    モデルに配置したコントロールポイントと設定したブラシ情報を元に線を描画することができる、映像用途の機能です。
    原画の線の質感や表現を活かしたまま、より直感的な線の操作・表現が可能になりました。
  • Cubism Viewer がcdi3.jsonに対応しました。
    モデル書き出し時にcdi3.jsonを書き出すにチェックを入れて書き出したモデルは、
    Cubism Viewer上でパラメータ名、パーツ名が表示されるようになります。

《改善項目》

  • [まばたき・リップシンク設定]ダイアログの項目の並び順が、
    パラメータパレットの項目の並び順と同期されない不具合を修正しました。
  • ブラシ選択ツールおよびグルーツールのブラシサイズが、ツール詳細パレットの値から想定されるサイズに対して、半径比2倍(面積比4倍)の大きさとなる不具合を修正しました。
    ツール詳細パレットの値から想定されるサイズに対して、半径比2倍(面積比4倍)の大きさとなる不具合を修正しました。
  • メッシュ編集モードにおいて、矢印キーによる頂点の移動ができない不具合を修正しました。
  • 物理演算設定の書き出し時にIDが重複する不具合を修正しました。
  • 物理演算・シーンブレンド設定の表示拡大時に表示品質の低下を軽減しました。
  • 複数選択しているときに値の違うワープデフォーマの変換の分割数、ベジェの分割数、アートメッシュの描画順、
    クリッピング、ユーザーデータに対して意図しない編集を検出した場合、確認ダイアログを表示するように修正しました。
  • 背景色のスポイトツールのカーソルの表示位置がずれる不具合を修正しました。
  • 特定の操作を行った際に、矢印ツールで操作できない変形パスが生成される不具合を修正しました。
  • ターゲットバージョン選択ダイアログ経由で、[デフォーマ変換(3.2方式)]が更新された際に
    インスペクタパレットの表示が更新されない不具合を修正しました。
  • インスペクタパレット上で[デフォーマ変換(3.2方式)]のUndo/Redoができない不具合を修正しました。
  • プロジェクトパレットで別の原画にレイヤーを移動させた際に未使用と認識される不具合を修正しました。

アニメーション

《機能追加》

  • アニメーションの用途に応じたターゲットバージョンの設定を追加しました。
    シーンの新規作成時、デフォルトのターゲットバージョンを設定することが可能です。
    プロジェクトパレットの[アニメーションデータ]をクリック → インスペクタパレットの[ターゲットバージョン設定]から
    再設定を行うことも可能です。
  • 連番画像トラック機能を実装しました。
    連番で書き出した画像を専用のトラックに一括配置できます。
    配置した連番画像はタイムリマップ機能を使用してグラフエディタ上で表示タイミングを調整することができます。
  • コマ打ち機能を実装しました。
    リミテッドアニメーションのように切れのある動きを再現することが可能となります。
  • フォームアニメーション機能(映像用途)を実装しました。
    パラメータを編集せずにAnimatorのタイムライン上でモデルデータの形状を直接編集できる映像制作に便利な機能です。

《改善項目》

  • 連番画像/動画を出力で「すべてを出力」すると、1フレーム不足する不具合を修正しました。

Cubism Viewer

  • [表示]メニューの[ミップマップを有効にする]が正常に機能しない不具合を修正しました。
  • マスクの反転機能に対応しました。

 

 

Cubism 3シリーズの更新履歴

Cubism 3シリーズの更新履歴はこちらです

© 2010 - 2021 Live2D Inc.