更新历史记录

* Cubism 4系列的更新历史记录如下。

Cubsim 4 更新历史记录

您还可以在此处下载最新的Cubism Editor。

3.3.03(2019/04/26)

Modeler

《改善项目》

  • 修复了当“变更”参数时未与所选物体中的参数相关联时无法执行“变更”的问题。
  • 修复了在某些处理十进制数的UI中,从键盘输入值时可能无法应用该值的问题。

3.3.02(2019/04/23)

Modeler

《功能追加》

  • 在moc3输出中追加了显示辅助文件输出(cdi3.json)。
    * After Effects插件用途
  • 追加了设置参数文件夹颜色和重置颜色的功能。

《改善项目》

  • 修复了物理模拟设置中存在同名参数时无法设置输入/输出的问题。
  • 修复了物理模拟设置无法在某些Editor中打开的问题。
  • 修复了经常阻止单击Editor左上角的目标版本组合框的问题。
  • 修复了在画布上选择图形网格后立即按右键进入网格编辑模式的问题。
  • 修复画布的绘制顺序变更滑块、选择部件时,修复了变更子级物体的绘制顺序时,无法Undo子级物体绘制顺序的问题。
  • 修复了在显示创建变形器对话框的状态下关闭选项卡时发生异常的问题。
  • 修复了双击参数时对话框闪烁的问题。
  • 修复了在创建参数文件夹时将新文件夹追加到参数面板顶部的问题。
  • 修复了由于检查器的输入状态和参数面板上的右键吸附处理时间不匹配而执行意外编辑的问题。
  • 修复了在按住Ctrl的同时调整旋转变形器大小时倍率会改变的问题。
  • 修复了即使在锁定默认形状的情况下按下Ctrl也无法移动旋转变形器位置的问题。
  • 修复了在不影响物体的情况下使用Ctrl + 拖动变换弯曲变形器时,如果先释放Ctrl则动作不正确的问题。
  • 修复了在锁定默认形状的情况下尝试通过拖动表面变形器进行移动时仅手柄移动的问题。
  • 修复了在多个表面变形器分层时按住Ctrl调整父变形器大小时,子变形器的手柄会移动到不正确位置的问题。
  • 修复了物理模拟设置无法在某些Editor中打开的问题。

Animator

《功能追加》

  • 追加了允许在模型更新时变更轨道名称的设置。

《改善项目》

  • 修复了删除组轨道时内部源没有被删除的问题。
  • 修复了如果在时间线面板上通过键盘输入并通过数值变更后Enter键进行更新时,不按两次Undo无法恢复的问题。
  • 修复了在没有音轨的场景中选择AAC(带“嘟”音)的视频输出失败的问题。

3.3.01(2019/02/25)

通用

《改善项目》

  • 修复了在Editor开启时重新打开文件时,根据条件持续保持模型参考的问题。

Modeler

《功能追加》

  • 更新了查找和替换对话框UI。
  • 实装了参数文件夹的颜色区分设置。
    * 右键单击参数组 ⇒ 设置组的颜色(设置的颜色应用在时间线上)

《改善项目》

  • 修复了在Mac版上单击无法打开部件/变形器面板的展开图标的问题。
  • 修复了Mac版中子级对话框隐藏在后面的问题。
  • 修复了Mac版中无法调整物理模拟/场景混合视窗大小的问题。
  • 修复了Mac版参数面板中显示参数值的文本区域太小无法完整显示的问题。
  • 修复了Mac版中右键单击视图并按原样移动时上下文菜单反复显示和隐藏的问题。
  • 修复了Mac版菜单中不显示快捷键的问题。
  • 修复了Mac版快捷键设置中无法登录Command键的问题。
  • 修复了文件菜单中输出快捷键显示破损的问题。
  • 修复了设置快捷键时输入符号时显示破损的问题。
  • 修复了在部件面板中选择多个物体并通过拖动重新排列它们时,顺序可能出现上下颠倒的问题。
  • 修复了使用Ctrl + Delete删除部件文件夹时,部件被删除而不显示各种警告的问题。
  • 修复使通过“折叠该变形器以下内容”让孙级结构以下也关闭。
  • 修复使在检查器弹框中操作绘制顺序时,实时应用在部件面板显示中。
  • 调整了检查器中绘制顺序和顶点信息显示框的宽。
  • 修复使输出moc3文件时,部件显示顺序与部件面板匹配。
  • 修复了在关键点编辑对话框中编辑结合参数时,输入参考值之外的值时发生错误的问题。
  • 修复了参数的有效最大值和最小值以外的值可以在登录到关键点中的问题。
  • 修复了通过自动网格生成功能,即使选择并决定设置的任何数值,网格也不会被分割的问题。
  • 修复了包含蒙皮的模型无法作为模板模型导入的问题。
  • 更正了Editor左上角目标符号的措辞。
  • 修复了导出PSD时,若画布外有物体将发生错误的问题。

Animator

《改善项目》

  • 修复了复制场景时未保持参数的掩盖状态的问题。
  • 修复了输出MP4和MOV视频时,如果输出范围包含帧数从4位变为5位的部分,则会出现错误且无法导出的问题。
  • 修复使批量输出动态时显示motion3.json覆盖保存确认的警告对话框。
  • 修复了在Mac版上输出GIF动画和序列图片时出现错误的问题。
  • 修复了导致在曲线Editor中向右移动和缩放时出现错误的问题。
  • 修复了在Modeler中变更部件显示状态时,Animator未正确更新部件显示状态的问题。

Cubism 3 Viewer(OW)

《功能追加》

  • 您现在可以在“统计”中查看导入的moc3文件的版本信息。

3.3.00(2018/12/20)

通用

《改善项目》

  • 修复了当Editor开启时正在编辑的文件从系统路径中消失时,即使执行“保存”也不执行保存处理的问题。
  • 修复了更新画布绘制时内存记忆使用量逐渐增加的问题。
  • 修复了快捷键不起作用的问题。
  • 修复了Mac版中打开文件时UI崩溃导致按钮无法操作的问题。

Modeler

《功能追加》

  • 实装了编辑网格时将一个三角形一分为四的功能。
  • 实装了编辑网格时通过拖动增加点的功能。
  • 扩展以在复制和贴上图形网格时(输出和导入部件时)保持纹理集。
  • 动作反转功能现在支持图形网格。
    • 可以将设置为图形网格任意参数的键的动作反转。
  • 在参数面板上追加全部展开/折叠按钮。
  • 部件面板的过滤功能中追加了按物体名称/ID过滤的字符串过滤功能。
  • 扩展以能够设置模型的目标版本。
    • Cubism 3.0 (3.2) … 当您想使用与旧版本相同的表达式时设置。(请在使用3.0 SDK时使用)
    • 当您想使用Cubism 3.3 … 3.3中引入的功能时设置。(请在使用3.3 SDK时使用)
  • 改进以使弯曲变形器的变换更加美观。尤其是梯形变换的弯曲变形器质量更高。
    * 为了使用这个表达式,需要选择Cubism 3.3或更高版本的目标版本设置。
    为了使用SDK的高质量版弯曲变形器,Core版本必须为3.3或更高版本。在Core3.3或更早版本上读取模型数据(moc3)会导致错误。
    如果要继续使用3.3或更早版本的SDK,请在moc3输出设置中将输出版本指定为“支持SDK 3.0 / Cubism 3.0 (3.2)”。
  • 追加了模型物体搜索和替换功能。
  • [Pro版]追加了批量设置模型物体和参数的功能。
    • 可以通过CSV输出/载入。
    • 可以批量设置物体名称/ID和参数设置信息。
  • 实装了栅格颜色变更功能。
  • 通过空格 + 左拖动移动画布时,您现在可以通过按Shift键沿您第一次移动的方向进行平移。
  • 追加了部件面板的快捷键。
    • 创建部件
    • 部件设置
    • 删除所选部件
  • 追加了参数面板的快捷键。
    • 取消选择
    • 结合/取消结合
    • 选择上一个
    • 选择下一个
    • 选择第一个键
    • 选择下一个键
    • 选择上一个键
    • 选择最后一个键
    • 选择默认键
    • 选择第一个键(结合时)
    • 选择下一个键(结合时)
    • 选择上一个键(结合时)
    • 选择最后一个键(结合时)

《改善项目》

  • 调整弯曲变形器的分割数时,拖动变更数值的速度过快,现已提高到合适的速度。
  • 修复了使用弯曲变形器的边界框进行编辑时,贝塞尔曲线的形状被重置的问题。
  • 修复了在工具细节面板的网格线条颜色输入栏中输入无效数值时显示错误的问题。
  • 更改为在工具细节面板中保存笔刷设置值。
  • 修复了在网格线条颜色中选择颜色时,8位颜色代码设置值被截断等UI崩溃的问题。
  • 修复了“手动”和“随机姿势”在循环参数设置的键移动到末尾时显示不同的问题。
  • 修复了存在同名参数时参数变更命令相关的问题。
  • 修复了在进阶搜索参数的状态下关闭模型并按原样使用Editor打开模型时参数面板中的问题。
  • 修复了某些模型作为模板使用时,应用模板后变得沉重的问题。
  • 修复了带有转换路径的图形网格的网格编辑完成时发生错误的问题。
  • 修复了进度条完成时动作不稳定的问题。
  • 修复了批量输出PSD时未添加文件扩展名(.psd)的问题。

Animator

《功能追加》

  • 为视频输出添加了对音频流的AAC支持。(除Pro版外,包括“嘟”音)
  • 在时间线面板上追加了全部展开/折叠按钮。
  • 实装了“掩盖所有未选择的属性”的功能。
  • 您现在可以设置动画的开始帧。
  • 变更了部分检查器的显示和术语。
    (3.2.07:最后一帧 [29] ⇒ 3.3:开始帧 [0] 长度 [30])

《改善项目》

  • 改进了在时间线面板中显示大量属性时画布上的FPS。
  • 修复了在工作区域中拖动条以缩短它时,它不会在另一端停止并会移动的问题。
  • 修复了在打开“启用掩盖属性操作”的情况下,从轨道的按右键菜单插入关键帧时,所有参数都不会应用的问题。
  • 修复了即使在参数组掩盖时关闭了“启用掩盖属性操作”,也会从对所有属性通过按右键菜单插入关键帧的问题。
  • 修复了替换模型时保持了最初创建轨道的模型的默认值,can3上的默认值没有改变的问题。
  • 修复了项目面板中的组未正确创建的问题。
  • 修复输出gif文件时外框出现黑色边框的问题。

3.2.07(2018/11/15)

通用

《改善项目》

  • 更新了日文版教程视频的菜单。

Modeler

《功能追加》

  • 您现在可以为参数组设置ID。为了组的通用性,建议设置为标准参数组名/ID。
    标准参数列表
  • 添加了对结合参数插入2个/3个键的支持。
  • 实装了对多个指定参数批量反转参数键的功能。

《改善项目》

  • 修复了在关键点移动的状态下创建新参数时,关键点返回默认值的问题。
  • 修正了在操作参数的状态下进阶搜索时显示成为参考值的问题。
  • 变更为在参数面板中的参数名称变长时缩小显示。(与2.1相同的规格)
  • 修复了手动设置参数ID并执行【返回默认设置值】时,参数ID可能无法返回正确位置的问题。
  • 修复了参数设置中无法同时变更上下限、设置循环的问题。
  • 修复了当键设置超出参数的最大值和最小值时,会显示关于蒙版的警告的问题。
  • 蒙版的警告显示现在可以正确检测由参数编辑引起的情况变化。
  • 修复了macOS版拖入部件和变形器面板时动作延迟的问题。
  • 修复了确认删除所有参数文件夹名称后,无法再次变更名称的问题。
  • 修复了在参数面板上执行“变更”时显示的参数列表与实际顺序不同的问题。
  • 在物理模拟/场景混合设置对话框中,修改为保存变更的“计算FPS”设置。
  • 更正了蒙版提示显示的措辞,并更正了警告以使其更易于理解。
  • 修复了参数值较大时数据偶尔显示不正确的问题。
  • 修复了创建变形器时,如果存在其他同名部件,则会将其存储在非预期部件中的问题。
  • 修复了项目面板中模型导引图像名称大于原始字符数时显示不正确的问题。
  • 修复了进阶搜索参数时显示为解除连接的问题。
  • 修复了信息对话框多次显示,且Editor似乎无法退出的问题。
  • 变更为在变更参数设置对话框的大小时保存设置。
  • 修复了使用形状混合功能时Undo/Redo无法正常工作的问题。
  • 修复了Atlas置入的的部件在保存时的倍率可能不同的问题。
  • 修复了不透明度数值大于规定值的问题。

Animator

《改善项目》

  • 修复了即使隐藏状态的不透明度为100%,也会隐藏部件的问题。
  • 修复了贝塞尔曲线的形状吸附在帧上的问题。
  • 修复了使用贝塞尔曲线的形状复制和贴上键时,曲线形状在贴上后发生变化的问题。
  • 将动态输出范围限制为至少2帧。(为了防止SDK出现问题)
  • 修复了未保存模型轨道的轨道名称编辑的错误。
  • 修复了复制场景时轨道隐藏信息被重置的问题。
  • 修复了删除场景素材后Undo/Redo无法正常工作的问题。
    如果您在对话框中确认无法Undo,然后删除该素材,则将无法执行在此之前的Undo操作。

Cubism 3 Viewer(OW)

《功能追加》

  • 追加了导入两个moc3数据并比较信息的功能。

3.2.06(2018/10/22)

Modeler

《改善项目》

  • 修复了创建纹理集时取消导致无效数据的问题。
  • 修复了应用反转功能时,旋转变形器的基准角度未反转的问题。
  • 修复了复制图形网格时模型导引图像损坏的问题。

3.2.05(2018/09/20)

通用

《改善项目》

  • 更新了英文版教程视频的菜单。

Modeler

《改善项目》

  • 修复了macOS Mojave (10.14)中的一个问题,即当尝试通过在数值输入框中向左或向右拖动鼠标来更改数值时,它不会停在任意值上,而是会继续更改。
  • 修复了moc3输出设置对话框中的设置未被保存的问题。
  • 修复了单击参数的录制按钮后,变更保存目的地设置时,显示错误信息且记录的动态内容未被保存的问题。
  • 修复了将项目从部件面板拖放到变形器面板时,无法变更变形器的父子级的问题。
  • 修复了将项目从变形器面板拖放到部件面板时,无法变更部件的父子级的错误。

Animator

《改善项目》

  • 视频输出功能现在可在macOS Mojave (10.14)上使用。
  • 修复了选择所有键并调整间隔后,直接移动键时关闭参数文件夹的键不移动的问题。

3.2.04(2018/09/06)

Modeler

《功能追加》

  • 扩展以便在留下图形网格状态下删除原图。
  • 扩展为能够在物理模拟设置中指定计算FPS。
  • 追加了自动备份设置对话框。
  • 实装了记录参数操作并生成动画的功能。
    (随机动画或手动参数操作均被记录)
  • 在编辑纹理集时追加了“文件” > “锁定纹理 (beta)”菜单。
  • 实装了编辑纹理集时输出和替换PNG图片的功能。
  • 此功能允许您如Cubism 2.1一样替换置入纹理集的图片。
    • 可以在编辑纹理集时从“文件” > “输出纹理图像(beta)”和“纹理图像替换(beta)”中使用。
      * 由于处于beta阶段,不支持Undo。
  • 追加了从锁定的纹理中提取原图和模型导引图像的功能。
    此功能可以针对已执行“纹理图像替换”的数据进行物体重新置入。
    • 建模时,您可以从“建模” > “纹理” > “将纹理集应用于原图(beta)”中使用它。
      * 由于处于beta阶段,不支持Undo。
  • 追加了在编辑纹理集时隐藏模型导引图像的设置。
    • 编辑纹理集时可以从“显示” > “显示模型导引图像”中使用。
  • 扩展为编辑纹理集时,在鼠标悬停选项卡上时弹框显示纹理名称。
  • 实装了在编辑纹理集时通过右键单击选项卡来变更纹理名称的功能。
  • 实装了原图的PSD输出功能。您可以使用以下方法之一进行输出。
    • 从“文件” > “输出图像/视频” > “PSD图像(beta)”,“将所有原图输出为PSD”
    • 右键单击项目面板中的特定原图并选择“PSD输出(beta)”
  • 扩展为可以删除原图的空层组。
    • 右键单击项目面板中的原图,并选择“删除空层组”。
  • 为nizima生成投稿数据,“输出moc3文件”中追加了输出功能。
    它可以从“文件 > 输出嵌入文件 > 输出moc3文件”中调用。
    此输出格式的投稿将在nizima支持后立即可用。
  • 提高绘制速度。特别是具有大量图形网格的模型明显更轻。
  • 缩短了导入和输出模型文件的时间。
  • 实装了在编辑纹理集时通过拖放选项卡更改顺序的功能。
  • 扩展为当显示“鼠标处的物体”弹框时,在底部批量显示隐藏的物体。

《改善项目》

  • 修复了在编辑网格时使用橡皮擦工具快速拖动鼠标导致擦除不均匀的问题。
  • 修复了具有某些文件扩展名的文件无法使用Editor打开的问题。
  • 修复了使用绘制顺序滑块设置分组部件时,检查器的绘制顺序显示未更新的问题。
  • 修复了部件面板和变形器面板中的以下问题。
    • 移动物体时滚动返回顶部的问题
    • 替换物体时可能不会突出显示的问题
  • 修复了在参数面板中选择多个参数,并从按右键菜单中选择“删除”时删除多个选择的问题。
  • 修复了变更参数名称或范围等时,除非解除参数进阶搜索,否则不会应用变更的问题。
  • 如果在剪贴中为蒙版指定的图形网格有问题,则会在执行时显示提示,并在输出时显示警告。
  • 修复了缺少为部件设置的关键点时有关隐藏的行为。
  • 修复了当网络驱动器上的文件在“最近打开的文件”列表中时,Editor动作变慢的问题。
  • 修复了如果同一物体被特定操作复制,则无法删除的问题。
  • 修复了部件输出数据尺寸变大的问题。
  • 修复了将带有参考图的模型用作模板时,物体与参考图关联的问题。
  • 修复了重新载入PSD时,部件面板和变形器面板的图标未更新的问题。
  • 修复了重新载入PSD时,Animator模型轨道缩略图未更新的问题。
  • 修复了在部件面板和变形器面板中以特定状态复制和贴上文件时生成双重物体的问题。
  • 修复了编辑纹理集的Undo/Redo无法正常工作的问题。
  • 修复了编辑网格后,纹理显示切换到Atlas模型导引图像并执行Undo/Redo时显示崩溃的问题。

Animator

《功能追加》

  • 添加了对在时间线上同时显示时间码和帧的支持。
  • 您现在可以为检查器中的“最终帧”设置选择基于时间码或基于帧。
  • 将时间线的参数文件夹列的背景颜色变更为黄色。
  • 支持属性的选择颜色和Graph Editor的显示颜色。
  • 实装了导入动态文件(motion3.json)的功能。(右键单击模型轨道名称)
  • 您现在可以通过Shift + 单击Dope Sheet来选择一个范围。
    从指示器/选择行选择一个关键帧到Shift + 单击位置。
  • 范围外的背景颜色已变更为浅紫色,以便可以轻松识别音频数据的起点/终点。
  • 增强了掩盖功能。
    • 掩盖所有选择属性的功能。
    • 掩盖所有未设置关键帧的属性的功能。
  • 修复为在素材链接断开时显示文件名而不是文件的完整路径。

《改善项目》

  • 词条修正:将动画的符号“长度”变更为“最终帧”。
  • 即使在时间线上置入名称很长的模型时,也能正常缩小参数滑块。
  • 检视区域上的模型选择已修改为与时间线上的选择同步。
  • 为防止错误选择,现在在轨道、效果或文件夹关闭时解除选择Dope Sheet选择范围。
  • 修复了即使在Editor上设置背景颜色,输出GIF时不会应用的问题。
  • 修复了在Graph Editor中将全体关键帧移动到0之前的位置时,曲线绘制被破坏的问题。
  • 修复了使用箭头键在曲线Editor上移动关键帧时数值很少变化的问题。
  • 修复了通过选择关闭“部件显示和置入&不透明度”的矩形删除关键帧时,不删除部件显示键以外的关键帧的问题。
  • 修复了在场景面板中拖动时,打开的场景和选中的场景外观不同的问题。
  • 修复了在语音动态中打开循环时发生的错误。
    • 如果您在循环之前按Enter,声音将不会停止。
    • 循环之前,播放停止几秒钟。

Cubism 3 Viewer(OW)

《功能追加》

  • 追加了图形网格列表功能。您可以通过选择列表来掌握显示的位置。

《改善项目》

  • 修复了双击开启moc3时无法打开文件的问题。
  • 修复了通过剪贴指定蒙版的ArtMesh如果没有正常输出时,无法导入到Viewer的问题。
  • 更改为在剪贴中的蒙版出现问题时显示警告。

3.2.03(2018/08/06)

Modeler

《功能追加》

  • 您现在可以从以下项目中选择第一次创建纹理集时要置入的元素:
    • 显示状态下的模型导引图像
    • 所有模型导引图像
    • 不置入
  • 变更为在生成纹理集时不置入参考图。以后可以手动置入。
  • 实装了在编辑纹理集时,在右端列表中进阶搜索并显示“仅显示和未放置”的功能。

《改善项目》

  • 修复了由于模型导引图像相关错误导致Editor动作变得繁重的问题。
  • 修复了重新载入PSD时重建纹理集的问题。
  • 修复了重新载入PSD层大小发生变化的PSD时,纹理集置入未对齐的问题。

3.2.02_1(2018/07/25)

* 仅用于更新安装程序

通用

《改善项目》

  • 修复了Editor在Windows环境中可能需要几分钟到几小时才能开启的问题。

3.2.02(2018/06/28)

Animator

《改善项目》

  • 修复了Animator中无法删除或复制从另一个场景复制的轨道的问题。

3.2.01(2018/06/21)

通用

《改善项目》

  • 优化使内存记忆使用量不会因隐藏的图形网格、参考图等而增加。
  • 在置入很多大型参考图的情况下,权重大大减轻。
  • 修复了变形器的透明度在某些情况下没有立即应用的问题。
  • 修复了当您在未保存文件的情况下退出时,如果您在要求您保存的对话框中执行保存操作,它将被保存为不同名称的问题。
  • 修复了替换文件时也会显示与选择对话框无关的文件的问题。
  • 选择项目面板时的颜色已与其他面板匹配统一。
  • 改进了“确认”对话框的功能:
    • 按Y键与按“是”按钮的效果相同。
    • 按N键与按“否”按钮的效果相同。
    • 按C键与按“取消”按钮的效果相同。
    • 通过按左右箭头键,焦点移动到每个按钮。

Modeler

《功能追加》

  • 修复为在编辑多个网格时显示网格选择的弹框。可以避免在警告“网格未关闭”时,无法重新选择网格的情况。
  • 重新载入PSD时,规范已变更,以便仅在旧文件中的层与旧文件保持关联。
    此变更可防止意外删除仅与旧文件关联的文件。
  • 扩展为在重新载入PSD时能够选择并替换多个现有PSD文件。
  • 扩展了项目面板。
    • 扩展为原图层未使用时,在树图层上显示“## 未使用 ##”。
    • 扩展为在原图的检查器上显示“模型导引图像中的使用次数”和“模型导引图像的连接数”。
    • 使用次数是当前状态下连接的模型导引图像(实际显示在图形网格上)的数量。
    • 连接数是包括非当前状态的模型导引图像(通过切换原图正在使用的图片)的数量。
    • 扩展为能够打开/关闭原图检查器上的“取代标志”。(注:不支持撤销)
    • 关于PSD原图、原图层、模型导引图像组和模型导引图像,扩展为可以在检查器上输入“备忘录”。
    • 扩展为能够变更PSD原图、层和模型导引图像的名称。(注:不支持撤销)
    • 追加了通过右键单击原图“删除未使用层的功能”。
      此功能允许您清理仅部分使用的PSD文件。
    • 添加了对在面板中拖动原图层的支持。
      此功能允许您将项目中的多个PSD文件合并到一个文件中。
    • 追加了通过右键单击原图层“生成模型导引图像”。
    • 追加了通过右键单击模型导引图像“删除图形网格的错误连接(beta)”。
      由于某些程式错误,当多个模型导引图像与图形网格相关联时,它可用于恢复。
    • 关于模型导引图像和原图层的拖拽,扩展为可以同时进行多次拖拽。
  • 辅助线功能得到了增强。
    • 现在可以通过快捷键追加辅助线。
    • 现在可以批量设置所有辅助线颜色。
    • 现在可以设置辅助线的默认颜色。
  • 扩展了动作反转功能。
    • 选择多个物体时,保留相同的参数,并将处理应用到具有父子结构的屋物体。
      (以前,该处理会被中断,但显示警告后可以继续该处理。)
    • 添加了对旋转变形器的轴位置和旋转角度的支持。
  • 现在可以将快捷键分配给“转换路径”、“胶水”和“网格编辑模式下的工具细节”。
  • 追加了显示/隐藏边界框的功能。(支持快捷键)
  • 追加了在“变形器面板”和“部件面板”锁定物体时,同时锁定检查器中信息的功能。
    • 您可以从文件菜单 → 设置菜单 → “锁定物体时锁定检查器”进行变更。

《改善项目》

  • 修复了在某些条件下不应用动作反转的问题。
  • 修复了moc3文件输出设置对话框的PixelsPerUnit中放入1.0时,部分设置未保存的问题。
  • 修复了旋转变形器的转变无法撤消的问题。
  • 将项目面板中“链接断开”的资源的文本颜色变更为红色以使其突出。
  • 更改为在项目面板中显示相关图标。
  • 修复了第一次启动网格编辑模式时缺少GUI的问题。
  • 修复了图形网格的预览图标显示不对齐的问题。
  • 修复为在执行“复制形状”时也应用不透明度和绘制顺序。
  • 输出moc3文件时,如果要覆盖现有的moc3文件,现在可以选择是否输出model3.json。
  • 修复了在编辑具有多个选择的网格时,反转元素的移动等无法正常工作的问题。
  • 修复为在从检查器变更物体的“不透明度”或“绘制顺序”时,能够通过一次撤消操作返回。
  • 修复了PSD重新载入、追加载入、PSD原图删除、项目面板中各种操作的撤消/重做相关的问题。
  • 修复了快捷键周围的小错误。
  • 修复了在输出特定文件时使用模型文件的名称作为默认文件名称。
  • 在“创建变形器”对话框中追加了“连续创建”和“创建快捷键”。
    • 连续创建:Shift + Enter
    • 创建:Ctrl + Enter
  • 更新了修改转换路径、删除路径图标。
  • 修复了选择物体在部件面板/变形器面板中锁定时,无法使用箭头键移动的问题。
  • 增强了Solo功能。
    • 通过将待用区域变灰(可以变更颜色),可以更轻松地显示和编辑所选物体。
    • 修复处理以使临时锁定选择物体以外的物体。

Animator

《功能追加》

  • 实装了“标记功能”,以便可以在时间线上标记帧位置。
  • 增强了Graph Editor上与键插入相关的功能。
    • Ctrl + 按左键:在图表上的任意位置追加一个键
    • Ctrl + Shift + 按左键:在图表上的曲线位置追加一个键
  • 您现在可以通过Shift + 按左键选择多个属性。
  • 您现在可以在场景检查器的“默认插值方法”中默认设置参数和部件曲线。
  • 您现在可以通过将鼠标悬停在工作区的栏上来查看信息。
  • 增强选择全部功能(Ctrl + A)。
    • Dope Sheet:为所有选择轨道选择关键帧。
    • Graph Editor:为所有选择参数选择关键帧。
  • 追加了快捷键。(如果不显示,请原始化快捷键)
    • J:移动到上一个关键帧(所选参数)
    • K: 移动到下一个关键帧(所选参数)
    • Shift + J:移动到上一个关键帧(所选轨道)
    • Shift + K:移动到下一个关键帧(所选轨道)
    • Shift + B: 将当前位置移动到轨道的开头
    • Shift + N:将当前位置移动到轨道的末尾
    • Shift + M:将轨道移动到当前位置
    • 未设置:展开和折叠时间线上的所有轨道
  • 实现了在检查器上变更场景大小时保持长宽比的功能。

《改善项目》

  • 修复为输出视频时,如果输入的数值超过了Mac OS版的分辨率限制[宽(4096)和高(2304)],将出现警告而无法输出。
  • 修复了Cubism 2.1的渐变设置不应用的问题。
  • 修复了对时间线应用删除、选择全部和解除绑定编辑菜单。
  • 修复了反转关键帧功能中默认值不是中心值时,键被击出范围的问题。
  • 修复为如果在移动全体组轨道后撤消,则里面的子轨道也将被撤消。
  • 修复为应用关键帧复制贴上及模板时,保持贝塞尔曲线的形状的位置。
  • 修复了当选择单个键然后为其他键选择矩形时,选择状态不能正常切换的问题。
  • 您现在可以看到在Dope Sheet上第0帧之前击中的键。
  • 修复了切换场景时显示倍率不保持的问题。

Cubism 3 Viewer(for OW)

《改善项目》

  • 修复了即使在moc3的输出设置中勾选了“输出隐藏部件”也不会应用的问题。

3.2.00(2018/04/27)

Modeler

《功能追加》

  • 追加了变形器验证功能。
    (您可以检查会导致嵌入期间性能下降的父变形器的突出。)
  • 追加了动作反转功能。
    (弯曲变形器中设置的参数一侧的键生成为另一侧的键,向对应定点反转动作并应用。)
  • 追加了在检查器中显示和编辑顶点信息的功能。
  • 追加了辅助线功能。
    • 在画布上的任意座标位置追加辅助线
    • 为所选顶点的座标位置追加辅助线
    • 移动顶点时对齐辅助线
  • 追加了选择空变形器的功能
  • 在变形器面板的菜单中追加了将对象变形器以下折叠的功能。
  • 追加了将物体的显示状态恢复到之前状态的功能。
    (仅在主菜单、按右键菜单和快捷键中显示和隐藏物体时)
  • 正式实装了beta中搭载的蒙皮功能。

《改善项目》

  • 修复了锁定/解锁锁定、显示/隐藏多选物体的处理内容。
  • 修复了部件面板和变形器面板的弹框菜单中选择处理中的一些问题。
  • 修复了在生成纹理集时导致错误的问题。
  • 修复了motion3.json等在“最近打开的文件”中显示的问题。
  • 改进了检查器的显示。
  • 修复为在创建变形器时,插入目标部件成为“选择部件”。
  • 修复为在连续创建变形器时保留输入的名称。
  • 修复为在创建变形器时,通过按Enter键立即创建。
  • 修复为在追加新部件时,所选物体为部件的子级。
  • 修复了复制/贴上形状后,未解除网格顶点选择的问题。
  • 变更了设置绘制顺序时弹出的“加算按钮”的布局。
  • 修复了在打开多个模型的情况下,为每个参数创建文件夹时共享序列号的问题。
  • 修复了输出PSD图片时出现周期性偏移表达的问题。
  • 修复了在物理模拟设置中播放包含静音的动画时播放声音的问题。

Animator

《功能追加》

  • 追加了在Animator中输出motion3.json时,对参数烘焙口形同步和眨眼曲线的功能。
    原始工作流程中的口形同步和眨眼曲线建议从Editor输出时进行烘焙使用,而不是保持原样并使用 SDK 合成它们。
  • 追加了视频输出功能(.mp4、.mov)
  • 实装了将所选关键帧值与参考值反转的功能。
  • 实装了跨参数的关键帧复制/贴上功能。
  • 追加了将口形同步和眨眼动态烘焙到动态输出的功能。
  • 在掩盖功能中追加了“全部掩盖/全部解除”功能。
  • 您现在可以在Graph Editor上通过箭头键移动关键帧。
  • 实装了在Graph Editor中移动键时的捕捉功能。
  • 实装了能够将场景复制并贴上到跨越场景的轨道的功能。
  • 追加了工作区栏的水平移动功能。
  • 实装了为多个参数设置单独渐变的功能。

《改善项目》

  • 修复了在mac上输出动态时,文件保存对话框中没有自动添加motion3.json的文件扩展名的问题。
  • 修复了在时间线中包围选择区域显示按右键菜单时,选择范围被解除的问题。[macOS版]
  • 添加了防止PC在连序输出期间进入睡眠模式的机制。
  • 修复了输出2.1用动态(mtn)时,部件显示值中包含整数0和1以外数值的问题。
  • 修复了进行gif动画和连序输出时,不启用Live2D图标显示的问题。
  • 修复了音轨的“音量”值在播放过程中未应用的问题。

Cubism 3 Viewer(for OW)

《功能追加》

  • 追加了与Original Workflow对应的Viewer。
    背景透明度(beta)仅适用于Windows版。

3.1.04(2018/03/13)

Modeler

《功能追加》

  • 扩展为能够选择纹理(Atlas)的生成方法。
    您可以从“编辑纹理集”对话框中的菜单“纹理 > 纹理生成方法 > 高质量/低质量(不建议)”中进行选择。
    高质量是3.1.04之后搭载的方法。低质量是3.1.03之前的方法。

《改善项目》

  • 修复了移动多个选中参数(参数文件夹)时,解除选择状态的问题。
  • 在关键点编辑对话框中,改进了追加和删除键时的判断,提高了可操作性。
  • 修复了选择多个参数并拖放到参数列表以外部分时,移动的参数显示消失的问题。
  • 修复了通过为多个图形网格设置转换路径进行复制贴上时,复制后编辑转换路径会影响复制前图形网格的问题。
  • 修复了对于多个图形网格应用换路径应,在一方的图形网格被锁定(或隐藏)的状态下操作转换路径时,锁定的图形网格移动的问题。
  • 修复了在编辑纹理集时,如果缩小到25%等倍率,质量下降的问题。
  • 修复了快捷键“关闭选项卡”的[Ctrl] + [W]不起作用的问题。
  • 由于存在物理模拟设置(physics3.json)的设置信息ID重复的情况,因此已修复为不会重复。
  • 修复了同一个can3文件可以多次打开的问题。
  • 修复了有关部件面板、变形器面板和检视区域之间的选择状态同步的一些行为。
  • 修复输出文件时选择不带文件扩展名保存时,自动添加文件扩展名功能无法正常工作的问题。
  • 追加了教程视频引导对话框(仅限日文版)

Animator

《功能追加》

  • 追加了通过按下鼠标滚轮 + 拖动同时垂直和水平滚动时间线的功能。
  • 您现在可以在轨道和属性组上启用或禁用掩盖属性操作(追加、删除、移动)。
  • 您现在可以编辑轨道名称。(在轨道名称上按右键)
  • 追加了切换动画编辑模式的快捷键。(C键)

《改善项目》

  • 修复为切换场景时保持属性选择、编辑模式、掩盖模式、参数宽度等的状态。
  • 修复了置入音频文件并移动位置后执行撤消时,音频位置没有正确返回的问题。
  • 修复了移动全体轨道时,不会批量执行撤消,而是逐步撤消的问题。
  • 修复了复制模型轨道后设置口形同步时,无论选择哪个模型轨道,都只为存在于顶部的模型轨道设置口形同步的问题。
  • 修复了在播放有音频的场景时,如果单击时间线,仅音频播放返回到开头的问题。
  • 修复了无法从动画模板的面板中删除文件夹的错误。
  • 修复了在时间线上缩短音轨开头时,音频在播放过程中不一致的问题。
  • Graph Editor上的选择状态和播放位置等不重要的项目已从撤消中排除。
  • 修复了操作记录面板和检查器后,快捷键不起作用的问题。
  • 即使音频的链接断开,您现在也可以复制场景。(可能的话不建议)
  • 修复了复制和贴上关键帧并在未解除选择的情况下移动时,部分未选择的关键帧被移动的问题。

3.1.03(2018/02/08)

通用

《改善项目》

  • 修复了在Animator和Viewer中播放音频时,内存记忆使用量逐渐增加的问题。

Modeler

《改善项目》

  • 修复了输出图片(PNG)时,半透明部分劣化的问题。
  • 修复了未选中时锁定的变形器显示为灰的问题。
  • 修复了“上一帧”快捷键标签名称的重复,并追加了“下一帧”。
  • 修复了显示/隐藏物体和切换锁定时,变形器面板的信息不更新的问题。
  • 修复了图片作为参考图置入时不变为半透明的错误。
  • 修复了“最近打开的文件”中显示png文件的问题。
  • 修复了选择锁定的变形器并解除锁定时,边界框不会重新显示的问题。
  • 修复了边界框在某些情况下看不到也可以操作的问题。
  • 修复了操作弯曲变形器的贝塞尔曲线的形状时,意外转变的分割点移动的问题。
  • 修复了在同时复制胶水和胶水连接的图形网格时,胶水连接原始图形网格的问题。
  • 修复了当焦点在文本组件上时,按Ctrl + S后文本组件没有响应的问题。

Animator

《功能追加》

  • 追加了输出动态时眨眼和口形同步的输出选项。

《改善项目》

  • 修复了结合参数“Ctrl + 按左键”无法命中关键帧的问题。
  • 修复了播放动画时,音频和动态不同步的问题。
  • 修复了在时间线上水平滚动时,时间线显示发生偏移的问题。
  • 变更了口形同步关键帧的生成方法。减少了不必要的键,更容易进行微调。
  • 使用时间线下方的放大/缩小UI进行缩放时,它将围绕播放位置进行缩放。
  • 修复使关键帧选择的背景颜色和键颜色更明显。
  • 修复了使用page up、page down快捷键变更播放位置时,关键帧一起移动的问题。
  • 修复了编辑Animator骨架时Undo无法正常工作的问题。
  • 修复了输入参数值并按Enter时开始播放的问题。

3.1.02(2017/12/25)

Modeler

《改善项目》

  • 修复了3.1.1以后编辑网格时橡皮擦功能无法正常工作的问题。

Animator

《改善项目》

  • 修复了左键单击单个参数滑块并变更值时,禁用第一次单击的问题。

3.1.01(2017/12/21)

Modeler

《功能追加》

  • 追加了beta版的PSD文件输出功能。它可以从菜单“文件 > 输出图像/视频 > PSD图片(beta)”中执行。
    将参数变换的结果输出为分层的PSD图片。请注意,表达可能与部分原图的PSD不同。
  • 实装了beta版的蒙皮功能。从菜单“建模 > 蒙皮”执行各种蒙皮处理。
    此蒙皮处理是一种简单的蒙皮功能,可轻柔地变换细长的图形网格,例如长发和摇动的绳等。
    (计划在未来支持可以像3D一样自由变换的蒙皮)
    详情请参考手册。
    https://docs.live2d.com/cubism-editor-manual/skinning/
  • 在选项卡中追加了使用Explorer打开的项目。

《改善项目》

  • 修复了在变形器/部件面板中选择多个变形器并建立父子结构时,无法批量撤消的问题。
  • 提高了参数面板上的参数选择精度。
  • 修复了快照可能无法保存在参考图中的问题。
  • 修复了栅格显示快捷键的显示不正确的问题。
  • 修复了绘制顺序组设置无法Undo/Redo的问题。
  • 追加了可以在Viewer的物理模拟设置表中,针对列批量设置数值的处理。
  • 修复了部件创建无法Undo/Redo的问题。

Animator

《功能追加》

  • 实装了使用箭头键逐帧移动所选关键帧的功能。

《改善项目》

  • 提高了操作过程中Undo的精度。
  • 提高了时间线顶部时长的操作精度。
  • 修复了在关键帧之间追加关键帧时,曲线不平滑过渡的问题。
  • 提高了时间线的缩放精度。
  • 提高了关键帧拖动移动的精度。
  • 修复播放动画时播放位置红条上下不对齐的问题。

3.1.00(2017/11/30)

3.1 新功能

  • 实装了物理模拟生成动画功能。
    您可以将物理模拟设置的“头发摇动”和“衣服摇动”等动作刻录(烘焙)为Animator时间线上的关键帧。
  • 实装了通过混合多个场景进行预览的功能。
    您现在可以在Editor上检查Cubism SDK的动态混合。 此功能和物理模拟设置已集合到Viewer中。
    它可以从菜单中的“建模” → “打开Viewer”中调用。
  • 实装了多键编辑功能,可同时变更与参数关联的多个关键点(绘制顺序和不透明度)。
  • 实装了将用户数据追加到场景模型轨道的任意时间线的功能。
    通过与Cubism SDK组合,可以随时制作效果等,更容易与应用端配合。
    追加的用户数据追加到动态(.motion3.json)并输出,且可以与最新的SDK组合。
  • 实装了可以将用户数据追加到图形网格的功能。
    在Cubism SDK上对特定的图形网格进行单独处理时等,与应用程序端的链接会更容易。
    追加的用户数据输出为用户数据文件(.userdata3.json),可以与最新的SDK组合。
  • 您现在可以在文件夹中管理Animator模型轨道中的参数。
    在Modeler中设置的模型参数文件夹将按原样显示在Animator的时间线上。

有关3.1新功能的详细信息,请参考以下页面。
[新功能介绍 3.1]

通用

《改善项目》

  • 正式支持macOS High Sierra。
    【注意事项】
    请解除绑定许可证,然后升级到High Sierra。
    如果您在未解除绑定许可证的情况下升级,则许可证将被解除绑定,且将无法再次注册。
  • 已修改为可以根据安装的RAM量自动决定最大Java内存记忆分配量。
    这改善了无法打开文件大小较大的模型文件的问题。

Modeler

《功能追加》

  • 修复了在物理模拟设置中使用多级摆锤时,动作与摆锤模拟器不匹配的问题。
    由于使用多级摆锤时物理模拟的计算处理会出现变更,请重新确认动作,并在使用SDK时更新到最新版本。
  • 胶水现在显示在部件面板中。您可以在部件面板中对胶水进行隐藏或锁定权重。

《改善项目》

  • 修复了在删除包含带有胶水的图形网格的部件时导致错误的问题。
  • 修复了读取Cubism 2.1模型(cmox) 时不应用剔除的问题。
  • 修复了通过剔除物体进行剪贴无法正常工作的问题。
  • 修复了通过操作贝塞尔样式的锚(或手柄),使弯曲变形器变换直至发生由内向外反转的状态为止之后再次编辑时发生错误变换的问题。
    * 在极少数情况下,如果在编辑非常大的转变点(粉红色方形点)时编辑贝塞尔样式的锚点(或手柄),可能会发生意外变换。
  • 在建模菜单中追加了“对齐选定的物体的参数配置”功能。
  • 改进了物理模拟设置预览时,物理模拟动作卡顿的问题。
  • 修复了免费版只能创建29个部件的问题。

Animator

《功能追加》

  • 追加了输出动态时不透明度输出选项设置。
  • 追加了使用箭头键逐帧移动时间线播放位置的功能。
  • 修复了在时间线上拖动移动播放位置时,同时播放音频文件的问题。

《改善项目》

  • 修复了在检查器中设置[长度]时,滚动条显示未更新的问题。
  • 修复了使用Animator结合参数时,可以通过按右键移动的问题。
  • 修复了从Cubism 2.1 canx文件输出motion3.json时,全体不透明度值超出正常范围的问题。
  • 修复了在Graph Editor中操作设置循环的参数的键时,Editor冻结的问题。
  • 变更了带有掩盖设置的参数的关键帧编辑规则。
    详情请参考手册。
    https://docs.live2d.com/cubism-editor-manual/timeline-basic-operationtimelinepalette/
  • 修复了部分Mac环境下动画数据输出/导入失败的问题。

3.0.16(2017/11/01)

Modeler

《功能追加》

  • 改进了生成旋转/弯曲变形器时自动决定的名称和ID规则。
    如下修正了添加在末尾的连序规则。
    修正前:脸、脸0、脸1、脸2
    修正后:脸、脸2、脸3、脸4
  • 添加了对长宽不同大小纹理集的创建、编辑和moc3输出的支持。

《改善项目》

  • 修复了读取2.1 cmox文件时参考图消失的问题。
  • 修复为通过双击展开参数面板中的文件夹时,仅显示名称的位置
    变为“名称更改”,其他则变为“打开/关闭文件夹”。
  • 修复了使用绘制顺序滑块编辑绘制顺序后无法Undo的问题。
  • 修复为当4个或更多参数与一个物体关联时,将显示警告信息。

Animator

《改善项目》

  • 修复了切换到Graph Editor后切换工作表时,左右面板滚动同步在时间线上不起作用的问题。
  • 修复了在尝试打开can3文件时,如果替换文件则会冻结的问题。
  • 修复了GIF动画循环连接不顺畅的问题。
  • 修复了变更场景名称后,场景面板的选择显示不切换到变更后的场景的问题。

3.0.15(2017/10/10)

Modeler

《改善项目》

  • 修复了3.0.14之后,变更参数顺序的模型输出的moc3文件无法在SDK中正常使用的问题。
  • 修复了3.0.14之后,读取部分模型数据时出现大量错误且变重的问题。
  • 修正为如果部分模型数据处于无效状态,在读取时进行修复。
    恢复的物体被命名(recovered)并追加到部件面板的开头。
    如果您不需要标记(recovered)的物体,请将其删除后使用。

3.0.14(2017/10/05)

Modeler

《改善项目》

  • 将处理变更为在已编辑文件的选项卡名称的开头显示*。
  • 修复了关闭选项卡后,下一个要打开的选项卡是结合参数的模型时发生错误的问题。
  • 修复了在编辑模型时按下Enter键会在幕后播放动画的问题。
  • 修复了输入名称、ID等文字时,按Shift + A、Shift + D等,会出现快捷键Event,之后无法输入的问题。
  • 修复了通过未击键的参数打开关键点编辑对话框时,如果按2点/3点追加按钮后追加更多键,[OK]按钮灰显且无法按下的问题。
  • 修复了即使在未设置参数关键点的位置也可以使用箭头键移动物体的问题。
  • 修复了参数设置对话框中[说明]项目列宽无法调整的问题。
  • 追加了图形网格自动连接设置信息保存处理。将“保持轮廓”检查的默认变更为ON。
  • 修复了编辑网格时在菜单 > 网格编辑模式中单击“自动生成网格”时发生错误的问题。
  • 修复了调整胶水权重时Undo/Redo无法正常工作的问题。
  • 修复了参数面板中的文件夹和参数不能置入底部的问题。
  • 修复了在对部件进行分组时,部件面板上的选择状态消失,且不更新检查器的问题。
  • 修复了使用钢笔选项卡时,部件面板和变形器面板的各项目显示/隐藏及锁定行为不稳定的问题。
  • 修复了拖放变形器面板中层次交换操作中的问题。
  • 修复了即使变形器面板的“打开链接到选择状态的树”关闭,也会展开的问题。
  • 修复了当变形器子级包含带有胶水的图形网格时,“选择子物体”无法正常工作的问题。
  • 修复了处理,以便在创建变形器时“插入目标部件”的顺序是部件面板中显示的顺序。
  • 修复了处理,以便即使一个组被展开时,所有组的展开/集合按钮也会被集合。
  • 修复了工具细节面板未正确更新的问题。
  • 修复了栅格间隔不保留为Editor信息的问题。
  • 修复了显示倍率设置为2%或3200%时,选择部件后即使使用对焦也无法对焦,1:1按钮不起作用的问题。
  • 修复为SDK和Editor上的参数以相同的顺序排序。
  • 修复了在某些情况下无法正常执行moc输出的问题。
  • 在物理模拟设置中追加了支持清单。
  • 修复了与模型统计对话框自动更新相关的问题。
  • 追加了处理以在模型统计对话框中保持自动更新检查。

Animator

《功能追加》

  • 实装了在Graph Editor中按shift键移动键时仅垂直移动的功能。
  • 实装了使用Ctrl + A选择所选轨道的所有关键帧的功能。
  • 实装了在包围选择区域时垂直自动滚动功能。

《改善项目》

  • 修复了在从快捷键变更工作区长度的处理中无法Undo的错误。
  • 修复了当文本字段具有焦点时,在画布上编辑时Undo无法正常工作的问题。
  • 修复了包围选择区域时,在0之前被选中的问题。
  • 修复了删除背景图位置的键时,也会删除模型位置的键的问题。
  • 将循环参数的默认曲线类型变更为直线。
  • 修复了通过在Graph Editor中拖动键进行编辑时,模型在视图上的动作未实时更新的问题。
  • 修复了在Graph Editor中操作贝塞尔曲线的形状后,在Dope Sheet上移动键时曲线的形状重置的错误。
  • 修复为输出动态(所有场景)时,在Explorer中打开保存目的地。

3.0.13(2017/09/06)

Modeler

《功能追加》

  • 实装了根据所选选项卡自动切换工作区的模式。
    • 根据文件 → 设置 → 选项卡选择自动切换模式
  • 扩展为复制贴上(载入/输出部件)时,根据需要自动插入位置调整变形器。
    • 位置调整变形器可以轻松移动、放大/缩小和旋转分配了参数的物体,提高了复制贴上后的工作便利性。
      (调整位置后,请删除变形器)
    • 通过这次修正,模型之间复制贴上、载入/输出部件的便利性得到了改进,变得更加稳定,并且重用具有参数的变形器、图形网格变得像部分模板一样容易。

《改善项目》

  • 改进使视图上的选项卡部分可以在中途显示。
  • 修复了可以在多视图中选择本来无法选择的选项卡的问题。
  • 追加了一个以列表显示选项卡的按钮,以便在同时打开多个选项卡时可以选择所有选项卡。
    * 废除了原来的选项卡和视图追加功能的+按钮。
    * 您可以通过以下两种方式继续使用追加选项卡功能。
    • 右键单击要追加的选项卡时,显示菜单中的“追加选项卡”
    • 主菜单视窗 > 追加当前选择的选项卡
  • 修复为可在检视区域固定鼠标位置的情况下连续关闭选项卡。
  • 修复了在视图上右键单击选项卡时,选项卡的右键菜单偶尔不显示的问题。
  • 修复了从Cubism Editor 3.0.11开始,当在网格编辑模式下设置“模型导引图像显示”模式时,外观从原始PSD缩小并且多边形的显示位置发生偏移的问题。
    (虽然3.0.11中显示崩溃,但是即使导入已有数据也不会发生崩溃问题。)
  • 修复了在使用Cubism Editor 3.0.11中实装的功能将显示质量减半等时,如果编辑纹理集,则初始网格置入时编排崩溃的问题。
  • 修复了创建新模型时生成的参考图部件在追加纹理时无法用作参考图的问题。
  • 修复了创建新模型时参考图部件未设置为参考图的问题。
  • 修复了导入图片并选择追加为参考图时发生错误的问题。
  • 修复了执行自动网格生成时浮动面板未被锁定的问题。
  • 修复了在网格编辑模式下可以将多边形顶点追加到菜单等UI部分的问题。
  • 修复了参数关键点编辑对话框的编辑结果无法撤消的问题。
  • 修复为按下参数面板中的“选择”时,将选择状态更新到检查器、部件面板和参数面板。
  • 变更为在根据2.1于部件面板上构建默认父子结构时,部件的结构不会改变。
  • 修复了在部件面板和变形器面板中变更全体显示状态和全体锁定状态时,打开最后选择的文件夹的问题。
  • 修复了在部件面板和变形器面板中变更各项目的可见度和锁定状态时,Editor上的选择状态发生变更的问题。
  • 修复了复制贴上时,如果贴上目的地不存在父变形器,则无法正常工作的问题。
  • 修复了载入和输出部件时,如果导入的目的场景不存在父变形器,则无法正常工作的问题。
  • 修复为当图片中发生连接断开错误时,将出现连接断开的物体名称和解决方案输出到记录中并进行更正。
  • 修复了从Cubism Editor 3.0.10或更早版本中创建的物理模拟数据输出物理模拟设置文件时,物理模拟设置文件在Cubism SDK上无法正常工作的问题。
  • 修复了物理模拟设置中输入设置的预置名称较长时,编排损坏的问题。
  • 修复了物理模拟设置中显示未播放场景的问题。
  • 更改为在物理模拟设置中的导出调整按钮上显示工具提示。

Animator

《功能追加》

  • 追加了Animator快捷键。(自定义快捷键设置对话框)
    • Home 移至时间线的起点
    • End 移至时间线的终点
    • Shift + Home 移至工作区的起点
    • Shift + End 移至工作区的终点
    • 未设置 将当前位置设置在工作区的开头
    • 未设置 将当前位置设置在工作区的末尾
    • PageUp 上一帧
    • PageDown 下一帧
  • Graph Editor改进如下
    • 现在可以打开和关闭垂直宽度自动调整大小。(从时间线的选项菜单中设置)
    • 实装了删除复制关键帧的功能。(delete键)
    • 现在可以通过多个选择变更关键帧插值方法。
  • 追加了通过双击轨道或效果列来扩展列的功能。
  • 您现在可以通过拖动在掩盖(隐藏)状态下打开和关闭参数。您可以高效地在多个参数之间切换。

《改善项目》

  • 修复了由于模型文件的参数结合状态导致Animator无法导入的问题。
  • 时间线放大/缩小功能已改进如下:
    • 使用Alt + 鼠标滚轮缩放时,以“光标”为中心放大/缩小
    • 支持Ctrl + 鼠标滚轮(仅限Graph Editor:垂直)
    • 修复了缩放时画面滚动的问题。
  • 选择多个关键帧时,变更为“使所选区域的背景颜色变暗”而不是“橙色突出显示”,以更清晰地查看选择状态。
  • 修复了隐藏包含音轨的组轨道时,音频静音的问题。
  • 修复了使用关键帧编辑撤消时,选择区域和播放位置的位置未撤消的问题。
  • 修复了在时间线中变更duraion、workspace后,无法撤消的问题。
  • 修复了在Graph Editor中移动键时,贝塞尔控制器位置被重置的问题。
  • 修复了在Graph Editor中按[Enter]键播放时,编辑内容偶尔会出现变更的问题。
  • 修复了Graph Editor上有两个键时,上下移动无法正常工作的问题。
  • 修复了通过Cubism 3输出的mtn文件的口形同步和眨眼设置没有应用在Viewer中的问题。

3.0.12(2017/08/28)

Modeler

《改善项目》

  • 修复了3.0.11中出现的小图形网格的单击选择不能用箭头工具等正确完成的问题。
  • 修复了物理模拟GUI编排被破坏的问题。

3.0.11(2017/08/17)

Modeler

《功能追加》

  • 正式支持物理模拟设置功能。追加了:
    • 预置常用设置
    • 物理模拟模型预览
    • 模型摇动幅度的半自动调整
    • 播放动态时的动作检查
    • 读写physics3.json
      等方便使用物理模拟的功能。
      关于菜单,beta版是“菜单 > 文件 > 打开Viewer”,但在正式版
      已更改为“菜单 > 建模 > 打开物理模拟设置”。
      详细操作方法等请参考以下手册。
      关于物理模拟设置
      如何设置物理模拟
      【注意事项】
      由于正式支持对计算处理进行了较大修改,因此,beta版中设置的物理模拟将无法正常工作。
      对于给您带来的不便,我们深表歉意,但请重新设置。
  • 模型中使用的纹理已扩展,因此可以使用更轻的纹理进行显示和编辑。(缩小倍率支持1/2、1/4、1/8)
    • 如果减半,则纹理面积缩减为1/4,提高导入和编辑速度,减少内存记忆使用量。
    • 显示倍率可以从“显示”菜单 > “显示质量(模型导引图像显示)”、或在项目面板上选择模型时从检查器中选择。
  • 当前视图的显示状态已扩展,以便可以从“显示”菜单 > “”中检查和设置。
    • 显示状态为模型导引图像显示或纹理集显示。
    • 仍可使用T键进行切换(标准设置时)
  • 当用[T]切换显示方式时,画布上的信息从“原图显示”变更为更合适的“模型导引图像显示”。
  • 在参数面板中追加了用于在选择多个参数时更改顺序的功能。
  • 支持转换路径的多个点选择和边界框编辑。

《改善项目》

  • 修复了将参数面板置入视窗右端时,子菜单视窗显示在画面外,无法操作的问题。
  • 修复了模型以缩小尺寸显示(模型导引图像显示)时,与正确显示(纹理集显示)略有不同的问题。
  • 变更参数范围时,如果设置得比当前关键点更窄,则会显示确认对话框“您要变更范围吗?”作为警告。
  • 修复了即使在参数变更对话框中取消变更也会应用变更的问题。
  • 修复了关键点编辑对话框中对话框闪烁(无法追加键)的问题。
  • 修复了光标在字符输入框时,Ctrl + S等快捷键不起作用的问题。
  • 修复了导致图片内存记忆管理状态无效的问题。

Animator

《功能追加》

  • Animator间隔调整功能改进如下。
    • 修复为可以连续应用。
    • 修复为保持应用后的值。
    • 修复为在显示对话框时,可以重新封闭关键帧选择区域。
  • Animator的Graph Editor改进如下。
    • 追加了一条值为0的整数线。
    • 修复为垂直栅格随着键的移动而移动。
    • 修复了垂直栅格的值超过参数上限/下限的问题。
  • 您现在可以选择多个时间线上组列(粉红色)的关键帧。
  • 实装了在Graph Editor中切换键值列表的功能。
  • 在轨道的部件显示中插入关键帧时,将默认曲线类型从“顺畅”变更为“步”。
  • 修复为从参数滑块变更键值时,根据参数范围将其设为一个合适的值。

《改善项目》

  • 修复了删除场景后未执行任何其他操作而关闭Editor时,不显示保存确认对话框的问题。
  • 修复了在Graph Editor的链接参数上使用滑块插入关键帧时,图形未更新的问题。
  • 修复了无法在Graph Editor上将关键帧直接插入到链接参数中的问题。
  • 修复了删除或复制场景后,在场景面板中选择的场景与视图上显示的场景不同的问题。
  • 修复了时间线上按右键显示的关键帧操作菜单在效果轨道上不显示的问题。
  • 修复了当轨道水平移动时曲线类型会被重置的问题。
  • 在场景检查器中追加了文件名称项目。
  • 修复了选择多个关键帧并移动后,使用撤消返回时,仅选择范围不返回的问题。
  • 修复了在参数滑块上更改关键帧值,会解除设置的曲线类型并导致顺畅的问题。
  • 修复为置入模型时的默认大小为100%。
  • 修复了在循环参数集复制设置场景后,触摸循环参数时Editor冻结的问题。
  • 修复了移动设置为反向的键时,解除反向的问题。
  • 修复了切换场景时,无法使用快捷键进行关键帧复制/贴上等操作的问题。
  • 修复了使用快捷键播放和停止动画时,响应延迟的问题。

3.0.10(2017/08/03)

通用

《改善项目》

  • 修复了macOS版的许可证输入画面显示在许可证验证画面背面的问题。
  • 修复了在使用滑动变更面板的值时,如果通过切换视窗等变更焦点,光标将保持透明的问题。
  • 修复了在最小化Editor时,仍显示参数和绘制顺序的弹框菜单对话框的问题。

Modeler

《改善项目》

  • 正式解决了在Windows 10 Creators Update环境中启用GodMode后显示文件选择对话框时,应用程序异常退出的问题。
  • 解决了多个应用程序同时写入同一个文件时创建无效文件的问题。
  • 修复了操作“Ctrl + Space + 拖动”时放大/缩小方向与显示图标不同的问题。
  • 修复了按下部件面板、变形器面板的“全体展开/打开/关闭”按钮时,选中状态的显示消失的问题。
  • 修复了从画布上的按右键菜单中选择物体时,参数面板未更新的问题。
  • 修复了栅格设置未保存的问题。
  • 当一个元素无法在部件面板、变形器面板中编辑(被其自身或父级锁定)时,相应的物体将变灰。
  • 修复了结合参数后,即使是通用关键点,键也显示为黄色的问题。
  • 修复了在关闭参数文件夹的情况下移动时,隐藏文件夹内容的问题。
  • 修复了当您从部件和变形器面板中选择一个物体,并尝试使用“方向键”移动它时,面板中物体的顺序发生更改而不是视图中移动物体位置的问题。
  • 修复3.0.08之后参数无法多选并删除的问题。
  • 修复了3.0.08之后删除参数后,Undo不起作用的问题。
  • 修复了弯曲变形器转变的分割数和贝塞尔的分割数可以输入超过上限的数值的问题。
    • 即使分割数设置为超过上限100,也会被替换为100。
  • 修复了模型显示在某些条件下被破坏的问题。
    (在组合使用混合模式(通常、加算、正片叠底)、剔除开/关、剪贴有/无时发生)
  • 修复了导入部分文件时显示如下错误的问题、以及输出文件时输出大量错误的问题。
    ERROR [ deserialize failed : wrong CImageResource :.. 略
    * 第一次导入时会出现同样的错误,但通过使用此版本输出,不会出现同样的错误。
    * 通过本次修改,废弃了不必要的数据,部分文件的数据大小会变小。
  • 关于moc3输出,修复了SDK和Editor之间动作不同的以下错误。
    • 如果在参数的最小值~最大值范围之外按下某个键,则删除该键并输出。

Animator

《功能追加》

  • 实装了将工作区信息输出到动态数据的功能。
  • 实装了将模型文件拖到检视区域的选项卡显示部分后打开模型、拖到选项卡下方后追加模型轨道的功能。
  • Modeler上连接的参数现在可以在Animator上重现。

《改善项目》

  • 修复了打开包含音频文件的canx文件时,如果音频文件的路径包含日文,则无法正常工作的问题。
  • 修复了载入canx时,如果是在2.1中使用QuickTime的数据,则无法载入音轨的问题。
  • 修复了创建模型轨道时,轨道名称和文件名称不匹配的问题。
  • 修复了执行“用音频文件自动生成场景”时,第一个置入的模型的位置和场景大小没有应用的问题。
  • 修复了选择和移动多个关键帧时,某些键不跟随的问题。
  • 修复了在Modeler侧更改部件结构后,即使在Animator侧刷新模型,部件结构也不匹配建模器侧的问题。
  • 修复了输出png连序时进度条无法取消的问题。
  • 修复了动态数据中模型不透明度和部件不透明度的数值范围不统一的问题。
  • 修复了动态数据(motion3.json)中平滑曲线的贝塞尔控制器与1/3、2/3的位置不匹配的问题。

3.0.09(2017/07/27)

Modeler

《改善项目》

  • 临时解决了在Windows 10 Creators Update环境中开启GodMode时,显示文件选择对话框时应用程序异常推出的问题。
    同时,文件选择对话框的部分将为英文显示。
  • 修复了在Cubism Editor 3.0.08 或更高版本中,满足以下条件的Cubism 2.1模型文件(cmox)无法打开的问题。
    • 在2.1上重新载入PSD文件时,包含从新PSD放弃层生成的绘制物件(图形网格)的cmox文件

3.0.08(2017/07/20)

Modeler

《功能追加》

  • 实装了“自动生成四角形状”中记忆前一次参数设置的功能。
  • 改进为仅显示“自动生成四角形状”中当前选择物体可用的参数。
  • 改进为切换到“胶水”工具时,如果未选择物体,则显示所有胶水的选项卡。
  • 改进为在变形路径编辑以外的状态下选择转换路径点时,通过选择“编辑”菜单 > “删除”(或Delete键)删除转换路径。
  • 选择转换路径后,可以对要转换的图形网格进行颜色区分并识别。
  • 主图形网格显示为蓝色,子图形网格显示为红色。
    (转换路径保持为主图形网格的选项元素)
  • 实装了在检查器中显示的功能,以便在选择转换路径时可以识别要转换的图形网格。
  • 变更为在项目面板 > 原图中将文件扩展名.psd添加到PSD文件名称。
  • 按右键菜单中追加了参数编辑功能。

《改善项目》

  • 修复了最后一张纹理集无法删除的问题。
  • 将网格编辑时的“生成多边形”按钮变更为“自动连接”。
  • 修复为在自动生成网格预置中,于按钮之间追加了一个余量,以防止错误操作。
  • 修复为“覆盖”自动网格生成预置时显示确认对话框。
  • 修复为如果在未选中状态下开始网格编辑,工具按钮将变为错误状态。
  • 修复了转换路径的“变形路径宽度”可以设置为负值的问题。
  • 修复了转换路径的折线设置无法Undo的问题。
  • 修复了当转换路径中有两个控制点时,部分线条显示不完整的问题。
  • 修复了在某些条件下尝试移动转换路径时,导致错误发生并且不移动的问题。
  • 修复了读取包含无效转换路径的模型时,出现显示数字的错误对话框,之后该错误继续出现的问题。
    • 读取时删除处于无效状态的转换路径。(计划单独修复处于无效状态的问题)
  • 修复了对编辑级别2、3设置转换路径时,其中之一不响应Delete键的问题。
  • 修复了在将转换路径应用于多个图形网格时,若执行自动网格生成等,将无法正常工作的问题。
  • 修复了绑定胶水时,3个或更多点绑定在一起的问题。
  • 修复了将胶水绑定到大量点时,需要很长时间处理的问题。
  • 改进了胶水权重的显示颜色,使印象更恰当。
  • 修复为防止设置有胶水的物体进行自动网格生成。
  • 修复了“放大缩小指定倍率”功能在某些情况下无法正常工作的问题。
  • 修复了从按右键菜单中的“选定的物体”分层列表中选择物体后,面板和检查器的状态不更新的问题。
  • 修复了导入2.1的模型(.cmox)时,透明部分颜色发生变化的问题。
    (当高透明度的PSD层作为多个绘制物件置入时发生)
  • 修复了在部件面板和变形器面板中拖放时,高亮颜色与图标重叠的问题。
  • 修复了反转弯曲变形器时,角落的三角形消失的问题。
  • 修复了创建变形器时选择部件后,可以在“部件父级”中创建变形器的问题。
  • 修复了在变形器面板中选择并移动多个元素后,选择状态未正确绘制的问题。
  • 修复了变形器面板中元素的顺序与部件面板的顺序不同的问题。
  • 修复了在变形器面板中拖放元素时,未突出显示单元格的问题。
  • 修复了如果没有变形器,图形网格不会显示在变形器面板中的问题。
  • 修复了在变形器面板中移动元素时,导致元素变平而不保持层次结构的问题。
  • 修复了无法将元素追加到变形器面板中的根层次结构的问题。
  • 变更了弯曲变形器和旋转变形器创建对话框中“插入目标部件”和“名称”的项目顺序。
  • 修复了选择多个旋转变形器并移动原点时,仅移动一个旋转变形器的问题。
  • 修复了选择旋转变形器和表面变形器并移动原点时,表面变形器的类贝塞尔手柄没有出现的问题。
  • 修复了导入部分2.1模型并输出moc时,表达与2.1和3.0 Editor不同的问题。
  • 修复了针对与两个或多个参数关联的物体,如果删除任意一个参数的所有键,则形状可能会损坏的问题。
  • 修复了未选中物体且不显示边界框时可以操作边界框的问题。
  • 修复了在创建纹理集后,通过预置执行自动网格生成时出现错误的问题。
  • 修复了导入通过Fire Alpaca等部分软件输出的PSD文件时,颜色发生变化的问题。
  • 修复了在多视图中将鼠标悬停在物体上时,工具提示会出现在所有显示视图中的问题。
  • 修复了通过3.0读取替换PNG的cmox文件时,多个物体使用同一区域的部分暗度变暗的问题。

Animator

《功能追加》

  • 实装了在场景面板上按“名称”排序的功能。
  • 实装了链接模型轨道倍率编辑XY进行编辑功能。
  • 实装了轨道的“显示/隐藏”功能和“锁定/静音”功能。
  • 追加了辅助线显示功能。

《改善项目》

  • 修复了选择连接参数后,在Graph Editor中仅显示其中一个的问题。
  • 修复了时间线组中绘制顺序颠倒的问题。
  • 修复了交换模型或背景轨道前后顺序时,即使置入下方的轨道向上移动也无法交换的问题。
  • 修复了无效信息输出到动态数据(motion3.json)段的问题。
  • 修复了切换场景时,展开的轨道会关闭的问题。
  • 改进使在切换场景时保持选择状态。
  • 修复重启Editor后音轨位置重置为0秒0帧的问题。
  • 修复了在设置音频文件的状态下勾选“限制用于SDK”时,贝塞尔曲线的形状未实时更新的问题。
  • 修复了如果您在工作区开始和音频文件开始之间停止播放,重新开启时音频将重叠播放的问题。
  • 修复了在复制&贴上组的置入和不透明度时,也会复制&贴上到组中的轨道的问题。
  • 修复了选择模型轨道上的多个关键帧并执行删除或复制时,仅应用部分键的问题。
  • 修复了选择模型轨道或效果列的键并调整间隔时,仅应用部分键的问题。
  • 修复了在按时间线上的键后,使用工作区橙色条左端的箭头移动全体时间线时,键消失的问题。
  • 修复了播放动画时模型从画布突出的部分被隐藏,停止时不会变成半透明的问题。

3.0.07(2017/07/06)

通用

《功能追加》

  • 实装了在打开由新应用程序而不是当前打开的应用程序所生成的文件时,发出警告的功能。(使用cmo3、can3时)

《改善项目》

  • 解决了读取2.1模型(cmox)时缺少网格的问题。
  • 解决了物理模拟中中段部件设置的反应速度设置为“0”时停止工作的问题。

Modeler

《功能追加》

  • 实装了删除未使用模型导引图像的功能。您可以通过以下方法将其删除。
    • 右键单击项目面板中的模型名称 > 模型导引图像,并选择“删除未使用的模型图像” * 仅在有未使用的模型导引图像时可用
    • 右键单击项目面板中的模型名称 > 模型导引图像 > 组名,并选择“删除未使用的模型图像” * 仅在有未使用的模型导引图像时可用
    • 在项目面板中右键单击模型名称 > 模型导引图像 > 组名 > 模型导引图像名称,并选择“删除模型导引图像” *仅在未使用时可用
  • 实装了删除空模型导引图像组的功能。
    • 右键单击项目面板中的模型名称 > 模型导引图像,并选择“删除空的组” * 仅在有空组时可用
  • 实装了在检查器中变更模型导引图像组名的功能。
    • 您可以选择项目面板 > 模型导引图像中的组,并从检查器进行变更。
  • 实装了查看模型导引图像使用状态的功能。
    • 当您在项目面板中选择各模型导引图像,则可以在检查器中检查图形网格的数量和纹理集中的置入数量。
  • 实装了在与模型导引图像关联的原图中解除不是当前使用原图的连接的功能。
    • 在项目面板中选择各模型导引图像,并按右键执行“除当前使用的之外,解除与原图的连接”
    • 在项目面板中选择各模型导引图像组,按右键执行“除当前使用的之外,解除与原图的连接”后,将对组内的所有模型导引图像进行相同的处理。
  • 实装了删除空模型导引图像组的功能。
    • 在项目面板中,右键单击模型导引图像(列表)并选择“删除空的组”。
    • 在项目面板中,右键单击模型导引图像组并选择“删除组”。
  • 实装了选择使用模型导引图像的图形网格的功能。
    • 在项目面板中,选择各模型导引图像,按右键执行“选择相关的图形网格”。

《改善项目》

  • 修复了在检查器中变更物体名称后,树未更新的问题。
  • 修复了在检视区域中打开“锁定变形器”时,显示部分GUI的问题。
  • 修复了父级部件不可见的图形网格转换路径显示在画布上的问题。
  • 修复了在选择多个参数的状态下移动后再次尝试移动时,会被当作单选处理的问题。
  • 修复了即使在参数面板上变更了参数顺序,也不会应用在参数设置对话框的顺序中的问题。
  • 修复了锁定父级时,未锁定转换路径的问题。
  • 修复了部件锁定时物体绘制状态的问题。
  • 修复了绘制顺序组中有绘制顺序组时,绘制顺序不能正确应用,且显示不正确的问题。
    • 如果您是在3.0.06之前的同样情况下输出moc3,则可以通过再次输出,以在SDK上正确显示。
  • 修复使编辑纹理集画面倍率设置的快捷键与2.1相同。
  • 修复了编辑网格时丢失的问题。
  • 修复了“保持边轮廓”无法正常工作的问题。
  • 修复了“网格重建”无法正常工作的问题。
  • 修复了选择图形网格并反转时,参数反转无法正常工作的问题。
  • 修复了图形网格化的快照处于不正确状态,且cmo3文件无法正确导入的问题。
  • 修复了一个图形网格中有多个单独的网格区域时,它们将被连接的问题。
  • 修复了在连续多次从快照生成图形网格时导致状态不正确的问题。
  • 修复了关闭部件面板中“联动选择状态打开树”时,出现错误动作的问题。
  • 修复了无法正确应用显示/隐藏部件的问题。
  • 修复了在变形器面板中单独解除锁定时,无法解除父级锁定的问题。
  • 修复了当所有变形器都隐藏时,即使打开图形网格显示,它们也不会显示的问题。
  • 追加了在变形器面板和画布上选择“变形器的子元素”的功能。

Animator

《功能追加》

  • 根据SDK规范实装了贝塞尔控制器限制功能。

《改善项目》

  • 修复了复制置入背景的场景时,背景和模型的前后关系与复制源不匹配的问题。
  • 现在可以在选择关键帧时,批量选择轨道列和效果列中的键。
  • 修复了如果工作区的结束点设置在音频中间,在结束点之后会继续播放,且音频重复的问题。
  • 修复了在选择音轨并尝试在画布上编辑时出现错误的问题。
  • 修复了在时间线中变更场景长度未应用在检查器或场景面板中的问题。
  • 修复了当时间线面板位于检视区域一侧时,由于时间线原始化错误而无法打开动画文件(can3)的问题。
  • 修复了在时间线面板上选择轨道时,它不会立即应用在画布上的问题。
  • 修复了从场景面板复制场景时追加选项卡的问题。
  • 修复了每次打开场景时都会在视图上创建选项卡,导致无法选择选项卡的问题。
  • 将在场景面板中打开场景的操作从“双击”变更为“单击”。
  • 追加/修改了功能,以便在打开动画文件时执行多视图。
  • 修复了切换选项卡时,场景面板的选择/显示状态与画布的选择/显示状态不同的问题。
  • 修复了打开多个动画文件时,即使切换选项卡,场景面板的内容也不会切换的问题。

3.0.06(2017/06/23)

Animator

《问题修复》

  • 修复了将设有眨眼和口形同步的模型导入到时间线时,模型在画布中的显示倍率发生变化、Editor的操作变得繁重的问题。

3.0.05(2017/06/22)

通用

《改善项目》

  • 修复了解除绑定许可证时,不显示文件保存信息的问题。
  • 修复了在macOS版中编辑Viewer的物理模拟设置时,无法顺利输入的问题。
  • 修复了macOS版中Viewer的“复原”和“重做”修饰键不是commad键的问题。
  • 修复了在物理模拟的输入设置中指定“Angle”类型时无法正常工作的问题。
  • 修复了在Editor中按下Enter键执行播放/停止命令时出现错误的问题。
  • 修复了Viewer物理模拟设置按钮被截断的问题。

Modeler

《功能追加》

  • 实装了在输出模型时,如果残留已替换的PSD文件,则进行检查并删除的功能。
  • 修复为在分层显示检查器上的部件设置。
  • 在参数列表中追加了说明栏。
  • 实装了参数排序时自动滚动功能。

《改善项目》

  • 修复了选择旋转变形器时,工具提示中不显示变形器名称的问题。
  • 修复了工作区中动画面板置入,以便通过重置工作区(默认状态)显示参数面板。
  • 修复了画布按右键菜单中的“对齐选定的物体的参数配置”功能无法正常工作的问题。
  • 修复了创建弯曲变形器对话框的UI根据环境而折叠的问题。
  • 修复了将使用胶水的模型输出到moc3后,使用SDK导入时可能出现错误的问题。
    重新输出moc3将解决SDK中出现的错误。
  • 修复了使用参数面板进阶搜索显示时,无法选择参数导致无法手动编辑键的问题。
  • 修复了可以在检查器中将自己指定为父级部件的问题。
  • 修复了部件面板中“绘制顺序”显示保持在500不变的问题。
  • 修复了点击参数面板上的键时,可以创建具有较多位数数字的键(例如10.333333)的问题。
  • 修复了使用Ctrl + Space放大时,不应用倍率数值的问题。
  • 修复了选择部件面板中的部件时,可能无法选择和展开的问题。
  • 在ID转换工具中追加了用Part <-> PARTS替换部件ID的第一个字符串的选项。
  • 修复了在面板上选择时,无法使用Ctrl + C(快捷键)复制的问题。
  • 修复了在部件面板中选择部件并执行“选择所有子级物体”处理时,选择部件面板中的过滤物体的问题。
  • 修复了在部件面板中选择物体时,不解除过滤物体选择的问题。
  • 修复了在部件面板中选择部件并执行“选择所有子级物体”处理时,当子元素包含部件时未选择部件的问题。
  • 在部件面板元素的按右键中追加了复制、剪切和贴上功能。
  • 修复了通过选择部件面板中部件以外的其他内容来显示按右键时,“选择所有子级物体”变为有效的问题。
  • 修复了在部件面板使用Alt键选择所有子级物体时,焦点转移到主菜单并且选择状态不正确的问题。
  • 修复了当按下ESC时,部件面板和变形器面板的选择状态没有正确更新的问题。
  • 修复了在部件面板中移动项目后,可能无法保持层次结构的问题。
  • 修复了在部件面板中移动部件中的物体时顺序颠倒的问题。
  • 修复了在部件面板中选择多个物体时,多个元素选择不应用在变形器面板中的问题。
  • 修复为参数中不通用的关键点以黄色显示键颜色。
  • 解决了在将转变分割数的长或宽为1的弯曲变形器输出为2.1cmox、moc时发生错误的问题。
    2.1的表面变形器会自动转变为2 × 2并输出,因为2 × 2是最小分割数。
  • 解决了2.1cmox、moc输出时,如果有图形网格没有置入纹理集则会发生错误,导致无法正常输出的问题。
    未置入在纹理集中的图形网格将在发出警告后被放弃并输出。
  • 解决了2.1moc输出时,如果选择了1/2、1/4等纹理大小,根据数据内容无法正常输出的问题。
  • 修复为纹理集自动编排时出现进度条。
  • 修复了在开始编辑纹理集时,能够删除非图形网格的模型导引图像的置入。
    修复为非图形网格的模型导引图像在编辑Atlas时于画面上显示“No ArtMesh”(之前显示为no polygon)。
  • 编辑纹理集时,从右侧模型导引图像列表中排除了非图形网格的模型导引图像。
  • 解决了如果检查器中将部件的父级部件设置为自身或子元素,会导致错误状态的问题。
  • 解决了载入PSD时,层组的显示/隐藏没有正确应用的问题。
  • 在3.0.04中,笔刷大小(笔刷选择、编辑网格时的橡皮擦、胶水调整)的下限设置为10,且为解决无法做细节工作的问题,将下限变更为1.0。
  • 解决了将针对2.1输出的模型重新导入到3.0时,会导致出现ID重复错误的问题。
  • 修复了模型关闭时,内存记忆未释放的问题。
  • 解决了某些特定模型时,部分图片消失的问题。
  • 解决了可以生成只有2个点或更少点的图形网格的问题。
    请查看FAQ的Q19,了解如何恢复已创建的2点或更少的图形网格。
  • 解决如果同时选择了存在父子结构的变形器并进行反转,父变形器反转后,子元素也会反转,导致子元素双重反转,外观无反转的问题。
  • 解决了在应用模型模板后,将大量PSD载入到部件面板中时,会留下空白部件的问题。
  • 解决了重新载入PSD时,即使匹配完全成功,也会创建一个不匹配的文件夹的问题。
  • 解决了在选择旋转变形器的情况下创建弯曲变形器时,显示错误消息并且未创建变形器的问题。
  • 解决了3.0创建的模型作为模型模板使用时,无法在应用画面上播放的问题。
  • 解决了2.1模型中跨类型使用相同ID字符串时,3.0无法导入的问题。
  • 修复了锁定、显示/隐藏也适用于部件的问题。
  • 修复了锁定、显示/隐藏的Undo、Redo不起作用的问题。
  • 修复了主菜单的锁定、显示/隐藏有效状态无效的问题。
  • 我们加快了Viewer中的模型显示速度,提高了显示质量,并减少了内存记忆使用量。

Animator

《功能追加》

  • 您现在可以在3.0中使用2.1动画模板文件。
  • 为2.1的SDK和Viewer实装了输出动态数据(mtn)的功能。
  • 在Dope Sheet中追加了垂直栅格线。
  • 在主菜单中追加了模型更换(所有场景)项目。
  • 实装了在Graph Editor中选择多个关键帧并缩放边界框时,使用Shift键的辅助功能。
  • 实装了在Graph Editor中Shift + 关键帧移动时锁定X轴的功能。

《改善项目》

  • 修复了模型置入和音频导入无法Undo的问题。
  • 修复了在Graph Editor上撤消追加在Dope Sheet上的关键帧时,不会立即应用的问题。
  • 修复了应用动画模板后,即使选择多个键也会发生单个键移动的问题。
  • 修复了应用动画模板时,视图中模型没有动态变化的问题。
  • 解决了未应用轨道的“置入&不透明度” > “倾角(Sheer)”的问题。
  • 解决了变更场景大小后,无法在画布上正常编辑轨道的问题。

3.0.04(2017/06/12)

Modeler

《改善项目》

  • 解决了应用模板时输出错误记录的问题。
  • 解决了应用模板后Undo时,旋转变形器留在左上角(0,0)的问题。
  • 解决了将3.0格式ID(ParamAngleX等)的模型数据作为模板使用时,无法正常工作的问题。
  • 解决了将带有无父级部件的变形器的模型作为模板使用时,无法正常工作的问题。
  • 解决了3.0.03或更高版本中,某些数据可能无法复制和贴上的问题。

Animator

《改善项目》

  • 解决了部分动画数据无法正常导入的问题。

3.0.03(2017/06/05)

通用

《功能追加》

  • 实装了免费版本。与Pro版的功能差异请参考以下内容。
    [Cubism 3 PRO/FREE 功能对比]
  • 追加了Viewer功能。您可以在Viewer中使用物理模拟功能(beta)。
    物理模拟功能的使用方法请参考以下手册。
    [物理模拟(beta)]

《改善项目》

  • 更正了GPU原始化时与环境相关的标签名称。
  • 更正了帮助 → 版本信息的符号。
  • 将最小视窗大小变更为800 * 600。
  • 追加了处理,在尝试打开2.1模型时,将提示ID转变。
  • 修复了支持清单中的[打开记录文件]路径。
  • 更新了支持清单的链接目的地的URL。
  • 修复了在关闭项目面板上的模型、动画文件时,Editor关闭前无法删除该文件的问题。
  • 解决了对话框出现在与应用程序无关位置的问题。
  • 解决了显示Modeler/Animator画布大小的框架转向角色背面,且看不到框架的问题。

Modeler

《功能追加》

  • 追加了ID转换工具。可以将2.1的ID转变为3.0推荐的ID格式。
  • 追加了在使用Alt + 单击选择部件时,与2.1一样选择部件中所有物体的处理。
  • 搭载了生成重叠检测用图形网格的功能。
    [建模菜单 > 图形网格 > 创建重叠检测用图形网格]
  • 追加了编辑纹理集时,模型导引图像列表扩展为显示在右端,
    可以将未放置的模型导引图像置入纹理集中的功能。

《改善项目》

  • 修复了单击部件面板中的物体后,如果将其向左或向右稍微移动,则该物体将移动到部件的底部或顶部的问题。
  • 修复了在创建部件时,可以创建超出绘制顺序范围(0~1000以外)的部件的问题。
  • 修复了Mac版部件面板的绘制顺序为1000时,显示为[…]的问题。
  • 修复了在面板之间同步选定的物体的问题。
  • 修复了使用绘制顺序递增、递减功能时,绘制顺序值可以设置在范围之外的问题。
  • 修复了双击部件时,选择状态关闭的问题。
  • 修复了在视图中按右键选择网格时,部件面板上不显示为选中状态的问题。
  • 修复了创建弯曲变形器后,在参数面板中追加键时,追加目标变得不自然的问题。
  • 修复了尝试在检查器上滑动设置图形网格的不透明度时,数值和显示不匹配的问题。
  • 修复了锁定图形网格时,显示转换路径的问题。
  • 修复了GUI重叠显示在视图菜单和图形网格编辑菜单上的问题。
  • 修复了旋转变形器的前端由于相机的倍率而变得难以看到的问题。
    此外,修复了旋转变形器前端的手柄焦点因相机的倍率而偏移的问题。
  • 修复了在部件面板中删除部件时,变形器面板未更新的问题。
  • 追加了一个显示弹窗的处理,以说明按下胶水图标时如何使用胶水。
  • 解决了Ctrl + 拖动旋转变形器时,发生略微变化的问题。
  • 解决了Cubism 2.1中也会出现的“旋转变形器插入表面变形器时错位”的问题。
  • 解决了读取cmox时,无法正常导入反转元素的问题。
  • 解决了旋转变形器形状混合无法正常工作的问题。
  • 修复为在自动网格生成时,避免处理完成前执行其他操作,且变为错误状态。
  • 解决了选择多个图形网格并进入网格编辑模式后,顶点无法正常编辑的问题。
  • 解决了复制图形网格时,无法在SDK上正确关联纹理的问题。
  • 解决了在编辑纹理集时,即使删除了空的图形网格并按OK,它也不会消失且保留的问题。
  • 解决了在纹理集中多次置入相同模型导引图像的问题。
  • 解决了导入PNG参考图后尝试重新载入PSD时无法正常工作的问题。
  • 解决了重新载入PSD时出错,且无法正常工作的问题。
  • 解决了笔刷选择、橡皮擦、胶水功能等指定范围的工具,在使用B + 拖动变更大小时,如果一次变得太小,将无法正常工作的问题。
  • 解决了使用PNG图片置入、快照等后,重新载入(替换)PSD没有应用的问题,以及旧的原图(PSD)无法删除的问题。
  • 解决了尝试编辑部分物体时,参数值动作不正确的问题。
  • 修复了将新键追加到具有两个或多个相关参数的物体时,形状折叠的问题。
  • 解决了输出和导入部件时,物体顺序被打乱的问题。
  • 解决了在某些条件下无法输出moc3的问题。
  • 解决了选择多个图形网格并进行网格编辑时,无法正常编辑顶点的问题。
  • 修复为在混合形状时打开上一次使用的值作为默认状态。
  • 解决了执行“选择父变形器”时,部件面板和变形器面板的选择状态没有改变的问题。

Animator

《功能追加》

  • 您现在可以在时间线上移动一个关键帧。
  • 将所选轨道的标签变更为较深的颜色,以便更容易在时间线上看到“所选轨道”。
  • 追加了轨道复制功能。(按右键 → 弹框菜单)
  • 实装了动画模板功能。
  • 贴上关键点和应用动画模板时,显示适用范围。

《改善项目》

  • 修复了如果Graph Editor中贝塞尔控制器超过所击键的最大值和最小值时无法抓取手柄的问题。
  • 修复了在Animator中置入素材时,锚未设置到中心的问题。
  • 修复了在特定环境中展开时间线面板中的所有动画轨道并播放动画时,帧率急剧下降的问题。
  • 修复了曲线类型被重置的问题。(拖动键、复制贴上、调整间隔后)
  • 改进了动画播放速度控制UI。
  • 修复了键移动、复制和贴上的Undo处理。
  • 修复了在时间线上选择多个列的键,并按右键显示弹框的状态下,拖动该键只会移动一行的问题。
  • 由于难以了解选择状态,因此对关键帧的选择范围进行了修正,使其完全被选择区域(蓝框)包围。
  • 修复了使用Backspace/Delete键删除键时,轨道的展开状态关闭的问题。

3.0.02(2017/05/11)

通用

  • 修复了残留已从场景面板中删除的场景选项卡的错误。
  • 修复了即使单击工具栏编辑级别图标也不变化的问题。
  • 修复了部件数据的文件图标显示不正确的问题。
  • 更正了英文版UI的一般措辞。
  • 修复为在GPU不满足运行环境要求时通知用户。
  • 修复了部分在更新绘制时不必要地消耗内存记忆并且无法正常工作的问题。
    • 虽然这个问题的稳定性得到了显着改善,但仍然存在部分问题,我们计划在下一次更新中解决。
  • 修复了应用程序安装信息在Windows上显示不正确的问题。
  • 修复Windows中登录用户的账号名包含空格时无法启动Editor的问题。

Modeler

  • 修复了在macOS上未选择任何内容的状态下按右键时,不显示弹框菜单的问题。
  • 修复了英文版macOS中参数文本框弹出的菜单中选择、反转等按钮宽度变窄、字符中断的问题。
  • 修复了英文版macOS中创建变形器对话框中按钮上的字符被截断的问题。
  • 修复了当视图有两个或更多画面时,检视区域菜单中的“锁定图形网格”会应用在所有视图中的问题。
  • 修复了在未打开模型的情况下,尝试创建部件面板的部件、打开部件设置时发生错误的问题。
  • 修复了在模型未打开的情况下,尝试创建参数面板的参数、编辑参数、打开参数过滤器时发生错误的问题。
  • 修复为打开模型时,将编辑级别设置为2。
  • 修复了载入PSD时,按照2.1规格设置模型默认参数ID的问题。
    • 3.0以后的ID规格请参考以下手册。[FAQ]可以导入2.1模型吗?  
  • 将PSD载入时的图形网格默认ID从Layer更改为ArtMesh。
  • 修复了可以在网格线宽中输入无效值的问题。
  • 修复了3.0规格ID下随机姿势无法正常工作的问题。
  • 修复为删除自动网格生成的“预置”时显示确认对话框。
  • 修复了在部件列表中的变形器上移动多个部件并建立父子结构时,在绘制顺序相同的情况下,它们的顺序都相反的问题。
  • 修复了在打开纹理集编辑时按下空格键,会在按下OK按钮时退出编辑的问题。
  • 修复了通过按钮切换到网格编辑模式时,按空格键退出网格编辑的问题。
  • 修复了应用模板时参数面板未更新的问题。

Animator

  • 为防止时间线面板的错误操作,变更为当建模视图有焦点时不能进行操作。
  • 修复了在使用掩盖隐藏参数的状态下,选择隐藏参数下方的参数时,显示偏移的问题。
  • 修复了Ctrl和Alt键在macOS的时间线上不起作用的问题。

3.0.01(2017/04/27)

通用

  • 修复了macOS上语言区域为中国、韩国时,文字中包含日语的问题。
    • 将以安装程序对应的语言显示。
  • 修复了切换选项卡时,参数面板和时间线面板未更新的问题。

Modeler

  • 修复了选择物体时,检查器中显示的绘制顺序更新未正确显示(变为0)的问题。
  • 修复了英文版文字显示被破坏的问题。
  • 修复了参数面板上的文件夹图标显示不对齐的问题。
  • 针对在检视区域的按右键菜单中显示的变形器层次结构,修复为显示图形网格名称。
    • 如果没有名称,则显示ID。

3.0.00(2017/04/26)

通用

  • Modeler和Animator已统一,模型编辑和动画可以同时进行。
  • 借助多视图支持,您现在可以打开多个相同模型并进行编辑。
    • 您可以在多个视图中设置不同参数,并在查看显示的同时进行编辑。
    • 您可以在部分视图中播放动画,并在检查动作的同时进行编辑。
  • 借助多文档支持,您现在可以同时打开多个模型进行比较、复制和粘贴等。

Modeler

  • 载入PSD时,您不再需要先将其制作为纹理集。
    • 在创建动画时,您可以在不创建Atlas的情况下创建作品。
    • SDK开发所需的纹理集可以通过编辑纹理集进行创建和编辑。
  • 您现在可以同时编辑图形网格和变形器。
    • 如果要锁定图形网格并编辑变形器,可以使用Shift + A锁定图形网格。
    • 如果要锁定变形器并编辑图形网格,可以使用Shift + D锁定变形器。
  • 搭载了锁定默认形状的功能。
    • 如果开启“锁定默认的形状”,在编辑某些物体时选择了默认参数值,则会被锁定且无法编辑。
    • 能够在保持与原图完全匹配的状态下添加动作,有助于防止错误。
  • 搭载胶水(顶点吸附功能),接头等更易连接。
    • 现在可以自动连接不同图形网格的顶点。
    • 通过根据参数调整权重,可以定义微妙的动作。
  • 实装绘制顺序组。
    • 您可以为部件本身设置“绘制顺序”,并将嵌套物体的绘制顺序临时设置为与父文件夹相同。
    • 在绘制顺序组的部件内,为局部绘制顺序,绘制顺序仅在该部件内。
    • 现在可以为按绘制顺序分组的部件通过参数设置关键点。
  • 实装参数循环。
    • 现在可以使用单个参数来表达循环动作。
  • 大幅改进网格编辑功能。
    • 现在可以在主画布上的显示位置切换为网格编辑模式并进行编辑。
    • 现在即使在追加顶点后自由移动,也可以毫无问题地表达。
  • 您现在可以在之后实时应用自动网格生成。
    • 现在可以应用于单个图形网格。
    • 实装了可以保存设置值的“预置功能”。
  • 转换路径变更为全新形式。
    • 您可以为“编辑级别”的2和3分配不同的转换路径,并区分使用详细编辑和粗略编辑。
    • 转换路径现在自动跟随图形网格的变换。
    • 现在可以将多个转换路径与一个图形网格相关联。
    • 现在可以在非路径形状的“点”状态下进行影响。
    • 现在可以为每个路径设置转换路径的影响范围。
  • 改进以便当选定的物体处于由参数设置的键以外的不可编辑位置时,当您尝试编辑它时,它会自动移动到可编辑的键位置,然后开始编辑。
  • 改进了模型模板。
    • 匹配时,根据原始数据自动划分网格。
  • 大幅改进了参数面板。
    • 参数现在可以分层显示。
    • 现在可以通过面板上的按钮执行常用功能,例如键的2点插入、3点插入、删除等。
    • 现在可以通过拖放更改顺序。
    • 现在可以在面板上显示数值并使用滑块进行编辑。
  • 大幅改进了部件面板和变形器面板。
    • 图形网格现在显示为缩略图。
    • 现在可以在部件面板上过滤显示物体。
    • 部件面板现在支持多个层次。
    • 在部件面板上显示与Photoshop层相同的树形。
    • 绘制顺序以数值形式显示在部件面板上。
    • 在变形器面板中实装了显示/隐藏功能。
  • 实装了项目面板。
  • 搭载自动动画功能,无需设置动画即可预览动作。
    • 您可以从随机姿势菜单中选择3种模式。
  • 可以使用Solo功能(S键)临时显示仅选定的物体并进行编辑。
  • 使用对焦功能(F键)可以立即将选定的物体移动到显示中心。
  • 您现在可以将快照作为图形网格置入。
    • 可以将多个形状作为参考图置入、通过反转它们来使用、通过分配参数进行变换等。
  • 改进了弯曲变形器。
    • 现在可以连续创建弯曲变形器。您现在可以立即建立父子结构。
    • 现在可以直接编辑转变分割中设置的交叉分割点。
    • 现在可以在编辑时,选择6种贝塞尔编辑类型模式。
    • 现在可以实时变更转变的分割数和贝塞尔分割数。
  • 改进了旋转变形器。
    • 现在可以连续创建旋转变形器。由于它们是在相同位置创建的,因此可能不需要对齐。
    • 您现在可以设置基准角度。您可以通过输入双臂的位置等相对角度来进行旋转。
  • 实装了旋转变形器创建工具。
    • 通过在拖动时立即创建它,可以在调整位置及手柄长度的同时进行置入。

Animator

  • 您现在可以通过操作滑块直接在时间线上调整参数。
  • 实装了固定播放位置(插入符号)的功能。
  • 现在可以在秒和帧之间切换时间整数。
  • 您现在可以随时在检查器上变更场景信息。
  • 部件显示现在可以从简单的ON/OFF调整到不透明度调整。
  • 现在可以通过取消对要应用的参数数量的限制,并选中要应用的参数来设置任意次数的口形同步和眨眼效果。(详情请参考口形同步/眨眼设置方法)
  • 改进了滚动功能。
    • 通过鼠标滚轮进行垂直滚动
    • 通过Shift + 鼠标滚轮进行横向滚动
    • 通过Ctrl + 鼠标滚轮进行水平放大显示
    • 通过Alt + 鼠标滚轮进行垂直放大显示(仅限曲线)
  • 追加GUID识别功能,即使参数或部件的ID发生变更,Animator侧对应的关键帧也不会被擦除。
  • 动态数据的格式统一为json格式。
  • 改进了Graph Editor。
    • 拥有直线、平滑、贝塞尔、步、冲击步五种曲线,曲线操作更直观。
    • 现在可以从无、1帧、5帧和秒四个栅格线中选择栅格。
    • 曲线可以垂直放大。(Alt + 鼠标滚轮)
关于本报道,敬请提出您的意见及要求。