更新历史记录

您还可以在此处下载最新的Cubism Editor。

* 某些翻译可能需要一些时间。

 

4.2.01 (2022/09/27)

常见的

《改进项目》

・修复了在颜色设置中点击 ESC 键时对话框没有关闭的问题。
・修复了执行[重置对话框大小和位置]时[导出图像/电影]显示的对话框未重置的错误。
・修复了[编辑级别]的快捷键[1][2][3]在快捷设置对话框中有效,但按键设置为空白的问题。

建模

《改进项目》

・修复了使用变形画笔工具双击画笔按钮时导致选择某些文本的错误。
・Warp Deformer 将整形笔刷的鼠标光标更改为笔刷光标。
・修复了使用[B +拖动]调整变换画笔工具大小时导致画笔大小反转的错误。
・使用扭曲变形器的塑形刷时,已从工具细节调色板中删除了权重颜色项目。
・在零件面板中,将零件拖放到变形器上时发生错误。
・添加了一个警告对话框,使包含混合形状的模型不能被选为模板。
・调整了表单特殊粘贴选项对话框的初始大小。

动画

《改进项目》

・修复了[单独复制标签]对话框中场景和场景调色板的顺序相同的问题。
・在[单独复制标签]对话框中,具有相同参数组合的标签现在一起显示。
・修复了ID不匹配的参数不会在[单独复制标签]对话框中重复。

 

 

4.2.01 beta1 (2022/08/25)

常见的

《功能追加》

・现在可以在颜色设置中输入[RGB]和[HSL]的数值。
・添加了[重置对话框大小和位置]功能。

《改进项目》

・修复了在快捷设置对话框中连续双击群组时,无法打开和关闭群组的问题。
・修复了在快捷设置对话框中执行[载入]、[全部恢复]和[初始化]时保存项目选择、分组打开/关闭状态和滚动位置。
・整体调整了对话框显示位置的行为。
・在颜色设置中输入文本时,现在无需按 Enter 键即可反映颜色。
・在快捷设置对话框中为组添加了[展开全部/全部合并]按钮。
・添加了在使用 [选择] 参数选择对象时取消选择隐藏和锁定对象的功能。
・修复了自动备份设置的自动备份容量设置没有正确反映的问题。

建模

《功能追加》

・添加了[沿着贝塞尔手柄的变形变形器形状]功能。
・变形笔刷工具新增[变形变形刷]功能。

《改进项目》

・修复了[吸附到附近的键]、[选择上一个关键点]和[选择下一个关键点]快捷键在混合形状参数中无法正常工作的错误。
・修正了随机摆姿势时眼睛的开合不反映的问题。
・在参数键以外的地方,扭曲变形器修复了在操作后执行[重置为默认值]时导致手柄移动的错误。
・修复了组合参数时滑块线状态未正确更新的错误。
・您现在可以在密钥表单编辑对话框的列表中选择多个项目。
・扩展插值对话框现在总是显示在前台。
・修复了在键表单编辑对话框中无法滚动列表的错误。
・修正了在参数设置对话框中未经编辑而取消时显示不必要的确认对话框的问题。
・修复了使用套索或画笔选择工具进行选择和移动时手柄和顶点未对齐的错误。
・启用[锁定默认的变形器]时,图形网格修复了在同时选择艺术路径的同时操作变形路径的控制点时发生错误的错误。
・修复了物理计算组设置对话框中输入和输出参数警告信息的颜色显示未对齐的错误。
・修复了单击反转设置对话框中的复选框时滚动到顶部的错误。
・修复了混合形状重量限制设置对话框中参数名称超过一定长度时无法正确显示的错误。
・修复了物理设置对话框中的[启用物理]复选框将使用空格键打开/关闭的错误。
・修复了从文件中选择模板模型时的文件类型。
・修复了更改参数文件夹名称时撤消/重做无法正常工作的错误。
・修复了导出大尺寸 PSD 文件时无法导出文件的问题。
・修复了将最多 3 个参数与一个对象关联时,信息对话框显示两次的错误。
・修正了[蒙皮]和[变形路径进行蒙皮]中显示的信息对话框的措辞。
・在新参数创建对话框中单击[名称]、[ID]和[范围]时,现在选择所有字符串和数值。
・修正了在记录参数操作和生成动画时将物理计算FPS设置为添加场景的帧率。
・当参数的[变更]中没有候选更改目标时,现在会显示信息对话框。
・修复了勾选[锁定角度和放大率]时,可以使用快捷键更改纹理图集编辑的错误。
・修复了纹理图集编辑中的一个错误,该错误可以从另一个纹理移动到锁定的纹理。
・使用混合形状参数时,如果选择变形路径的多个控制点并使用边界框进行操作,图形网格修复了顶点没有正确移动的错误。
・修复了在特定程序中执行[恢复到最新的可见度]时未恢复先前显示状态的错误。
・修复了在部件面板中移动父部件和子部件时结构不正确的错误。
・修复了在选择零件时扩展/合并其他零件时,零件调色板和变形器调色板中任意滚动到所选零件位置的错误。

动画

《功能追加》

・添加了将参数书签标签复制到任何曲目的功能。
・添加了显示/隐藏轨迹轨迹以及设置轨迹颜色和形状的功能。

《改进项目》

・修复了变形画笔工具在 FA 视图中对变形器无法正常工作的问题。
・修复了在前面有隐藏曲目时点击视图时选择隐藏曲目的错误。
・修复了在图表编辑器的框编辑中更改参数值但未反映在图表中的错误。
・修复了在图形编辑器中编辑框时,光标键的左右移动会覆盖关键帧的错误。
・修复了导入场景时曲目名称未反映的错误。
・修正了图形编辑器值的内存显示不跟随滚动的问题。
・修正了运动数据设置对话框中组合框的垂直宽度。
・修正了编辑与 CAN3 文件链接的 CMO3 文件并在未保存的情况下关闭时,编辑仍保留在 CMO3 文件中的错误。
・修复了复制轨道时,图像序列轨道的导出设置无效的错误。
・开始免费版时,当加载超过时间线限制的模型时,将显示一个信息对话框,表示无法使用保存/导出。
・在图形编辑器中,现在可以同时编辑两个倍率 XY。
・修复了在图形编辑器中长时间编辑时导致错误的错误。

Cubism Viewer

《改进项目》

・根据 Cubism 4 SDK R5 的更正修改了 Cubism Viewer 中使用的算法。此更改对 Cubism Viewer 没有影响。

 

 

4.2.00 (2022/06/16)

有关此版本的新功能的详细信息,请参阅以下页面。
新功能介绍4.2

常见的

《功能追加》

- 增加了保存文件时如果保存未正常完成,重新保存文件的功能。
・不再支持 Windows 8.1。
・不再支持 macOS Mojave。

《改进项目》

- 修复了在多视图中使用[隐藏选择状态]时提示仍然显示的问题。
- 修复了修改键+Tab快捷键不起作用的问题。
- 修复日志显示两次的问题。

建模

《功能追加》

-在导出设置中增加了[将计算的FPS导出到物理模拟配置文件]项。
- 在编辑纹理集对话框的模型导引图像中添加了项目[仅放置和选择]。
 当您选择放置的图像时,它将显示在模型导引图像中。
- 现在,当打开“编辑纹理集”对话框时,会选择画布上的单个选定图形网格。

《改进项目》

- 修复了在随机姿势设置中更改参数组结构时UI不更新的问题。
- 修复了物理模拟设置类型的项目显示不正确的问题。
- 修复了物理模拟设置中撤销编辑时表格宽度被初始化的问题。
-[随机姿势设置]已添加到物理/场景混合设定中。
- 修复了将部件移入自己的层次结构时部件调色板处于无效状态的问题。
- 修复贴上复制对象时,可以将普通参数贴上到融合变形参数中的问题。
 
- 修复了将与普通参数相同ID的对象复制粘贴到融合变形参数时,Undo / Redo无法正常工作的问题。
 
- 修复了参数键的粘贴范围较小的问题。

动画

《功能追加》

- 增加了将参数书签的标签复制到另一个轨道的功能。

《改进项目》

- 修复了对有自动眨眼和口形同步的设定的参数,冻结不起作用的问题。
- 在参数书签中,您现在可以在更改键的当前值时输入数值。
- 场景切换和动画文件切换更快。
- 修复了拖动参数书签的标签时标签位置可能偏移的问题。
- 修复了在参数书签中点击参数时,参数组被选中的问题。
- 修复了在显示分辨率设置不同的环境中创建的标签中显示参数书签时,弹框显示在屏幕范围之外的问题。
 
- 修复导出动态文件时导出场景设置中的[输出所有场景]中动作文件没有正常导出的问题。
-使用免费版本编辑器创建运行时模型轨时,会显示一条带有保存/导出限制的警告消息。

Cubism Viewer

《改进项目》

- .physics3.json的FPS信息现在可以在物理模拟的设置项区域确认。
-改进了当 .physics3.json 中存在 FPS 信息时,物理模拟结果将基于 FPS 信息。

 

 

4.2.00 beta2 (2022/06/02)

动画

 《改进项目》 

- 修复了运行时模型轨的模型中正片叠底色和屏幕色没有正确再现的问题。
 MOC3文件不受影响,所以4.2.00 beta1导出的文件可以原样使用。

Cubism Viewer

 《改进项目》 

・修复了正片叠底色和屏幕色在 Cubism Viewer (for OW)中无法正确再现的错误。

 

 

4.2.00 beta1 (2022/05/19)

常见的

有关此版本的新功能的详细信息,请参阅以下页面。
新功能介绍4.2

《功能追加》

・重新设计了快捷设定对话框的UI。
 ・改进能够选择和扩展/聚合类别。
 ・追加了通过输入名称或键进行搜索的功能。
 ・可以追加快捷方式2。

・追加了选项卡功能。
 ・追加了[对齐所有视图的显示位置]功能。
 ・追加了[切换到上一个选项卡/切换到下一个选项卡]功能。
 ・复制选项卡时,视图的显示位置保持不变。

・[Windows 版本]现在可以在安装 Cubism 时选择要安装的语言。
・[Mac 版本]现在在操作系统设定中变更了语言。
・现在可以从编辑器的菜单项中切换显示语言。

《改进项目》

・将用于表示“除了顶点信息之外还包括不透明度和绘制顺序”的“形状”名称变更为“形状”。
・将[追加选项卡]重命名为[复制选项卡]。
・改进了文件菜单中[设定]项目的显示。
・改进了将模型从项目拖到画布上时的行为。
・在[动画的目标版本选择]对话框中将视频图标的文本从“Movie”变更为“Video”。
・将文件菜单中的[导出运作档]修复为[导出运作档]。

建模

《功能追加》

・追加了融合变形功能。
・追加了正片叠底色和屏幕色功能。
・在网格编辑模式中追加了镜像编辑功能。
・在网格编辑模式中追加了“合并顶点”功能。
・追加了形状的特殊粘贴功能。
・在功能中追加了选择[基准的参数值]和[覆盖键]自动生成四个角的形状的功能。
・追加同步同一模型在选项卡间的参数值功能。
・现在可以选择参数以随机姿势移动。
・已追加目标版本以及次要版本升级。

《改进项目》

・变更了在部件中选中[参考图]的文件夹图标。
・修复画布反转UI未根据视图反转状态更新的问题。
・修复了不同编辑级别的变换路径被删除变形路径按钮(垃圾桶按钮)删除的问题。
・修复了使用delete键删除变形路径时,无法创建跨越多个图形网格的变换路径的问题。
・将“4角”形状合成的符号变更为“四角”。

动画

《功能追加》

・追加了参数书签功能。
・追加了运行时模型轨功能。
・追加了冻结功能。
・追加了移动标记的快捷方式。

《改进项目》

・修复了如果在时间线的时间显示部分按下 shift 的同时拖动,它会粘在洋葱皮标记上。
・修复了混合使用平滑曲线和其他曲线时,极少数情况下曲线不正确的问题。
 (修改过去的文件时需要重新计算)
・修复了掩盖图标的透明部分。

Cubism Viewer

《功能追加》

・追加查看OWViewer中motion3.json事件信息的功能。
・您现在可以在OWViewer中追加、删除和检查userdata3.json的内容。
・现在可以从 OWViewer 的菜单项中切换显示语言。

《改进项目》

・已修复,以便可以使用 OWViewer 中的参数滑块确认动作和效果。

已知错误

・贴上复制的对象时,存在可以将普通参数贴上到融合变形参数的问题。
 当融合变形参数中没有键并且复制源和贴上目标是具有相同 ID 的参数时发生。(2022/05/23)

* 以上错误将在 Cubism 4.2.00 发布版本中修复。

 

 

4.1.05 (2022/04/21)

建模

《改进项目》

  • 修复了部件中[按文字过滤]图标显示没有切换的错误。

 

 

4.1.05 beta2(2022/03/24)

建模

《改进项目》

  • 修复了在Solo模式下变更非活动颜色时背景颜色未正确绘制的错误。
  • 修复了在图形路径的[默认笔刷设定]对话框中变更设定后,即使切换画笔刷也不会更新设定的错误。

动画

《改进项目》

  • 修复了关闭多个动画视图时无法关闭相关表单动画视图的错误。

 

 

4.1.05 beta1(2022/02/08)

常见的

《改进项目》

  • 修复了物理模拟的组名中包含[<>]符号时,写入嵌入文件后SDK无法正常读取的BUG。
  • 当文件未打开时禁用工具栏按钮。
  • [导出物理模拟设定]已追加到快捷方式设定对话框中。
  • 修复了鼠标悬停在菜单栏的[编辑][视窗][帮助]上时不高亮的问题。
  • 修复了从文件菜单执行[关闭全部]时打开多个选项卡时信息保留在盘中的错误。
  • 使用临时变形工具选择控制点时,可以通过 [Shift + 拖动] 进行平移。

建模

《功能追加》

  • 在编辑纹理集中,[角度]和[倍率]被锁定以进行编辑。
  • 计算的 FPS 值可以在物理模拟/场景混合设定中自由输入和指定。
  • 追加了在部件选项板中复制和粘贴对象时在名称末尾插入编号的设定。

《改进项目》

  • 如果您在移动部件中的对象后撤消,并且在部件中设定了标签颜色的部件中设定了另一种颜色,
    修复了移动对象的颜色没有恢复的问题。
  • 修复了一个错误,即如果您在创建新部件后按原样在参数上按下键,则该键将在里面的对象上按下。
  • 修复了即使删除了已键入参数的对象也仅保留键显示的错误。
  • 修复了在参数中变更组颜色设定时无法撤消/重做的错误。
  • 修复了在Solo模式下,在非活动颜色变更对话框中单击取消时,非活动颜色变暗的错误。
  • 修复了在Solo模式下执行临时变形工具时,视图左上角的显示和非活动颜色的显示不会被覆盖。
  • [变形笔刷工具]、[笔刷选择工具]、[编辑胶水]的笔刷大小上限由2000px修正为10000px。
  • 修复了编辑纹理集,使鼠标悬停在纹理图片上时工具提示显示不会延迟。
  • [部件设定]、[参数设定] 和 [组设定] 对话框的标题宽度现在在编辑器运行时保存。
  • [部件设定]、[参数设定] 和 [组设定] 对话框的大小现在已设定并保存。
  • 修复了[B+拖动]可以设定笔刷选择工具和编辑胶水的笔刷大小超过上下限的BUG。
  • 修复了图形网格通过网格编辑复制贴上时会自动连接的问题。
  • 在物理/场景混合设定中,跳帧被应用于场景的播放。
  • 在物理模拟组编辑中,当在编辑后通过取消关闭时,会显示一个确认对话框。
  • 修复了在最后一列中的关键点的编辑被关键点编辑对话框中的 Enter 键反映后不接受下一个输入的错误。
  • 修复了[动作反转]中可能无法正常应用的错误。
  • 修复了使用多个监视器时上下文菜单可能显示在另一个监视器上的错误。
  • 修复了可能在参数中创建多个参数和参数组的错误。

动画

《功能追加》

  • 增加了[动作导出设定],现在可以为每个场景导出任意指定的动作文件。
  • 修复了要保存的运动导出设定。

《改进项目》

  • 修复了录制运动和生成动画数据后无法创建新场景的错误。
  • 如果在导出动作文件时选中 [将口形同步和眨眼烘焙到动作],
    修复了参数组中设定的跳帧规范被忽略并输出与编辑器行为不同的动作的错误。
  • 修复了形状动画编辑在特殊情况下没有重新拓扑的错误。
  • 修复了在记录中一直显示“没有对象”的错误。
  • 修复了当 [眨眼] 和 [口形同步] 在指定跳帧的轨上时不应用跳帧的错误。
  • 修复了动画选项卡和形状动画选项卡同时关闭时场境显示保留的错误。
  • 修复了变更音轨的音轨长度时没有输出音频的错误。
  • 如果您在打开两个动画文件的情况下执行特定操作,
    修复了在视图和场境中显示不同动画信息的错误。
  • 修复了物理模拟播放或场景轨中,即使将跳帧设置为“指定一帧”,一帧也不起作用的问题。
  • 通过指定跳帧,从第 0 帧到第一个开始帧的部分现在作为一帧操作。
  • 修复了在场境中变更场景后关闭动画视图选项卡时导致错误的错误。
  • 修复了滚动时间线时左右显示偏移的错误。
  • 选择掺杂表上的[将关键帧贴到选定的行]和[当应用范围不同时按比例调整值]时,
    修复了要调整的贝塞尔曲线手柄。
  • 修复时间线浮动时部分关键操作无法执行的问题。

 

 

4.1.04 (2021/12/23)

常见的

《功能追加》

  • 解决了 Log4j 中的漏洞问题 (CVE-2021-44228)。
    作为具体措施,Cubism Editor 中使用的 Apache Log4j 版本已更新至最新版本 2.17.0,并带有漏洞对策。
    除了 CVE-2021-44228 之外,最新版本 2.17.0 还支持 CVE-2021-45105。
    请放心,CVE-2021-45105 漏洞不会出现在以前版本的 Cubism Editor 中。

    如果您使用的是 Cubism Editor 4.1.03或更早版本,请参阅帮助站点了解如何处理 Apache Log4j 漏洞(CVE-2021-44228)。
    关于Log4j漏洞问题(CVE-2021-44228)的响应

 

建模

《改进项目》

  • 修复了选择变形路径的多个控制点时边界框未更新的错误。

 

 

4.1.03(2021/12/10)

常见的

《改进项目》

  • 当打开模型/动画等一个或多个文件并尝试通过“拖放”打开模型时
    修复了无法正确打开数据的问题。

    * 由于 4.1.02 支持的“将模型从项目拖到画布上时的行为改进”的效果,出现了上述问题。
    既然找到了,就更正并再次发布为4.1.03。
    此版本包含除 4.1.02 的上述错误之外的更正。

    有关更新,请参阅第 4.1.02 节。

 

 

4.1.02 (2021/12/9)

我们在这个版本中发现了一些错误,所以请使用最新版本。
(无法下载)

 

常见的

《功能追加》

  • 与 Windows11兼容。
  • 添加了对 macOS Monterey 的支持。(将停止对 macOS High Sierra 的支持)
    * 仅与配备 Intel CPU 的型号兼容。目前不支持带有 Apple M1芯片的型号。
    * 请务必在更新操作系统之前停用 Cubism Editor。
     帮助网站“我想升级安装了 Cubism Editor 的 macOS

《改进项目》

  • 改进了将模型从项目拖到画布上时的行为。
  • 修复了[cmo3/can3联动设定]对话框中[联动模型]的模型名称显示不正确的问题。

建模

《改进项目》

  • 修复了在[物理/场景混合设定]中更新场景混合时,场景播放中的[随机A]和[随机B]项消失的错误。

动画

《改进项目》

  • 修复了参数解耦和选择后切换选项卡时无法编辑时间线的问题。
  • 修复了在Dope Sheet上应用复制粘贴或模板时贝塞尔曲线形状发生变化的错误。

 

 

4.1.02 beta1(2021/10/28)

常见的

《功能追加》

  • [Impact] 和 [反转] 已追加到物理/场景混合设定和 Cubism Viewer (for OW)中的光标跟踪设定。
    此外,现在可以在[类型]中设定右键单击和左键单击。
  • [复制参数值]新增[贴上参数值]功能。您将能够复制和贴上参数值。

《改进项目》

  • 修复了单击“开始免费试用 PRO 版本”按钮时显示的确认对话框。
  • 修复了盘布局重置时盘显示/不显示状态与菜单检查状态不匹配的问题。
  • 修复了将盘布局重置为当前选择的工作区。
  • [Mac版] 修复了部分键盘是Ctrl键的BUG。
  • 修复了在部件设定对话框中单击取消按钮时确认对话框显示两次的错误。
    此外,当您在确认对话框中单击取消时,您已经进行了更正以返回到部件设定对话框。
  • 修复了在关闭检视区域中的选项卡时激活上一个活动选项卡。
  • 修复了在关闭检视区域中的选项卡时关闭正在该选项卡上工作的无模式对话框。
  • 修复了当检视区域中没有任何内容打开时执行[视窗]菜单-> [重置检视区域]不会记录错误记录的问题。
  • 修复了拖动选项卡关闭按钮时尝试移动选项卡的错误。
  • 已取消默认分配给 [Ctrl + Shift + Alt + E]、[Ctrl + Shift + Alt + L] 和 [Ctrl + Shift + Alt + T] 的快捷键。
    我们还修复了它,以便可以将快捷键分配给这些键。
  • 现在,当物理模拟 FPS 和场景帧率 fps 不同时,将出现一个警告对话框。

建模

《功能追加》

  • 快捷键设定对话框新增[吸近键]。
  • 您现在可以变更旋转变形器的颜色。
  • 现在可以在物理/场景混合设定中选择 [随机A] 和 [随机B] 运动。
  • 您现在可以在变形器验证对话框中检查 [转换的分裂数量] 和 [贝塞尔分割数]。
  • 为网格编辑模式追加了部分顶点复制功能。
  • [标签颜色]现在可以在部件中设定。

《改进项目》

  • 快捷方式设定对话框中增加了[追加单个关键点]和[删除关键点]。
  • 修复了重新载入 PSD 时追加的图形网格不会立即出现在变形器中的错误。
  • 修复了在网格的手动编辑模式下退出模式并显示图集时导致模型外观与参数状态之间存在差异的错误。
  • 修复了切换图形网格的输入层时,部件上的图标没有更新的错误。
  • 修复了无法加载使用某些 Photoshop 版本保存的 PSD 的错误。
  • 修复了在 检查器 中输入文本期间撤消/重做的行为。
  • 增加了参数快捷方式[选择默认关键点]中选择的所有参数返回默认键的设定。
  • 修复了选择并移动多个参数时顺序更改为选择顺序的错误。
  • 修复了在未选择胶水的情况下切换到编辑胶水时显示笔刷的错误。
  • 修复了启用[锁定默认的变形器]时,选择变形路径的控制点时可以操作边界框的问题。
  • 修复了焦点选择对象不适用[专注所选物体]的错误。
  • 通过在物理/场景混合设定中跟随光标,将范围参考从画布范围变更为视图范围。放大时会更容易操作。
  • 在物理/场景混合设定中,现在可以在范围内选择[输入/输出参数]的[使用]勾选。
  • 具有物理/场景混合设定的记录功能,现在根据计算FPS与场景设定一起保存。
  • 修复了在变形器中拖放到同一部件时仍然突出显示的错误。
  • 修复了启用洋葱皮时,在参数上选择参数时,建模视图中的洋葱皮未更新的错误。
  • 修复了使用[旋转变形器创建工具]时点击Shift键鼠标光标变为无效图标的问题。
  • 修复了删除空白部件时不显示警告对话框的问题。
  • 修复了无法通过编辑模型导引图像名称来编辑撤消/重做的错误。
  • 修复了在背景颜色设定对话框中变更[与深色的差异]和[检查图案大小]时,措辞被切断的错误。
  • 修复了在部件中拖放到同一部件时突出显示仍然存在的错误。
  • 修复了当胶水不在关键点上时,可以在检查器中编辑胶水适合度的错误。
  • 修复了旋转变形器的角度/倍率不在关键点上时可以在检查器中编辑的错误。
  • 修复了在执行临时变形工具时,即使没有启动临时变换,部件和变形器也会变灰的问题。
  • 修复了启用锁定变形器时,部分变形器变换操作可以在检视区域通过鼠标操作执行的错误。
  • 修复了在参数中复制组合参数时参数 ID 重复的错误。
  • 将图形路径的最大线宽变更为 2000 像素。
  • 修复了锁定默认的变形器时可以在检查器中变更旋转变形器的角度和倍率的错误。
  • 修复了将对象放置在锁定的部件文件夹中时,该对象可能未处于编辑锁定状态的错误。
  • 修复了追加/删除原始图像时可能会出现错误的撤消/重做的错误。
  • 修复了部件上的对象显示/隐藏按钮可能与内部状态不匹配的错误。
  • 修复了当单击部件设定和参数设定对话框中的取消按钮时显示确认对话框。
  • 修复了在部件选项板中选择多个对象后打开和关闭部件文件夹时取消选择的错误。
  • 改变建模中的混合模式后,修改为体现在动画中。
  • 修复了旋转变形器圆的大小,即使在锁定默认的变形器时也可以通过 Alt + 拖动来调整大小。
  • 修复了变形器中的一个错误,该错误会导致拖放到选择变形器时出现无效状态。
  • 修复了要锁定默认的变形器,以便在按住 Ctrl (Alt) 键的同时编辑弯曲变形器或旋转变形器不会发出警告。
  • 修复了当选择包括隐藏艺术网格在内的多个图形网格时,相应的隐藏图形网格也会一起移动的错误。
  • 修复了在打开新的纹理集设定对话框时显示在父视窗的中心。
  • 现在为每个模型保存物理模拟计算FPS。
  • 修复了建模视图[右键菜单]中的参数滑块在参数名称较长时会缩小的错误,即使对于其他参数也是如此。
  • 未在部件设定对话框中进行编辑而按下取消按钮时,不会显示确认对话框。
  • 修复了建模视图中的右键菜单在任务栏后面被截断的错误。
  • 修复了使用笔刷选择工具选择多个顶点时,检查器中的顶点信息未更新的错误。
  • 修复了Solo显示的非活动颜色设定未正确反映的错误。
  • 复制部件时,已修改要复制的参数以匹配复制源的外观。
  • 在保存模型时确认是否删除未使用的原始图像的对话框中,显示未使用的原始图像的名称。
  • 固定,以便可以单独设定笔刷选择工具和编辑胶水的常用设定。
  • 修复了使用变形路径编辑选择循环路径起点和终点的控制点时折线无效的错误。
  • 修复了即使复制模型并在复制目标变更参数 ID 并再次载入复制源,也会应用变更前的参数的问题。
  • 当变形路径中只有一个控制点时,无法在 检查器 中变更变形路径宽度和硬度。
  • 修复了在物理模拟设定的输出设定选项卡上变更倍率时不会自动调整最大输出的错误。

动画

《功能追加》

  • 现在可以为时间线的[盘菜单]中的所有项目设定快捷键。
  • 追加了在时间线左侧的属性面板中选择参数时选择所有键的功能。

《改进项目》

  • 修复了在FA视图中同时使用调整模式1和2时无法正常编辑形状的错误。
  • 修复了载入canx格式动画文件场景时出错的BUG。
  • 修复了在 FA 视图中操作变形器时出现不必要警告的错误。
  • 通过导出多帧序列号静止图片,现在可以将图片分组到每个场景的文件夹中。
    此外,在导出所有场景时,同名场景不会被覆盖。
  • 修复更换音频文件时,音轨波形显示未更新的问题。
  • 修复文件展开后解决音频文件断开链接时无法正常读取音频文件的问题。
  • 修复了编辑形状动画时,在检查[调整模式2]中无法编辑的项目中可以输入数字的错误。
  • 修复序列号图片、GIF、视频输出不释放GPU内存的BUG。
  • 修复了轨位置改变,超出区域时发生错误的问题。
  • 修复了参数选择状态不能正常转换的问题。
  • 修复了在对链接断开的文件执行[替换数据]时无法选择具有非目标扩展名的文件。
  • 修复了标记工具提示窗口有错误判断的错误。
  • 修复了在保存运动记录时将场景追加到未打开的 can3文件的错误。
  • 在物理烘焙生成动画中,当物理模拟设定 FPS 和场景 FPS 不同时,您现在可以选择用于烘焙的 FPS 设定。
  • 当模型中设定了形状编辑的部件发生变化时,顶点数会随着建模的网格编辑功能而增加或减少。
    修复了对话框可能在动画中重复显示而无法操作的问题。
  • 修复了模型部件在某些情况下会显示为白色的错误。
  • 修复了在轨锁定时解锁轨选择。
  • 修复了复制轨时形状动画恢复失败的错误。
  • 修正了静止图像(序列号)输出设定对话框中的警告文本“导出范围之外的场景的帧将不被导出”,以便仅在存在相应场景时才显示。
  • 修复了替换素材文件时[使用文件名]中设定的轨名称不更新的问题。

Cubism Viewer

《功能追加》

  • 您现在可以在 Cubism Viewer (for OW)中检查帧率。

 

 

4.1.01(2021/9/15)

常见的

《改进项目》

  • 修复了启动时显示的低紧急错误记录,使其不显示在记录中。(所有都列在记录文件中)

建模

《改进项目》

  • 修复了在物理/场景混合设定中仅进行组编辑时结果不保存的问题。
  • 模板函数的模型已更新为3.0或更高版本的格式。

动画

《改进项目》

  • 修复了将canx格式的动画文件转换为can3格式时场景长度变长一帧的问题。
  • 修复了单击[最后一帧]按钮时工作区域不移动到末尾的错误。

 

 

4.1.01beta1(2021/8/19)

常见的

《改进项目》

  • [变形笔刷工具]已追加到快捷设定对话框中。
  • [搜索和替换]已追加到快捷方式设定对话框中。
  • 修复了在打开无模式对话框的情况下进行鼠标滚轮操作(例如缩放画布)时整个编辑器的显示大小发生变化的错误。
  • 修复了重新启动编辑器时画布背景颜色设定将返回默认透明度的错误。
  • [Windows 版] 修复设定高 DPI 设定时滴管采集位置偏移的问题。
  • [Mac版] 修复启动时可能出现错误的BUG。
  • [Mac版] 修复读取文件时可能出现错误的BUG。

建模

《功能追加》

  • 修复了在按笔触划分网格(beta)中的笔划后尝试切换到另一个工具而不确认时显示确认对话框。
  • 在物理/场景混合设定对话框中,您现在可以在输出设定表和摆锤设定表上使用多个选择同时进行编辑。
  • 您现在可以复制并贴上到物理/场景混合设定对话框中的输出设定表。

《改进项目》

  • 修复了在特定条件下选择多个对象时,对象名称变更为 ID 名称的错误,并且工具细节的 [弯曲面的分割数] → 临时弯曲变形发生了变更。
  • 修复了 ID 为 63个字符且末尾有字母的参数重复时设定无效 ID 的错误。
  • 修复了使用图形路径工具时鼠标光标显示不一致的问题。
  • 修复了图形路径工具中的默认笔刷设定没有立即反映图形路径笔刷设定中编辑的内容的错误。
  • 优化[混合形状]过程以提高响应。
  • 修复了选择多个绘图对象并逐个选择每个顶点时不显示边界框的错误。
  • 修复了变更部件名称会在部件中展开部件的错误。
  • 修复了重命名变形器会在变形器中展开变形器的错误。
  • 修复了使用“B+拖动”变更变形笔刷工具的笔刷大小时,减小笔刷大小时笔刷圆圈反转的错误。
  • 修复了使用按笔触划分网格(beta)中的快捷方式确认网格编辑时,[确定正在编辑的笔触] 保留在画布上的错误。
  • 调整了按笔触划分网格(beta)的全选和删除时的行为。
  • 修复了按笔触划分网格(beta)时鼠标光标不更新的问题。
  • 修复了在参数快捷方式的[选择上一个关键点][选择下一个关键点]中参数有循环设定时循环选择键。
  • 修复了参数的列表在参数快捷方式的[选择上一个]和[选择下一个]中可能无法滚动的错误。
  • 在项目的右键菜单中,[设定为所选对象的输入图像]在原始图片侧和模型导引图像侧具有相同的名称,因此已变更名称以便于区分。
  • 修复了在画布反转时执行[选择对象的焦点]时取消反转状态的错误。
  • 修复建模菜单中[锁定未选物体]、[全部解锁]、[隐藏未选物体]、[显示全部]目标中不包含胶水的问题。
  • 修复了在物理/场景混合设定对话框中操作移动表格行的箭头按钮时行可能消失的问题。

动画

《功能追加》

  • 在图形编辑器中,已修复当手柄和键重叠时,它们会分开显示。
  • 您现在可以在Dope Sheet和图形编辑器中上下变更该值。
  • 在Dope Sheet和图形编辑器中,已对其进行了修改,以便通过一次撤消处理光标键的多次移动。
  • 您现在可以在静止图像(连续)输出设定对话框中选择所有场景的输出。
  • 您现在可以在 GIF 动画输出设定对话框中选择所有场景的输出。

《改进项目》

  • 修复了图形编辑器中鼠标中键无法移动的问题。
  • 修复了在图形编辑器中编辑框时对应键的值颜色没有变化的问题。
  • 修复了在Dope Sheet和图形编辑器中通过光标键移动键可能无法正常工作的错误。
  • 时间线上的Dope Sheet改善了恶劣环境中的以下问题。
    ・编辑键时的响应
    ・钥匙可能不动。
  • 修复了 Live2D 参数组的跳帧属性中无法撤消编辑的问题。
  • 修复了在动画中排列多个模型轨时洋葱皮绘制负荷过大的问题。
  • 在创建模型轨时,如果模型的 cmo3文件被删除或移动,则会显示错误消息。
  • 修复了通过拖动变更检查器的[大小(宽度)]和[大小(高度)]时,即使选中[固定纵横比]也无法正确保持纵横比的错误。
  • 修复了多个轨的键一起调整时键消失或被覆盖的错误。
  • 修复了导出图片或视频时取消时即使不输出文件也会显示保存目的地的错误。

Cubism Viewer

《改进项目》

  • 更改为显示一个消息对话框,为Viewer无法打开的文件提供错误或警告。

 

 

4.1.00 (2021/6/10)

有关此版本的新功能的详细信息,请参阅以下页面。
新功能介绍4.1

常见的

《改进项目》

  • [Mac 版] 修复了在多显示器环境下,选择目标版本对话框可能显示在编辑器以外的显示器上的问题。
  • 部分变更了建模和形状动画中菜单项的顺序和名称。
  • 在临时变形工具的旋转中,现在即使拖动到临时变形工具显示的矩形之外也可以旋转。
  • 修复了使用临时变形工具时显示边界框的问题。
  • 调整了临时变形工具执行时画布上的显示。
  • 修复了执行临时变形工具时无法编辑部件和变形器的行为。
  • 已修复,以便在执行临时变形工具时可以在工具细节上切换临时变形工具。
  • 修复了执行临时变形工具时鼠标光标根据操作而变化的问题。

建模

《改进项目》

  • 在物理/场景混合设定的 [鼠标跟随设定] 对话框中追加了 [Apply] 按钮。
  • 变更了规范,以便在创建胶水时将目标图形网格名称包含在胶水名称的末尾。
  • 修复了当画布上的胶水按钮的 UI 字符串超过一定宽度时省略 end。
  • 改进了临时变形路径的变换算法。
  • 修复了临时快照功能,以在视图中每个选项卡最多保留 4 个。
  • 修复了在选择闭合部件的情况下执行[重置为默认值]时部件展开的错误。
  • 修正了一些与模型创建相关的英文/中文参数。
  • 修复了在 Find and Replace 对话框中执行 [Select on Canvas] 时参数没有更新的问题。
  • 修复了在[参数复制]中选择的所有参数都被复制的问题。
  • 更正了[参数复制]追加的参数名称,使其与重复源相同。
  • 修复了在创建带有笔划的图形路径时端点可能会关闭的错误。
  • 修复了在完成网格编辑时路径显示继续保留在画布上的错误,同时正在执行按笔划分割网格 (beta)。
  • 在使用 Stroke Mesh Split (beta) 工具和笔划创建/编辑图形路径时变更了鼠标光标。
  • 修复了在使用网格分割 (beta) 工具按笔划进行编辑时切换到另一个工具时取消编辑的内容。
  • 修复了在使用网格分割 (beta) 工具逐笔编辑时,可以通过执行 [削除] 来删除编辑的内容。
  • 修复了使用网格分割(beta)工具通过描边进行[模型导引图像显示] [图集显示]时不显示路径的错误。
  • 在编辑网格时变更了工具细节上的一些按钮图标。

动画

《功能追加》

  • 图形编辑器新增[显示键名]功能。

《改进项目》

  • [Mac版] 修复导出视频时对话框和进度条可能显示在视窗后面的问题。
  • 修复了启用掩盖时在某些情况下无法移动键的问题。
  • 修复了选择时间线属性时颜色不变化或不一样的问题。
  • 修复了当起始帧不是0时,显示图形编辑器关键信息的窗口的值发生偏移的错误。
  • 修复了在 FA 中选择特定对象使用笔刷选择工具时笔刷光标圆圈闪烁的错误。
  • 在 FA 中使用笔触编辑图形路径时变更了鼠标光标。

Cubism Viewer

《功能追加》

  • 新增[光标跟踪设定]功能。

 

 

4.1.00 beta1(2021/5/13)

有关此版本的新功能的详细信息,请参阅以下页面。
新功能介绍4.1(测试版)

常见的

《功能追加》

  • 洋葱皮现在是官方的。主要增加了以下功能。
    ・在检视区域底部安装了洋葱皮ON/OFF按钮
    ・增加了洋葱皮显示条件和目标等详细设定
    ・新增洋葱皮标记功能
    ・增加了偏移功能,可以将洋葱皮的绘制位置在 X/Y 方向偏移
  • 保存或导出时存在同名文件时的命名方法已变更如下。
    ・图片/视频等:“保存的名称(X)”
    ・ cmo3、can3等:可以选择“保存名称_X”或“保存名称(X)”
     在菜单->文件->设定中增加了[另存为文件名末尾追加(X)]项。

《改进项目》

  • 终止对 macOS10.12 (Sierra) 的支持。
  • 修复了启动多个编辑器时背景颜色设定相互影响的错误。

建模

《功能追加》

  • [变形笔刷工具]已追加到工具中。
  • [参数复制]已追加到参数中。
  • 在图形路径工具中追加了[使使用笔触创建/编辑图形路径]功能。
  • 新增[隐藏选择状态]功能。
  • [将所选对象作为子对象] 功能已追加到新部件对话框中。
  • 使用笔刷选择工具选择弯曲变形器时,表面会涂上渐变,这样看起来很容易理解。
  • 编辑纹理集的自动布局新增[布局目标]、[倍率]、[允许/不允许旋转]设定项。
  • 在物理模拟设定中变更输出目标参数时,
    追加了变更同一物理模拟组中相同规则可以变更的所有输出目标参数的功能。

《改进项目》

  • 修复了切换工作区时重置部件选项板的搜索状态的错误。
  • 带有套索工具、笔刷选择工具、变形路径编辑、编辑胶水、图形路径工具、旋转变形器创建工具
    修复了按Ctrl操作部件时不显示边界框的问题。
  • 修复了使用参数的快捷方式转换到下一个/上一个键时值可能暂时无效的错误。
  • 修复了参数编辑对话框关闭时参数重置为默认值的问题。
  • 关于改变图形路径控制点不透明度/粗细的工具的笔刷大小
    修复了表情的抖动,使其与笔刷选择工具相同。
  • 修复了在手动编辑网格时尝试使用 ESC 取消编辑时无法追加顶点的错误。
  • 固定以随机姿势播放眨眼。
  • 修复了编辑纹理集中空格+拖动无法滚动屏幕的问题。
  • 修复了在编辑纹理集中通过文本输入变更倍率和位置时无法撤消的错误。
  • 修复了当设定为参考图的部件未放置在纹理集中时显示不必要的警告的错误。
  • 已修复,以便鼠标光标的外观在物理/场景混合设定编辑器的对话框中适当更改。
  • 修复了 PSD 图层名称在32 个字符或更多字符时只能读取一半的错误。
  • 修复了加载 6 层或更多层的 PSD 时层次结构崩溃的错误。
  • 修复了用中文版编辑器阅读中文PSD时出现乱码的BUG。
  • 修复了将具有多个胶水的相同顶点的模型导出到 moc3时,SDK 上的显示可能会失真的错误。

动画

《功能追加》

  • 时间线的可操作性和UI都得到了很大的改进。
    图形编辑器:
    ・改进了关键帧和手柄的可操作性
    ・增加了更直观的曲线编辑功能
    ・增加智能吸附(取整值)功能
    ・增加复制粘贴功能
    ・追加了 Alt + Shift 的智能吸附功能的启用/禁用开关。
    Dope Sheet:
    ・改进了关键帧和值的可操作性
    ・提高参数输入精度
    ・改进了编辑重型模型时的可操作性
  • 新增轨Solo显示功能。
  • 增加了通过拖动变更显示按钮和锁定按钮的功能。
  • 追加了收集文件的功能。
  • 新增场景载入功能。
  • 新增场景追踪功能。
  • [文件名设定]已追加到静止图像序列号导出对话框。
    (您可以自由设定静止图像序列号的位数和起始编号)
  • 新增静止图像序号导出对话框[输出指定帧]。
    (可以自由设定输出帧范围)

《改进项目》

  • 修复创建动画后变更模型参数ID时模型轨参数可能不正确的BUG。
  • 修复了与跨场景复制和贴上轨相关的错误。
  • 修复了跨多个轨执行编辑后可能无法撤消的错误。
  • 修复了在编辑器上播放包含多个音轨的场景时音频输出延迟的错误。
  • 修复了组轨中的音轨将在组轨范围之外播放的错误。
  • 修复了在播放包含音轨的动画时移动指示器时音频无法正确播放的错误。
  • 修复了序列号图片轨的序列号图片文件名中混入大小写字母不同的文件时,绘制会出现奇怪的BUG。
  • 修复了序列号图片轨在 macOS 上无法正确显示的错误。
  • 修复了Dope Sheet中的错误,其中包括轨、部件和属性组的范围选择不正确。
  • 修复了图形编辑器中也显示掩盖属性的错误。
  • 修复了释放所有掩盖时未释放连接参数下排掩盖的错误。
  • 修复了属性的“倍率X / Y”的值设定为“0.0”时发生错误的错误。
  • 当在 FA 表单编辑中选择没有关关键点的框架来转换图形网格时
    修复了图形网格将返回默认形状的错误。
  • 修复了当轨正在读取的文件处于断开链接状态时操作时间线时发生错误的错误。
  • 修复了在复制包含素材链接中断的轨的场景时导致错误的错误。
    现在会显示一个对话框,警告该场景不能被复制。
  • 修复了 Cubism Editor 导出的 MOV 文件无法载入 After Effects 的问题。

Cubism Viewer

《功能追加》

  • 追加了在 Cubism SDK for Native 和 Cubism SDK for Web 中再现贝塞尔曲线再现性的状态下播放动作的功能。
    现在可以通过图片中的曲线曲线确认功能直观地确认劣化情况下的差异。
  • 您现在可以从检查器检查贝塞尔运动曲线的处理类型。

 

 

4.0.09 (2021/4/20)

建模

《改进项目》

  • 在 4.0.08 中,变更了规范,以便在创建胶水时使用图形网格名称作为胶水名称。
    由于处于容易被切断的状态,我们恢复到与 4.0.08 beta1之前相同的规格。
  • 修复了按关键点编辑对话框在特定模型上无法正常操作的问题。
  • 修复未选中参数时,Shift+左键单击参数时无法正常选中参数的BUG。

 

 

4.0.08 (2021/3/18)

常见的

《改进项目》

  • 修复了参数名称中包含“><”时,写入嵌入文件后SDK无法正确读取的BUG。

建模

《改进项目》

  • 修复了创建胶水时部件未更新的错误。
  • 变更了规格,以便在创建胶水时使用图形网格名称作为胶水名称。
  • (*) 修复了在特定模型上按关键点编辑对话框无法正常操作的问题。
  • (*) 修正未选中参数时Shift+左键单击参数时无法正常选中参数的BUG。

* 已确认这些未完全纠正。
它将在版本 4.1.00 beta1(计划于 5 月中旬)和 4.0.09(计划于 4 月下旬)中修复。

Cubism Viewer

《功能追加》

  • 关键位置现在显示在参数列表中。

 

 

4.0.08 beta1(2021/2/15)

常见的

《改进项目》

  • 修复了在某些配备 RADEON 的环境中,每次绘图时专用 GPU 内存使用量都会增加的错误。
  • 修复了在 macOS Big Sur 上某些链接无法正常打开的问题。

建模

《改进项目》

  • 修复了在构建旋转变形器的父子结构时,错误地为下面的子子设定了与父子的旋转相同的值。
  • 修复了参数键中旋转变形器的角度显示变更为受父级旋转影响的值的错误。
  • 修复了在检查器中重命名胶水时部件上的显示未更新的错误。
  • 修复了 Root 中的变形器可能在检查器的变形器栏中重复显示的错误。
  • 如果从“关键点编辑对话框”中删除一个键,并选择了多个为扩展插值设定的绘图对象,
    修复了不可删除的键可以被删除的错误。
  • 动作反转,当应用的图形网格或与变形器关联的参数不是默认值时
    修复了一个可能无法正确应用的错误。
  • 导出动作时,将导出目标设定为所有参数时,会显示说明规格的弹框。
  • 修复了载入 Cubism 2.1模型时可能会丢失多边形的错误。

 

 

4.0.07 (2020/12/17)

常见的

《功能追加》

  • 添加了对 macOS11.0 Big Sur 的支持。
    * 仅与配备 Intel CPU 的型号兼容。目前不支持带有 Apple M1芯片的型号。
    * MacOS11.0 Big Sur 有以下限制。
     即使系统语言设定不是英语,菜单栏上的标准 Mac 菜单也会用英语书写。
    * 请务必在更新操作系统之前停用 Cubism Editor。
     帮助网站“我想升级安装了 Cubism Editor 的 macOS

建模

《改进项目》

  • 修复了在某些操作中无法使用快捷键“删除”的问题。

Cubism Viewer

《改进项目》

  • 修复了通过将运动与Viewer关联来导出 model3.json 时路径表示法变得依赖于操作系统的错误。
    如果您在 4.0.07 beta1中导出了 model3.json,建议在此版本中重新导出。

 

 

4.0.07 beta1(2020/11/26)

常见的

《功能追加》

  • 新增快捷设定对话框中出现重复键设定时显示警告的功能。

《改进项目》

  • 修复了教程视频的部分菜单。
  • 从打开 cmox / canx 文件并在编辑后关闭编辑器时显示的对话框中保存时
    修复了它被无效扩展名覆盖的错误。
  • 已修复以抑制在记录中被错误地视为错误的记录的输出。
  • 在快捷方式设定对话框中,
    修复了在设定重复键时显示确认对话框以删除现有设定。

 

建模

《功能追加》

  • 在物理模拟设定对话框中,[复制]按钮已恢复到组设定区域中的原始位置。
  • 在物理模拟设定对话框中,在输出设定的右键菜单中增加了[分离组]功能。
  • 在物理模拟设定对话框中,追加了一个复选框,用于临时启用/禁用组设定区域中的计算。
  • 您现在可以在物理模拟设定对话框的摆锤显示区域中以 45° 的增量旋转。
  • 调整弯曲变形器的大小时,子元素(弯曲变形器、旋转变形器、图形网格)的大小和位置现在可见
    追加了[显示调整弯曲变形器尺寸时的子元素]功能。
  • 您现在可以一次查看/隐藏和锁定/解锁部件选项板中选择部件下的对象和部件。
  • 现在可以一次展开/折叠部件中所选部件下方的部件。

《改进项目》

  • 修复了 部件 Palette 和 变形器 Palette 中的 [全部折叠],使其可以折叠,包括子层次结构。
  • 修复了部件中的一个错误,即在创建新部件时所选部件会展开。
  • 修复了部件的部件设定,参数的参数设定和组设定的撤消/重做行为不正确的错误。
  • 修复了在参数中删除或创建参数后执行撤消/重做时显示位置偏移的问题。
  • 添加了限制,因此不能同时为同一参数设定“循环”和“眨眼/口形同步”。
    (这是为了防止同时设定时发生错误等问题的限制。)
  • 修复了 检查器 中输入 ID 或长时间剪辑时文本框会被截断的错误。
  • 修复了检查器的变形器下拉顺序可能与变形器的顺序不同的错误。
  • 修复了 检查器 中的一个错误,即使它不在 关键点 上,也可以变更不透明度。
  • 调整了 检查器 的布局。
  • 在动画视图中,行为已被修改,因此您可以通过单击图形路径以与图形网格相同的方式选择模型。
  • [Mac 版] 修复了在变形器中显示代表层次的线条。
  • 修复了在多视图状态下删除或重新排列选项卡时可能出现错误的错误。
  • 修复了编辑纹理集时边界框和纹理显示不对齐的问题。
  • 修复了即使在扩展插值的情况下,洋葱皮的轨迹在线性插值时也显示不匹配的问题。
  • 修复了从画布中选择锁定对象并解锁时,父层次的变形器被解锁的错误。
  • 同时选择锁定和解锁对象
    修复了可以在画布上编辑的错误。
  • 修复了允许手动编辑锁定的图形网格网格的错误。
  • 修复了旋转变形器旋转时下属部件洋葱皮不匹配的错误。
  • 修复了在将旋转变形器创建为非关键点的旋转变形器的子项时导致错误的错误。
  • 修复了在物理模拟设定对话框的输入归一化字段中无法正确输入值的错误。
  • 复制或导出胶水时,目标图形网格现在包含在副本或部件输出中。
  • 修复了当同时选择图形路径和图形网格时,可以在检查器中编辑绘制顺序等常见项目。
  • 修复了选择为两个图形网格设定的变形路径时高亮可能不正确的错误。
  • 选择了具有不同变形路径的多个图形网格,
    修复了拖动变形路径的控制点时导致错误的错误。
  • 修复了不透明度和绘制顺序不正确的关关键点以自动修复。修复详细信息显示在记录中。
  • 修复了有时在编辑变形路径时无法撤消图形网格变换的错误。
  • 修复了当删除变形路径的一个控制点时,检查器的显示可能不会更新的错误。
  • 修复了如果您在拖动对象时操作鼠标滚轮,它会出现错误行为并且您将无法撤消的错误。
  • 使用批量设定模型物体输出/载入 CSV 时
    修复了在对象或参数的名称中包含“,”(逗号)时发生错误的错误。
  • moc3导出设定中导出类型为 nizima 时
    修复了“模型名称”末尾包含半角空格时写入失败的错误。

 

动画

《功能追加》

  • 追加了锁定时间线上的标记的功能。
    锁定时无法通过拖动来追加/删除/移动标记。
  • FA功能中增加了表单编辑和删除表单编辑属性组的功能。

《改进项目》

  • 修复了即使仅选择了对象,FA 视图中仍会显示表示未保存状态的“*”的错误。
  • 修复了关闭 FA 视图时时间线显示损坏的错误。
  • 修复了 FA 视图中的错误,即在默认形状锁定的情况下操作弯曲变形器时执行了意外的形状编辑。
  • 修复了 FA 时间重映射功能在执行 Undo / Redo 时导致错误行为的错误。
  • 修复了在 FA 视图中撤消时检查器和部件之间的绘制顺序不同的错误。
  • 修复了对象的绘制顺序在检查器和 FA 视图中的绘制顺序滑块之间未对齐的错误。
  • 修复了图形网格的绘制顺序在FA视图中无法设定小于原始值的问题。
  • 修复了在 FA 视图中操纵旋转变形器时,在某些情况下旋转变形器角度不正确的错误。
  • 修复了复制模型轨时更改表单编辑对象顺序的错误。
  • 修复了时间线中的一个错误,该错误导致锚点的轨坐标和大值的显示被切断。
  • 改进了播放动画时序列号图片轨的绘制。
  • 在某些情况下,即使“启用对属性组的掩藏属性的操作”设定已关闭
    修复了掩盖和隐藏的参数键会移动的错误。
  • 修复了结合参数/解除绑定参数时,时间线轨上显示的参数值没有正确更新的问题。
  • 在时间线中启用[切换自由/固定鼠标时间轴导航]
    修复了“下一个/上一个关键帧”快捷键无法正常工作的问题。
  • 修复了时间线中的“下一个/上一个关键帧”操作相对于已编辑键的行为不正确的错误。
  • 在执行物理烘焙生成动画改进了进度条的显示。此外,可以在执行期间取消。
  • 提高了物理烘焙生成动画的速度。
  • 创建新场景时,动画的默认目标版本为“视频”“SDK(其他)”时
    修复了与“SDK(Unity)”相同的限制应用于图形编辑器的贝塞尔操作的错误。
  • 修复了在各种导出期间取消时行为变得不正确的错误。
  • 修复了导出 GIF 动画时 Live2D 徽标出现在第一帧中的问题。

 

Cubism Viewer

《功能追加》

  • 变更为在读取不同于 moc3文件的驱动器上的 json 文件时显示询问是否复制的对话框。

《改进项目》

  • 修复了在与 moc3文件不同的驱动器上读取 json 文件时显示错误。
  • 修复了统计数据中显示的多边形总数与Cubism Editor的模型统计数据不同的错误。

 

 

4.0.06 (2020/10/22)

Cubism Viewer

《改进项目》

  • 修复了 [跟踪鼠标] 功能在 Mac 上可能无法使用的问题。
  • 修复了上次启动时视窗的布局设定没有恢复的问题。

 

 

4.0.06 beta1(2020/09/23)

常见的

《改进项目》

  • 保存文件或导出各种视频等时。
    修复了运行用户指定没有写权限的文件夹时出错的问题。
  • 修复了在某些操作过程中鼠标光标可能会移动很多的错误。
  • 修复了在某些情况下拖动数字输入行为不正确的问题。
  • [Mac 版] 变更为在不允许 Cubism Editor访问辅助功能时显示提示权限的对话框。

 

建模

《改进项目》

  • 修复读取模型文件时在记录中显示关键点无效数值的不透明度信息。
  • 修复了在正常情况下应用扩展插值的弯曲变形器转换的分裂数量不正确的错误。
  • 修复了在参数键之间选择时旋转变形器的角度值显示为“0.0”的错误。

 

动画

《功能追加》

  • 限制已被取消,因此可以无限制地放置音轨的数量。

《改进项目》

  • 修复了在 Mac 上打开在 Windows 上创建的动画文件时素材链接断开的问题。
  • 修复了读取 canx 文件时因错误而失败的错误。
  • 在时间线中为 Live2D 参数设定小数点后的值时
    修复了通过在图形编辑器中操作键进行编辑和直接输入值进行编辑时行为不同的错误。
  • 修复删除场景时场境选中状态和场景显示状态不正确的问题。
  • 修复了从场境中选择和切换场景时行为很重的错误。
  • 更正了导出视频、静止图像(序列号)和动态文件时显示覆盖确认对话框的次数。
  • 修复了免费编辑器中某些条件下视频导出失败的问题。
  • 修复了为场景设定淡入淡出值时,运动文件在小数点后写入无效数字的错误。

 

Cubism Viewer

《改进项目》

  • 修复了编辑面部表情参数和切换加算/正片叠底模式时小数点后数字不正确的问题。
  • 修复了当不透明度参数数量不正确时模型消失的错误。
  • 修复了在检测到具有不正确数值不透明度的图形网格时显示确认对话框。

 

4.0.05 (2020/08/27)

常见的

《改进项目》

  • 修复了Windows下某些条件下安装时无法打开cmo3/can3的BUG。
    * 如果此问题出现在 4.0.04 beta1或更高版本
    这可以通过删除 Cubism Editor 设定文件然后重新安装来改进。
    有关帮助站点的详细说明,请参阅此页面。
    帮助网站“无法打开 .cmo3或 .can3文件”

  • 修复了从记录上的复制按钮复制的记录中包含许多换行符的错误。
  • 修复了加载模型和动画文件时检视区域的显示倍率可能不合适的错误。

 

建模

《改进项目》

  • 修复了在检查器中输入数值改变绘制顺序时,部件的绘制顺序可能不会更新的错误。

 

4.0.05 beta1(2020/07/30)

常见的

《功能追加》

  • 以下已追加到检视区域的操作中。
     R键→反转画布
     R 键 + Shift + 拖动 → 使用栅格旋转画布
     R键/E键/W键+双击→重置旋转和3D显示
  • 追加了变更弯曲变形器栅格颜色的功能。
  • 您可以在选中 [不再显示] 的情况下重新显示对话框。
    新增[重新显示隐藏的全部对话框]功能。
  • 诸如 clear 之类的功能已追加到记录中。

《改进项目》

  • 修复了即使在键盘快捷键设定对话框中按下取消按钮也会反映编辑内容的错误。
  • 即使您在键盘快捷键设定对话框中删除了快捷键
    修复了在重新启动编辑器之前不会反映的错误。
  • 修复了为键盘快捷键设定某些键时菜单栏上的显示被破坏的错误。
  • 修复了使用键盘快捷键在数字小键盘上注册“+”时不起作用的错误。
  • 修复了在专注于项目时进行复制/剪下/贴上操作时发生错误的错误。
  • 修复了将光标放在无法操作数字输入的字段时,光标看起来可以操作的错误。
  • 修复了在 FA 中使用快照功能时参数反映不正确的问题。
  • 修复了在检视区域中使用 E 键以3D 显示画布时直接指向上方和下方时发生错误的错误。
  • 修复了检视区域右下角的提示重叠显示的错误。
  • 修复了载入动画文件时取消素材替换时出错的问题。
  • 修复了在载入动画文件时使用✕按钮关闭素材替换对话框时发生错误的错误。
  • 载入纹理时,已加载纹理的名称显示在Editor左下方的状态显示中。
  • 修复了当弯曲变形器极度变形时,只有选择的顶点移动的错误。
  • 当弯曲变形器弯曲变形时,
    修复了转换贝塞尔控制点时分割点的栅格行为不正确的错误。
  • 修复了通过拖动输入弯曲变形器的不透明度值时值发生变化的错误。
  • 修复了将对象的不透明度变更为 0 可能无法反映的错误。
  • 修复了变更洋葱皮设置时输入值未正确应用的错误。
  • 修复洋葱皮设置对话框的项目,使其可以撤消/重做。
  • 修复了在物理/场景混合设定中显示时钟摆长度四舍五入为整数的错误。
  • 保存文件或导出各种视频等时。
    修复了当文件名包含操作系统禁止的字符串时发生错误的错误。
  • 修复了显示操作功能中部分快捷键显示不正确的问题。

建模

《功能追加》

  • 在物理/场景混合设定对话框中追加了记录模型运动的功能。
  • 为搜索和替换追加了 [区分大小写] 按钮。
  • 为搜索和替换追加了取消全选按钮。
  • 追加了当鼠标悬停在编辑纹理集屏幕上放置的图片上时,将名称显示为工具提示的功能。
  • 当剪贴画网格的检查器的裁剪字段由于蒙版图形网格的删除而变为“空”时,
    固定显示警告。
  • 固定以便可以通过笔标签的压力来调整笔刷选择工具和编辑胶水的重量。

《改进项目》

  • “搜索和替换”对话框的 [在画布上选择] 功能已加快。
  • 修复了搜索和替换对话框,以便在替换时不会清除选择。
  • 修复了删除原图后打开编辑纹理集对话框出错的问题。
  • 修复了物理模拟设定,即使在模型工作区也可以撤消它们。
  • 将部件设定对话框提示中的 [单击此处显示 ID 规则] 变更为 [显示 ID 规则] 按钮。
  • 建模菜单->修复了编辑级别显示与实际值不匹配的错误。
  • 修复了在不执行 [复制形状] 的情况下执行 [贴上形状] 和 [混合形状] 时会显示警告的问题。 
    (复制行为本身没有变化)
  • 在与执行了[复制形状]的目标不同的对象上执行 [贴上形状] 和 [混合形状] 时。
    固定显示警告。 (复制行为本身没有变化)
  • 修正了参数中的鼠标点击行为。
  • 修复了双击参数文件夹重命名时文本输入框不聚焦的问题。
  • 当参数被删除时,物理模拟的输入和输出项现在以可以撤消的形式删除。
  • 网格编辑模式中取消/完成按钮的布局已根据操作系统进行了更正。 
    此外,它已被修改为在取消网格编辑时显示确认对话框。
  • 修复了网格编辑模式的选择/编辑工具生成边缘的错误。
  • 修复了网格编辑模式下工具细节中的 [绑定] 按钮正确显示的问题。
  • 使用变形路径的[删除控制点]工具删除控制点时,
    修复了转换路径信息没有被正确删除的问题。
  • 修复了在工具细节中的颜色选择器按钮的背景颜色中显示不透明(棋盘图案)。

动画

《功能追加》

  • [帧数]已追加到场景设定项目中。
    您可以从 [从0开始] 或 [从1开始] 中选择帧的开始。(初始值为[从0开始])
  • 追加了调整缩放比例的功能,以便时间线中的工作区域全宽显示。
    使用动画菜单→指示器→[显示整个工作区]或“Shift + F”快捷键。
  • 创建动画模板时,如果您已经有一个同名的动画模板,您现在可以选择覆盖它。
  • 修复了打开动画文件时素材不断开链接的问题。
    (如果自保存动画文件后,素材的相对路径没有改变)

《改进项目》

  • 修复了在时间线上拖动变更参数等值时,多次注册 Undo 的错误。
  • 修复了在时间线中的键盘上输入参数值时,Undo 被注册两次的错误。
  • 修复了时间线中的一个错误,该错误导致追加轨时行为不正确。
  • 修复了在时间线中尝试连接没有伙伴连接的参数时发生错误的错误。
  • 修复了时间线中的一个错误,即在重负载下移动键时键的数量可能会增加。
  • 修复了能够撤消显示/隐藏轨的操作。
  • 修复了场景帧率设定为低值时出现的显示和行为错误。
  • 修复了切换场景时检视区域的视点不合适的问题。
  • 修复了场景长度显示比实际长度少一的错误。
  • 固定以便场景的开始帧可以设定为100 或更多。
  • 修复了长场景位置等操作过程中出现错误的BUG。
  • 修复了使用 Alt + 鼠标滚轮放大/缩小长场景的时间线时发生错误的错误。
  • 选择新创建的动画文件时
    修复了编辑器标题栏中显示不同文件名的错误。
  • 修复了保存和载入时对话框名称可能不合适的错误。
  • 在载入动画文件时的选择目标版本对话框中,
    修复了在不按确定的情况下关闭文件时在不打开文件的情况下结束进程。
  • [Mac版] 修复动画模板不按名称顺序排列的问题。
  • 修复了场景开始帧设定为非 0 时,静止图像序列号导出完成时,导出目标目录不打开的问题。
  • 修复了在音频文件中复制轨时轨长度返回默认值的错误。
  • 导出带音频的视频时,如果导出范围包含链接断开的音轨,
    修复了显示一个对话框,指示存在链接断开的音轨并取消视频导出过程。
  • 修复了在导出带音频的视频时,存在多个音轨时,音频无法正常输出的问题。
  • 修复了在未压缩视频导出的情况下不检查分辨率的问题。
  • 将视频导出 (MOV) 的视频编解码器变更为 QuickTime RLE。
  • 已修复,以便可以在视频导出 (MP4) 中指定 YUV 转换时的色彩空间。
  • 已修复,以便可以在视频导出 (MP4) 中指定比特率。
  • 修复了能够在视频导出的免费版本中隐藏 Live2D 徽标。

Cubism Viewer

《功能追加》

  • 新增面部表情和动作淡出时间一次性转换的功能。

《改进项目》

  • 修复了切换面部表情和动作时,部分参数值相同的部件可能会移动的问题。

 

 

4.0.04 (2020/07/30)

常见的

《改进项目》

  • 修复了在某些 macOS 环境中过期的错误,即使第一次试用已开始。
    如果您对此问题有任何疑问,请更新到此版本并开始试用。

建模

《功能追加》

  • 修复了在 .cdi3.json 中为 AE 插件保存参数绑定状态的错误。
    Editor顶部菜单文件> 导出运作档> 导出为moc3文件
    如果您选中“导出显示辅助文件(cdi3.json)”,它将被导出。

 

 

4.0.04 beta1(2020/07/09)

常见的

《改进项目》

  • 修复了可能无法应用 FA 编辑的错误。
  • 如果您将文件夹和参数拖放到另一个文件夹中,并且在参数中选择了该文件夹和参数,
    修复了文件夹包含在文件夹中的错误。
  • [Mac] 当您选择“退出 CECubism App”或按 Cmd + Q 退出Editor时
    修复了如果有未保存的文档时显示确认对话框。

建模

《功能追加》

  • 现在可以使用 Shift + 左键单击参数进行多项选择。

《改进项目》

  • 在参数中,同时选择文件夹及其子元素的参数。
    修复了尝试从垃圾桶图标中删除时导致错误的错误。
  • 修复了参数按键颜色可能显示不正确的问题。
  • 修复了当在参数滑块上选择了具有绘制顺序组的部件并选择了没有关键点的地方时,部件的绘制顺序滑块的显示颜色没有变为灰色的错误。
  • 修复了使用图形路径工具编辑图形路径时显示的鼠标光标图标的显示。
  • 修复了有时图形路径的控制点在组合时没有正确组合的错误。
  • 修复了切换图形路径笔刷后画布显示立即折叠的错误。
  • 修复了选择包含无效值的对象时画布显示消失的错误。
  • 修复了即使单击某些按钮也不显示弹框的错误。
  • 修复了在颜色代码输入框中没有输入任何内容而按回车时发生错误的错误。
  • 修复了在未选择任何内容时打开形状混合设定对话框的错误。
  • 修复了物理模拟组的列表显示和处理顺序可以更改。
  • 修复了要在物理/场景混合设定的工具提示中显示的参数名称。
  • 使用创建的模型,您可以在物理/场景混合设定中跟随光标。
    修复了跟踪参数初始化失败的问题。
  • 修复了在物理/场景混合设定中打开光标跟踪设定时可能会恢复初始状态的问题。
  • 修复了在物理/场景混合设定中,摆锤显示部分的鼠标滚轮操作与视图等操作相反的问题。
  • 改进了 moc3导出对话框的 UI。
  • 将导出类型为 nizima 时的纹理文件夹名称变更为“纹理”。

动画

《功能追加》

  • 在动画预览设置对话框中增加了“将表单编辑的目标引入前面”。
    当它打开时(默认值),用于表单编辑的目标对象被绘制在前景中。
    关闭时,它以与动画视图中相同的绘制顺序进行绘制。
  • 追加了“轻量播放”模式以减少播放动画时的负载。

《改进项目》

  • 修复了在时间线上拖动鼠标选择范围时,指示所选范围的矩形显示不正确的问题。
  • 修复了使用时间线上的 Enter 键停止播放时导致时间滞后的错误。
  • 修复了能够在 FA 视图中使用动画快捷方式的问题。
  • 修复了当通过改变播放速度播放动画时,音轨的播放速度也会相应改变。

Cubism Viewer

《改进项目》

  • 已修复,以便您可以在 .model3.json 文件的表达式名称中指定文件名以外的文件名。
    (也可以使用半角字母数字符号以外的符号)

Cubism AE 插件

《功能追加》

  • 实现了将参数的参数组合信息写入cdi3.json的功能。

 

 

4.0.03(2019 年12 月12 日)

常见的

《改进项目》

  • 现在启动Editor时会显示 [来自Live2D的通知] 对话框。

建模

《改进项目》

  • 修复了在网格编辑模式下变更显示模式时网格状态可能不会更新的错误。
  • 修复了在物理模拟设定对话框中影响程度降低的设定不遵循视线时无法正确执行计算的错误。
  • 修复了在物理模拟设定对话框中操作设定物理模拟的参数时显示闪烁的问题。
  • 在统计信息中追加了有关剪切蒙版的信息。
  • 修复了当遮罩形状的数量超过一定数量的 moc3输出时显示警告对话框。
  • 在曲面变形器创建对话框中变更插入目标部件时的默认名称已从 [○○ Warp] 变更为 [○○ Curved Surface]。
  • 修复了动作反转对话框的设定状态,即使没有按下 OK 按钮也会保存它。
  • 当仅选择变形器打开动作反转对话框时,
    修复了轴设定可能不正确,您可能无法按 OK 的错误。
  • 修复了自动眨眼和口形同步的设定对话框的参数文件夹中的参数显示两次的错误。
  • 修复了当图形路径的所有控制点被擦除时有时会留下空白图形路径的错误。
  • 改进了与图形路径相关的 GUI。
    ・按钮排列在详细的和笔刷设定对话框中,以便轻松访问每个功能。
  • 图形路径的线宽获取设定中[纯线纹理]的初始值已变更如下。
    ・可以看成一条线的最大值是5px
    ・被视为透明的最小值为 0%
  • 增加了对图形路径工具快捷键的支持。

动画

《改进项目》

  • 修复了能够在动画视图上选择序列号图片轨。
  • 变更为在您单击时间线中的属性组时选择属性组。
  • 修复了在时间线中连续单击“创建新组”按钮时显示多个对话框的错误。
  • 切换或更新场景时,时间线中轨和属性组的打开/关闭标记
    修复了轨即使打开也被标记为关闭的错误。
  • 修复了在时间线中选择键时的行为不正确的错误。
  • 修复了时间线中复制组会使内部属性加倍的错误。
  • 修复了在时间线中追加或删除关键帧时光标显示的错误。
  • 在时间线内移动选择中的键时
    修复了光标图标变化的范围和实际可以选择的键的范围不同的错误。
  • 修复了可以在图形编辑器中编辑锁定轨的错误。
  • 更正了 GIF 动画导出和静止图像(序列号)导出的默认文件名以匹配场景名称。
  • 任意变更静止图像(序列号)导出的[导出选定的一帧]中保存的文件名时
    固定保存为输入的文件名。
  • 执行用于导出静止图像(序列号)的 [输出工作区] 时
    当整个场景的帧数为 4 位时,赋予要保存的文件名的序列号也被修正为 4 位。
  • 修复了通过导出动态文件导出时,所有同名轨为相同运动数据的问题。
  • 修复加入/释放参数时参数显示不正确的问题。
  • 当您尝试使用 Ctrl + click 批量按下/删除一个键到轨、参数文件夹等时
    修复了轨在未执行的情况下打开和关闭的错误。
  • 修复了动画视图中部件的显示状态与建模视图中部件的显示状态同步的问题。
  • 在FA编辑中的表单编辑属性的关键帧中执行[将关键帧贴到选定的行]时
    修复了可以粘贴到普通参数的错误。
  • 修复了 FA 编辑生成关键帧时恢复已删除的关关键点的错误。
  • 在 FA 编辑中,如果您分别在调整模式1和 2 中编辑表格,
    修复了调整模式2中边界框显示位置偏移的问题。
  • 修复了通过FA编辑操作变形路径时形状被重置的错误。
  • 修复了导致物理烘焙生成动画在设定为较低影响设定时与物理模拟设定编辑器的行为不同的问题。
  • 修复了快捷键的错误。

Cubism Viewer

《改进项目》

  • 修复找不到model3.json中指定的cdi3.json文件路径时无法正确打开模型的BUG。

 

 

4.0.02 (2019/10/15)

常见的

《改进项目》

  • 修复了 macOS10.15 Catalina 上编辑器安装失败的问题。

动画

《改进项目》

  • 修复了 macOS10.15 Catalina 无法导出视频的问题。

 

4.0.01(2019/10/03)

建模

《改进项目》

  • 修复了撤消/重做中与选择箭头工具和套索工具处理相关的错误。
  • 修复了缩小参数时可能无法突出显示键的错误。
  • 统一在各种对话框中通过拖动调整表格宽度时的行为。
  • 当在部件选项板中没有输入的情况下启用过滤器时,
    修复了空文件夹被隐藏的错误。
  • 修复了变形器的不透明度未反映在检查器中的错误。
  • 当您在变形器中选择变形器执行 [展开全部] 时,
    修复了选择状态未更新的错误。
  • 调整笔刷调整线宽和图形路径不透明度的初始值。
  • 导出图形路径笔刷设定时将默认文件名变更为笔刷名称。
  • 添加了对使用图形路径工具时按下 Ctrl 时变为箭头工具的功能的支持。
  • 修复了删除图形路径控制点时检查器消失的错误。
  • 修复了通过选择鼠标的矩形可以选择隐藏的图形路径的错误。
  • 在图形路径的工具细节中追加了一个按钮,用于从默认笔刷 UI 打开笔刷设定对话框。
  • 将自动图形路径生成对话框的默认显示位置变更为编辑器的中心。
  • 修复了该过程,以便在使用 ✕ 按钮关闭图形路径笔刷设定对话框时更新检查器。
  • 修复了连接图形路径时即使按下 ✕ 按钮也会执行的错误。
  • 修复了有时难以看到图形路径控制点的 GUI 的错误。
  • 改进了选择图形路径时的突出显示。
  • 修复了自动生成四个角时值可能设置不正确的问题。
    修复了自动生成四个角时检查器显示消失的错误。

动画

《改进项目》

  • 修复了无法使用项目的数据替换功能替换序列号图片文件夹的错误。
  • 在 FA 模式下,该功能受到限制,因此变形器的结构不会被 Ctrl + 拖动改变。
  • 即使您在免费版本中不使用跳帧功能
    修复了显示“任意跳帧是PRO版本功能”对话框并且无法变更每个值的错误。

 

4.0.00(2019 年 9 月 4 日)

常见的

《功能追加》

  • 追加了形状动画工作区。
  • 实现了洋葱皮(beta)功能。
    关键帧或关键点前后的状态半透明显示,可以确认移动的过渡。
  • Live2D 官方 Live2D 模型和插图素材市场“Nizima(Nijima)”链接按钮
    我将它安装在编辑器的右上方。(仅限日文版)

<< Cubism 4 过时的功能>>

  • 随着 Cubism4 的发布,以下 2.1格式数据导出功能已被取消。
     ・菜单[文件]-> [保存为模型数据(cmox)为 2.1]
     ・菜单的[文件]-> [导出运作档]-> [Export moc file (for 2.1)]
     ・菜单[文件]-> [导出运作档]->
      从 [导出动态文件] [Export as 2.1format (mtn)] 打开的对话框中的项目

《Cubism的变化3》

  • 盘放置和快捷方式等编辑器设定现在分别保存在 Cubism 4 和 Cubism3中。
    第一次启动 Cubism4 时,会自动继承 Cubism3的设定。

建模

《功能追加》

  • 实现了掩码反转功能。
    传统的剪贴蒙版可以在绘图时反转和应用。
    这使得表达诸如用面具隐藏之类的事情成为可能。
  • 实现了扩展插值功能。
    通过在曲线中的关键点之间进行插值,可以实现旋转等自然表达。
  • 实现了图形路径功能。
    这是一个视频应用功能,可让您根据放置在模型上的控制点和设定的笔刷信息绘制线条。
    现在可以更直观地操作和表达线条,同时保持原始画面中线条的质感和表现力。
  • Cubism Viewer 现在支持 cdi3.json。
    对于导出模型时勾选Export cdi3.json导出的模型,
    参数名称和部件名称将显示在 Cubism Viewer 上。

《改进项目》

  • [自动眨眼和口形同步的设定] 对话框中的项目顺序为
    修复了参数中项目顺序不同步的问题。
  • 修复了笔刷选择工具和编辑胶水的笔刷大小相对于工具细节值的预期大小是半径比的两倍(面积比的 4 倍)的错误。
    修复了半径比是工具细节值预期大小的两倍(面积比的 4 倍)的错误。
  • 修复了网格编辑模式下无法通过箭头键移动顶点的问题。
  • 修复了导出物理模拟设定时 ID 重复的错误。
  • 减少了放大物理/场景混合设定显示时显示质量的恶化。
  • 多选时不同值的弯曲变形器转换的分裂数量,贝塞尔的分割数,图形网格的绘制顺序,
    修复了在检测到用户数据的剪辑或意外编辑时显示确认对话框。
  • 修复了背景色吸管工具光标显示位置偏移的问题。
  • 修复了执行特定操作时会生成无法使用箭头工具操作的变形路径的错误。
  • 通过选择目标版本对话框更新[变形器转换(3.2方法)]时
    修复了检查器的显示未更新的错误。
  • 修复了无法在 检查器 上执行 [变形器转换(3.2方法)] 的 Undo / Redo 的错误。
  • 修复了将图层移动到项目中的另一个原始图像时被识别为未使用的错误。

动画

《功能追加》

  • 根据动画目的追加了目标版本设定。
    创建新场景时,您可以设定默认目标版本。
    单击项目上的 [动画数据] → 从 检查器 上的 [目标版本设置]
    也可以重置它。
  • 实现了序列号图片跟踪功能。
    使用序列号导出的图片可以立即放置在专用轨上。
    您可以使用时间重映射功能在图形编辑器上调整放置的序列号图片的显示时间。
  • 实现了跳帧功能。
    可以再现有限动画等尖锐动作。
  • 实现了形状动画功能(用于视频)。
    这是一个方便的视频制作功能,允许您直接在 Animator 时间线上编辑模型数据的形状,而无需编辑参数。

《改进项目》

  • 修复序列号图片/视频输出中“全部输出”时丢失一帧的问题。

Cubism Viewer

  • 修复了[显示]菜单中的[启用Mipmap]无法正常工作的BUG。
  • 添加了对掩码反转功能的支持。

 

 

Cubism3系列更新历史记录

点击此处查看Cubism3系列的更新历史记录

© 2010 - 2022 Live2D Inc.