Update history

Latest version

3.0.11(2017/08/17)

Modeler

“Added Functions”

  • Physics Setting function is officially supported.
    · Frequently used settings can be add into the preset
    · Preview of Physics Model
    · Semi-automatically adjust the model sway width
    · Check movement while motion is playing
    · Import/Export the physics3.json
    et cetera, convenient functions were added for Physics Setting.
    Part of Menu is changed.””Menu -> Modeling -> Open Physics Setting Editor”” in the official version instead of “”Menu -> File -> Open Viewer”” in beta version.
    Please check out the manual site for the detail usage.
    About Physics
    Physics Setting
    【Notes】
    Physics calculation was redesigned and rewritten in the official version.Physics Setting set in beta version won’t operate properly.
    Sincerely sorry about this, but please set Physics Setting again.
  • Added a function to save storage capacity of a memory for a texture and to reduce a load for editing. Three reduction ratios are prepared; 1/2, 1/4, and 1/8.
  • Added a function to check/set the current display state from ‘Display’ menu > ‘Display methods.
  • Changed a message for switching of display method from ‘Show source image’ to ‘Show model image.
  • Added a function to sort order of selected multiple Parameters in Parameter Palette.
  • Added a function to select multiple points in a Deform Path and also a function to edit them with bounding box.

“Bug Fixes”

  • Fixed a bug where a submenu window would be hidden and out of control when a Parameter Palette was set on the right side of a window.
  • Fixed a bug where a minimized model image would not matched to the correct image in Texture Atlas.
  • Added a function to display a confirmation dialog when a range of Parameter was set narrower than the current Key Form.
  • Fixed a bug where a canceled change of a Parameter would be remained when canceled in a dialog for ‘Parameter(s) change.
  • Fixed a bug where a Key could not be added on a dialog of Keyform editor.
  • Fixed an issue that a shortcut such as Ctrl + S doesn’t work when the cursor focus is on the text input box.

Animator

“Added Functions”

  • Improved ‘Adjust spacing’ function as below;
    (1) allowed repeated application,
    (2) modified to keep the applied value,
    (3) allowed re-selection of Keyframes when displaying a Dialog.
  • Improved Graph editor in Animator as below;
    (1) added a Ruler Mark of zero,
    (2) modified vertical lines of a grid to move with Key movement,
    (3) fixed a bug where a vertical value of a grid would be incorrect.
  • Incremented a function to select multiple Keyframes in a group sequence (pink colored) on Timeline.
  • Incremented a function to switch lists of Key value in Graf editor.
  • Changed a default type of Curve from ‘Auto smooth’ to ‘Step’ when inserting a Keyframe in Part View of Track.
  • Increment an auto-adjustment function for Key value when changing by Parameter Slider.

“Bug Fixes”

  • Fixed a bug where a save-confirmation dialog would not appear when closing Editor immediately after Scene deletion.
  • Fixed a bug where a Graf would not be updated when inserting Keyframes in a linked Parameter by Slider, on Graf editor.
  • Fixed a bug where Keyframe could not be inserted directly in a linked Parameter on Graf editor.
  • Fixed a bug where a selected Scene in Scene Palette would not be reflected in Viewer after deletion/copy of a Scene.
  • Fixed a bug where Operation Menu for Keyframe would be hidden in Effect Tracks.
  • Fixed a bug where Curve type would be reset after moving a Track horizontally.
  • Added an item of file name in Inspector for a Scene.
  • Fixed a bug where a selected area would not accept Undo after selecting and moving multiple Keyframes.
  • Fixed a bug where Curve type would be ‘Auto smooth’ after changing a value of a Keyframe on Parameter Slider.
  • Changed a default size of a model would be 100 % when putting it.
  • Fixed a bug where Editor would be freezed by changing Repeat Parameter after copying a Scene including it.
  • Fixed a bug where Inverse Step would be released after moving a key with it.
  • Fixed an issue that shortcut of keyframes copy paste etc didn’t work after scene was changed.
  • Fixed an issue that the reaction was delayed when using shortcut to control animation playback.

3.0.10(2017/08/03)

General

“Bug Fixes”

  • (For macOS) Fixed a bug where a dialog for license key entry would be hidden behind a dialog for license activation.
  • Fixed a bug where a cursor would be hidden when using slideron Palette and switching the focusing window.
  • Fixed a bug where a popup dialog for Parameters and draw order would be kept displaying when minimizing Editor window.

Modeler

“Bug Fixes”

  • Officially fixed an issue that if GodMode was enabled in the Windows 10 Creators Update environment.The application terminated abnormally when displaying the file selection dialog.
  • Fixed a bug where an incorrect file would have appeared when overwriting the same file from multiple applications.
  • Modified the scaling direction and its icon by “Control + Space + Drag.
  • Fixed an issue that selection status disappeared when “Expand/Collapse All” buttons on the parts palette and Deformers Palette are pressed.
  • Fixed a bug where Parameter Palette would not be updated when selecting Objects from the right-click menu on Canvas.
  • Fixed a bug where settings of Grid would not be saved.
  • Changed the color of a locked object to gray on Parts and Deformer Palette.
  • Fixed a bug where the color of Key would be yellow in the normal Keyforms after joining Parameters.
  • Fixed a bug where contents in Parameter Folder would be hidden when moving it in closed form.
  • Fixed a bug where the order of Objects in Palette would change when pressing a direction key to move the selecting Object.
  • Fixed a bug where deleting multiple Parameters would not work in 3.0.08 or later.
  • Fixed a bug where Undo would not work after deleting Parameters, in 3.0.08 or later.
  • Fixed a bug where out-of-range number of Warp Deformer/ Bézier divisions could be inputted. The number of divisions will set to 100 if exceeded 100.
  • Fixed an issue that the model was displayed inappropriately in the following conditions.
    (Using Blend Mode (normal, addition, multiplication), Culling ON/OFF, Clipping in various combinations)
  • Fixed an issue that errors occurred when importing some specific files, and a large number of errors were output when exporting those files.
    ERROR [deserialize failed: wrong CImageResource: …
    * The same error occurs when importing the file at the first time, but a similar error will not occur when exporting in this version.
    * With this fix, unnecessary data is discarded, some files’ data size might reduce.
  • Fixed a bug where out-of-range Keys of a Parameter would be deleted in an outputted moc3 file.

Animator

“Added Functions”

  • Add a function to add Workspace information in the motion data.
  • Add function to open a model file by dragging it on the tab of View Area and to add a new Model Track when dragging a file under Tab.
  • Fixed a bug where joined Parameters in Modeler would not be reflected in Animator.

“Bug Fixes”

  • Fixed a bug where a canx file would not be opened correctly when a sound file path included Japanese letters.
  • Fixed a bug where sound tracks in a canx 2.1 would not be imported when using QuickTime.
  • Fixed a bug where a track name would not match to the corresponding file name when generating a model track.
  • Fixed a bug where an initial position of Model and a scene size would not be reflected when using the function of “Generate a scene automatically from the audio file.”
  • Fixed a bug where some Keys would not move when selecting and moving multiple Key Frames.
  • Fixed a bug where Parts structure in Animator would not match to that in Modeler, even if re-loading corresponding Model.
  • Fixed a bug where a cancel function in progress bar would not work when outputting sequential png images.
  • Fixed a bug where a range of model opacity would not match to that of Parts opacity in a motion data.
  • Fixed an issue that smooth curves’ Bezier controllers in the motion data (motion3.json) do not match the position of 1/3, 2/3.

3.0.09(2017/07/27)

Modeler

“Bug Fixes”

  • Provisionally fixed an issue that if GodMode was enabled in the Windows 10 Creators Update environment.
    The application terminated abnormally when displaying the file selection dialog.
  • Fixed an issue that Cubism 2.1 model file(cmox) can’t be opened in following condition at Cubism Editor3.0.08 or later.
    – A cmox file containing the drawing object(Atrmesh) generated from discarded layer by the new PSD when reimporting the PSD file on 2.1.

 

3.0.08(2017/07/20)

Modeler

“Added Functions”

  • Incremented a function which can memorize previous settings of parameters in ‘Synthesize corners.’
  • Modified to display only the available parameters for the current selecting object in ‘Synthesize corners.’
  • Modified to display all Tabs when using Glue tools and selecting no object.
  • Added a function to delete the selected deform path by ‘Edit > Delete’ or Delete key, even if not using deform path tool.
  • Changed colors of Art Meshes which are targets to deform; the main Art Mesh will be blue, and the others will be red.
  • Incremented a function to display the target Art Meshes in Inspector, when selecting Deform Path.
  • Changed to add an extension .psd to a PSD file in Project Palette.
  • Added parameter edit function on right click.

“Bug Fixes”

  • Fixed a bug where the last Texture Atlas could be deleted.
  • Changed ‘Generate polygon’ button to ‘Automatic attach’ during editing Mesh.
  • Added a margin between buttons in the preset of Automatic Mesh Generation.
  • Added a confirmation dialog when overwriting a preset of Automatic Mesh Generation.
  • Fixed a bug where tool buttons would act incorrectly if started editing of Meshes without selecting it.
  • Fixed a bug where width of Deform path could be minus value.
  • Fixed a bug where ‘Chang to Broken Line’ would not accept Undo.
  • Fixed a bug where part of line would be hidden when Deform Path had two Control Points.
  • Fixed a bug where Deform Path would not move.
  • Fixed a bug where an error would be happen when loading a model including incorrect Deform Path. The incorrect Deform Path will be deleted after loading the model.
  • Fixed a bug where one of Deform Paths in Editing level 2 and 3 would not be responded to Delete key.
  • Fixed an issue that particular function such as Automatic-Mesh-Generate doesn’t work when path deformer is applied to several ArtMeshes.
  • Fixed a bug where three or more points would be bound each other when binding Glue.
  • Fixed a bug where it would take a long time when binding many points.
  • Modified colors of weights of Glue.
  • Modified ‘Automatic Mesh generation’ not to perform for objects in which Glue have already been set.
  • Fixed a bug where a function of ‘Zoom In / Zoom Out Specifying Magnification’ would not work correctly.
  • Fixed a bug where Palette and Inspector would not be updated when selecting objects from the list of right click menu.
  • Fixed a bug where color of a transparent part would change when loading 2.1 model (.cmox).
  • Modified a highlighted color when drag-and-dropping elements in Parts Palette and Deformer Palette.
  • Fixed a bug where a triangle mark would disappear when reflecting Warp Deformer.
  • Fixed a bug where Deformer could be created in the participant of selected Part.
  • Fixed a bug where selection of multiple elements would not be reflected in Deformer Palette.
  • Fixed a bug where order of elements and that of Parts Palette would not matched in Deformer Palette.
  • Fixed a bug where a cell would not be highlighted when drag-and-dropping elements in Deformer Palette.
  • Fixed a bug where Art Mesh would not be displayed in Deformer Palette when there were no Deformers.
  • Fixed a bug where a hierarchical structure of elements would not be kept when moving in Deformer Palette.
  • Fixed a bug where elements could not be added to root layer in Deformer Palette.
  • Changed the order of items in “Create Deformer” dialog.
  • Fixed a bug where only one of selected Rotation Deformers would move when moving the origin point.
  • Fixed a bug where Bézier handle in Curve Deformer would not move when moving the origin point with selecting both Curve Deformer and Rotation Deformer.
  • Fixed a bug where output of moc format would not work correctly when loading 2.1 model.
  • Fixed a bug where form of an Object would be broken, when the object associated with two or more parameters and all Keys of a parameter were deleted.
  • Fixed a bug where a bounding box would be accessible when selecting no Object.
  • Fixed a bug where Automatic Mesh generation would not work after generated Texture Atlas.
  • Fixed a bug where color of loaded PSD file, which was output by some software like Fire Alpaca, would change.
  • Fixed an issue that when an object on multivew is mouse-hoovered tooltip is shown on every view on the screen.
  • Fixed an issue that the area in which multiple object shares has darker color when cmox file in which PNG file is switched get loaded.

Animator

“Added Functions”

  • Incremented a function which can sort by names in Scene Palette.
  • Incremented a function which can link the zoom of X and Y axes in Model Track.
  • Incremented ‘Display/Hide’ and ‘Lock/Mute’ functions.
  • Added a function to show the guide.

“Bug Fixes”

  • Fixed a bug where only a part of linked parameters would be shown in Graf Editor.
  • Fixed a bug where the order of drawing in timeline group would be reversed.
  • Fixed a bug where a track of model or background image placed at bottom layer could not move to top.
  • Fixed a bug where incorrect information would be included in a segment of motion data (motion3.json).
  • Fixed a bug an expanded track would be closed after switching Scene.
  • Improved to keep a selecting state after switching Scene.
  • Fixed a bug where a start point of sound would be reset after restarting Editor.
  • Fixed a bug where Bézier Handle would not be updated, when setting a sound file and checking ‘Restrict for SDK use.’
  • Fixed a bug where sound would be played incorrectly when re-playing after stopping between the start of Work area and the head of sound file.
  • Fixed a bug where ‘Placement & Transparency’ of a track in a group would be overwritten by that of group when copy-and-pasting it.
  • Fixed a bug where delete and copy function would work for a part of Keys when selecting multiple Key frames on Model Track.
  • Fixed a bug where Interval adjustment would work for a part of Keys when selecting Keys on Model Track or Effect List.
  • Fixed a bug where a Key would be disappeared when moving Timeline by an arrow mark at the left side of orange bar in Work Area.
  • Fixed an issue that some part of models out of cambus is not hidden when animation is played and does not have half- transparency when the animation is stotped

3.0.07(2017/07/06)

General

“Added Functions”

  • implemented a function which would alert when opened files generated by a newer version of the application. (for cmo3 and can3)

“Bug Fixes”

  • Fixed a bug where part of Mesh would be lost when loading 2.1 model (cmox).
  • Fixed a bug where Physics would not work if Response Speed was set to zero.

Modeler

“Added Functions”

  • Added a function that allows to delete unused model images in the following operations:
    ・model in project palette -> right click on model images -> delete unused model images (Only function when unused model image isn’t empty)
    ・model in project palette -> model image -> right click on group name -> delete unused model images (Only function when unused model image isn’t empty)
    ・model in project palette -> model image -> group name -> right click on model image name -> delete unused model images (Only function when model images are unused)
  • Added a function that allows to delete empty model image group in the following operation:
    ・model in project palette -> right click on model images -> delete empty model image group(Only function when empty model image group is exist)
  • Added a function that allows to rename model image group on inspector palette in the following operation:
    ・project palette -> select group inside model image -> rename on inspector palette.
  • Added a function that allows to check model images’ use conditions in the following operation:
    ・ArtMesh number,Texture altas number can be checked on inspector palette after select model image in project palette.
  • For the source images related to model image,Added a function that allows to disconnect from source images except in use in the following operations:
    ・Select model image in project palette,”Disconnect from source images except in use” by right click.
    ・Select model image group in project palette,”Disconnect from source images except in use” by right click and it will apply on all model images inside group.
  • Added a function that allows to delete empty model image group in the following operations:
    ・project palette -> right click on model images(list) -> delete empty group
    ・project palette -> right clikc on model image group -> delete group
  • Added a function that allows to select ArtMesh are using by model image in the following operations:
    ・project palette -> select model image -> “Select related ArtMesh”by right click.

“Bug Fixes”

  • Fixed a bug where Tree would not be updated when Object name was changed on Inspector.
  • Fixed a bug where part of GUI would appear when ‘Lock of Deformer’ had been turned on.
  • Fixed a bug where path deformer which parent part is invisible shown on canvas.
  • Fixed a bug where multiple selections of items which were once released before.
  • Fixed a bug where order of parameters would not matched between Parameter Palette and Parameter Settings Dialog box.
  • Fixed a bug where Deform Path would not be locked when its parent Path was locked.
  • Fixed a bug where object drawing would not work correctly when Parts were locked.
  • Fixed a bug where draw order would not be correct when there was a hierarchical relationship between groups of draw order.
  • Changed shortcuts for zoom settings to be the same of 2.1.
  • Fixed a bug where part of Mesh would be lost when editing Mesh.
  • Fixed a bug where “Protect Edge exterior” function inappropriately.
  • Fixed a bug where “Reconstruct Mesh” functions inappropriately.
  • Fixed a bug where Reverse of parameters in Art Mesh would not work correctly.
  • Fixed a bug where an ArtMeshed snapshot becomes an illegal state and cmo2 can’t be imported.
  • Fixed a bug where spaces between Mesh areas would be interpolated.
  • Fixed a bug where editor becomes an illegal state after did”create ArtMesh from snapshot” couple times.
  • Fixed a bug where Parts Palette would not work when ’Collapse tree when selected’ was off.
  • Fixed a bug where Show/Hide of Parts would not work correctly.
  • Fixed a bug where lock of parent Deformer would not work correctly.
  • Fixed a bug where Art Mesh would be hidden when Deformer was hidden.
  • Added a function which would select child elements of Deformer.

Animator

“Added Functions”

  • Added “Bezier controllers’ restiction for SDK” function.

“Bug Fixes”

  • Fixed a bug where layer order of background and model would not keep when copying Scene.
  • Implemented a function which can select all of Keyframes in Track and Effects.
  • Fixed a bug where sounds would be overlaid when they were cut at the middle of them by the end point of Workspace.
  • Fixed a bug where sound files could not be edited in Canvas.
  • Fixed a bug where change of length of Scene would not be reflected to Inspector and Scene Palette.
  • Fixed a bug where animation files in can3 format would not be opened.
  • Fixed a bug where selection of Tracks in Timeline Palette would not be reflected in Canvas.
  • Fixed a bug where a tab would be added when copying Scene from Scene Palette.
  • Fixed a bug where selection of a tab was impossible when opening Scene.
  • Changed “Double click” to “Single click” while opening a scene on scene palette.
  • Mutilple View function can be applied on animation canvas.
  • Fixed an issue that scene palette doesn’t synchronize when change the tab on canvas.

3.0.06(2017/06/23)

Animator

“Bug Fixes”

  • Fixed an issue that editor freezing when model file which involved eyeblink, lipsync setting be imported to animator.

3.0.05(2017/06/22)

General

“Bug Fixes”

  • Fixed a bug where a save dialog box would not appear after product activation.
  • (for mac OS ver.) Fixed an issue that Viewer was unstable to editing of physics settings.
  • (for mac OS ver.) Fixed an issue that Command key would not work as a modifier key for Undo and Redo in Viewer.
  • Fixed a bug where physical computing would not work properly when selecting ‘Angle’ as a unit.
  • Fixed a bug where an error would occur when pressing ENTER in Editor.
  • Fixed a bug of Viewer where buttons for settings of physical computing would be hidden.

Modeler

“Added Functions”

  • Added Delete Confirmation Dialog, which would appear when there remained the replaced previous PSD file.
  • Modified the view of Inspector to display Parts hierarchically.
  • Added descriptions in the list of parameters.
  • Implemented an auto scroll function, which would act when re-ordering parameters.

“Bug Fixes”

  • Fixed a bug where a name of Rotation Deformer would not appear in a tooltip.
  • Fixed a bug where Parameter Palette would not appear in an initial condition of Work Space
  • Fixed a bug where a function of ‘Arrange Parameter configuration for selected object’ would not work correctly.
  • Fixed a bug where UI of Create Warp Deformer dialog box would collapse.
  • Fixed a bug where models using Glue in ‘moc3’ format could not read correctly in SDK. Please output the model in ‘moc3’ format again.
  • Fixed a bug where keys of filtered parameters could not edit in Parameter Palette.
  • Fixed a bug where a Part could be its parent Part when editing in Inspector
  • Fixed a bug where Drawing Order in Parts Palette would not be displayed correctly.
  • Fixed a bug where Key with large number of digits (e.g., ‘10.333333’) could be inputted on Parameter Palette.
  • Fixed a bug where zooming using Ctrl+Space would not be reflected.
  • Fixed a bug where selection and expansion of Parts on Parts Palette would not work.
  • Added an option to replace the beginning of Part’s ID with ‘Part’ or ‘PARTS.’
  • Fixed a bug where Ctrl+C, the short-cut key of Copy function, would not work on Palette.
  • Fixed a bug where the function of ‘Select All Child Objects’ would select filtered objects when selecting Parts on Parts Palette.
  • Fixed a bug where selection of filtered objects would not be released if applied a filter with selecting any objects on Parts Palette.
  • Fixed a bug where ‘Select All Child Objects’ would not work correctly when selected Parts included their child Parts.
  • Added Copy, Cut, and Paste functions in a right-click menu of Parts Palette.
  • Fixed a bug where right-click would activate ‘Select All Child Objects’ when selecting areas other than Parts on Parts Palette.
  • Fixed a bug where selection of all objects by using Alt key on Parts Palette would not work correctly.
  • Fixed a bug where a state of Parts Palette and Deformer Palette would not update correctly after pressing ESC.
  • Fixed a bug where Parts Palette would not keep its hierarchical layout after moving items.
  • Fixed a bug where order of objects on Parts Palette would be reversed(check!!) after moving(moved) an object in Parts.
  • Fixed a bug where multiple selection of objects on Parts Palette would not be reflected on items inside Deformer Palette.
  • Changed the color of Key Form, which was not common to multiple parameters, would be yellow.
  • Fixed a bug where output of Warp Deformer in 2.1 cmox or moc format would not work when any one of the division numbers was ‘1’. Curve Deformer in 2.1 will automatically be divided in 2×2.
  • Fixed a bug where output in 2.1 cmox or moc format would not work correctly when there was Art Mesh not placed on Texture Atlas. Art Mesh not placed on Texture Atlas will be deleted after displaying a warning message.
  • Fixed a bug where output in 2.1 moc format would not work when selecting some of the texture size (e.g., 1/2, 1/4).
  • Fixed a bug where a progress bar would not appear when automatic layout function was active in Texture Atlas.
  • Changed the alert message when opening Model Guide Images without Art Mesh in the editor window of Atlas; Before: ‘No Polygon’ -> After: ‘No ArtMesh’
  • Excluded Model Guide Images without Art Mesh from lists in the right side of editor of Texture Atlas.
  • Fixed a bug where setting a parent Part as a current or child item on Inspector would cause an error
  • Fixed a bug where switching of ‘Show’ and ‘Hide’ function for layer groups would not be reflected correctly.
  • Changed the minimum brush size in 3.0.04 (10 -> 1.0) to be possible to do fine tunings.
  • Fixed a bug where loading a model outputted in 2.1 format into 3.0 would cause ID doubling alert.
  • Fixed a bug where the memory would not be released after closing models.
  • Fixed a bug where some images in a loaded model would be hidden.
  • Fixed a bug where Art Mesh with one or two points could be generated. To recover such type of Art Mesh, please see FAQ Q19.
  • Fixed a bug where Invert Selection of child Deformer would not work when selecting both parent and child Deformers.
  • Fixed a bug where blank Parts, which had been generated when importing PSD file, would be remained in Parts Palette after applying a model template.
  • Fixed a bug where a folder for non-matching items would always be made when re-importing PSD file.
  • Fixed a bug where Deformer would not be generated when executing ‘New Warp Deformer’ with selecting Rotation Deformer.
  • Fixed a bug where animation preview would not run when a model build in 3.0 was used as a Model Template.
  • Fixed a bug where a 2.1 model could not be imported when its ID had been used in 3.0
  • Fixed a bug where Lock and Show/Hide functions would be applied to Parts.
  • Fixed a bug where Undo and Redo of Lock and Show/Hide function would not work.
  • Fixed a bug where state of Lock and Show/Hide in the main menu would not indicate correct one.
  • Implemented fast model rendering, improvement of display quality, and reduction of memory load.

Animator

“Added Functions”

  • Template files of animation for 2.1 can be used in 3.0.
  • Implemented an output function in mtn format, which is for 2.1 SDK and Viewer.
  • Added a vertical grid line to Dopesheet.
  • A function ‘Model Replacement (All Scenes)’ was added in the main menu.
  • Implemented a supporting function of Shift key, which enables multiple selection of the Keyframes to change the scale of Bounding Box in Graf Editor.
  • Implemented a function to lock the X-axis when moving Keyframes in Graf Editor.

“Bug Fixes”

  • Fixed a bug where Undo function would not work when setting models or loading sound files.
  • Fixed a bug where Undo of Keyframe, which was added on Dopesheet, would not be reflected when it had executed on Graf Editor
  • Fixed a bug where selected multiple Keys could not be moved together after applying an animation template.
  • Fixed a bug where motion of model in Viewer would not change immediately after applying an animation template.
  • Fixed a bug where ‘Placement & Transparency > shear’ would not be applied to Track.
  • Fixed a bug where a track on Canvas could not edit after changing the scene size.

3.0.04(2017/06/12)

Modeler

Bug Fixes

  • Fixed an issue that an error log is exported when template is applied to a model.
  • Fixed an issue that a rotation deformer remains on the top left (0,0) when Applying template is undone.
  • Fixed an issue that preview doesn’t work appropriately when a model data with 3.0-formatted ID (such as ParamAngleX) is used as a template.
  • Fixed an issue that template doesn’t work appropriately when a model containing deformers with no parent is used as a template.
  • Fixed an issue that Copy & Paste fails (after ver 3.0.03 ) on specific data.

Animator

Bug Fixes

  • Fixed an issue that some animation data is not imported appropriately.

3.0.03(2017/06/05)

General

Added Functions

  • Added a distinct FREE interface. Please refer to the following page for the functional difference between Free and Pro versions of the program.
    [Comparison of Cubism 3 PRO / FREE versions]
  • Viewer function was added. Physical operation function (β) can be used in Viewer. For details on how to use the physical calculation function, please refer to the following manual
    [Physical operation (β)]

Bug Fixes

  • GPU initilization invironment label name had been modifed.
  • Corrected the text in Help → Version popup window.
  • The minimum window size has been changed to 800 * 600.A process to show ID conversion has been added at the time of opening a model in 2.1.
  • Fixed the path of [Open log file] in the help menu.
  • The desitnation URL of the link in the help menu has been updated.
  • Fix: The Project palette would lock files, and would not allow the user to delete files used in a project until the editor and animation are closed.
  • Fix: The dialog popup window appears in a different location than the application window.
  • Modeler · Animator: The frame that surrounds the character canvas disappears when the character is mirrored or flipped.

Modeler

Added Functions

  • ID conversion function added: It is now possible to convert the ID of 2.1 parts to the ID format recommended by 3.0.
  • When selecting a part using Alt + click, processing was added so that all objects of the part are selected like 2.1.
  • Added a function to generate Art Mesh for collision detection.
  • [Modeling Menu> Art Mesh> Generate Art Mesh for Collision Detection]
  • The model image list will now be displayed in the right corner when editing the Texture Atlas.
  • Added a function to add images into the texture atlas of unsaved models.

Bug Fixes

  • Fixed a bug where clicking an object in the Parts Palette and then moving the mouse to the left or the right, the object would move top to bottom instead.
  • Fixed a bug that made it possible to create a new part outside the normal range of Drawing Order (exceeding the 0 to 1000 limit).
  • Fixed a bug where the Drawing Order of the Parts Palette on Mac OS was displayed as […] instead of 1000.
  • Fixed a bug concerning synchronization of selected objects between palettes.
  • Fixed a bug that made it possible to manually set the range of Drawing Order outside the limits using the Drawing increment / decrement function.
  • Fixed a bug where the selection state would be lost after double clicking a part.
  • Fixed a bug that would not show the selected state of the Mesh on the right click menu “Parts Palette”.
  • Fixed a bug where adding keys in the parameter palette after creating warp deformers behaves unexpectedly.
  • Fixed a bug that caused the numerical values and actual display to not match when the user is trying to set opacity of the Art Mesh on the inspector slider.
  • Fixed a bug where locking the Art Mesh did not stop it from deforming.
  • Fixed a bug where the GUI was displayed on top of the View Menu and when editing the Art Mesh.
  • Fixed a bug where the tip of the rotating deformer becomes harder to see when the camera is zoomed excessively.
  • Fixed a bug that affected the the handle at the tip of the rotating deformer, it shifted according to the zoom ratio of the camera.
  • Fixed a bug where the Deformer Palette would not update when parts are deleted through the Parts Palette.
  • When the user clicks on the Glue function icon, a popup window will now display to introduce new users to the function and help them understand it’s usage.
  • Fixed a bug where using Ctrl + dragging on a Rotating Deformer resulted in only slight movement.
  • The problem, that was also occurring in Cubism 2.1, where “Inserting a rotating deformer into a curved deformer shifted their positions” was fixed.
  • Fixed an issue where mirrored elements could not be loaded correctly when loading cmox.
  • Solved a problem where blending the shapes on a rotating deformer did not function as planned.
  • When automatic generation of mesh is used, it will allow for other operations to finish before ending the process to avoid creating problems with overlapping of functions.
  • Fixed a bug where vertices could not be edited correctly when multiple art meshes are selected in Mesh Editing mode.
  • Fixed a bug where the texture associations did not set up correctly in the SDK when there’s duplicates of art meshes.
  • In the Texture Atlas editing window, there was a bug where deleting an empty art mesh and pressing OK did not actually remove it, this was fixed.
  • Fixed a bug where of the same model image was being placed more than once on the Texture Atlas.
  • Fixed a bug where trying to re-import a PSD after loading a PNG underlay did not function as expected.
  • Fixed an issue where an error occurred when attempting to re-import a PSD.
  • The tool that indicates the range (such as brush size, eraser, glue function, etc..) had a problem where changing the size by pressing B + dragging to make it smaller, it will become too small and will no longer function as intended.
  • Fixed a bug where PSD re-import (replacement) did not reflect onto the canvas, and the old original PSD would not be deleted if there is a PNG image layout or snapshot in effect.
  • Fixed a bug where parameter values move incorrectly when trying to edit some objects.
  • Fixed a bug where shapes warped incorrectly if new keys were added to objects that corresponded to two or more parameters.
  • Fixed a bug that happens when importing and exporting parts where the Drawing Order would not load correctly.
  • Fixed a bug where moc3 files could not be written under specific conditions.
  • Fixed a bug where vertices can not be correctly edited when mesh editing is done by selecting multiple art meshes.
  • Added a fix to remember recently used values as the tentative range when attempting to blend shapes.
  • Fixed a bug where the selection state of the Parts Palette and Deformer Palette did not respond when ‘Select Parent Deformer’ function is executed.

Animator

Added Functions

  • It is now possible to move one keyframe on the timeline.
  • The label of the selected track now turns a darker color to make it easy to see the track currently selected on the timeline.
  • Added track duplication function. (Right click → popup menu)
  • Animation template function was added.
  • When pasting a key form or applying an animation template, an indicator will show when the action will affect other parts of the project.

Bug Fixes

  • Fixed a bug where the Bezier controller could not be grabbed after expanding or contracting it to the maximum and minimum values.
  • Fixed a bug where the anchor is not set to be the center of the canvas when placing material in the animator.
  • Fixed a bug where the frame rate drops noticeably when attempting to play an animation where all the animation tracks of the timeline palette had been expanded (in a specific environment).
  • Fixed a problem where the curve type is reset. (After dragging a key, copy and paste, adjusting the interval)
  • Improved the UI of animation playback speed control.
  • Fixed undo processing for keyactions: move, copy, and paste.
  • Fixed a problem where if multiple rows of keys are selected on the timeline, right clicking will display a popup which causes dragging to move only one line.
  • Because it was difficult to distinguish the selection state, the selected range of key frames will now be highlighted entirely in the selection area (blue frame).
  • Fixed a problem where deleting a key with Backspace or Delete would reset the expansion state of tracks.

3.0.02(2017/05/11)

General

  • Fixed an issue where scene tabs remain even after the scene was deleted from scene paratte.
  • Fixed an issue where clicking the edit level icon on the toolbar showed no change.
  • Fixed a bug where the Parts data file icon was not displayed correctly.
  • Changed the wording of UI items in the English version.
  • Added a notification that pops up when the GPU did not meet the requirements to run in the user’s operating environment.
  • Partially fixed an issue with unnecesary memory usgae where the software would stop working.
    ・Stability about memory usage is getting improved so much and remaining issue is going to be fixed in the next update.
  • Fixed a problem where installation data did not show properly on Windows operating system.
  • Fixed a problem where Editor could not be started properly when the username contains blank spaces on Windows operating system.

Modeler

  • On macOS: Fixed an issue where right clicking with nothing selected won’t bring up a popup menu.
  • On the English version of macOS: Fixed a bug where the width of buttons becomes too small, cutting off the characters in the popup menu of the parameter text field.
  • On the English version of macOS: Fixed a problem where the characters were not displayed in the deformer creation dialog and buttons.
  • Fixed a bug where when more than 2 Views are shown in view area, the ‘art mesh lock’ will apply to all of them.
  • Fixed a problem where an error occured when trying to create a new part in the parts pallet or to open the parts setting when no model is open.
  • Fixed a problem where an error occurred when trying to create a new parameter, edit a parameter, or apply a parameter filter on the parameter palette when no model is open
  • The editing level when a model is opene is now set to 2.
  • Fixed a problem where when a PSD imported the default parameter ID of the model was got set to the technical specifications of 2.1 instead of 3.
    ・About the specifcations of 3.0 parameter IDs, please refer to this page: [ FAQ ]Can Cubism 3.0 load modules made with 2.1?
  • Changed the default ArtMesh ID from Layer to ArtMesh when PSD gets imported.
  • Fixed a bug that makes it possible to enter incorrect values ​​for mesh line width.
  • Fixed a bug where random pause does not work properly with ID in the 3.0 specification.
  • A popup to confirm was added when the deletion of a preset in automatic mesh generation.
  • Fixed a problem where moving several parts into deformers and creating a parent-child relationship in the parts list will make the order of ArtMesh reverse.
  • Fixed an issue where when space key is pressed in the Texture Atlas the editing process automatically get compeleted.
  • Fixed an issue where when space key is pressed after selecting mesh editing mode by button the editing process of mesh automatically gets compeleted.
  • Fixed an issue that the parameter palette was not refreshed when applying the template.

Animator

  • When the modeling view has focus, any input is disabled to prevent accidental changes to the timeline palette.
  • Fixed a bug where the display was misaligned when selecting a parameter under hidden parameters by the (Shy) filter.
  • Fixed a problem that where Ctrl and Alt keys did not work on the timeline on macOS.

3.0.01(2017/04/27)

General

  • Fixed a problem where if the language locale in macOS is set to Chinese or Korean some Japanese words are included in English UI.
    ・The UI will be displayed by the language of the downloaded installer.
  • Fixed a bug where the parameter palette and timeline palette are not refreshed by switching tabs.

Modeler

  • Fixed a bug where draw orders after refresh are not shown appropriately in the inspector when some objects are selected.
  • Fixed a bug where some messages are not displayed correctly in the English version.
  • Fixed a bug where the folder icon of the parameter palette was displayed at incorrect location.
  • Fixed the deformer hierarchy displayed by the right click menu in view area to show ArtMesh names.
    ・IDs are displayed when there are no name,

3.0.00(2017/04/26)

General

  • Model editing and animation can be done simultaneously by integrating Modeler and animator.
  • Implemented multi view which makes it possible to open and edit the same model on multiple views at the same time.
    ・By setting different parameters in several views, you can edit a model checking the effect of each parameter.
    ・Animations can be played to check motions in one view while editing in the other views.
  • Multiple models can now be opened at the same time, for instance, to compare, or to copy and paste its parts, and so on.

Modeler

  • When importing PSD, it is no longer needed to create a texture atlas first.
    ・In case of animation production, a project can be created without an atlas.
    ・The texture atlas required for SDK development can be created and edited from the texture atlas editing window.
  • ArtMesh and deformer can be now edited at the same time.
    ・Deformers can be edited with artMeshes locked by Shift + A.
    ・ArtMeshes can be edited with deformers locked by Shift + D.
  • Implemented a function to lock the default form.
    ・By checking “Lock default form”, parameter value will be locked and can not be edited when the default parameter value on an object is selected.
    ・This function makes it possible to revert to the original artwork even after changing and deforming the parts in order to prevent from mistakes.
  • Glue (linking of unrelated vertex) is now available to connect parts such as joints where two parts need to be connected while having seperate model pieces.
    ・The vertices of different art meshes can be connected automatically.
    ・More delicate movements can be achieved by adjusting the weight of the object according to it’s parameters.
  • Implemented a function to make drawing order group.
    ・You can set “Drawing order” for the parts individually, and temporarily set the same drawing order to inside objects as its parent folder.
  • In a parts which became drawing order group every drawing order will become local order and will have no relation to outside the part.
    ・Parts belonging to one drawing order group can now have key forms in its parameter.
  • Implemented an option to repeat a parameter.
    ・It is now possible to repeat a motion with a single parameter.
  • The mesh editing functions has greatly been improved.
    ・It is now possible to switch to the Edit Mesh mode on the main canvas.
    ・You can now move freely after adding a vertex without any problems.
  • Automatic mesh generation can now be applied in real time.
    ・It is possible to apply automatic mesh generation to an isolate art mesh.
    ・Implemented a Preset function to save a set values.
  • The ‘deform path’ has been completely changed.
    ・It is possible to set different path deformers to the “editing level” at 2 or 3, and use them like a tool for detailed editing or rough editing.
    ・Path Deformers now automatically follow deformation of the art mesh.
    ・Multiple path deformers can be applied to one art mesh.
  • It is now possible to influence artmesh by not only path but also a “point”.
    ・It is now possible to set the range of effects to each path deformer.
  • When parameter is on the position where editing is not possible, the parameter will automatically move to the nearest available point to edit.
  • The model template process has been improved.
    ・On matching, division of meshes is now done automatically according to the original data.
  • The parameter palette is now greatly improved.
    ・Parameters can now be displayed in a hierarchy.
    ・Now there are quick buttons to quickly access frequently used functions such as adding 2 or 3 points, and deleting key forms on the parameter palette.
    ・The parameter order can be changed by drag & drop.
    ・Numerical values ​​can be displayed on the pallet and edited with the slider.
  • Parts pallet and Deformer pallets have been greatly improved
    ・The art mesh is now displayed as a thumbnail.
    ・It is now possible to filter the display of objects in the parts palette.
    ・Multiple hierarchies can be used in parts pallette.
    ・Now the parts palette follows the same tree display as the layers in the original Photoshop file.
    ・Drawing order is now shown as a number display on the parts palette.
    ・It is now possible to hide/ show items in the Deformer palette.
  • Implemented a new Project Palette.
  • Implemented automatic animation to preview model’s motions without setting animation manually.
    ・Three animation patterns can be selected in random pause menu.
  • With the Solo function (S key), only the selected objects can be temporarily displayed and edited
  • With the Focus function (F key), a selected object can be instantly moved to the center of the display window.
  • Snapshots can now be placed as art meshes.
  • Snap shot can be placed as a sketch, and can be used by mirroring and deformed by setting parameters for instance.
  • Improved Warp Deformer.
    ・Warp deformers can be created in succession. It is now possible to apply a parent-child relationship to them.
    ・Intersecting division points set by using ‘division of conversion’ can now be edited directly.
    ・When editing Beziers, the editing type can now be selected out of 6 patterns.
    ・It is now possible to change the number of ‘divisions of conversion’ and the number of ‘divisions of Bezier’ in real time.
  • Improved the Rotation deformer.
    ・Rotation Deformers can now be created in succession. Manually editing the alignment may not be necessary since they are created in the same position,.
  • Objects can be rotated by the input of relative angle to the reference angle for the parts like both arms.
  • Implemented a tool to create rotation deformers
    ・By creating rotation deformers in succession, it is now possible to place them adjusting their position and handle length.

Animator

  • It is now possible to adjust the parameters by manipulating the slider directly on the timeline.
  • Implemented the function to fix the playback position (caret icon) in place.
  • It is now possible to switch the time scale between seconds and frames.
  • It is now possible to edit the scene information at any time in the inspector palette.
  • The parts display can now be set not only ON / OFF setting but also set opacity.
  • The lip sync and eye blink functions can now be set to be applied as many times as desired by checking parameters (For details see how to set lip sync / eye blink)
  • Improved the scrolling function
    ・Vertical scrolling can be done with the mouse wheel
    ・Horizontal scroll can be done with the mouse wheel pressing Shift.
    ・Horizontal zoom can be done by using mouse wheel pressing Ctrl
    ・Vertical zoom can be done by using the mouse wheel pressing Alt
  • Implemented GUID function for Parameter or Part ID does not to affect the corresponding key frame on the animator side.
  • Unified motion data format into json.
  • Improved Graph Editor.
    ・Five default curves can be set up to achieve more accurate expressions on animating: Linear, Smooth, Bezier, Step, and inverse Step.
    ・The grid can now be selected out of four grid lines: none, 1 frame, 5 frames, and seconds.
    ・It is possible to expand the curve vertically by pressing Alt with mouse wheel.

Plans for Future Updates

  • Implement Live2D Viewer functions into Live2D Cubism.
    ・Physics and function to play motions is going to be implemented.
  • Animation templates are going to be implemented in future updates.
  • .mp3 file is going to be supported in future updates.
  • After Effects plug-in is going to be implemented.
  • Video export features are not implemented in Cubism 3 because of a security issue of QuickTime.
    ・Some file formats are going to be supported for export

Depricated Features

  • Text input features in Animator was deprecated in Cubism 3.0.
  • Function to replace texture atlas by PNG was deprecated in Cubism 3.0.
  • Made it unnecessary to make texture atlas on PSD import in Cubism 3.0.
  • This change is to avoid deterioration of resolution in some cases like video production.
  • This decision was made by the fact that tPSD files have been used in the most cases. However, if many users require the use of PNG files for the replacement of texture atlas, it might be brought back into consideration.

Copyright © 2017 Live2D. All Rights Reserved.